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Einleitung
Dieses Buch dient dazu, die Grundlagen des 3D-Modellierens  und Animierens mit Maya zu verdeutlichen. Die 
erworbenen Fähigkeiten sind auf die meisten 3D-Programme anwendbar. 

Dieses Buch versucht einen schnellen und leichten Einstieg in einen sehr vielseitigen und complexen Bereich zu er-
möglichen.

Ursprünglich wurde dieses Buch als Begleitskript für den 12 wöchigen Kurs „Projektkompetenz Multimedia: Maya“ 
konzipiert. Es wurde jetzt überarbeitet für die Maya 2014. 

Die einfachste Art und Weise Maya zu lernen ist mit dem Programm herumzuspielen und auf Entdeckungsreise zu 
gehen. Das Buch stellt nur eine von vielen Wegen dar das Programm zu lernen.

„Remember to play, it‘s the best way to learn“ Bert Monroy

Geschichte von Maya
Alias (heute Autodesk) hat drei Softwarelinien „Wavefront - Advanced Visualizer“, „Thomson Digital Image - Explo-
re“ und „Alias - Power Animator“ besessen. Mit diesen wurden fotorealistische Bilder erzeugt wie z.B. in “Terminator 
2”(James Cameron, 1991) oder “Jurassic Park” (Steven Spielberg, 1993). 1999 wurden sie kombiniert in ein einziges 
Softwarepaket benannt nach dem Sanskrit Wort für „Illusion“ - „Maya“. 

Während der Entwicklung von Maya 1.0 (1999) hat das Produktionsteam mit dem Animierer Chris Landreth zusam-
mengearbeitet. Mit der Beta-Version von Maya entstand  der erste Kurzfilm “Bingo” (1998). Kurz darauf wurde Maya 
für die Spezial Effekte in “The Matrix” (Wachowski-Brothers, 1999) und “The Mummy” (Stephen Sommers, 1999) 
verwendet. Dies führte dazu, dass “Industrial Light and Magic” (ILM) Maya als Standard für die Special Effects 
Industrie einführte. Eine Umfrage von April 2010 (3500 Teilnehmer an der Studie) hat ergeben dass in dem Profes-
sionellen Umfeld Maya mit ca. 42% Marktanteil benutzt wird und an zweiter Stelle 3dSMax mit 40% Marktanteil. 

Animationsstudios bevorzugen Maya wegen seiner einfachen Erweiterbarkeit. Maya hat seine eigene Skriptsprache 
MEL (Maya Embedded Language), darüber hinaus können Programmierer Werkzeuge mit Python, C++ oder .Net 
erstellen.

Der heutige Anwendungsbereich von Maya ist nicht auf die Animation in Filmen beschränkt, sondern erstreckt sich 
auch über die Entwicklung von 3D-Objekten für Computerspiele, Architekturvisualisierung und Physik-Simulation.

Was lernt man in diesem Buch?
Dieses Buch ist eine Einführung wie man 3D Objekte und Animationen erstellt und einen Überblick über die gän-
gigsten Module und Werkzeuge von Maya. Diese Module sind „Modellieren“, wie 3D Objekte entstehen,  „Shader / 
Materialien“, welche visuellen Materialeigenschaften das Objekt haben sollte, „Beleuchtung“, wie Licht in die Szene 
gebracht wird, „Animation“, wie die Objekte animiert werden können, „Dynamics / Effekts“, Partikel und Physik 
Simulationen, und „Rendering“, wie der Computer am Ende das Bild für den Film errechnet. 

Nach beenden des Buches hat man die Grundlagen von allen Bereichen der „3D Content Production Pipeline“ ken-
nengelernt und die Fähigkeit eine eigene 3D Animation zu erstellen. Darüber hinaus betrachtet das Buch auch die 
Grundlagen für Visualisierung und 3D-Spiele.

Für wen ist dieses Buch?
Das Buch ist geschrieben für jeden der in die Welt der 3D Computergrafik eintauchen möchte. Daher ist es primär 
ausgelegt für Leser die Anfänger in dem 3D Bereich sind. Hat man bereits Erfahrung in einem anderer 3D Software, 
so bietet das Buch einen schnellen Einstieg und Übersicht über die gängigsten Werkzeuge. 

Wie arbeite ich dieses Buch?
Die Kapitel sind strukturiert nach folgendem Muster: zunächst werden die verschiedenen Werkzeuge vorgestellt, 
danach werden sie in einem praktischen Beispiel angewendet und am Ende gibt es Übungsaufgaben um selbstständig 
den Umgang mit den Werkzeugen zu üben und eine Übersicht von weiteren Möglichkeiten das Wissen zu vertiefen.

Daher ist es zu empfehlen Maya auf einem Computer installiert zu haben und die verschiedenen Schritte selbst aus-
zuprobieren. 

Bleibt man stecken kann man sich die entsprechenden Szenendateien online herunterladen unter:

 <online file repository>

Überblick des Buches
Zuerst beschäftigt sich das Skript mit den Grundlagen des Maya Userinterfaces. 

Die darauf folgenden Kapitel sind gemäß dem Arbeitsprozess aufgebaut: Modellieren, Rendern, Animieren. Da Maya 
ein nodebasiertes System ist, kann man die Arbeitsschritte aber auch nach belieben in der Reihenfolge ändern. 

Beim „Modelling“ werden die Modellier-Techniken NURBS und Polygon zum Erstellen von Objekten genauer be-
trachtet. Lichter und Schatten, sowie Materialeigenschaften werden beim anschließenden „Rendering“ zugewiesen. 
Hierfür wird primär die Render Engine „Mental Ray“ verwendet. Die Objekte können nun animiert werden. Dies 
geschieht entweder mithilfe des Keyframe Verfahrens, oder mit einer physikalischen Simulation. 

Benötigte Hardware und Software
Autodesk Maya läuft auf allen gängigen Betriebssytemen (Windows, Linux, und OSX). Um Maya zu bedienen 
braucht man eine 3-Tasten Maus, bzw. eine Maus mit klickbarem Scrollrad. Viele Funktionen des Programms kön-
nen nur durch die 3. Maustaste benutzt werden, beispielsweise die Navigation innerhalb einer Szene.

Die empfolenen Hardwareanforderungen findet man unter:

	 http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=15458252&linkID=9242258

Anfangs in der Lernphase ist es meist nicht notwendig neue Hardware anzuschaffen. Einige meiner Studenten haben 
Maya sogar auf einem Netbook ohne 3D Grafikkarte benutzt. Um angenehm mit Maya zu arbeiten sollte man eine 
dedizierte Grafikkarte und mindestens 8GB Arbeitsspeicher achten sowie darauf achten, dass das System die neusten 
Treiber für die Hardware installiert hat.

Autodesk Maya
Der Funktionsumfang von Maya ist bei all den Lizenzen identisch. Die Lizenzen bestimmen wie und für was Maya 
verwendet werden darf. Autodesk bietet verschiedene Lizensierungstypen an einige davon sind:

Trialversion:	 Ermöglicht Maya 30-Tage lang zu testen



12 13Einleitung ||  || ﻿

	 http://www.autodesk.com/products/autodesk-maya/free-trial

Studentenversion:  Erlaubt Studenten die Möglichkeit eine kostenlose für ihr Studium Maya zu verwenden

	 http://students.autodesk.com/

Kommerzielle Lizenz:  Diese Lizenz kostet ca. 4000Eur und erlaubt die kommerzielle Nutzung von Maya. In Deutsch-
land, wird Autodesk Maya nur von Vertriebspartnern verkauft. Eine Liste von vertriebspartnern findet man unter:

	 http://www.autodesk.com/products/autodesk-maya/buy

Installationshinweise Windows
Unter Vista/7/8 muss die Installation als Administrator ausführt werden. 

Falls Fehler bei der Installation auftreten sind diese meist zurückzuführen auf die Benutzerkontensteuerung. Um die 
Benutzerkontensteuerung zu deaktivieren muss man folgende Schritte ausführen:

1.	 Die Systemsteuerung öffnen (Start > Systemsteuerung)

2.	 Benutzernutzenkoten öffnen

3.	 Einstellungen der Benutzerkontensteuerung ändern

4.	 Den Regler auf „Nie benachrigen“ stellen

5.	 Den Computer neustarten

Falls Maya nicht startet sollte man sicherstellen das die aktuelle Version von DirectX installiert ist. Diese lässt sich auf 
der Microsoft DirectX Webseite herunterladen (http://www.microsoft.com/windows/directx/).

Installationshinweise Linux
Die Maya Installation ist ausgelegt für Fedora (ein rpm Paket).

Um Maya unter Ubuntu zu installieren kann man folgendes Skript verwenden: https://gist.github.com/borg-
friend/5597742

Schreibweisen in diesem Buch
Manche Schreibweisen sind durchgehend in dem Buch zu finden und werden hier erläutert.

Zwar ist Maya für eine Vielzahl von Betriebssystemen ausgelegt, jedoch sind die jeweiligen Oberflächen identisch.

Die Auswahl eines Menüpunkts wird wie folgt dargestellt:

-- Menü > Befehl (wie z.B. File > New Scene)

Wenn die spezifischen Konfigurationseinstellungen eines Menüpunkts benutzt werden sollen:

-- Menü > Befehl q  (wie z.B. Create > NURBS Primitives Cube q)

Maus- und Tastaturbefehle werden in dieser SCHRIFTART angezeigt.

-- RMB - Rechte Maus Taste (right mouse button)

-- LMB - Linke Maus Taste (left mouse button)

-- MMB - Mittlere Maus Taste (middle mouse button)

http://students.autodesk.com/
http://www.microsoft.com/windows/directx/
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2. Grundlagen
„Without having a goal it is difficult to score.“ Paul Arden

Umsetzung einer Idee in Maya
Abgesehen von Pre- und Post-Production ist jeder Arbeitsschritt in Maya mithilfe von Modulen realisiert. Diese 
Modularisierung wird durch das Node-Konzept von Maya unterstützt. D.h. jedes Objekt ist ein Node und hat Ein- 
und Ausgabeverbindungen zu anderen Nodes. Daher können z.B. Modell und Materialien unabhängig voneinander 
erstellt und erst im finalen Schritt durch Verbinden der Nodes zusammengeführt werden. Dies ermöglicht flexible 
Workflows.

3D Animation Pipeline

Pre-Production
Im Pre-Production Schritt arbeitet man mit „Storyboards“ und „Layouts“. Enthält die Animation Charaktere, fertigt 
man auch sogenannte „Model Sheets“ an. 

Storyboard
Die beste Art und Weise ein Storyboard anzufertigen, ist weiterhin mit Papier und Stift. Es eignen sich schon sehr 
grobe Konzeptzeichnungen um den späteren Inhalt der Szenen darzustellen. Das Storyboard zieht sich dann bei der 
Umsetzung wie ein roter Faden durch alle Produktionsschritte.

Storyboards können auch in einfache Animatics (Stop-Motion Clips) umgewandelt werden um ein Gefühl zu bekom-
men ob die Szenen zeitlich zueinander passen.

Layouts
Ist das Storyboard fertig und entspricht die Umsetzung den eigenen Vorstellungen, versucht man das Layout der 
einzelnen Elemente festzulegen, z.B. das Aussehen der gesamten Umgebung oder Details wie die Art der Kostüme 
von Charakteren.

Model Sheet
Für die Charaktere werden Model Sheets angelegt um sich ein klareres Bild vom Aussehen der Welt und der Cha-
rakteren sowie deren möglicher Bewegungen. Dies sind wichtige Vorüberlegungen für den Aufbau und die nötige 
Flexibilität des Charakters.

Animatic
Das Storyboard wird grob umgesetzt, damit man schnell sehen kann wie die Animation wirkt. Dies ist notwendig 
um ein Gefühl zu bekommen ob die Animation funktioniert oder nicht. 

Man kann gar nicht genug betonen wie wichtig es ist einen klaren Überblick über das gesamte Projekt zu haben. 
Ein  Storyboard ist unverzichtbar, Layouts und Modelsheets erleichtern die Visualisierung. Vorallem bei der Arbeit 
in einem Team hat jedes Mitglied eine eigene Vorstellung von der Animation. Diese vorgestellten Hilfsmittel helfen 
Missverständnisse zu vermeiden.

Production

Post Production
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User Interface
Das Interface ist Anfangs sehr überwältigend mit vielen verschiedenen Einstellungsmöglichkeiten und versteckten 
Funktionen. Es ist nicht notwendig alle Funktionen auf einmal zu lernen. 

Erstes Starten von Maya
Als Standardansicht wird ein Panel mit der Kameraansicht “Perspective” (kurz persp) angezeigt. 

Panels
Jedes Panel hat sein eigenes Panel Menü sowie eine Leiste mit Anzeigeoptionen. In einem Panel wird standardmäßig 
die “Camera View Type” eingeblendet, sowie ein “Axis Direction Indicator”.

Dieses Panel hat den Titel “persp”, da man auf die Szene durch die perspektivische Kamera blickt.

Der Ursprung (Origin) des Koordinatensystems in einem Grid befindet sich in dem Schnittpunkt der beiden schwar-
zen Linien. Alle Werte in Maya werden relativ zu diesem Punkt errechnet.

Menu Bar
Die Funktionen von Maya sind in mehrere Menu Sets gegliedert: Animation (F2), Polygons (F3), Surfaces (F4), Dy-
namics (F5), Rendering (F6), nDynamics (F7). 

In jedem neuen Menu Set ändern sich Menüeinträge. Falls ein bestimmter Menüpunkt nicht auffindbar ist, sollte 
man überprüfen ob man sich im richtigen Menu Set befindet.

Anmerkung: Alle Menüs können als 
Tearoff Menü, also als kleines eigen-
ständiges Fenster benutzt werden. So 
bleiben sie auch bei einem Wechsel 
des Menu Sets bestehen. 

Arbeiten im 3D-Raum
Die Arbeit im 3D-Raum ist vergleichbar mit dem Umgang einer Kamera in der Realität. Durch die Kamera sieht man  
nur einen  bestimmten Ausschnitt aus der Welt. Wenn man ein Objekt aus verschiedenen Blickwinkeln betrachten 
will, so muss man die Kameraposition verändern. Bedingt durch den Öffungswinkel treten Verzerrungen auf.  

Die perspektivische Kamera in Maya hat eine 35mm Öffnung, dies entspricht der natürlichen Wahrnehmung (28-
58mm).

Eine alternative Darstellung im 3D-Raum ist die orthografische Ansicht, dies entspricht z.B. Blaupausen. Alle Projek-
tionsstrahlen sind parallel zueinander. In Maya entspricht das der „Top“, „Side“ und „Front“-view.

Oben links: „top-View“, Oben rechts: Perspective-View(„persp“) Unten links: „front-View“, 
Unten rechts: Side-View

Eine Besonderheit von 3D-Programmen ist, dass die Kamera, mithilfe von Clipping Planes, keine Objekte anzeigt die 
zu nah oder zu weit entfernt von der Kamera sind. Dies ist für die optimierung notwendig und verhindert aufwendige 
Berechnungen um kaum sichtbarare Objekte, bzw. Objekte die das gesamte Bild einnehmen würden darzustellen.

Koordinatensystem
Viele 3D-Programme benutzen ein kartesisches Koordinatensystem. Der Ursprung liegt im Punkt XYZ (0,0,0).

Die Startperspektive von Maya zeigt ein kleines Koordinatengitter (Grid) welches die XZ-Ebene auf dem NullPunkt 
repräsentiert. Die positiven Y-Werte sind über der XZ-Ebene.

Die Standard Werkzeuge

In Maya werden die Achsen durchgehend im gleichen Farbschema dargestellt: Rot für X, Grün für Y und Blau für Z.
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Status Line

Die Status Line ist in mehrere Elemente aufgeteilt:

Menu Set Dropdown - zeigt das aktuelle Menu Set an und ermöglicht den Wechsel in andere.

File System Icons  - New Scene, Open File, Save File

Selection Set (ausgeblendet) - eine Kontrolle für die gerade aktive Selektionsart.

Selection Mode Icons - verändert das allgemeine Selektierverfahren.

Selection Mask Icons - lassen den ausgewählten Selektionsmodus noch genauer bestimmen.

Snapping Icons - ermöglichen, dass Objekte an Objekten/Komponenten einschnappen.

Rendering Icons - die grundlegenden Renderingtools und -einstellungen.

Select Field - ermöglicht eine genaue Transformation des gerade selektierten Objekts.

Anmerkung: Elemente der Status Line können ein- und ausgeblendet werden. Ausgeblendete Teile sind markiert mit 
einem kleinen Dreieck, eingeblendete Teile mit einem kleinen Viereck. Durck klicken auf das Symbol wird der Teil  
der Leiste ein bzw. ausgeblendet.

Shelf

Curves Shelf

Die Shelf wird verwendet um schnell an Tools zu gelangen. Es stehen mehrere Shelfs zur Verfügung für den jeweiligen 
Arbeitsbereich in Maya. Mit einem einzigen LMB klick wird ein Befehl ausgeführt, mit doppelklick öffnet sich das 
Optionsmenü für das Werkzeug (falls vorhanden).

Anmerkung: Um effektiver mit Maya zu arbeiten kann man auch eine eigene Shelf anlegen, bzw. die vorhandenen 
modifizieren.Um Menübefehle hinzufügen, drückt man STRG+SHIFT und klickt mit der linken Maustaste auf den 
entsprechenden Menübefehl. Der Befehl wird nicht ausgeführt, aber ein Icon für den Befehl wird der aktiven Shelf 
hinzugefügt. Mit MMB-klickdrag kann man die Reihenfolge der Werkezeuge verändern. Anschließend um die mo-
difizierung zu speichern auf das kleine Dreieck an der linken Seite klicken und „Save Shelf“ auswählen.

Channel Box / Layer Editor
Im Channel Box werden die typischen Eigenschaften eines selektierten Objekts aufgelistet; diese Werte werden per 
Tastatureingabe verändert. Durch selektieren mehrerer Felder gleichzeitig können diese simultan auf den gleichen 
Wert gesetzt werden. Im unteren Bereich INPUT sieht man die Konstruktions-Nodes des Objekts.

Der Layer Editor lässt Objekte verschiedenen Layern zuordnen. Es gibt drei Typen von Layern. Mit einer „Display“-
Layer lässt sich die Sichtbarkeit von Objekten verändern. Mit einer „Render“-Layer verändert man das Verhalten der 
Renderengine für die selektierten Objekte und mit „Animation“-Layern kann man die Animationen eines Objects 
aufteilen.

Time Slider

Time Slider

Der Time Slider ist eine Zeitlinie, mit der zu bestimmten Frames gesprungen werden kann (LMB auf die Leiste oder 
manuelle Eingabe im Feld neben der Leiste). Keyframes werden darauf als rote Striche angezeigt; durch Selektieren 
und Gedrückthalten von MMB lassen sich diese verschieben. Am Ende der Leiste sind die Playback Controls um die  
Frames abzuspielen.

Range Slider

Range Slider

Mit dem Range Slider manipuliert man die Zoomstufe des Time Sliders. Mit den Zahleneingaben kann man die 
Anzahl der Frames verändern. Der Schlüssel am Ende der Bar ist der Auto-Keyframe Toggle. Wenn dieser aktiviert 
ist, fügt er animierten Objekten automatisch neue Keyframes zu wenn sie in einem Frame verändert werden.

Command Line

Command Line

Hier können direkt MEL oder Pythonbefehle eingeben werden. Auf der rechten Seite sieht man den Konsolen-
Output. Falls irgendeine Operation fehlgeschlagen, verfärbt sich der Konsolenuntergrund rot. 

Der Button am Ende der Zeile öffnet den Skript Editor, der alle bisher ausgeführten Befehle auflistet. Klickt man auf 
die Aufschrift MEL lässt sich zu der Python-Eingabe wechseln. 

Toolbox

ToolBox

Die Toolbox bietet Zugriff auf alle grundlegenden Manipulationswerkzeuge und wird wegen den zugehörigen Key-
boardshortcuts auch QWERTY-Tools genannt (siehe Bild).

Der untere Bereich „Views“ bietet eine Auswahl verschiedener Panel-Views. Diese unterteilen den Bildschirm in meh-
rere Fenster um effizientere Workflows zu ermöglichen. Maya bietet hierzu einige vorgefertigte Panel-Layouts, wie die 
Four View. Man kann auch seine eigenen Layouts anlegen.
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Help Line

Help Line
Die Help Line zeigt das gerade verwendete Werkzeug an, sowie eine kurze Anleitung, wenn es sich um ein komplexes 
Tool handelt.

Marking Menus
Maya bietet viele sogenannte Marking Menus. Diese sind im Prinzip kontextabhängige Popup-Menüs, zeigen also je 
nach Kontext unterschiedliche Elemente an. Um einen Befehl im Menü auszuführen zieht man die Maus in Richtung 
des Befehls und lässt die Maustaste wieder los.

Das am meisten verwendete Menü läasst sich durch gedrückthalten von der RMB öffnen. Für ein Objekt lässt sich so 
beispielsweise die Darstellungsweise ändern, während sich auf leerem Raum ein Selektionsmenü öffnet. 

Um schnell das aktive Menu Set zu wechseln, lässt sich ein Marking Menu  mit  RMB + H aufrufen.

RMB auf einer NURBS Sphere und das 
dazugehöringe Marking Menu

Maya Nodes
In Maya wird jedes Element (Kurven,  Polygon-Objekte, Texturen, etc.) als Node bzw. als Netzwerk von verbun-
denen Nodes repräsentiert. Man kann sich die Nodes visualisieren lassen im Hypergraph. Shading Nodes werden im 
Hypershade visualisiert (Siehe „Arbeiten mit dem Hypershade Editor“ Seite 70).  Um Werte von Nodes zu verändern 
benutzt man den Attribute Editor oder die Channel Box. 

Beispiel: Eine neu erzeugte Nurbs-Sphere hat vier Nodes (Create > Nurbs Primitive > Sphere):

1.	 Transform Node: Speichert alle Translationen, Rotationen und Skalierungen

2.	 Shape Node:  Verwaltet alle Eigenschafften über das Aussehen des Objekts

3.	 Input Node:  Enthält Informationen wie die Geometrie erzeugt wurde

4.	 Shading Node: Verwaltet die Material-Eigenschaften für den Render-Prozess

Anmerkung: Beim Duplizieren (STRG-D) eines Objekts werden nicht die Input Nodes dupliziert! Als Alternative 
muss man Edit > Duplicate Special mit der Option „Duplicate Input Connections“ verwenden.

Hypergraph
Der Hypergraph  lässt sich in zwei Modi ausführen:

Hierarchy
(Window> Hypergraph: Hierarchy) In diesem Modus wird die Hierarchie, also alle Eltern-Kind-Beziehungen der 
Objekte einer Szene graphisch dargestellt.

Hypergraph Hierarchy

Connections
(Window> Hypergraph: Connections) Man muss zunächst ein Objekt auswählen um dann den Hypergraph Con-
nections zu öffnen. Hier sieht man für ein einzelnes Objekt wie es mit anderen Nodes verknüpft ist. Man kann hier 
auch „hereinzoomen“ auf einzelne Objekte und die weiteren Connections der einzelnen Nodes sehen. 

Am Beispiel einer NURBS-Sphere werden folgende Nodes dargestellt: „makeNurbsSphere1“ (Input Node), „nurbs-
SphereShape1“ (Shape Node), „initalShadingGroup“ (Shading Node) und „nurbsSphere1“ (Transform Node)

Mit RMB auf den einzelnen Nodes lassen sich die Verbindungen zwischen verschiedenen Nodes erstellen. Mit DEL 
lassen sich Nodes löschen.

Hypergraph Connections
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Effektiv mit Maya Arbeiten
Um mit Maya effektiv zu arbeiten muss man die Keyboard-Shortcuts benutzen. Die am meisten benutzten Shortcuts 
sind ALT und eine Maustaste gedrückt für die Kamerasteuerung, sowie LEERTASTE kurz gedrückt um von der 
aktuellen Ansicht in die vorhergehende zu wechseln (dabei muss ein  Panel aktiv selektiert sein).

Camera Controls
Um sich im 3D-Raum zu bewegen, gibt es vier Möglichkeiten:

1.	 Tumble (Kamerarotation): ALT + LMB

2.	 Dolly (Kameraposition rein oder raus bewegen): ALT + RMB

3.	 Track (Kamera auf einer Schiene bewegen): ALT + MMB

4.	 Zoom: Mit dem Mausrad scrollen

Um zu einer bestimmten Stelle hinzuzoomen kann man auch STRG + ALT + LMB gedrückt halten und macht 
eine Selektion von oben nach unten. Um herauszuzoomen, selektiert man von unten nach oben.

Anmerkung: A verstellt die Kamera für einen optimalen Überblick auf die gesamte Szene. F fokussiert die Kamera 
auf die selektierten Objekte. Bei gleichzeitig gedrückt halten der SHIFT Taste wird die funktion für alle offenen 
Ansichten durchgeführt.

Hotbox
Bei länger gedrückt gehaltener  LEERTASTE erscheint die Hotbox. Diese enthält genau die gleichen Befehle wie die 
Menubar, spart aber den langen Weg mit der Maus zum Rand des Bildschirms.

Hotbox

Darüberhinaus ist das Menü in Zonen eingeteilt, in denen man mit der RMB Marking Menus öffnen kann. Der  
Maya Button in der Mitte der Hotbox ist auch eine Zone. Mit dessen Menü kann man schnell vom aktiven Panel in 
ein Standard-Kamerapanel (persp, top, side, front) wechseln.

Anmerkung: Die Hotbox kann so konfiguriert werden, dass sie nur das Menü des aktiven Moduls anzeigt.Hierfür 
öffnet man die Hotbox (LEERTASTE) und LMB auf Hotbox Controls, wählt aus dem Menü das gerade aktive Modul 
aus und wählt den Befehl „Show only <aktives Modul>“.

Attribute Editor
Der Attribute Editor, ist die einfachste Art und Weise Eigenschaften von Nodes zu verändern.

Öffnet man den Attribute Editor (STRG-A) findet man die gleichen vier Nodes wie im Hypergraph Connections Edi-
tor. Hier sind alle Einstellungsmöglichkeiten für die einzelnen Nodes. Zusätzlich lassen sich hier für viele Eigenschaf-
ten Keys für Animationen setzen. Hier kann ein Node umbenannt oder mit einem Kommentar versehen werden.

Der Attribute Editor
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Überblick der wichtigsten Shortcuts
Die QWERTY-Tools, (Q Select Tool, W Move Tool, E Rotate Tool, R Scale Tool, T Show Manipulator, Y Last Tool 
Used) sind wohl die am häufigsten benutzten Tools in Maya. Die dazugehörigen Tastaturkürzel sind  gleichbleibend 
über das gesamte Programm und können in vielen Interaktionsfenstern benutzt werden.

General

STRG-S Speichern (oft benutzen)
Q Select
W Move Tool
E Rotate Tool
R Scale Tool
T Show Manipulator Tool
Y Last Used Tool

Z Undo
SHIFT – Z Repeat

D Toggle Edit Pivot Point (nur mit Move,Rotate, Scale)
INS Edit Pivot Point

STRG-D Duplicate

STRG-SHIFT-D Duplicate Special
SHIFT-D Duplicate with previous Transform
STRG-A ChannelBox/Attribute Editor

Camera
ALT + LMB Tumble (rotieren)
ALT + RMB Dolly (Zoomen)
ALT + MMB Track 

Snapping

X Toggle Grid Snapping
C Toggle Curve Snapping
V Toggle Point Snapping

Animation

SHIFT-W Transform Keyframe
SHIFT-E Rotate Keyframe
SHIFT-R Scale Keyframe 

S Key All (Keyframe für Transform, Rotate, Scale)

	

Displayeigenschaften des View Panels
Alles was man in den ViewPanels sieht ist eine stark vereinfachte vorschau auf die späteren Objekte. Erst mit dem 
Rendervorgang wird das finale Bild erzeugt.

In View Panels kann man mit 1(geringe Qualität), 2(mittlere Qualität), 3(hohe Qualität) die Displayqualität des 
selektierten NURBS-Objekts verändern - dies hat keinen Einfluss auf das spätere Rendern. (Am Beispiel einer Nurbs 
Sphere Create> Nurbs Sphere)

Nurbs low (1) Nurbs medium (2) Nurbs Default (3)

Bei Polygon-Objekten wird beim Benutzen der Taste 2 (Smoothing with Polycage), oder 3 (Smooth Mesh Preview) 
ein Smoothing angewendet. Dies hat Einfluss auf das spätere Rendern. Mit 1 kann man den ursprünglichen Zustand 
wiederherstellen. (Am Beispiel einer Poly Sphere Create> Poly Sphere)

Poly Default (1) Poly Cage Display (2) Smooth Mesh Preview (3)

Am Anfang sind alle Panels von Maya im Wireframe Modus (Taste 4). d.h. Maya stellt alle Objekte als Gitterobjekte 
dar. Man kann in einen Shaded Modus mit der Taste 5 wechseln. In diesem Modus werden die Flächen angezeigt. 
Hat man dem Objekt eine Textur dem Objekt zugewiesen so lässt sich eine Vorschau mit der Taste 6 anschalten. Sind 
Lichter in der Szene vorhanden lässt sich eine Vorschau der Lichter mit der Taste 7 aktivieren.

Wireframe Modus (4) Shader Modus (5) Shader mit Texturen Modus (6)
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Weiterführende Literatur
Maya Dokumentation
Die Hilfe-Datei bzw. die Dokumentation von Maya ist äußerst umfangreich ist und sehr viele Probleme mit anschau-
lichen Beispielen erklärt. (Entweder dem Link folgen oder die Taste „F1“ in Maya drücken

http://download.autodesk.com/global/docs/maya2014/en_us/index.html

Getting Started Manual
Das offizielle Einsteiger-Handbuch stellt viele grundlegenden Funktionen von Maya vor.

http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=9502844&linkID=9242256

Autodesk Area Community

Die Autodesk Area Community hat eine Sammlung von mehreren Tutorials und nützlichen Plugins, wie z.B. die 
Maya Bonus Tools.

http://area.autodesk.com/

Bonus Tools: http://area.autodesk.com/bonus_tools

Maya Station
Der offizielle Blog vom Maya Support Team. Insbesondere wichtig für Maya Updates und Workarounds für existie-
rende Bugs.

http://mayastation.typepad.com

CG Society - Society of Digital Artists
Eine umfangreiche Website mit Forenbereich und interessanten Informationen über die aktuellen Neuigkeiten in der 
CG-Szene. 

http://www.cgsociety.org/

Maya Tutorial Sammlung: http://forums.cgsociety.org/showthread.php?threadid=6360

FXGuide
Beschäftigt sich primär mit Neuigkeiten aus dem Visual Effects Bereich.

http://www.fxguide.com/

Creative Crash
Eine Plattform auf der sich 3D-Artists, Modelle, Texturen etc. austauschen und Showcases von ihren Arbeiten zeigen 
können.

http://www.creativecrash.com/

Tuts+ Network
Das Tuts+ Network verfügt über eine Reihe von verschiedenen Websites die sich über viele medienrelevante Themen 
beschäftigt. Das CGTuts+ beschäftigt sich mit  Maya, 3DSMax, Blender etc. und bietet neben Tutorials auch Tex-
turen und andere Ressourcen.

http://cg.tutsplus.com/

Lynda.com
Eine Website mit kostenpflichtigen Video Tutorials für viele verschiedenene Programme. Hat sehr gut ausgearbeitete 
Einführungen in komplexe Maya Themen.

http://www.lynda.com/Maya-training-tutorials/255-0.html

Digital Tutors
Der offizielle Autodesk Partner für Video Tutorials für Maya.

http://www.digitaltutors.com/11/training.php?cid=5

Maya Einstellungen
Fast alles in Maya kann individuell eingestellt werden. Es ist zu empfehlen folgende Einstellungen vorzunehmen:

Infinite Undo/Redo aktivieren
Undo (Z) und Redo (SHIFT-Z) sind standartmäßig auf 50 Undo-Schritte limitiert. Das hört sich zwar nach einer 
hohen Zahl an, in Realität ist diese Schrittanzahl viel zu niedrig angesetzt.

Dies lässt sich ändern unter Window > Settings and Preferences > Preferences - (Settings) - Undo. Dort setzt man 
die Queue auf Infinite oder einen beliebigen  anderen Wert.

Autosave aktivieren
Maya stürzt oftmals ab bei komplexen Berechnungen, das ist leider öfters der Fall als man vermutet. Es ist ratsam das 
Autosave feature zu aktivieren:  Unter Window > Settings and Preferences > Preferences - (Settings) - Files/Projects 
bei dem unter dem Punkt Autosave bei Enable ein Häckchen setzen.

Man sollte die Anzahl der Autosaves begrenzen, ansonsten läuft man Gefahr die gesamte Festplatte vollzufüllen mit  
Dateien.

ViewCube deaktivieren
Der ViewCube „vereinfacht“ das benutzen von Maya, aber in den meisten Fällen verändert er die Kameraeinstel-
lungen und führt zu verwirrungen. Darüberhinaus verleitet dazu, nur mit der Maus innerhalb eines Panels zu arbei-
ten, anstatt sich mit Tastaturkürzeln auseinanderzusetzen. 

Daher sollte man den Viewcube deaktivieren indem man unter Window > Settings and Preferences > Preferences 
- (Interface) - ViewCube das Häckchen bei „Show ViewCube“ entfernt.

Interactive Creation deaktivieren
Interactive Creation erlaubt es interaktiv eine Geometrie in ein Viewport zu erzeugen. Jedoch weichen dabei unter 
Umständen die Eigenschaften von einer direkt erzeugten Geometrie ab. Außerdem ist es in den meisten Fällen ein-
facher eine Geometrie direkt zu erzeugen um sie dann mit den QWERTY-Tools anzupassen.

Alle Beispiele im Skript verwenden keine Interactive Creation. Man deaktiviert Interactive Creation indem man das 
Häcken unter Create > NURBS Primitives > Interactive Creation, sowie bei Create > Polygon Primitives > Interac-
tive Creation entfernt.

Hintergrund Gradient deaktivieren
Um klarer mit Maya zu arbeiten kann der Hintergrund Gradient von Panels deaktiviert werden indem man unter 
Window > Settings and Preferences > Preferences > Display - bei „Background gradient“ auf „Off“ schaltet.

Anmerkung: Um alle Einstellungen von Maya wieder zurückzusetzen löscht man einfach das Verzeichnis „prefs“. 
Man findet es unter: 
	 Windows 7:	 \Users\<username>\Documents\maya\2012-x64\en_US\prefs 
	 Mac OS X:          /Users/<username>/Library/Preferences/Autodesk/maya/en_US/2012/prefs 
	 Linux:		  ~/maya/2012-x64/prefs

http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=9502844&linkID=9242256
http://area.autodesk.com/
http://mayastation.typepad.com
http://www.cgsociety.org/

http://forums.cgsociety.org/showthread.php?threadid=6360
http://www.creativecrash.com
http://cg.tutsplus.com/
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3. Modelling
In Maya gibt es drei Typen von Geometrie: NURBS, Polygon und Sub-Division Surfaces. Jeder dieser Typen hat 
seine eigenen Vor- und Nachteile. Diese verschiedenen Geometrietypen können innerhalb einer Szene gemischt ver-
wendet werden.

Beim Modellieren können verschiedene grundsätzliche Vorgehensweisen verwendet werden. Für welchen man sich 
entscheidet, hängt dabei von persönlichen Präferenzen ab.

Spline/Curve-Modelling
Beim Spline-Modelling  zeichnet man die äußeren Kanten eines Objekt (ähnlich einer Blaupause) und lässt Maya die 
Geometrie aus den Kurven erstellen. 

Box-Modelling
Man manipuliert Primitive solange, bis sie die gewünschte Form haben. Der Vorteil dieser Variante ist, dass man von 
einem groben Modell ausgehen kann, das dann Schritt für Schritt verfeinert wird.

Sculpting
Beim Sculpting erzeugt man eine Rohmasse, die man d durch Abtragen, Hinzufügen oder Verformen zu dem ge-
wünschten Ergebnis hin bearbeitet. Man muss sich das vorstellen wie mit Ton oder Marmor zu arbeiten. Maya ist 
nicht auf Sculpting spezialisiert, es bietet nur einfache Werkzeuge dafür. Pixologic ZBrush oder Autodesk Mudbox 
ist spezialisiert auf Sculpting und kann Maya Geometrien importieren und bietet deswegen hierfür nur einfache 
Werkzeuge.

Workspace Einstellungen

Menü
Um mit Nurbs zu arbeiten braucht man das Menü „Surfaces“ (F4). Um mit Polygonen zu arbeiten braucht man das 
Menü „Polygons“ (F3). Sub-Divs ist eine zwischenform zwischen Poly und Nurbs und benötigen beide Menüs.

Panels
Grundsätzlich benutzt man beim Modelling zwei Perspektiven, die Single View Perspective und die Four View Per-
spective. Zwischen ihnen kann durch kurzes drücken der LEERTASTE gewechselt werden.

Single View Perspektive
Die Single-View Ansicht bietet mit einer perspektivischen Kamera einen Überblick über die Szene. Sie ist die Stan-
dardansicht in Maya (im Menü: Window >  Saved Layout >  Single Perspective View). 

Anmerkung: Mit STRG-LEERTASTE lassen sich alle UI-Elemente (wie die Toolbox, Timeline etc.) ausblenden. 
Drückt man ein weiteres mal STRG-LEERTASTE so lassen sich die ausgeblendeten Elemente wieder einblenden.

Four View Perspective 
Diese Perspektive erlaubt einen schnellen Wechsel zur orthographischen Ansicht der Szene. Einzelne Fenster der 
Perspektive lassen sich über den ganzen Bildschirm ausweiten, indem der Mouse-Cursor über das gewünschte Fenster 
bewegt und LEERTASTE gedrückt wird.

Shelf
Maya bietet für jeden Modellier-Typ eine eigene Shelf an: „Curves“ und „Surfaces“ für das NURBS Modelling, „Po-
lygon“ für das Polygon- und „SubDiv“ für das SubDivision Modelling. Darüber hinaus  kann die „Deformers“ Shelf 
für einfachen Zugriff auf Deformations-Werkzeuge verwendet werden.

Curves Shelf

Surfaces Shelf
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CV-Curve Tool der Curves-Shelf hinzufügen
Das CV-Curve Tool wird sehr häufig verwendet und sollte der Curves-Shelf hinzugefügt werden.

1.	 Shelf auf Curves setzen.

2.	 Den Menüpunkt Create > CV-Curve mit STRG+SHIFT und der LMB auswählen. Am Ende der Shelf sollte 
ein neues Icon erscheinen.

3.	 Das neue Icon mit MMB neben das EP-Curve Tool ziehen. (siehe Abb.)

Polygon Shelf

NURBS - Grundlagen
Definition
Non-Uniform Rational B-Spline (kurz: NURBS) sind eine Weiterentwicklung von Bézier-Kurven. Im 3D-Raum 
kann man mehrere solcher Kurven verwenden um eine Oberfläche (Surface) aufzuspannen.

Es gibt zwei verschiedene Arten um eine NURBS Geometrie zu erzeugen:

•	 Man zeichnet Kurven in den Raum und lässt die Fläche auf Grundlage dieser Kurven erzeugen. 

•	 Man manipuliert ein Primitiv (z.B. Sphere, Cylinder, Cone, etc. mit Ausnahme des Box Primitivs) solange bis 
die gewünschte Form erreicht

In den meisten Fällen wird ersteres (sogenanntes Curve-Modelling) mit NURBS betrieben.

Curves
Eine einfache Kurve besteht aus einem Span, einer Linie zwischen zwei Edit Points (EP). Die Anzahl der Control 
Vertex Points (CV) richtet sich nach dem Grad der Kurve + 1. So hat eine Linear Curve (Grad 1) 2 CV Points, eine  
Cubic-Curve (Grad  3) entsprechend 4 CV Points.

Eine komplexe Kurve besteht aus multiplen Spans. Die Kurve verläuft durch die Edit Points und werden durch die 
CV-Points „angezogen“.

NURBS Curves können auf zwei unterschiedliche Arten erstellt werden:

•	 EP-Curves: Beim Erstellen der Curve werden die Edit Points gesetzt

•	 CV-Curves: Beim Erstellen der Curve werden die Control Vertex Curves gesetzt

Man zeichnet die Kurven indem man die Punkte mit LMB auf die top, side oder front view setzt. Man zeichnet kaum 
in der perspektivischen Ansicht Kurven. Alle Punkte werden auf der XZ-Ebene gezeichnet es passiert leicht, dass die 
Linie perspektivisch verzerrt wird. Zum Abschluss bestätigt man mit ENTER.

NURBS Curve Components
Neben dem Objekt-Modus lassen sich auch Komponenten eines Objektes selektieren und modifizieren. Hierfür RMB 
auf das Objekt klicken und wählt den entsprechenden Darstellungsmodus aus dem Selektions-Menü aus.

Edit Point
Mit Edit Points kann man leicht erkennen aus wievielen Spans eine Kurve besteht. Ihre Position kann zwar verändert 
werden, dies passiert jedoch nur sehr selten bzw. nur für sehr geringfügige Anpassungen. CVs eignen sich viel besser 
um Curven zu modifizieren.

Control Vertex
CV-Points beinflussen indirekt die Form der Kurve. Die ersten beiden Control Vertex (CV) Punkte einer Kurve 
werden als zwei hohle Quadrate angezeigt, , um die Richtung der Kurve zu verdeutlichen. Die restlichen CVs sind 
dann ausgefüllte Quadrate. 

Da CVs nur Punkte im Raum sind, kann nur ihre Position im Raum verändert werden (Move Tool W). Selektiert man 
mehrere CVs so kann man in Relation zu dem Pivot Point skalieren und rotieren. Beim Skalieren werden die Punkte 

Oben Edit Points, Unten CV-Points Eine CV-Point erstellte Curve Eine EP-Point erstellte Curve
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eigentlich nicht skaliert, sondern nur im Raum bewegt.

Curve Point
Ein Curve Point ist ein selektierter Punkt auf der Kurve, der nicht verändert werden kann. Man kann mit (Edit Cur-
ves > Insert Knot) diesen Punkt als Edit Point der Kurve hinzufügen. So erhält man einen neuen Edit Point und die 
entsprechende Anzahl von CVs.

Curve Tools
Hier wird nur eine Auswahl an häufig benutzten Curve Tools vorgestellt. Alle Befehle findet man im Menü 

Anmerkung: Viele der Curve Tools haben bei der Eigenschaft „Keep Originals“ ein Häckchen gesetzt. Mit dieser Op-
tion bleiben die ursprünglichen Kurven erhalten, wenn das Tool verwendet wird. Da sie meistens jedoch nicht mehr 
benötigt werden, kann das Häckchen entfernt werden.

Attach Curves
„Attach Curves“ verbindet mehrere Kurven. Die Reihenfolge in der die Kur-
ven selektiert werden vor allem in größeren Verbänden spielt eine Rolle. Es 
wird immer das Ende der ersten Kurve mit dem naheliegensten Start- bzw. 
Endpunkt der nächsten Kurve verbunden. In den Optionen lassen sich zwei 
Modi auswählen:

Im Modus „Blend“ werden beide Kurven ineinander übergeblendet.  Der 
„Blend Bias“-Faktor stellt eine Gewichtung dar, welche der beiden ausgewähl-
ten Kurven von den Veränderungen weniger beeinflusst wird. Ein Wert von 
0.5 lässt beide Kurven gleichviel manipuliert werden. Bei einem Faktor von 
1.0 wird die erste Kurve gering beinflusst, bei 0.0 entsprechend die zweite. 

Anmerkung: Um den gewünschten Effekt zu erzielen, können auch höhere 
Werte als 1.0 bzw. niedrigere Werte als 0.0 eingegeben werden. 

Im Modus „Connect“ wird die erste Kurve vollkommen unberührt gelassen 
und die zweite Kurve wird verformt um eine direkte Verbindung zum End-
punkt der ersten Kurve herzustellen. Dies kann zu sehr spitz verlaufenden Er-
gebnissen führen. Dies kann durch setzen des Häckchens bei „Keep Multiple 
Knots“ vermieden werden.

Detach Curves
Man trennt Kurven mit „Detach Curves“. Man selektiert die Stelle an der man die Kurve trennen möchte mithilfe 
eines „Curve Point“ oder „Edit Point“ der Kurve und trennt sie anschließend mit „Detach Curves“. 

Open/Close Curves
Mit Open/Close Curves schließt bzw. öffnet einen Kreis an der Seam Stelle (Der Beginn/Ende eines Kreises).

Cut Curves
Zwei Kurven können mittels „Cut Curves“ an ihrem Schnittpunkt getrennt werden. Es entstehen vier Kurven.

Duplicate Surface Curves
Selektiert man ein Isoparm auf einem Nurbsobjekt, so lässt sich dieses Isoparm extrahieren als eigene Kurve mit dem 
„Duplicate Surface Curves“. (Siehe „Isoparm“ Seite 33)

Bézier Curves
Man kann auch Bezier Curves ähnlich wie z.B. das Pen Tool in Adobe Illustrator verwenden. Eine detaillierte Anlei-
tung zum Tool findet sich in den Tool Settings (Window > Setting and Preferences > Tool Settings).

Die Kurven wurden erst mit Maya 2011 eingeführt. Sie können in den meisten Fällen genauso verwendet werden wie 

Attach Curves mit Blend

Attach Curves mit Connect

normale Curve-Objekte. Wenn Fehler auftreten kann man mit Edit > Convert > Bezier to Nurbs die Kurve zu einer 
Nurbs-Curve umwandeln und gegebenenfalls manuell anpassen.

Nurbs Primitive erzeugen
Man erzeugt Nurbs Primitive mit Create > Nurbs Primitives. Man muss beachten, das Objekte mit ein harten Kan-
ten (z.B. Würfel, Zylinder, Kegel) als Gruppe von unabhängigen Ebenen erzeugt werden. Insbesondere der Würfel 
sollte gemieden werden und stattdessen ein Polygon Würfel benutzt werden.

Surface Components
Neben dem Objekt-Modus lassen sich auch Komponenten eines Objektes selektieren und modifizieren. Hierfür RMB 
auf das Objekt klicken und wählt den entsprechenden Darstellungsmodus aus dem Selektions-Menü aus.

Isoparm
Isoparametric curves (auch Isoparm genannt) sind Linien die entlang der Oberfläche laufen und die Geometrie defi-
nieren. Sie haben ein eigenes Koordinaten System mit den Achsen UV. Isoparms können nicht manipuliert werden. 

Man kann jediglich neue Isoparms der Geometrie hinzufügen. Hierfür klickt man an die Stelle an der man ein Iso-
parm einfügen möchte (gestrichelte Linie) und fügt sie mittels Edit Nurbs > Insert Isoparm es der Geometrie hinzu.  
So werden der Geometrie mehrere CV-Points hinzufügt die man manipulieren kann um die Geometrie genauer zu 
definieren.

Control Vertex
Ein Control Vertex (CV) kontrolliert alle darunterliegenden Isoparms. Da CVs nur Punkte im Raum sind, kann man 
sie nur mit dem Move Tool (W) manipulieren. Selektiert man mehrere CVs so wird in Relation zu dem Pivot Point 
skaliert und rotiert. 

Hull
Die Hull Ansicht verbindet alle CVs eines Isoparms und lässt so das darunterliegende Isoparm manipulieren. Man 
kann sie skalieren, rotieren und bewegen.

Ein selektiertes Isoparm (gelb) Ein selektierter CV (gelb) - der Einfluss des 
Cvs auf das Objekt ist weiß dargestellt

Eine selektierte Hull dessen CVs sind gelb  
dargestellt
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Surface Tools
All diese Tools findet man im Modul „Surfaces“ unter Surfaces. Für eine bessere Übersicht in den Beispielbildern 
wurden die Objekte verschoben, um die Ursprungskurven sichtbar zu machen.

Revolve Tool
Das Revolve Tool rotiert eine Kurve um eine Achse um einen Schwingkörper zu erzeugen.

Um das Revolve Tool zu verwenden muss man eine Kurve ausgewählt haben. Die Kurve wird dann um eine Achse 
(Default y-Achse des Pivot Points) geschwungen. An den Editpoints der Kurve werden Isoparms erzeugt. Durch die 
Anzahl der „Sections“ wird die Zahl der Isoparms in U-Richtung festgelegt.

Standartmäßig wird ein Schwingkörper um die gesamte Achse also von 0°-360° erzeugt.  Möchte man andere Werte 
eingeben öffnet man den ChannelBox Editor -> Input -> revolve und setzt neue Werte für „Start Sweep“ (Startwinkel) 
oder „End Sweep“ (Endwinkel).

Loft
Ein Loft erzeugt eine Fläche zwischen mindestens zwei Kurven. Sollen mehrere Kurven verwendet werden, ist die 
Reihenfolge in der sie selektiert werden von Bedeutung.

Beim erstellen der Geometrie wird jeder Edit Point mit einem Isoparm mit dem Edit Point der anderen Kurve verbun-
den. Man sollte darauf achten, dass die verwendeten Kurven über die gleiche Anzahl von Edit Points verfügen.Anson-
sten erhält man eine ungleiche Verteilung von Isoparms auf dem neuen Objekt und kann zu Problemen führen. Um 
die Anzahl der Edit Points anzugleichen, ist  Edit Curves > Insert Knot sehr hilfreich. (Siehe „Curve Point“ Seite 32)

Loft mit zwei Kurven

Ein Revolve Objekt.

Planar
Ein Planar ist eine Fläche, die definiert wird durch eine in einer Ebene liegende geschlossene Kurve (z.B. Kreise, 
Rechtecke). Es ist auch möglich mehrere Kurven zu verwenden. Liegt eine Kurve innerhalb einer anderen Kurve, so 
wird das innere Objekt ausgeschnitten.   

Ein Planar ist ein rechteckiges Nurbs Planar. Wenn man z.B. ein kreisförmiges Planar erzeugt, so ist es nur optisch 
ein Kreis. Man hat keine CV-Points um den Rand zu manipulieren. Der Kreis wurde auf die Fläche projeziert und 
dann mit dem Trim-Tool ausgeschnitten. Daher ist der Rand eines Planars kein Isoparm sondern eine Trim Edge.

Man sollte es vermeiden Planar Objekte zu verwenden. In manchen Situationen bieten sie aber eine schnellere und 
einfachere Lösung. Alternativ können unter Umständen Boundaries (Siehe „Boundary“ Seite 36) verwendet werden.

Extrude 

Ein NURBS Extrude hat drei Modi:

-- Tube: Erzeugt eine Fläche indem es eine Profil-Kurve entlang einer Pfad-Kurve gezogen wird. Die Reihen-
folge wie man die Curves selektiert definiert dessen Aufgabe. 

-- Flat: Erzeugt eine Fläche wie im Tube Modus jedoch nur in einer Ebene 

-- Distance: Erzeugt eine Fläche mit nur einer Profil-Kurve und einer gegebenen Distanz

Tube Flat Distance

Planar: Es wird aus den 3 Kurven ein einziges Planar Objekt erzeugt
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Birail
Das Birail 1 Tool, Birail 2 Tool und Birail 3+ Tool erzeugen Flächen indem mindestens eine Profil-Kurve entlang zwei 
Schienen entlanggezogen werden. Der Abstand zwischen den Schienen definiert wie die jeweilige Kurve an diesem 
Punkt skaliert wird.

Benutzt man mehrere Profilkurven wird die Profilkurve zusätzlich von Profilkurve zu Profilkurve gemorphed. Man 
sollte daher darauf achten das alle Profil kurven die gleiche Anzahl von EP-Points haben.

Wichtig: Die Endpunkte der Profilkurven müssen auf den Schienen liegen. Dies stellt man sicher indem man Die 
Anfangs- und Endpunkt per Curve-Snapping (C) an den Schienen festmacht.

Boundary
Ein Boundary besteht aus 3 oder 4 Kurven und interpretiert eine Fläche zwischen diesen Kurven. Um das beste Er-
gebnis zu bekommen sollte man die Endpunkte der Kurven miteinander verbinden und sie sollten die gleiche Anzahl 
von EP-Points haben.

Boundary

Birail 1 Object

Bevel/Bevel Plus
Erzeugt eine abgeschrägte Fläche auf Basis der Kurve. 

Insbesondere Text lässt sich so einfach in eine Fläche umwandeln. In neueren Versionen von Maya ist das Bevel Plus 
tool integriert in dem Text Tool.

Bevel Object
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Martini Glas
Betrachtet man einen Martini, so besteht er aus einem Glas, einer Flüssigkeit, einem Stäbchen und einer Olive. Das 
Glas ist ein Schwingkörper,   es muss also zunächst eine Kurve erstellt und um die y-Achse rotiert werden.Als Flüs-
sigkeit wird vorerst ein kegelförmiges Objekt verwendet, welches genau das Innere des Glases ausfüllt.Das Stäbchen 
ist ein einfacher Zylinder und die Olive ist eine zu einem Oval deformierte Kugel 

Das Glas
1.	 Kurz die LEERTASTE drücken um aus der Single 

View in die Four View wechseln. 

2.	 Die Side View anklicken und kurz die LEERTA-
STE drücken um die Side View als Single View zu 
erhalten.

3.	 Das CV-Curve Tool selektieren und die Taste X 
(Grid-Snapping)  gedrückt haltend auf den Ur-
sprung klicken. Dies ist notwendig damit im spä-
teren Schwingkörper kein Loch entsteht. Danach 
kann man die Taste loslassen und die restlichen 
Punkte setzen um eine Querschnittslinie eines hal-
ben Martiniglases zu zeichnen (siehe Bild). Den 
letzten Punkt setzt man wieder mit gedrückt gehal-
tenem X auf die Y-Achse und drückt ENTER um 
die Kurve fertig zu stellen.

Anmerkung:  Die Tastaturkürzel - X (Grid), C (Curve), V (Point) wählen das Snapping nicht permanent aus. Wenn 
man das Snapping mit der Tastatur benutzen möchte, so muss man die Taste gedrückt halten. Alternativ kann man 
Snapping  dauerhaft auswählen indem man es im Menü mit der Maus anklickt.

4.	 Die Kurve im Object Mode (RMB auf das Objekt > Object Mode) selektierten und Surfaces > Revolve 
auswählen.

Die CV-Punkte des halben Martiniglas-Querschnittes

5.	 Man kann nun mit der Leertaste zurück in die Four View.

6.	 Das Glas kann man mit dem Move Tool auf der Z-Achse bewegen, 
damit die Kurve sichtbar wird.

7.	 Drückt man die Taste 5 so erscheint das Glas im Shaded modus. Mit 
der Taste 4 kommt man wieder in den Wireframe Modus.

8.	 Man kann nun die Kurve auswählen und im Control Vertex Mode 
(RMB auf das Objekt > Control Vertex) mit dem Move Tool (W) 
die Punkte verändern; das Glas verändert sich simultan mit, da es die 
Input-Curve ist.

Anmerkung: Wenn man die Kurve auswählt, so erscheint das Glas lila. Da-
mit wird angezeigt, dass die Kurve ein Konstruktions-Input für den Revolve-
Körper ist. Verändert man die Kurve, so wird das Objekt simultan mitver-
ändert.

9.	 Damit man nicht versehentlich das Glas verändert kann man die  
Curve nun löschen. Man selektiert sie im Object Mode und mit 
ENTF löscht man sie.

10.	 Das Glas selektiert man und im Channel Box macht man einen Dop-
pelklick auf „revolvedSurface1“ und benennt es “MartiniGlas”

11.	 Im ChannelBox setzt man TranslateZ auf 0

12.	 Speichern unter martini_glas.01.ma (Maya ASCII)

Flüssigkeit im Glas
1.	 Im Isoparm Modus (RMB auf das Objekt > Isoparms) selektiert 

man mit dem Selection Tool (Q) ein Isoparm welches die Höhe der 
Flüssigkeit darstellt (Siehe Bild). (Es sollte eine gelbe Linie, oder gelb 
gestrichelte Linie erscheinen)

2.	 Mit Edit Nurbs > Detach Surfaces trennt man das Glas in zwei Flä-
chen.

3.	 Auf eine der Teilflächen das gleiche Isoparm nochmal selektieren und 
dann Surface > Planar.

4.	 Man selektiert das Planar und das Revolve Objekt. (Am Mit STRG-
G gruppiert man sie und nennt sie “Liquid”.

5.	 Im Layer Editor (unter der ChannelBox) klickt man auf das Icon 
„New Layer with selected Objects“.

6.	 Mit Doppelklick auf der neuen Ebene kann man sie auf „Glas“ um-
benennen.

7.	 Man selektiert das „MartiniGlas“ und mit RMB auf der Ebene wählt 
man „Add Selected Objects“

8.	 Ändert man den Modus der Ebene auf “Template” durch klicken auf 
das mittlere Rechteck neben dem Ebenennamen. (Siehe Bild)

9.	 Speichern martini_glas.02.ma

Anmerkung:  Wenn sich Objekte auf einer Layer mit einem Displaytype 
„Template“ oder „Reference“ befinden, so sieht man die Objekte, kann sie 
jedoch nicht manipulieren. Man muss erst den Displaytype wieder auf Nor-
mal (leeres mittleres Rechteck) setzen um die Objekte wieder verändern zu 
können.

Grid-Snapping aktiviert

Schritt 4: Die Kurve selektiert mit der er-
zeugten Revolve-Surface

Schritt 13: Layers Controls - mit RMB 
auf den Ebenennamen öffnet alle Layer- 
Funktionen

Schritt 1: Selektierter Isoparm

Schritt 3: Fertiges Planar
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Die Olive
1.	 Create > Nurbs Primitives > Create Nurbs Sphere

2.	 Mit RMB auf dem Objekt wechselt man in den ControlVertex Modus 
bzw. Hull Modus.

3.	 Mit dem Move (W) und Scale Tool (R) manipuliert man solange die 
Controlvertex Punkte bis sie einer Olive ähnelt.

4.	 Das Objekt “Olive” nennen.

Der Zahnstocher
1.	 Create > Nurbs Primitives > Cylinder

2.	 Mit dem Scale-Tool (R) den Zylinder so manipulieren, dass er die 
Olive aufsticht.

3.	 Den Zylinder auf “Zahnstocher” umbenennen.

4.	 Die “Olive” und “Zahnstocher” gruppieren und im Martiniglas posi-
tionieren. (martini_glas.03.mb)

Rendervorbereitungen
1.	 Man ändert den Displaytype der Ebene “Glas” auf Normal

2.	 Selektiert alle Objekte und gruppiert sie (STRG-G) und benennt die 
Gruppe „MartiniGlas“.

3.	 Nun skaliert man die Gruppe, sodass sie eine Höhe von 3 Einheiten hat.    
(martini_glas.04.mb)

(Fortsetzung „Martini Glas Render“ Seite 88)

Übungsaufgaben
1.	 Eine Flasche Wein mit Weinglas modellieren.

2.	 Einen Chemie Baukasten, Reagenzgläser, Messbecher, Mörser mit 
Schale modellieren.

Anmerkung: Mit dem Edit Curves > Offset Curves lässt sich die Kurve re-
lativ zur Original Kurve  duplizieren und skalieren. So muss man nur die 
Äußere Kurve zeichnen und kann die Innere davon ableiten. (Und mit einer 
dritten Kurve und Attach Curves verbinden.)

Olive mit Zahnstocher

In der Front View angepasstes Glas

Spielwürfel
Ein Würfel hat stark abgerundete Ecken und somit einen Kreis als Grund-
form jeder Seite. Die Punkte sind meistens in die Flächen gestanzt. Betrachtet 
man den Würfel genauer erkennt man die Distribution der Punkte, addiert 
man die Punkte der zugewandten Seite mit der abgewandten Seite ergibt sich 
immer 7.

Grundform
1.	 Create>Nurbs Primitves> Circle (Channel Box > makeNurbCircle1 

> Radius 3)

2.	 STRG-D um den Kreis zu duplizieren.

3.	 Das Duplikat TranslateY = 6

4.	 Beide Kreise auswählen und gruppieren (STRG-G)

5.	 Modify> Center Pivot

6.	 Die Gruppe duplizieren und RotateX = 90

7.	 Die Gruppe nochmals duplizieren und RotateY = 90

8.	 Im Outliner (Window > Outliner) überprüfen, das man 3 Gruppen 
mit insgesamt 6 Kurven hat und ggf. Duplikate löschen.

9.	 Alle Curves auswählen und Edit Curves > Cut-Curve (ggf. den 
Schritt wiederholen, jeder Kreis sollte geviertelt sein)

10.	 Für jede Seite des Würfels selektiert man alle 4 Kreissegmente und 
macht Surfaces> Boundary (6xWiederholen)

Anmerkung:  Um das letzte Tool nochmal zu verwenden drückt man G 
(Repeat last tool)

Schritt 7: Dupilizerte Gruppen

Schritt 8: 2x Cut Curves 

Schritt 3: Duplizierte Circles
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11.	 Für jede Ecke wählt man die drei anliegenden Curves aus und wählt 
Surfaces > Birail 1 Tool (8xWiederholen)

12.	 Alles auswählen und  die History löschen ALT-SHIFT-D (Edit > De-
lete by Type > History)

Punkte
1.	 Eine Nurbs Sphere mit Radius 0.5, Translate(X,Y,Z) (0,6,1) erstellen.

2.	 Die Sphere 5x duplizieren und ensprechend dem Bild anordnen.

3.	 Die 6 Spheres gruppieren (STRG-G).

4.	 Den Pivot Point um TranslateY=3 setzen. Hierfür wählt man das 
Translate Tool (W) und hält dann D(Show Pivot Point Manipulator) 
und X (Grid Snapping) gedrückt und manipuliert den Pivot Point in 
der Side View.

5.	 Die Gruppe 5x Duplizieren und auf die entsprechende Seiten rotie-
ren.

6.	 Die unnötigen Spheres löschen. Bei einem Würfel ist das Ergebnis der 
gegenüberliegenden Seiten immer 7.

7.	 Die Spheres mit dem Translate Tool (W) positionieren.

8.	 Zuerst alle Spheres einer Seite und dann die dazugehörige Boundary 
selektieren. Dann Edit Nurbs > Intersect Surfaces.

9.	 Mit dem Edit Nurbs > Trim Tool klickt man auf die Bondary (Siehe 
Bild). Die Boundary wird nun gestrichelt weiß angezeigt diese wer-
den dann mit durchgezogenen weißen Linien angezeigt und drückt 
anschließend ENTER.

10.	 Man trimmt jetzt auch alle Spheres, sodass nur noch die Hälfte der 
Kugeln im Würfel zu sehen ist. (Das Panel auf Wireframe (4) setzen 
um einfacher die Halbkugel zu selektieren)

11.	 Den Trim Vorgang wiederholt man für jede Seite. Anschließend alles 
auswählen und Delete History ALT-SHIFT-D.

Schritt 9: Boundary auf den Seiten Schritt 10: Birails für die Ecken

Schritt 2: Anordnung der Spheres

Schritt 6: Angeordnete Spheres

Schritt 9: Boundary mit Trim Tool

Schritt 10: Getrimmte Spheres

Bauhaus Stuhl
Bauhaus ist eine Kunstschule die insbesondere im Design und Architektur 
markante Designs entwickelt hat. Dieser Stuhl ist angelehnt an einen solchen. 
Er besteht aus einem einzigen Chrom Rohr, einem Sitz und einer Lehne.

Das Stuhlgerüst
1.	 Zu der Perspektive „Side“ wechseln (LEERTASTE kurz drücken, 

Side Perspektive anklicken, LEERTASTE kurz drücken)

2.	 Einen Kreis (Erstes Icon auf der Curves-Shelf anklicken oder Create> 
Nurbs Primitives > NURBS Circle) erstellen. Nun folgende Werte 
manuell in die Channel Box eingeben: TranslateXYZ (0;5;-10), Ro-
tateY= -90, RotateZ = 90 

3.	 Mit dem Kreis noch ausgewählt im Channel Box im Input bei ma-
keNurbCircle den Radius auf 5 und den Sweep auf 180 setzen.

4.	 Für das Standbein des Stuhls eine Linie vom Ursprung des Koordi-
natensystems zum unteren Ende der Kurve zeichnen. Hierfür wählt 
man das EP-Curve Tool aus. Mit X-TASTE (Grid Snapping) ge-
drückt auf den Ursprung des Koordinatensystems den ersten Punkt 
setzen. Danach mit nur der C-TASTE (Curve Snapping) gedrückt 
der zweite Punkt an einer beliebigen Stelle auf den Kreis, mit der lin-
ken Maustaste gedrückt haltend, gesetzt (Click-Drag). Die Maus be-
wegen, sodass der Punkt an das untere Ende des Halbkreises gelangt 
(Die Maus richtung Ursprung bewegen). Danach wird die Maustaste 
losgelassen. Mit ENTER beendet man das EP-Curve Tool.

5.	 Für die Lehne, eine weitere EP-Curve anlegen mit dem ersten Punkt 
am oberen Ende des Halbkreises den ersten Punkt mit Hilfe des Cur-
ve Snappings (Taste C-gedrückt halten mit Click-Drag) setzen. Den 
weiteren Punkte wie im Bild setzen.

Schritt 3: Ein seitlicher Halbkreis

Schritt 5: Die vollständige Kurve
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6.	 Die Untergrund-Curve auswählen und mit dem Halbkreis auswählen. (SHIFT gedrückt halten um mehrere 
Objekte auszuwählen.

7.	 Edit Curves > Attach Curves q Die Einstellungen auf Connect setzen und das Häckchen bei Keep Originals 
entfernen und anschließend auf „Attach“ klicken. Die beiden Kurven sind nun miteinaner verbunden. Man 
muss immer mindestens zwei Kurven ausgewählt haben um das Attach Curves Tool zu verwenden.

Anmerkung: Ändert man die erweiterten Einstellungen bei einem Tool, so bleiben diese Einstellungen als Standar-
teinstellungen erhalten. Man kann jederzeit die Originaleinstellungen wiederherstellen, wenn man in dem jeweiligen 
Dialog Edit > Reset Tool auswählt.

Schritt 10: Die Zwei Kurven 

Schritt 12: Die Zwei Ansichten in der man Abwechselnd arbeitet

8.	 Die resultierende Kurve mit der Lehne auch mit Edit Curves > Attach 
Curves verbinden. Nun hat man eine einzelne durchgehende Kurve.

9.	 In die „persp“- Ansicht wechseln. 

10.	 Die Kurve nun mit STRG-D (Edit > Duplicate) duplizieren und an-
schließend auf der x-Achse verschieben (TranslateX = 12) 

Anmerkung: Wenn man ein Objekt dupliziert liegt das Duplikat genau über 
dem Original.  Man muss es erst verschieben um zwei Objekte zu sehen.

11.	 Zu der Ansicht Four View wechseln.

12.	 Mit dem Create > CV-Curve Tool in der Perspektive „persp“ und 
„Curve Snapping“ den ersten Punkt an das untere Ende der ersten 
Kurve setzen. Danach in der Perspektive „top“, die restlichen Kur-
venpunkte setzen. Den letzten Punkt in der Perspektive „persp“mit 
Curve Snapping an die zweite Curve setzen (wie im Bild). Mit Enter 
die Kurve-Tool beenden.

13.	 Den vorhergehenden Schritt wiederholen für das obere Ende der 
Kurven.

14.	 Alle Kurven mit Attach Curves verbinden (Stuhlkurve) 

Anmerkung: Immer zwei Kurven auf einmal miteinander verbinden. Falls 

bei dem Verbinden der letzten Kurve ein Fehler auftritt, so muss man die Richtung einer Kurve umkehren mit Edit 

Curves -> Reverse Direction. 

15.	 In der Perspektive „persp“ einen weiteren Kreis (NURBS Circle) erstellen, RotationX = 90, Radius 0.5)

16.	 Den Kreis und die Stuhlkurve selektieren und schließlich Surfaces > Extrude q auswählen.

17.	 Alle Elemente sollte man auf eine eigene Ebene setzen und anschließend die Ebene auf Template setzen.

18.	 Speichern als bauhaus_stuhl.01.mb

Der Sitz & Lehne
1.	 Einen weiteren NURBS Circle im Ursprung erstellen in der Perspektive persp, (RotationX = 90, Radius 0.8)

2.	 RMB > EditPoint Mode wählen und den oberen und unteren Edit Point markieren Edit Curves > Detach 
Curves.

3.	 Wechsel zu der Front View die rechte Hälfte des Kreises verschiebt man auf der x-Achse TranslateX = 12 

4.	 Mit dem Create > EP- Curve Tool  verbindet man die beiden Kreise und anschließend wieder mit dem Attach 
Curves zusammensetzen.

5.	 Mit der Kurve ausgewählt Edit > Delete by Type > Delete History 
(ALT-SHIFT-D)

6.	 Die Ebene mit dem Stuhlgestell wieder sichtbar machen und die Kur-
ve auf Höhe der Sitzfläche verschieben wie im Bild (am einfachsten ist 
dies mögich in der side view)

7.	 Die Kurve Duplizieren (wie im Bild) und mit beiden Kurven ausge-
wählt ein Loft (Surfaces-> Loft) erstellen.

8.	 Die Sitzfläche nun duplizieren, verschieben, rotieren, skalieren, so-
dass sie zu der Lehne passt. 

Anmerkung: Der Pivot Point wird bei einem Loft immer auf den Ursprung gesetzt, um einfacher zu skalieren etc. 
kann man den Pivot Point auch wieder in das Zentrum der Fläche setzen mit Modify > Center Pivot Point.

9.	 Alle Elemente auswählen und STRG-G (Edit > Group) und die Gruppe umbennen auf “Chair”.

10.	 Speichern als bauhaus_stuhl.02.ma

Schritt 4: Die resultierende Kurve
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Vorbereiten auf das Rendern
Da wir den Stuhl nicht in dieser Szene Datei ausrendern werden exportieren wir die Stuhl-Geometrie.

1.	 Die Gruppe „Chair“ auswählen (Eine Fläche anklicken und die Pfeiltaste nach oben drücken, oder im Out-
liner) 

2.	 Die History löschen (ALT-SHIFT-D)

3.	 Modfiy > Center Pivot

4.	 Modify> Freeze Transformations

5.	 Immer noch mit dem Stuhl ausgewählt File > Export Selection bauhaus_stuhl.export.ma

Anmerkungen zu NURBS

Tesselation
Für den Rendervorgang wird das NURBS Objekt automatisch in ein Po-
lygon Objekt umgewandelt. Diesen Prozess nennt man Tesselation. In den 
meisten Fällen muss man sich keine Gedanken darüber machen. In seltenen 
Ausnahmen kann es passieren, dass ein Objekt sehr „eckig“ statt rund geren-
dert wird, dann muss man die Tesselation Attribute anpassen. (Diese findet 
man im Shape Node des Objekts)

Man kann die Tesselation Attribute automatisch anpassen lassen. Hierzu se-
lektiert man das Objekt und benutzt im Modul „Rendering“ > Render> Set 
Nurbs Tesselation.

Man kann auch manuell Attribute Editor > Shape Node > Tesselation ein-
stellen. Hierzu wählt man „Display Render Tesselation“ und dann manipu-
liert man die Werte der Tesselation. Je nachdem ob man „Enable Advanced 
Tesselation“ aktiviert hat muss man die Simple Tesselation oder die Advanced 
Tesselation anpassen. Durch manipulieren der Regler sieht man sofort was 
die Regler machen und ob das Resultat besser oder schlechter wird. Am Ende 
sollte man wieder „Display render Tesselation“ ausschalten.

Anmerkung: Man sollte die Regler nicht unnötig hoch setzen d.h. man sollte 
versuchen mit möglichst kleinen Werten das Problem zu beheben. Ansonsten 
hat man beim Rendern eine sehr ineffiziente Szene.

Vorher: Eckige Kante

Vorher: Low Tesselation

Nacher: High Tesselation

Nacher: Runde Kante

Tessalation Attribute
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Polygon - Grundlagen
Definition
Ein Polygon ist eine durch eine endliche Anzahl von geraden Linien aufgebaute Figur. Man braucht mindestens 3 
Linien bzw. 3 Punkte um eine Ebene aufzuspannen bzw. um ein Polygon Objekt zu erzeugen.

Es gibt drei verschiedene Arten um eine Polygon Geometrie zu erzeugen:

•	 Man setzt Vertexpunkte in den Raum, die ein Polygon ergeben. 

•	 Man manipuliert ein Primitiv (Sphere, Cube, Cylinder, Cone, etc.) solange bis es die gewünschte Form hat. 

•	 Man zeichnet Kurven in den Raum und lässt eine Fläche anhand der Kurven erzeugen. 

Üblicherweise fängt man mit einem Poly-Cube Primitiv an und manipuliert ihn, daher der Begriff „Box-Modelling“.

Components
Neben dem Objekt-Modus lassen sich auch Komponenten eines Objektes selektieren und modifizieren. Hierfür RMB 
auf das Objekt klicken und wählt den entsprechenden Darstellungsmodus aus dem Selektions-Menü aus.

Vertex 
Ein Vertex ist ein Punkt im Raum. Man kann nur eine Translation (MoveTool W) auf sie anwenden. Ein Vertex sollte 
nur in Verbindung mit einer Edge exisiteren.

Edge
Eine Edge ist durch zwei Vertex Punkte definiert. Eine einzelne Edge ist eine fehlerhafte Geometrie und sollte nur in 
Verbindung mit einem Face existieren.

Face
Eine Face ist definiert durch umliegende Edges. Für eine optimale Geometrie sollten alle Faces eines Objekts entwe-
der Triangles (3 Edges) oder Quads (4 Edges) haben.

Anmerkung: Mit display Face Centers wird ein Punkt in der Mitte von Faces angezeigt. Dies erleichtert Faces zu 
selektieren. Unter Window > Setting & Preferences > Preferences geht man in der linken Leiste auf Selection und 
wählt dann unter Polygon Selection - Select Faces with Center. 

obere vier Vertex Punkte selektiert obere vier Edges selektiert obere Face selektiert

Polygon Tools

Extrude
Das Edit Mesh > Extrude Tool macht ein neues Face und verbindet sie mit 
den ursprünglichen Polygonen. Der Manipulator vom Extrude Face kombi-
niert das Transform, Skalier und Rotationstool. Um zwischen den Modi zu 
wechseln klickt man einmal auf das jeweilige Tool und die jeweiligen Achsen 
werden dann singulär angezeigt (Pfeile für Move, Cubes für Skalieren, Kreis 
für Rotate)  

Mit dem kleinen blauschwarzen Schalter wechselt man zwischen Objekt-
Koordinaten und Welt Koordinaten.

Interactive Split Tool/ Split Polygon Tool
Das Edit Mesh > Split Polygon Tool erlaubt eine beliebige Edge auf einer 
Face hinzuzufügen. Dieses hat den Vorteil, das man in den Tool-Settings 
die Anzahl von „Snap magnets“ einstellen kann. Um das Tool zu verwenden, 
klickt man auf mindestens zwei Punkte auf Edges einer Face und drückt 
anschließend ENTER.

Edge Loop Tool
Das Edit Mesh > Edge Loop Tool fügt einen ring von Edges dem Objekt 
hinzu. So werden aneinanderliegenden Faces gleichzeitig getrennt. Dies ist 
einfacher als mit dem Split Tool einzeln jede Face zu trennen. Um das Tool 
zu verwenden, klickt man auf die naheliegenste Edge an der man den Ring 
einfügen will. 

Boolean Operations

Unter Mesh > Booleans findet man die drei Typen von Boolschen Operationen die man auf 3D Objekte anwenden 
kann.

Union verschmilzt zwei Objekte miteinander. Difference entfernt das zweite Objekt aus dem ersten Objekt und In-
tersection erzeugt die Schnittmenge beider Objekte.

In manchen Fällen kann die Boolesche Operation fehlschlagen. Was in den meisten Fällen daran liegt das die Nor-
malen der Faces in verschiedene Richtungen zeigen. Mit Normals > Conform lässt sich das Problem in vielen Fällen 
beheben.

Eine andere Variante das Problem zu umgehen ist, die betreffenden Faces von den Objekten mit Extract als eigene 
Objekte zu erstellen und dann die Boolesche Operation auszuführen. Anschließend fügt man die extrudierten Faces 
mit Mesh > Combine, Edit Mesh> Merge bzw. Mesh > Cleanup wieder zusammen. 

Anmerkung: Boolesche Operatoren erzeugen schnell neue interessante Formen, aber die resultierende Geometrie  
besteht meistens nicht mehr nur aus Quads/Triangles und muss unter Umständen nachträglich korrigiert werden.

Interactive Split Tool

IntersectionDifferenceUnion

Extrude Tool (auf der Y-Achse verschoben)
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Tool Settings 
Man kann für die Move, Rotate und Scale Tools noch weitere Einstellungen vornehmen. Hierfür muss man die „Tool 
Settings“ (Window > Settings and Preferences > Tool Settings) öffnen. 

Reflection
Ermöglicht symmetrisches arbeiten mit symmetrischen Objekten. Aktiviert man Reflection so sollte man auch die 
„Reflection Axis“ bestimmen. 

Wurde das Objekt nur auf einer Seite verändert kann es passieren, dass nicht die richtigen Polygone auf der gegen-
überliegenden Seite ausgewählt werden. Es hilft wenn man in den Tool Settings „Reflection Space“ auf World setzt.

Um die Funktionalität wieder herzustellen um direkt symmetrisch zu arbeiten löscht man die Hälfte des Objekts 
löschen (ggf. mit Edge Loops oder dem Split-Polygon Tool die Hälfte genau definieren). Anschließend im Objekt-
Modus Mesh > Mirror Geometryq  und die entsprechende Achse auswählen um wieder einen vollen Körper zu 
bekommen

Soft Selection
Der „Soft Selection“-Modus ermöglicht umliegende Objekte/Componenten zu selektieren. Mit dem Keyboard Short-
cut (B) aktiviert und deaktiviert man die Soft Selection.

-- Falloff Mode: bestimmt welche Objekte betroffen sind: Die Modi 
Volume und Surface sind beschränkt auf das selektierte Objekt. Die 
Modi Global und Object beeinflussen multiple Objekte.  

-- Falloff-Radius: definiert die selektierten Objekte durch die Selekti-
on und dem maximalen Abstand definiert durch den „Falloff-Radius“. 

-- Falloff Curve: bestimmt wie stark die Objekte beeinflusst werden 
von der Selektion. Ändert man die Form der Kurve kann die Selektion 
angepasst werden.

-- Falloff Color: beinflusst nur die Darstellung im Viewport

Weitere Eigenschaften von Polygon Objekten

Unnatürlich scharfe Kanten

Cube ohne Bevel Cube mit Bevel (Offset= 0.01) Cube mit Bevel (Offset = 0.2, Segments=5)

Rendert man Polygone aus haben sie meist sehr scharfe Kanten z.B. die eines Würfels. Solche extrem kantigen Ob-
jekte exisitieren in der Natur nicht. Kanten in der Natur sind leicht abgerundet, z.B. durch Abnutzung. Um diesen 
typischen 3D-Look zu vermeiden, muss man an Kanten einen Bevel anwenden. Hierfür wählt man die Edges aus die 
man abstumpfen möchte und geht auf Edit Mesh > Bevel. Bereits ein Offset-Wert von 0.01 ist ausreichend um den 
typischen 3D-Look zu vermeiden. Optional lassen sich die Kanten abrunden indem man die Anzahl der Segments 
erhöht.

Normalen
Normalen bestimmen welche Seite außen und welche Seite innen sich befindet. Bei einer korrekten Objekt zeigen alle 
Normalen konform in die gleiche Richtung. Um die Normalen anzuzeigen geht man auf Display > Polygons > Face 
Normals. Es werden mit grünen Strichen die Richtung der Oberfläche angezeigt.  Eine Alternative Möglichkeit ist 
im Panel-Menü unter Lighting > Two Sided Shading zu deaktiveren. Drückt man 5, wird nun die Innenseite Eines 
Objektes schwarz (unbeleuchtet) dargestellt. 

Soft Selection

Es passiert leicht durch z.B. skalieren, dass die Normalen nicht mehr richtig sind. Mit Normals > Conform werden die 
Faces korrigiert. Die Mehrheit der Faces bestimmt die Richtung des Objekts. Unter Umständen muss man per Hand 
die Normalen richtig setzen. Mit Normals > Reverse lassen sich einzelne Faces korrigieren oder auch das gesamte 
Objekt. 

Im Beispiel ist der obere Teil des linken Diamanten fehlerhaft, dies erkennt man in der Normals Anzeige, da die 
grünen Striche nicht nach außen gehen. Einfacher erkennt man die Fehler wenn Two Sided Shading deaktiviert ist, 
da sieht man sofort der obere Teil ist einfach schwarz.

Mit Normals > Conform, lässt sich das Problem lösen, jedoch sind die Seiten vertauscht. Also selektiert man das 
Objekt und macht ein Normals > Reverse. Dann ist das Objekt vollständig korrigiert.

Normals anzeige Two Sided Shading Deaktviert Normals Conform

Anmerkung: Bei NURBS tritt manchmal das gleiche Problem auf. Man kann dies korrigieren mit Edit Nurbs > 
Reverse Surface Direction.

Surface Tools
Alle Nurbs Tools im Menüpunkt „Surfaces“ (Siehe „Surface Tools“ Seite 34) kann man verwenden um Polygon 
Objekte zu erzeugen. Hierfür muss man nur in dem jeweiligen Tool in den Eigenschaften unter „Output Geometry:“  
Polygon setzen. Das Dialogfenster erweitert sich und man kann die Tesselation Eigenschaften bestimmen. Man er-
zielt gute Ergebnisse wenn man Tesselation method auf „Control Points“ setzt. Die resultierende Geometrie wird im 
Vergleich zu einer Nurbs Geometrie sehr eckig wirken. Mit der Smooth Mesh Preview oder einem Mesh > Smooth 
bekommt man das Objekt wieder abgerundet.
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Diamant Ring

Der Diamant
1.	 Create > Polygon Primitves > Cylinder (Radius 1)

2.	 In der Channelbox ändert man in den Inputs (“polyCylinder1”) die 
Subdivision Axis auf 8.

3.	 Man wechselt in den Faces Modus (RMB auf den Zylinder > Faces) 
und löscht alle Faces unterhalb der achteckigen Fläche.

4.	 Nun wechselt man in den Edges Modus (RMB auf den Zylinder > 
Edges) und löscht alle Edges innerhalb der Fläche, sodass man ein 
Oktagon erhält.

5.	 Unter Edit Mesh > Keep Faces together entfernt man das Häck-
chen.

6.	 Weiterhin im Edges Modus selektiert man alle acht Edges indem 
man auf die einzelnen Edges klickt und dabei SHIFT gedrückt hält.

7.	 Edit Mesh > Extrude - Mit dem grünen Pfeil(z-Achse) des Extrude 
Manipulators zieht man eine neue Fläche aus dem Oktagon und be-
wegt sie anschließend mit dem blauen Pfeil ein wenig nach unten. 
(LocalTranslateZ -0.35, LocalTranslateY -0.5) 

8.	 In der ChannelBox im Input “polyExtrudeEdge” die Eigenschaft Lo-
calScaleX auf 0 setzen - Dies lässt die Fläche spitz zulaufen. Jedoch 
befinden sich jetzt 2 Vertexpunkte an der gleichen Position, das ist 
eine fehlerhafe Geometrie.

9.	 Um den Fehler der doppelten Vertexpunkte in der Geometrie zu be-
heben selektiert man das gesamte Objekt und benutzt Edit Mesh > 
Merge.

Schritt 2: Zylinder mit 8 Seiten

Schritt 8: Extrude

Schritt 4: Ein Oktagon

Anmerkung: Wenn man das Extrude Tool verwendet, kann man die Para-
meter in der Channelbox/Attribute Editor manuell setzen. So kann man die 
Parameter z.B. exakt auf 0 setzen.

10.	 Nun benutzt man das Edit Mesh > Append to Polygon Tool um 
Flächen zwischen den Spitzen hinzuzufügen. Dies macht man indem 
man das Tool auswählt und jeweils zwei aneinanderliegende Edges 
selektiert. (siehe Bild) Anschließend drückt man ENTER. Man muss 
diesen Vorgang für jede Spitze wiederholen.

Anmerkung: Mit dem Tastaturkürzel G kann man immer das zuletzt ver-
wendete Tool wieder aufrufen. Das ist sehr nützlich wenn man wiederho-
lende Aufgaben erledigen muss.

11.	 Man selektiert alle acht Edges am unteren Rand indem man auf die 
einzelnen Edges klickt. Nun wieder ein Edit Mesh > Extrude. (Local-
TranslateY  -0.5, LocalScaleX 0)

12.	 Edit Mesh > Merge um die Geometrie zu korrigieren

13.	 Wie in Schritt 10 für jede Spitze das Edit Mesh > Append Tool an-
wenden.

14.	 Mit Edit Mesh > Split Polygon Tool (Maya 2012: Interactive Split 
Tool) splittet man die letzte durch das Append Tool gemachten Faces 
in zwei gleiche Dreiecke. (Siehe Bild). Man LMB klickt einmal auf 
die Spitze des Dreiecks und einmal auf die Mitte der unteren Edge. 
Anschließend drückt man ENTER. Man muss diesen Vorgang für 
jede Face wiederholen.

15.	 Im Vertex Modus selektiert man jeden zweiten Vertex am unteren 
Rand des Objekts. In der topView und dem Scale Tool skaliert man 
die Punkte nach außen, sodass die Grundform kreis förmig wird (si-
ehe Bild).

16.	 Man selektiert den unteren Rand Im Edges Modus und aktiviert Edit 
Mesh > Keep Faces Together

17.	 Mit  Edit Mesh > Extude klickt man einmal auf den  kleinen hell-
blauen Kreis (dies verändert den Pivot Point von local zu global) 
Danach zieht man den grünen Pfeil ein kurzes Stück nach unten. 
(TranslateY -0.2)

18.	 Ein weiteres Edit Mesh > Extrude (TranslateY -2)

19.	 Mit den noch selektierten Edges Edit Mesh > Merge to Center

20.	 Im Objekt Modus die History Löschen (SHIFT-ALT-D)

Schritt 10: Das Append Tool angewandt 
(bevor Enter Gedrückt wurde)

Schritt 11: Extrude

Schritt 17: Extrude

Schritt 14: Split Polygon

Schritt 15: Kreisförmige Anordnung der 
Vertex Punkte

Schritt 19: Merge to Center
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21.	 Speichern als diamondRing.01.ma

Der Ring
1.	 Create > Polygon Primitives > Pipe (TranslateY -7, RotateX 90, Ra-

dius 5, Height 3)

2.	 Create > Polygon Primitives > Cylinder (TranslateY -2, RotateY 30, 
Radius 0.7, Height 0.3, Subdivision Axis 6)

3.	 In der „frontView“ zeichnet man eine CV-Kurve für die Halterung 
des Diamanten. Den Anfangspunkt setzt man kurz vor den Cylinder.

4.	 Man selektiert eine Curve und das am naheliegenste Face des Zylin-
ders.

5.	 Mit Edit Mesh > Extrude (Divisions 10-30 je nach Kurve, Taper 0.1) 
kann man entlang der Kurve extrudieren.

6.	 Optional: In der „front View kann man nun die Kurve modifizieren 
und anpassen das die Struktur den Diamanten besser hält.

7.	 Die Kurve selektieren und Edit > Duplicate Special q

8.	 Schritt 5 für jede Kurve wiederholen.

Fertigstellen vom Ring
1.	 Alle Objekte selektieren, Delete History (ALT-SHIFT-D), Mo-

dify> Freeze Transformations

2.	 Mithilfe einer Selektionsmaske die Kurven auswählen und dann lö-
schen.

3.	 Den Ring selektieren, Taste 3 drücken für PolySmooth

4.	 Erst den Diamanten selektieren dann die Halterung und dann Pa-
rent (P)

5.	 Erst die Halterung selektieren, dann den Ring und dann Parent (P)

6.	 Den Ring bewegen und rotieren, sodass er auf dem Boden liegt.

Schritt 2: Angeordnete Primitive

Schritt 5: Fertiger Extrude

Schritt 7: Fertiges Duplicate Special

Schritt 3: gezeichnete Kurve

Schritt 7: Duplicate Special Optionen

DNA-Helix
Um eine simple DNA-Helix zu modellieren müssen wir wissen, dass die 
Ebenen in einem 36° Winkel zueinander stehen. Ein Strang ist in der Regel 
rechtsdrehend und eine Windung enthält 10 Basenpaare.

Basenpaar
1.	 Create > Nurbs Sphere (TranslateX = 5) 

2.	 Create > Polygon Cube (TranslateX = 2, Width = 4.5, Height = 0,2 
Subdivisions Depth =2 )

3.	 Beides selektieren, gruppieren (STRG-G)

4.	 Duplizieren STRG-D, skalieren (ScaleX = -1)

5.	 In der „topView“ beide Cubes im Vertex Modus auswählen entwe-
der per Selektionsmaske, oder RMB auf den ersten Cube > Vertex, 
SHIFT+LMB auf zweiten Cube, RMB auf den zweiten Cube > Vertex

6.	 Die mittleren Vertex Punkte zur Seite verschieben. (Siehe Bild) Hier-
für muss man in den Tool Settings die Move Axis auf „World“ setzen.

7.	 In der „persp“-Ansicht im Objektmodus die beiden Cubes selektieren 
und rotieren (RotateX = 30)

8.	 Alle Objekte zusammen gruppieren

Helix
1.	 Edit > Duplicate Special q (Siehe Bild)

2.	 Im Hirarchie Selektions-Modus alle Objekte auswählen und gruppie-
ren bzw. im Outliner alle Gruppen Selektieren und zu einer Gruppe 

Schritt 4

Schritt 6

Move Tool Axis auf World umgestellt
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(mit Namen „DNA“) vereinigen.

3.	 Delete History, Freeze Transformations

4.	 Speichern unter dna.01.ma

Duplicate Special Einstellungen

Spielwürfel
Wir werden nun einen weiteren Spielwürfel modellieren. Diesmal werden wir 
jedoch nur die Polygon-Werkzeuge verwenden.

Grundkörper
1.	 Einen Poly-Cylinder (Create > Poly Primitives > Poly Cylinder) er-

stellen mit Subdivision Axis = 8

2.	 Im Faces-Modus die Seitenflächen des Cylinders löschen.

3.	 Im Objekt-Modus, mit Strg-D den Cylinder duplizieren.

4.	 Mit der Taste E zum Rotate-Tool wechseln und mit gedrückter J-Ta-
ste (Angle Snapping) den Cylinder um 90° um die X-Achse drehen.

5.	 Nochmals den Cylinder duplizieren (Strg-D) und um die Z-Achse 
drehen (90°, E, J gedrückt)

6.	 Alle drei Cylinder selectieren und zu einem einzigen Objekt vereinen 
(Polygon > Combine)

7.	 Die Ecken müssen nun mit neuen Flächen geschlossen werden. Wir 
fangen mit einer Ecke an und verbinden die naheliegenden Edges mit 
dem Append Tool. (Bei dem Append Tool immer auf den lila Pfeilen 
klicken) danach das dreieckige Loch mit dem Append Tool oder Po-
lygon > Fill Hole schließen.

8.	 Anstatt diesen aufwendigen Schritt 7x zu wiederholen, löschen wir 
alle Faces die nicht zu der Ecke gehören.

9.	 Mit Shift-RMB > Mirror -Z, Shift-RMB > Mirror -Y, Shift-RMB > 
Mirror -X den Würfel wieder vervollständigen. 

10.	 Wenn wir nun die Taste 3 drücken, sieht der Würfel nicht sehr gut 



58 59Kleines Flugzeug ||  || Modelling

Kleines Flugzeug

Hauptkörper
1.	 Man erstellt ein neues Projekt „Airplane_Barebcat“ mit File > Set 

Project

2.	 Im Dateisystem kopiert man die Dateien „bobcat_side.jpg“, „bare-
cat_top.jpg“, „barecat_front.jpg“.

3.	 Zu der Perspektive „Four View“ wechseln

4.	 Man lädt die Referenzbilder in der Top, Side und Front View. Hier-
für geht man auf die jeweiligen PanelMenüs View > Image Plane > 
Import Image und selektiert das jeweilige Bild. 

5.	 Im jeweiligen Attribute Editor, von den Image Planes, kann man das 
Attribut „looking through Camera“ aktivieren. Dann wird das Bild 
in der perspektivischen Ansicht nicht angezeigt. Setzt man den Alpha 
Gain auf 0.5 lässt sich einfacher arbeiten.

6.	 Einen Poly-Cylinder (Create > Poly Primitives > Poly Cylinder) im 
Ursprung mit der Eigenschaft (Input Menu) RotateX = 90 erstellen.

7.	 In der Side View im Vertex-Modus die Vertex Punkte selektieren und 
gleichmäßig skalieren und rotieren (siehe Bild).

8.	 In der Four View im Faces-Modus den ‚Boden‘des Zylinders selek-
tieren und das Extrude Tool 4x nacheinander verwenden um eine 
ähnliche Form wie im Bild zu erhalten. Hierfür orientiert man sich 
an der Top und der Side View und skaliert/rotiert die neuen Faces. 
(Siehe Bild)

9.	 Anschließend wird der ‚Deckel‘ des Zylinders selektiert. 2x das Ex-
trude Tool benutzen (Siehe Bild).

Schritt 5 - Fertige Image Planes

Schritt 7 - Angepasste Vertex Punkte

Schritt 8 - Nach multiplen Extrudes

Schritt 9 - Deckel des Zylinders

aus. Wir müssen Edges einfügen damit bei dem Smooth prozess die 
Kanten besser definiert sind. Daher selektieren wir alle Flächen ohne 
die Ecken (Siehe Bild xx).  (Dies ist am einfachsten wenn man die 
selektion in der „FourView“ vornimmt)

11.	 Polygon > Extrude (Offset 0.1, Divisions 2)

12.	 Nochmals mit der Taste 3 überprüfen ob die Form nun richtig ist.

Punkte
1.	 Wir werden nun einen einzigen Punkt so vorbereiten, damit er mehr-

fach verwendet werden kann.

2.	  



60 61Kleines Flugzeug ||  || Modelling

7.	 Am Ende des Hecks sollte man noch die Faces, die die Dreiecke bil-
den, umwandeln in Quadrate. Dies macht man am einfachsten wenn 
man jede zweite Edge löscht.

Rotor

1.	 Die vordersten Faces selektieren und Extrude Offset 0.1. Einen weiteren Extrude TranslateZ = -0.03. Einen 
letzten Extrude TranslateZ = - 0.4. Dies gibt beim Poly Smooth eine weiche Kante.

2.	 Die überflüssigen Faces löschen und die Vertex Punkte wieder an der Achse ausrichten.

3.	 Create> Polygon > Cone (RotateX = 90, Radius = 0.4, Height = 0.7, Subdivision Axis = 20) und an die 
Spitze des Flugzeugs setzen.

4.	 Die Cone, wie das Flugzeug, halbieren sowie die Face an der Rückseite löschen.(DEL)

5.	 Den Rand selektieren und mit Extrude zu dem Boden des Motors erweitern

6.	 Die vordersten Faces des Flugzeugs (die von Schritt 1) löschen (DEL)

7.	 Im  Object Mode das Flugzeug und die Cone auswählen und Edit Mesh > Combine

8.	 Die Ränder von dem Cone Object mit dem Rand des Flugzeugs selektieren und Mesh > Bridge  
(Divisions = 0)

9.	 Create > Polygon > Cube 

10.	 Dieser Cube soll ein Rotorblatt werden. Er muss so verändert werden, dass er zwischen dem Cone Objekt und 
das Flugzeug passt und modifizieren, sodass der Würfel eine Schräge bekommt.

11.	 Den Pivot Point modifizieren, sodass er auf der Achse liegt.

12.	 Edit > Duplicate Special q (Einstellungen siehe Bild)

13.	 Alle Rotorblätter sollte man auf eine eigene Ebene setzen und für jetzt unsichtbar machen.

Schritt 1 - Extrude Offset 0.1

Schritt 10 - Modifizierter Cube

Schritt 6 - Die vordersten Faces löschen

Schritt 1 - Extrude TranslateZ = -0.03

Schritt 10 - Angepasst an das Flugzeug

Schritt 8 - Ränder Selektieren

Schritt 12 - Duplicate Special

Schritt 8 -  Fertige Bridge

Schritt 7 - Edges zu löschen

Flügel
1.	 In der Side View und Wireframe Mode(4) mit dem Edge Loop Tool 

am Anfang und Ende der Flügelbasis eine Edge einfügen.

2.	 In der Side View im Vertex-Mode die Vertex Punkte identifizieren, 
die sich an der Flügelbasis befinden (ggf. der Flügelform anpassen)

3.	 In die Front View wechseln und im Faces Modus alle Faces löschen 
(DEL) die im -X Bereich liegen. So muss man sich nur noch mit der 
Hälfte des Modells beschäftigen

4.	 Die Faces an der Flügelbasis selektieren. 

5.	 Zunächst erstellt man grobe Flügel, indem man wieder mehrfach das 
Extrude Tool benutzt. Wechselt man das Tool in Welt Koordinaten 
(der blauschwarze Schalter) erhält man völlig flache Flügel.

6.	 Abwechselnd in der Top und der Front View passt man die Vertex 
Punkte mit dem Move Tool (W) an die Vorlage an. (Ggf. eine Edge 
Loop einfügen um die Form besser bestimmen zu können.

Anmerkung: Später wird das Modell mit einem Poly-Smooth abgerundet. 
Drückt man 3 sieht man die eine Voransicht, ggf. sollte man in diesem Mo-
dus bereits die Vertex Punkte anpassen, sodass es der Vorlage ähnelt. Mit der 
Taste 1 kommt man zurück in den Poly-Modus.

Heck & Cockpit
1.	 Ähnlich wie der Flügel wird das Heck extrudiert. Zunächst die Faces 

selektieren, die die Basis von dem Heck bilden und  zweimal im 
World-Modus nach oben extrudieren. Die Vertexpunkte mithilfe der 
Referenzbilder anpassen. 

2.	 In der Persp- Ansicht sieht man, dass nun zusätzlich Faces auf der 
X-Achse erzeugt wurden. Diese werden nicht gebraucht und werden 
später Probleme machen. Daher selektiert man und löscht sie.

3.	 Der Heck Flügel wird erstellt mit dem Extrude-Tool und entspre-
chende Vertex anpassungen. Es ist ratsam, bevor man extrudiert, die 
Vertexpunkte der Basis rechteckig anzuordnen.

Anmerkung: Sollte es im Smooth-Preview Modus(3) zu extremen Run-
dungen kommen, lässt sich mit dem Edge-Loop Tool eine zusätzliche Edge 
einfügen um den Effect abzuschwächen.

4.	 Für das Cockpit muss zunächst die Grundform des Cockpits durch 
verschieben der Vertexpunkte auf der Oberseite des Flugzeugs festge-
legt werden.

5.	 Mit Extrudes und Vertex die Form anpassen. Man muss jedoch da-
rauf achten die Punkte an der X-Achse nicht zu manipulieren bzw. 
nachträglich sie wieder zurück auf die X-Achse setzen.

6.	 Die überflüssigen Faces auf der Innenseite des Modells entfernen.

Anmerkung: Um schnell Vertexpunkte an der Achse zu positionieren, mit 
dem Move Tool mit Gridsnapping (X-gedrückt halten) auf den Pfeil der ent-
sprechenden Achse klicken.

Schritt 2 - Angepasste Basis

Schritt 1 - Basis vom Heck

Schritt 5 - Grober Extrude

Schritt 6-  Überflüssige Faces

Schritt 4 - Basis vom Cockpit

Schritt 5 - Angepasstes Cockpit
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Anmerkung: Es können Fehler auftreten beim Smooth, man sollte dann ggf. überflüssige Edges finden und löschen.

Vervollständigen des Flugzeugs
1.	 Das Flugzeug selektieren Mesh > Mirror Cut q (Mirror Axis YZ, TranslateXYZ = 0). Beim verwenden 

vom Mirror Cut wird das Objekt (meistens) fehlerhaft dargestellt. Wechselt man in den Wireframe Modus 
sollte das gesamte Objekt angezeigt werden. Um das Problem zu beheben RMB auf das Objekt > Assign Exi-
sting Material > lambert1. Dann sollte es auch im Shaded Modus wieder korrekt dargestellt sein.

2.	 Die Rotorblätter wieder sichtbar machen

3.	 Das Propellerblatt selektieren und Group (Strg-G), Duplicate (Strg-D), ScaleX = -1

4.	 Alle Objekte selektieren Delete History (SHIFT-ALT-D), Modify > Freeze Transformations 

5.	 Im Outliner: mirrorCutPlane und mirrorCutMesh1 löschen

6.	 Alle Rotorblätter selektieren, Mesh > Combine, umbenennen in „Rotor“

7.	 Beide Propellerblätter selektieren, Mesh > Combine, umbenennen in „Propeller“

8.	 Alle Objekte selektieren Delete History (SHIFT-ALT-D)

9.	 Erst den Rotor selektieren dann das Flugzeug und dann Parent (P) wählen.

10.	 Erst den Propeller selektieren, dann das Flugzeug und dann Parent (P) aktivieren.

Outliner am Ende

Fehlerhafte Edge löschen und fehlerhafte Vertexpunkte löschen

14.	 Create > Polygon > Cube

15.	 Dieser Cube soll der Propeller werden. Erst ihn positionieren und in 
die Länge und Breite skalieren. Danach selektiert man eine Face an 
der Spitze des Propellers und macht ihn an einer Spitze breiter und an 
der anderen schmaler in der Höhe und rotiert die Face um ca. 45°. (In 
der Seitenansicht hat man eine besseren Überblick)

16.	 Die Ränder vom Cube selektieren Edit Mesh > Bevel

Details
1.	 Optional: Um das Cockpit besser zu definieren muss man (je nach Modell) zunächst den Fluss der Geometrie 

verbesseren. Hierfür verwendet man das Split Polygon Tool und Delete Edge Tool.

2.	 Danach selektiert man die Edge die das Cockpit definiert und macht Edit Mesh > Bevel (Offset 0.1)

3.	 Die entstehenden Faces selektieren und Extrude TranslateY = 0.01 und dann Extrude TranslateY = 0.2

4.	 Die überflüssigen Faces am Rand löschen (DEL)

5.	 Insert Edge Loop Tool einmal verwenden um den unteren Rand der Fenster zu bestimmen

6.	 Die Faces der Fenster selektieren und mit Extrude definieren.

7.	 Mit multiplen Bevels die Struktur der Ränder des Fensters genauer definieren.

Schritt 16 - Fertiger Propeller

Geometrie mit Split Tool neu zeichnen

Schritt 5-  Insert Edge loop Schritt 6-  Faces für den Extrude

Pol-Stelle auflösen durch löschen der Edge

Schritt 7 -Fertiges Fenster

Mit dem Split Tool Geometrie anpassen Überflüssige Edges löschen

Schritt 3 - Selektion der Faces

Schritt 7- Ränder selektiert zum Bevel
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Eigene Modelle modellieren
Wenn man anfängt eigene Modelle zu erstellen, sollte man zuerst eine klare Vorstellung von dem Objekt, was man 
gerne Modellieren möchte, haben. Hierfür erstellt man eine Referenz in Form eines Fotos oder Zeichnung. 

Man kann sich diese Referenz als Hintergrund in die ViewPanels laden. Hierfür geht man auf das PanelMenü View 
> Image Plane > Import Image. Man sollte die Referenzbilder nur in der Top, Side und Front view Camera laden, da 
diese statisch sind und die Position nicht verändern.

Es gibt die Möglichkeit  sich das Bild nur dann anzeigen zu lassen, wenn man durch die Kamera blickt. Dazu aktiviert 
man in den Attributen für die ImagePlane > Image Plane Attributs > Display looking through camera. 

Anmerkung: Image Planes sind normale Objekte und werden von der jeweiligen Kamera ausgerendert und sollten 
ausgeschaltet werden vor dem rendern.

Man sollte nun das Objekt näher analysieren. 

Aus welchen Primitiven bestehen die einzelnen Teile des Objekts? Wenn man das Hauptobjekt in kleinere Teile 
zerlegt so stellt man fest, dass viele Objekte einfach nur aus Kugeln, Halbkugeln, Zylindern und Würfeln bestehen.

Bei diesem Schritt stellt man auch fest, das ein Objekt sich an manchen Stellen wiederholt oder symmetrisch ist. Bei 
Wiederholungen muss man die Stelle nur einmal modellieren und benutzt dann Duplicate bzw. Duplicate Special. 
Bei symmetrischen Objekten kann man direkt die Geometrie auf die andere Seite projezieren, so muss man nur die 
Hälfte des Objekts modellieren. 

Danach überlegt man sich wie man am besten die Details ausarbeitet. In machen Fällen ist ein Polygon-Objekt 
günstiger in manchen Fällen ein Nurbs Objekt. Es hängt davon ab mit welchen Werkzeugen man die Details später 
ausarbeiten möchte. 

Wie man modelliert hängt, jetztendlich davon ab, welche Technik man persönlich bevorzugt. Man muss das model-
lieren üben und verschiedene Ansätze ausprobieren. Man spart sich viel arbeiten wenn man nicht das Gesamtobjekt 
ansieht sondern es in kleine Teile aufteilt und diese nach und nach abarbeitet. 

Abschließende Schritte
Nachdem man mit dem Modellieren fertig ist, sollte man die Szene und Objekte optimieren. 

Man kann nun Hilfsobjekte wie Curves löschen.

Mit dem selektierten Objekt Modify > Freeze Transformations anwenden. Dies setzt die aktuelle Transformations-
werte als die Standartwerte also TranslateXYZ (0,0,0), ScaleXYZ (1,1,1) und RotationXYZ (0,0,0).

Anschließend kann man die Gesamte Konstruktions History löschen. Über Edit > Delete by Type > History (SHIFT-
ALT-D). Dies löscht alle Input-Nodes. Braucht man noch Input-Nodes wie Deformatoren (z.B. Lattice, Squash, etc.) 
wählt man Edit > Delete by Type > Non-Deformer History.

Man sollte auch allen Objekten einen Namen geben. Insbesondere Szenen in denen man mit mehreren Objekten 
arbeitet kann es extrem unübersichtlich werden ohne korrekte benennung der Objekte.
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4. Shading und Texturing
“There’s nothing quite like turning a grey-shaded model into something that looks real - or that could be real.” Lee Lainier

Rendering ist der Vorgang bei dem aus der modellierten Szene ein Bild errechnet wird. Zunächst muss man eine 
Render Engine auswählen, danach muss man der Szene und den Objekten mehrere Eigenschaften zuweisen:

Materialien
Dem Modell werden Shader zugewiesen. Je nach Typ von Shader können eine Vielzahl von echten und unechten 
Materialien simuliert werden. 

Lichter und Schatten
Um die Szene zu Beleuchten setzt man virtuelle Lichter in den Raum. Diese sind realen Leuchtmitteln für Filmsets 
nachgeahmt. Sie geben ein direktes Licht ab, werfen jedoch keine Schatten. Schatten müssen für jedes Licht einzeln 
aktiviert werden. 

Darüber hinaus kann man noch eine „indirekte“ Beleuchtung aktivieren. Diese simuliert die Eigenschaft von Pho-
tonen, welche sie die Farbe von der Fläche an der sie zuletzt reflektiert wurden annehmen.

Kamera
Man benutzt beim Rendern immer eine Kamera. Die Kamera funktioniert ähnlich wie eine echte Foto/Film-Kamera 
und definiert den Bildausschnit welcher schließlich gerendert wird.
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Unter Umständen kann das Plugin Deaktiviert werden, wenn Maya z.B. abstürzt dann muss man  das Plugin noch-
mals aktivieren. Ein einfaches MEL-Skript dafür findet man im Anhang. (Siehe „Activate Mental Ray Plugin“ Seite 
150)

Mental Ray als Standart Renderer einstellen
Damit Mental Ray immer als Standard Renderer zur Verfügung steht kann man unter Window > Settings and Pre-
ferences > Preferences unter Settings - Rendering bei „Prefered renderer:“ im Dropdown Menü mental ray auswählen.

Falls Maya abstürzen sollte und das Plugin nicht geladen wurde, wird der Maya Software Renderer verwendet.

Workspace Einstellungen

Menü
Um zu rendern braucht man das Menü „Rendering“ (F6). 

Panels

Beim vorbereiten auf das Rendern benutzt man den „Hypershade Editor“, die „Render View“ und eine Kamera-
Ansicht.

Shelf
Die “Rendering”-Shelf ist eingeteilt in Lichter, Camera,  Basis Shader und Render Einstellungen

Mental Ray Plugin aktivieren
Manche Funktionalitäten von Maya liegen als Plugin vor. Um Plugins in Maya zu laden muss man Window > Set-
tings and Preferences > Plugin Manager und dort an dem gewünschten Plugin ein Häckchen bei load setzen. (bzw. 
Auto load damit es automatisch mit Maya geladen wird). 

Viele Beispiele im Skript verwenden das Mental Ray Plugin. Man sollte sicherstellen das Mayatomr.dll aktiviert ist.

Plugin-Manager mit aktiviertem Mental Ray Plugin
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Renderer gerade verwendet wird.

Render-Vorbereitungen
Das Rendern braucht sehr viel Rechenleistung. Deswegen werden hierfür sog. RenderFarms verwendet. Pixar braucht 
durchschnittlich 7 Stunden um ein einziges Bild für ihre Animationsfilme zu erzeugen, sogar mit ihrer RenderFarm 
Wired Magazine 6/2010. Daher sollte man zuvor viele Testrenderings von einzelnen Elementen machen, bevor man 
einen finalen Render macht. 

Vor jedem Render sollte man unbedingt Abspeichern und alle unnötigen Programme schließen. Der Computer wird 
während dem Rendern üblicherweise kaum bzw. gar nicht reagieren. 

Um den RenderVorgang eines Einzelbildes abzubrechen muss man ESC drücken. Es dauert 1-10sek bis der Computer 
darauf reagiert.

Einen Test-Render erzeugen
„If you can shade a Teapot - you can shade anything“. In den Anfängen der Computergrafik hat man eine Teekanne 
verwendet um Shader auszutesten. Der Vorteil einer Teekanne ist, dass sie harte Kanten als auch weiche Kanten hat. 
Wenn es auf der Teekanne gut aussieht, sieht es wahrscheinlich auch auf dem eigentlichen Objekt gut aus. 

Heute ist so ein Testrender mit Teekanne unnötig, da man den Shader meistens direkt auf das Objekt anwenden und 
es ausrendern kann.  Jedoch kann man viel lernen wenn man Shader an Teekannen austestet.

In der Regel erstellt man mehrere Test-Render bevor man die Szene ausrendert. Diese Render haben eine sehr geringe 
Qualität und dienen nur um zu sehen ob einzelne Materialien, oder die Beleuchtung korrekt eingestellt ist. 

Anmerkung: Um im Output Fenster den Fortschritt des Renderns angezeigt zu bekommen (nur bei mental Ray) 
muss man unter Render > Render Current Frame q  gehen und unter Messages: Verbosity Level auf  “Progress 
Messages” setzen. 

Grundlagen Rendering

Arbeitsschritte
-- Render Engine auswählen

-- Shader den Materialien hinzufügen, ggf. Texturieren

-- Eine Kamera der Szene hinzufügen

-- Beleuchtung konfigurieren

-- Final Render

Render Engines
Die erste Frage die sich beim Rendern stellt ist, welche RenderEngine man verwenden soll. Die jeweiligen Render-
engines haben ihre Vor- und Nachteile und werden für verschiedene Zwecke eingesetzt und bestimmen daher das 
weitere Vorgehen. In allen Beispielen wird Mental Ray verwendet. Trotzdem sollen nun die verschiedenen Render-
Engines vorgestellt werden.

Maya Software

Ein Allzweckrenderer der direkt in Maya eingebaut ist. Es ist ein Hybrid Renderer der die Geschwindigkeitsvorteile 
eines Scanrenderers mit echtem Raytracing verbindet. Generell hat die Qualität des Bildes höhere Priorität als die 
Geschwindigkeit des Ausrenderns.

Der SoftwareRenderer hat den Vorteil, dass man das IPR (Interactive Photo Realistic rendering) Tool verwenden 
kann um das fertig gerenderte Bild interaktiv verändern zu können. Durch seine direkte Integration, kann man ein-
fach komplexe Shadingeigenschaften erstellen.

Maya Hardware
Im Grunde ist es ein hardwarebeschleunigter Allzweckrenderer. Im Allgemeinen ist der Hardwarerenderer schneller 
als der Softwarerenderer. Ein weiterer Vorteil ist die Möglichkeit des Ausrenderns von Hardware Partikeln. Jedoch 
kann der Hardwarerenderer keine Sub-D Objekte rendern und hat darüber hinaus noch weitere Limitationen. 

Meistens rendert man alle Objekte mit einem Softwarerenderer aus und lässt die Partikel Effekte mit Maya Hardware 
ausrendern.

Mental Ray
Mental Ray ist ein photorealistischer Raytrace Renderer. Dieser Renderer kann alle Materialien des Maya Software 
Renderers verwenden und zusätzlich noch eigene Materialien. Es kann auch den IPR-Renderer benutzen.

Mental Ray ist nicht direkt in Maya eingebaut sondern muss als Plugin (Mayatomr.mll) geladen werden.

Maya Vector 
Wie der Name bereits sagt ist Maya Vector ein Vektor Renderer. Dies ist besonders nützlich um Blaupausen des  
Modells zu erstellen. Die unterstützten Formate sind: Scalable Vector Graphics (SVG), Adobe Flash (SWF), Adobe 
Illustrator (AI) oder Postscript (EPS) 

Maya Vector wird selten verwendet und ist daher ein Plugin (VectorRenderer.mll)

Weitere Render Engines
Es gibt auch weitere Renderengines für Maya wie z.B. Visual Dynamics - V-Ray (http://www.vray.com/vray_for_
maya/) oder Pixar - Renderman (https://renderman.pixar.com/products/tools/rfm.html)

Wir werden uns hauptsächlich mit dem Mental Ray Renderer beschäftigen, da dieser Renderer in vielen gängigen 
3D-Modellierprogrammen, wie 3dsMax zur Verfügung steht.

Eine Render Engine auswählen
Unter den Render Settings direkt unter der Menüzeile ist „Render Using“ ein Dropdown Menü, was anzeigt welcher 

http://www.vray.com/vray_for_maya/
http://www.vray.com/vray_for_maya/
https://renderman.pixar.com/products/tools/rfm.html
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Möchte man ein Bild nicht mehr sehen so klickt man Remove Image und das aktuelle Bild wird entfernt.

Wenn man sich notieren möchte was man eigentlich zwischen den Bildern verändert hat, so kann man mit RMB auf 
die Icons Klicken und „Keep Image with Comment“ auswählen. Der Kommentar wird dann unten bei den Render-
informationen angezeigt.

Render Diagnostics
Die Render Diagnostics öffnet das Output Fenster und zeigt die letzten Meldungen der Render Engine an. Dies 
braucht man wenn z.B. Fehler beim ausrendern auftreten.                                                                

Render Engine
Das Dropdown Menü lässt einen die Render Engine auswählen ohne die Render Settings dafür zu öffnen. (Insbeson-
dere ist dies nützlich, wenn Objekte nicht angezeigt werden beim ausrendern. Benutzt man z.B. ein mia_material_x 
so kann Maya Software die Geometrie nicht rendern. Dann kann man hier überprüfen ob man auch mit Mental Ray 
rendert.)

IPR Controls
Die IPR Controls sind nur dann aktiv wenn man einen IPR Render macht. Der Pause Button pausiert den IPR 
Render, d.h. man kann veränderungen machen ohne das der render sofort neu ausgerechnet wird. Daneben ist eine 
Anzeige wieviel Zwischenspeicher für den IPR Render benötigt wird. Und der rote Knopf beendet das IPR-Rendering.

Arbeiten mit der Render View
Die Render View selbst hat eine Reihe von Funktionen die einem das Arbeiten und das Ausrendern sehr erleichtern.

Repeat Last Render
Dieser Button wiederholt einfach, den gleichen Render von der gleichen Kamera mit der man als letztes gerendert hat. 
Ungleich zu dem Button „Render Current Frame“ der immer die aktuelle Kamera ausrendert.

Render Region/Snapshot

Mit LMB kann man eine rechteckige Auswahl  auf dem Image Display Be-
reich selektieren. Drückt man den Button wird nur diese Region gerendert. 
Um die Auswahl wieder aufzuheben muss man einmal kurz LMB klicken.

Dies benutzt man wenn man Details korrigieren möchte ohne viel Zeit zu 
verschwenden das ganze Bild auszurendern.

Wenn man noch keinen Render von der aktiven Perspektive gemacht hat, 
kann man auf Snapshot klicken und man bekommt einen Wireframe-Render 
von der Szene. Mit LMB-drag kann man eine Region auswählen.

Interactive Photorealistc Render (IPR)
Man benutzt das IPR um schnell einen Überblick darüber zu bekommen wie 
Lichter und Farben wirken. Mit dem IPR kann man eine Render Region aus-
wählen. Der Unterschied zwischen Render Region und IPR, ist das man nun Materialeigenschaften verändern kann 
und die Veränderungen werden in Echtzeit in der Render View übernommen. 

Wenn man das IPR verwendet, sollte man die Qualität der Rendering Engine auf sehr niedrig stellen dies erlaubt 
dem IPR sehr schnell die Veränderungen zu übernehmen. Man kann für das IPR-Rendering nur MayaSoftware und 
Mental Ray verwenden.

Um einen IPR-Render zu erzeugen klickt man auf Repeat last IPR Render und selektiert die Region mit der man 
arbeiten möchte.

Render Settings
Öffnet die Render Settings.

Display RGB/Alpha/Real Size
„Display RGB“ zeigt das gerenderte Bild in Farben an, „Display Alpha“ zeigt den Alpha Kanal an.

Man kann auf dem Bild mit den normalen Camera Kontrollen Zoomen und bewegen. Möchte man ein unskaliertes 
Bild haben, klickt man einfach „Display Real Size“.

Keep Image /Remove Image
Wenn man verschiedene Werte verändert, möchte man machmal einen Vergleich zwischen vorher und nacher ma-
chen.

Klickt man auf „Keep Image“, so wird das Bild temporär abgespeichert d.h. schließt man Maya so werden alle geren-
derten Bilder wieder entfernt. Nachdem man ein Bild temporär gespeichert hat, kann man nun etwas in der Szene 
verändern und nochmal rendern. Mit dem Scrollbalken am unteren Rand vom Fenster kann man von Bild zu Bild 
springen.

Die RenderView Icons

Beispiel von einem Snapshot und anschlie-
ßender Render Region
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Kameras
In Maya hat man die Wahl ob man nur ein Einzelbild rendert oder eine Ani-
mation. Es wird immer eine virtuelle Kamera benutzt um das Bild auzuren-
dern. Es stehen einem immer die 3 Ortographischen Kameras „top“, „front“, 
„side“ und die perspektivische Kamera „persp“ zur Verfügung. 

In der Praxis verwendet man die „persp“ Kamera für das Modellieren und 
modifiziert sie oft wenn man sich in der Szene orientiert. Deswegen setzt 
man immer in die Szene eine neue Kamera die nur für das Rendern der Szene 
verwendet wird.

In Maya gibt es zwei Typen von Kameras. Die Standard Kamera simuliert 
eine Film Kamera und schießt ein einziges Bild. Die Stereo-Kamera besteht 
aus mehreren Standardkameras. Mit dieser Kamera können 3D-Bilder er-
zeugt werden (z.B. für 3D-Kinofilme wie Avatar). Man braucht dann spezi-
elle Displays bzw. Brillen um das Bild zu betrachten. Daher werden wir uns 
nur mit normalen Kameras beschäftigen

Eine Kamera erzeugen
Mit Create > Cameras > Camera erzeugt man eine Standart Kamera. 

Man findet auch „Camera and Aim“ und „Camera and Aim and Up“. Alle 
drei sind die gleiche Kamera, nur mit verschieden aktivierten Kontrollatt-
ributen. Es reicht wenn man eine „Camera“ erzeugt. Braucht man später weitere Kontrollen kann man sie im Attri-
bute Editor unter „Camera Attributes“- Controls hinzufügen. 

Allgemeine Attribute

Angle of View / Focal Length / Camera Scale
Mit dieser Einstellung lässt sich die perspektivische Verzerrung bestimmen die bei dem verwenden von Kameraob-
jektiven entstehen. Die Wertebereiche für die Focal Length ist für Weitwinkel Objektive 3-15, für normal Objektive 
35-55 und für Telezoom Objektive 100-550. 

Der Öffnungswinkel (Angle of View) und Brennweite (Focal Length) sind direkt voneinander Abhängig (d.h. setzt 
man den einen Wert wird automatisch der andere gesetzt). Das Camera Scale Attribut wirkt als Multiplikator für die 
Angle of View bzw. Focal Length.

Near Clip Plane / Far Clip Plane:
Virtuelle Kameras müssen aus praktischen Gründen Objekte die zu nah bzw. zu weit von der Kamera entfernt sind 

abschneiden. 

Meistens tritt dieser Effekt auf wenn die Far Clip Plane zu niedrig gesetzt wurde. Man mulitipliziert den Wert schritt-
weise mit 10 um einen geeigenten Wert zu bestimmen. Die Near Clip Plane bestimmt wie nah Objekte sein können 
ohne abgeschnitten zu werden. Falls Fehler auftreten dividiert man den Wert schrittweise um 10.

Anmerkung: Mit der Standard Kamera hat man keine Tiefenunschärfe. Man muss der Kamera zusätzlich einen 
Lens-Shader zuweisen (Siehe „Blurring Effekte“ Seite 166)

Teleobjektiv (120mm)Normal (35mm)Weitwinkel (10mm)

perspektivische Kamera

orthographische Kamera

Arbeiten mit dem Hypershade Editor

Man benutzt den Hypershade um sich zu visualisieren wie ein Shader funktioniert. Man kann eigene Shader „pro-
grammieren“ indem man verschiedene Nodes miteinander verbindet. 

Man öffnet den Hypershade mit Window > Rendering Editors > Hypershade.

Der Hypershade besteht aus drei Teilen

-- Create Nodes (linke Seite):  Hier lässt sich jeder Typ von Shading Node in die Work Area erstellen.

-- Existing Shaders (rechts Oben): Eine Übersicht von allen Shading Nodes (wie Materials, Lights, etc.)

-- Work Area (rechts Unten): Hier lassen sich Nodes miteinander verbinden.

Beispiel Checker-Texture
1.	 Im Create Nodes Panel ein neues Maya > Surface > Lambert Material erstellen. (Im Existing Shaders Panel 

wird ein neues Lambert angezeigt und in der Work Area wird das gleiche Lambert angezeigt)

2.	 Im Create Nodes Panel ein neues Maya > 2D Textures >  Checker erstellen. (Im Work Area wird ein place2d-
Texture-Node verbunden mit checker-Node angezeigt)

3.	 Man muss nun den Checker-Node mit dem Farbattribut vom Lambert-Node verbinden, dies passiert, indem 
man mit einem MMB-CLICKDRAG von dem Checker-Node über dem Lambert loslässt. Ein Menü öffnet sich 
und man wählt Color. 

4.	 In der Perspective-View erzeugt man einen PolyCube.

5.	 Mit dem Würfel selektiert. Im Hypershade RMB auf den lambert-Node und „Assign Material to Selection“ 
auswählen (Damit wird das Material an den Würfel gebunden.)

6.	 Rendert man das Bild sieht man einen Würfel mit einer Checker-Textur.

Hypershade
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Gesetz der Drittel

Symmetrie

Frosh Perspektive

Einzelbildkomposition
In der Bildgestaltung wird die Anordung der Gestaltungselemente Komposition genannt. Für die Fotografie/Malerei 
sowie Filmtechnik haben sich einige Grundlagen etabliert. Diese Grundlagen kann man ebenso auf Maya Kameras 
anwenden.

Gesetz der Drittel
Das „Gesetz der Drittel“ ist das am meisten benutzte Prinzip in der foto-
grafie. Es ist eine gängige Art und Weise immer im Drittel eines Bildes das 
interessanteste Objekt zu platzieren. Das liegt vor allem daran, das die Drit-
telschnittpunkte fast auf dem Goldenen Schnitt liegen und somit ein harmo-
nisches Bild liefern.

Anmerkung: Der Goldener Schnitt (Goldenes Verhältnis, Göttlicher Schnitt) 
ist in der Natur und in der Kunst immer wiederkehrendes Verhältnis mit dem 
Wert ~1,619. Beispiel: Das Breitbild Format 16:9 hat ein Verhältnis von ~1,77

Leitlinien
Einfache Strukturen und Linien im Bild verdeutlichen Tiefe und Räumlichkeit. Es ist für den Betrachter angenehmer  
wenn Leitlinien im Bild vorhanden sind.Es kommt zu einer Art Führung des Beobachters, ewlche das Gefühl der 
Harmonie vermittelt.

Symmetrie
Ein andererer Ansatz, gegensätzlich zu der ersten Regel, ist die vollkommene 
Symmetrie. Dieser Kompostitionstyp setzt das Objekt genau in die Mitte des 
Bildes. Die Wirkung entfaltet sich jedoch erst, wenn ein symmetrisches Ob-
jekt, bspw. ein Gebäude oder eine Blume oder eine interessante symmetrische 
Form abbildet. 

Ist das Objekt nicht genau in der Mitte verfehlt der Effekt, da das Gehirn 
diese Abweichung als störend empfindet. Meistens wirkt jedoch diese Kom-
postion als langweilig und unnatürlich.

Gerader Horizont
Eigentlich nicht erwähenswert, doch oft vergessen. Oftmals bildet man einfach eine Landschaft ab, und der Horizont 
ist irgendwie schräg im Bild. Dies lenkt sehr von der eigentlich schönen Landschaft ab, da auch hier das Gehirn den 
Fehler korrigiert.

Perspektivenwechsel
Eines der Dinge die beim positionieren der Kamera ans Tageslicht kommt ist 
seine eigene Perspektive wie man Dinge betrachtet. Um abwechselungsreiche 
Bilder schaffen zu können lohnt es sich selbst immer wieder mal einen Per-
spektivenwechsel zu veranlassen.

Um den Blickwinkel zu verändern muss man die Position und den Winkel 
von der Kamera zu dem Objekt verändern und mit den Kameraeinstellungen 
der Kamera experimentieren. z.B: der Brennweite der Kamera verändern

Mit Cameras arbeiten
Wenn man durch ein Panel auf die Szene sieht versucht Maya soviel wie 
möglich anzuzeigen. Beispielsweise die default Renderauflösung ist 640x480 
(4:3), benutzt man einen 16:9 Monitor wird mehr angezeigt was später ge-
rendert wird. 

Um den Bereich angezeigt zu bekommen der ausgerendert wird, muss man 
für das Panel das Resolution Gate aktivieren (View > Camera Settings > 
Resolution Gate)

Das Resolution Gate wird bestimmt über die Render Settings unter Com-
mon > Image Size.

Resolution Einstellungen
Je nach Ausgabe Medium muss man die „Dots per inch“ (dpi) anpassen, z.B. 72dpi sind ausreichend für Fernseher/
Monitore, 150-300dpi je nach Drucker.

Typische Video Auflösungen:

320x240px (QVGA) bzw 640x480px (VGA): auch “Desktop”-Auflösung genannt. Diese ist sehr klein und eignet 
sich gut um Testrender zu erzeugen. Seitenverhältnis 4:3

720x480 (DVD): Die Dvd Auflösung Seitenverhältnis 4:3

1280x720 (HD720) bzw. 1920x1080 (HD1080): Der Standard für HD Fernseher sowie BlueRay mit Seitenver-
hältnis 16:9

2K, 3k, 4k: Cinema Standardauflösungen die Breite ist z.B. für 2K 2x 1024px die Höhe ergibt sich aus dem verwen-
deten Seitenverhältnis.

In den „Image Size“-Presets findet man weitere Formate

Far Clipping Plane Error

Resolution Einstellungen
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Grundlagen Shading
Für die Renderengine ist ein 3D-Modell nur ein Gittermodell. Diesem Modell wird eine Materialeigenschaft (Ein 
Shader bzw. Shadingnetwork) zugewiesen. Jedes Objekt muss einen Shader haben, deswegen wird standardmäßig ein 
graues Lambert Material (lambert1) zugewiesen. In der Realität werden Materialien durch viele Eigenschaften wie z 
B. Diffuse Reflection (Shader ist ein Synoym von Material) bestimmt.

Anmerkung: Jede Geometrie sollte ein bestimmtes Material haben, beim Rendern sollte kein Material den Default 
Shader zugewiesen haben. Gleichzeitig kann man das lambert1 nicht löschen und man sollte es nicht modifizieren. 

Diffuse

Glossy Reflection

Fresnel Reflection

Basis Eigenschaften von Shader

Diffuse Reflection
Jedes Material, das nicht transparent ist, hat eine dif-
fuse Reflektion. Im Prinzip ist das die Grundlage wie 
Licht gestreut wird. Ein geringer Wert für ein diffuses 
Material reflektiert direkt und wirkt wie eine glatte 
Oberfläche. Ein sehr diffuses Material wäre hingegen 
z.B. Beton oder Papier diese haben sehr rauhe Oberflä-
chen und streuen das Licht in alle Richtungen. 

Glossy/Blurred Reflection
Eine Glossy Reflection simuliert die Eigenschaft eines 
Spiegels. Wie z.B. Porzellan oder Chrome. Hier ist zu 
beachten, dass nur die wenigsten Materialien die Um-
gebung perfekt spiegeln z.B. Silber oder Gold. Meistens 
handelt es sich um eine verschwommene Reflektion. 
Diese wird mit der Blurred Reflection Eigenschaft kon-
trolliert.

Fresnel Reflection
Der Fresnel Effect ist ein physikalischer Effekt, welcher 
die Reflektion je nach Einfallwinkel des Lichts errech-
net. Das bedeutet, dass Teile des Objekts die zu der Ka-
mera hin zeigen weniger reflektieren als die Teile des 
Objekts die einen Winkel zu der Kamera einnehmen.

Specular Highlights
Maya unterscheidet zwischen der Umgebung die reflek-
tiert wird und den Lichtquellen die in dem Material 
gespiegelt werden. Diese Trennung kommt nicht in der 
Natur vor. Man benutzt diese Trennung in 3D-Pro-
grammen, weil virtuelle Lichtstrahlen von einem un-
endlich kleinen Punkt ausgesendet werden und so nicht 
direkt im Material gespiegelt werden können. 

Refraction
Transparente Objekte brechen die durch Lichtstrah-
len sie hindurch gehen. Diesen Effekt nennt man „Re-
fraction“.  Jedes Material hat seinen eigenen Index of 
Refraction (IOR). Glas hat beispielsweise einen Bre-
chungsfaktor von 1.4. Um eine rauhe Oberfläche zu 
simulieren muss man „Refraction Blurring“ aktiviere.

Bruch eines Musters
Wenn sich ein homogenes Muster im Hintergrund befindet, so lässt sich ein 
Objekt davorstellen und das Gehirn wird seinen vollen Fokus auf dieses rich-
ten, da es das Muster bricht.

Bruch der Regeln
Irgendwann wird es auch reizvoll einfach die etablierten Regeln zu missach-
ten und was vollkommen anderes machen. Dies geht allerdings nur wenn  
man sich bewusst ist wie und warum diese Regel gerade bricht. Zu beachten 
ist jedoch, dass nur dann Regeln brechen kann, wenn man sie auch kennt... Bruch eines Musters
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Weight=1.0, Reflections = 1.0, Transpa-
rency = 1.0 Transparency Color = Black

Weight=1.0, Reflections = 0.25, Transpa-
rency= 1.0, Transparency Color = White

Weight=1.0, Reflections = 0, Transparen-
cy= 9

Mental Ray Shader
Mental Ray kann die Maya Shader rendern. Es gibt jedoch auch eigene Mental Ray Shader. Die nur von Mental 
Ray benutzt werden. Rendert man versehentlich das Bild mit z.B. Maya Software, so werden die Objekte komplett 
transparent.

Legacy Shader (dilectric  material, dgs_material, mib_*)
Die drei Shader, dilectric, dgs und mib sind sehr komplexe Shader. Um damit zu arbeiten braucht man viele Kennt-
nisse über verschiedene Shaderstrukturen um das gewünschte Ergebnis zu erhalten. Beispielsweise mit dem dilec-
tric_material lässt sich schnell ein Glasmaterial mit einer Refraction erstellen. Der wesentliche Nachteil von diesem 
Material ist, dass die Schatten die das Material wirft keine Transparenzen aufweist. Daher müsste man komplizierte 
Tricks verwenden, um doch einen halbtransparenten Schatten zu erhalten.

Diese Shader sind übriggeblieben aus früheren Versionen von Mental Ray. Das neuerere mia_material ist einfach zu 
bedienen und kann alle drei vorrangegangenen Typen ersetzen. Desweiteren wurden einige Schwächen behoben. 

Architectual Material (mia_material)

Das Architectual Material ist ein sehr flexibles fotorealistischer Shader. Er verbindet alle Legacy Shader zu einen ein-
zigen der einfach zu konfigurieren ist. Die Hauptattribute sind aufgeteilt in „Diffuse“, „Reflection“ und „Refraction“. 
Spezielle Eigenschaften wie Anisotropy werden in einen eigenen Teilbereich konfiguriert. Fresnel Reflection findet 
man unter „BRDF“. Unter den Presets findet man Materialien wie „Chrome“, „Matte Finish“, oder „Glossy Plastic“. 
Diese kann man als Basis verwenden um dann den Shader für das indivudelle Objekt einzustellen.

Man sollte das mia_material_x (x = Extended) verwenden, um bessere Ergebnisse beim Rendern mit weiteren Mental 
Ray Funktionen (wie Global illumination) zu erhalten. Der Shader kann jederzeit umgewandelt werden mit „Upgrade 
Shader“.

Shader einem Objekt hinzufügen
Man selektiert ein Objekt und RMB im Kontextmenü „Assign new Material“ oder „Assign Favorite Material“ um 
ein neues Material zu erstellen, oder „Assign Exisiting Material“ um ein bereits bestehendes Material hinzuzufügen.

Alternativ kann man auch den Hypershade Editor verwenden und mit Drag and Drop mit der MMB das Material 
auf das entsprechende Objekt ziehen. (Siehe „Arbeiten mit dem Hypershade Editor“ Seite 70)

Shader werden dann im Attribute Editor (STRG-A) konfiguriert.

Fehleranzeige
Wenn einem Geometrie Objekt kein Shader hinzugefügt ist (wenn man z.B. 
den Shader versehentlich löscht), wird es mit einem grünen Farbton einge-
färbt und wird nicht ausgerendert.

Fehlender Shader 

Maya Basis Shader

Lambert
Mit dem Lambert Material lässt sich eine komplett matte Oberfläche simulieren. Sie hat keine Glanzpunkte und 
kann keine Refractions oder Reflections simulieren. Ein hoher diffuse Wert lässt die Oberfläche heller erscheinen, ein 
niedriger Wert lässt die Oberfläche dunkeler erscheinen.

Das Lambert Material ist die Grundlage für Blinn, Phong, Anisitropic Materialien.

Phong / Phong E
Phong erweitert das Lambert Material mit der Eigenschaft einen Glanzpunkt zu simulieren, sowie Refractions und 
Reflections zu verwenden. Die Stärke des Glanzpunktes wird mit dem Attribut „Cosine Power“ angepasst. Initial 
wirkt das Material wie Platstik.

Blinn
Das Blinn Material berechnet den Glanzpunkt ebenso wie das Phong Materi-
al. Jedoch kann man den Glanzpunkt beim Blinn Material mit den Attribu-
ten „Eccentricity“ und „Specular Roll Off“ genauer bestimmen. Initial wirkt 
das Material wie ein Metall Objekt.

Anisitropic Shader
Um Mikrostrukturen der Oberfläche zu simulieren, verwendet man ein Ani-
sitropic Material. Solche Strukturen findet man z.B. auf der Unterseite einer 
DVD oder bei Seide.

Ramp Shader
Der Ramp Shader ermöglicht es verschiedene Materialien/Farben gleichzeitig 
auf einem Objekt zu verwenden. Je nach Betrachtungswinkel der Kamera 
werden die entsprechenden Materialien verwendet.

Ein Verwendungszweck von dem Shader ist eine künstliche Fresnel Reflec-
tion auf ein Objekt zu projezieren. (Insbesondere wenn man Maya Software 
renderer verwendet)

Refraction

Blinn

Anisitropic Shader

PhongLambert

Ramp Shader
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5. Lighting
“There’s nothing quite like turning a grey-shaded model into something that looks real - or that could be real.” Lee Lainier

Rendering ist der Vorgang bei dem aus der modellierten Szene ein Bild errechnet wird. Zunächst muss man eine 
Render Engine auswählen, danach muss man der Szene und den Objekten mehrere Eigenschaften zuweisen:

Materialien
Dem Modell werden Shader zugewiesen. Je nach Typ von Shader können eine Vielzahl von echten und unechten 
Materialien simuliert werden. 

Lichter und Schatten
Um die Szene zu Beleuchten setzt man virtuelle Lichter in den Raum. Diese sind realen Leuchtmitteln für Filmsets 
nachgeahmt. Sie geben ein direktes Licht ab, werfen jedoch keine Schatten. Schatten müssen für jedes Licht einzeln 
aktiviert werden. 

Darüber hinaus kann man noch eine „indirekte“ Beleuchtung aktivieren. Diese simuliert die Eigenschaft von Pho-
tonen, welche sie die Farbe von der Fläche an der sie zuletzt reflektiert wurden annehmen.

Kamera
Man benutzt beim Rendern immer eine Kamera. Die Kamera funktioniert ähnlich wie eine echte Foto/Film-Kamera 
und definiert den Bildausschnit welcher schließlich gerendert wird.

Grundlagen Direct Lighting
Im Grunde ist Direct Lighting, jede Lichtquelle die einen Schatten wirft. Alle Lampen in Maya sind vom gleichen 
Typ und ähneln denen eines Filmsets. 

Default Light
In 3D-Umgebungen gibt es eigentlich kein Licht solange man kein Licht der Szene hinzugefügt hat. Daher hat Maya 
ein eingebautes „Default Light“ dies wird verwendet damit man ohne zusätzliche Lichter die Szene ausrendern kann. 
Insbesondere auch, damit man überhaupt während dem modellieren etwas sehen kann.

Sobald man ein Licht der Szene hinzufügt wird dieses Licht automatisch ausgeschaltet. In manchen Fällen gibt es 
jedoch Konflikte,  daher kann man das Default Light zusätzlich in den Render Settings manuell ausschalten. 

Lichter in Maya erzeugen
Man kann entweder über Create > Lights oder über die Shelf Rendering Lichter in Maya erzeugen.

Die Shelf Icons:Ambient Light, Directional Light, Point Light, Spot Light, Area Light, Volume Light

Jedes Licht hat sein eigenes Light-Icon, in den meisten Fällen kommt das Licht von diesem Punkt. Das Light-Icon 
bzw. die Lichtquelle selbst wird beim ausrendern nicht ausgerendert.

Licht Typen

Ambient Light
Diese Beleuchtung erzeugt ein weiches diffuses Licht in jede Richtung. Die Intensität hat kaum Varianz, da es ver-
sucht eine indirekte Beleuchtung zu simulieren.

Das „Ambient Shade“-Attribut bestimmt das Verhältnis zwischen omidirec-
tionalen und direkten Strahlen. Ein Wert von 1 bedeutet, dass alle Licht-
strahlen von dem Light-Icon in der Szene stammen, damit ist es einem Point 
Light identisch. Ein Wert von 0 lässt das Licht von der Lampe an jeder Po-
sition im Bild gleich stark erscheinen (Dadurch gibt es keine Schatten mehr. 
Es gibt nur noch Farbflächen). Per Default ist der Wert auf 0.45 gesetzt. Die 
Positionierung des Lichts im Raum hat kaum Einfluss auf die Beleuchtung. 

Ambient Lights werden eigentlich nicht verwendet, da es einen sehr flachen 
Eindruck im Bild erzeugt. Mit anderen Lichtquellen hat man mehr Kontrolle 
über die Beleuchtung. Dieser Lichttyp wurde nur der Vollständigkeitshalber 
erwähnt.

Directional Light
Dieser Licht Typ ermöglicht die Simulation von unendlich vielen parallelen 
Lichtstrahlen, ausgehend von einer unbestimmten Lichtquelle. Daher bietet 
es sich an Directonal Light zu verwenden für Sonnenlicht.

Dadurch das die Strahlen parallel von einer unbestimmten Quelle kommen, 
spielt die  Positionierung  des Light Icons keine Rolle.  Nur die Rotation des 
Light-Icons hat einen Einfluss auf das Licht.

Möchte man z.B.. Sonnenlicht durch ein Fenster strahlen lassen, so muss 
man die Schatten von der Lichtquelle aktivieren ansonsten wird der gesamte 
Raum mit Licht erfüllt. 

Ambient Light

Directional Light
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Point Light
Die Lichtquelle vom Point Light ist ein einzelner Punkt und Licht strahlt von 
dem Punkt aus in alle Richtungen. Daher ist es ein gutes Licht um Glühbir-
nen, Kerzen, LEDs oder ähnliches zu simulieren.

Da die Beleuchtung von einem fixen Punkt ausgeht hat nur die Positionie-
rung einen Einfluss aufs Licht.

Spot Light
Spot Light sind Lichter die reale Spotbeleuchtungen aus dem Theater/Film 
simulieren. Ähnlich wie das Point Light entstammt das Licht von einem be-
stimmten Punkt, wird jedoch dann durch einen Kegel in die Szene proji-
ziert. Die gängigsten Anwendung für diesen Licht Typ sind, Taschenlampen, 
Scheinwerfer und Spotbeleuchtungen.

Positionierung und Rotation haben einen Einfluss auf das Licht. Darüber 
hinaus kann man den Öffnungswinkel über das Cone Angle Attribut verän-
dern um einen größeren/kleineren Bereich zu beleuchten.

Area Light
Dieses Licht simuliert eine Fläche aus Lichtern die in eine Richtung strahlt. 
Das Licht selbst wird von einer Reihe von Sampling-Punkten aus dem Light-
Icon in die Szene in alle Richtungen ausgestrahlt. Dies ist ein sehr diffuses 
Licht wie aus einer Softbox. Der Verwendungszweck ist  z.B. Licht aus einem 
Fernseher, Leuchtstoffröhren etc. aussenden zu können.

Positionierung, Rotation, Skalierung haben einen Einfluss aufs Licht. Skalie-
rung verändert gleichzeitig auch die Intensität des Lichtes, da die Sampling-
Points Anzahl immer gleich bleibt.

Volume Light
Das Volume Light ist ein künstlicher Licht Typ. Mit einem Volume Light, 
funktioniert es wie ein Point Light, nur das Licht existiert nur innerhalb der 
Begrenzung des Light-Icons. Das Licht entspricht keiner natürlichen Licht-
quelle und wird daher nur für bestimmte Special-Effects verwendet.

Position, Skalierung haben einen Effekt auf das Licht. Per default wird ein 
sphärisches Licht verwendet. Jedoch wenn die Einstellungen verändert wer-
den soll wie z.B.. die Begrenzung von Sphere zu Box dann hat auch die Rota-
tion einen Einfluss auf das Licht.

Spot Light

Point Light

Area Light

Volume Light

Allgemeine Attribute

Color
Alle Lichter haben als Standardwert die Farbe weiß. Jedoch emmitiert in der Natur kein Licht reines Weiß. Sogar das 
Sonnenlicht ist, je nach Tageszeit, rötlich oder bläulich. Florescent erscheint blau, Glühbirnen haben einen gelblichen 
Ton. Man sollte eigentlich immer die Farbe des Lichts anpassen um ein realistisches Bild zu erhalten.

Intensity
Dies bestimmt die Lichtstärke wenn sie auf eine Oberfläche auftrifft.

Decay Rate
Die Decay Rate definiert den Abfall der Licht-Intensität von Lampen. Benutzt man keine Decay Rate, so ist die 
Licht-Intensität an jeder Stelle gleich stark. Daher ist es ein sehr unnatürlicher Effekt wenn man Lichter ohne De-
cay Rate verwendet. Mit einer linearen Decay Rate berechnet sich die Intensität an jedem Punkt mit Intensity = 1/
Distanz (̂Faktor). Die Quadratic den Faktor 2 entsprechend dem realen Verhalten von Licht. Cubic, mit einem 
Faktor 3, lässt die Licht-Intensität schneller abfallen als in der Realität und wird nur in seltenen Fällen verwendet.

In den meisten Fällen reicht es jedoch eine Linear Decay Rate zu verwenden. Diese verbraucht später beim Ausren-
dern weniger Ressourcen und ist eine gute Annäherung an natürliche Lichter. 

Im Allgemeinen benutzt man nicht die Formel um zu errechnen wie das Licht eingesetzt werden sollte. Man passt die 
Intensity und Decay Rate ein paar Mal an und nimmt dann die ansprechendste Variante. (In vielen Fällen muss man 
die Intensity drastisch erhöhen, damit man das Licht überhaupt noch sehen kann).

Als Bsp sei das gleiche leicht gelbe Point Light, mit verschiedenen Decay Rate/Intensity Einstellungen dargestellt.

Mit Lichtern arbeiten
Man kann die Lampen in der Szene simulieren wenn man 7 drückt. Alter-
nativ kann man im Panelmenü Lighting > Use All Lights verwenden. Wenn 
man in diesen Modus wechselt und keine Lampen in der Szene vorhanden 
sind, dann werden alle Objekte schwarz dargestellt.

Mit dem „Show Manipulator Tool“ (T), bekommt man zwei Move Handles 
für das Licht, einen um die Position des Lichts zu bestimmen und einen um 
die Ausrichtung zu bestimmen. Man kann zusätzlich  z.B. beim Spotlight 
zwischen verschiedenen Einstellungsmöglichkeiten wechseln, indem man auf 
den kleinen Kreis unter dem Pivot klickt.

Anmerkung: Das Spot Light positioniert man am einfachsten, indem man das Licht selektiert und dann im Panel 
Menü auf Panels > Look through selected Camera. Das Panel verändert seine Ansicht sodass man durch das Licht 
schaut.

No Decay, Intensity 1 Linear Decay, Intensity 5 Quadratic Decay, Intensity 25

Spot Light mit Show Manipulator Tool

Panel aus Perspektive des Spotlights
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Schatten
Für jede Lampe muss man bestimmen ob sie Schatten wirft und muss seperat bestimmt werden. Dies ermöglicht z.B. 
eine  drei-Punkt Beleuchtung, wo nur das Haupt-Licht einen Schatten werfen soll und die anderen Lampen keinen 
Schatten werfen.

Es gibt zwei Typen von Schattenberechnung: Depth Map Shadows und Raytrace Shadows. Depth Map Shadows sind 
grundsätzlich schneller auszurendern als Raytrace Shadows. Letztere orientieren sich mehr an physikalisch realis-
tischen Gegebenheiten. Man kann für jede Lampe entweder Depth Map Shadows oder Raytrace Shadows benutzen. 

Depth Map Shadows
Bei Depth Map Shadows wird eine Depth Map erzeugt und dann mit einem Filter verwischt. Die DepthMap ist 
im Grunde ein Bild aus der Perspektive des Lichtes. Die Distanz zwischen Objekten und dem Licht sind in diesem 
Bild gespeichert. Beim ausrendern wird dann geprüft, ob der Punkt eine höhere Distanz zum Licht hat als in der 
DepthMap. Ist das der Fall, dann wird er dunkel gemacht. Da dies für jeden Punkt wiederholt wird entsteht dann 
ein Schatten.

Im Grunde gibt es für DepthMap Shadows zwei Variablen - Die “Resolution” der DepthMap und die “Filter Size”. 
Der Filter bestimmt den Grad des Verwischens. 

•	 Um scharfe Kanten bei einem Schatten zu erhalten, erhöht man die Auf-
lösung und benutzt einen geringen Filter. (Ein Wert von 0 für Filter Size 
entfernt das Verwischen komplett)

•	 Um weiche Kanten zu erhalten benutzt man eine geringe Auflösung und 
einen großen Filter. (Für unscharfe Schatten ist eine hohe Auflösung 
unnötig. So verkürzt man auch die Rechenzeit für das Rendern. Falls 
dabei zu viele Artefakte erzeugt werden muss man die Resolution und 
ggf. die Filtersize erhöhen).

Das Bias Attribut kann man in den meisten Fällen auf dem Wert 0.001 be-
lassen, falls Artefakte im Schatten beim Rendern auftreten, sollte man den 
Wert in 0.001 Schritten erhöhen.

Der größte Vorteil von DepthMap Shadows ist, dass man die DepthMaps 
nur einmal erstellen muss und man dann die DepthMaps wiederverwenden 
kann. 

Der Nachteil an dem Verfahren ist jedoch das man keine korrekten Schatten 
von transparenten Objekten erzeugen kann. 

Generell ist die Verwendung von DepthMap Shadows eher trickreich. Neben 
diesen Standardeinstellungen gibt es zusätzlich erweiterte Einstellungen, um 
z.B. Schattenartefakte zu vermeiden. Es gibt darüberhinaus für Mental Ray 
eigene Einstellungsmöglichkeiten die etwas simpler sind. (Fortsetzung „Men-
tal Ray Lights and Shadows“ Seite 84)

Raytrace Shadows
Bei Raytrace Shadows werden Shadowrays von der Lampe verschickt und 
dann dementsprechend eingefärbt. Daher können Transparenzen korrekt 
dargestellt werden.

Es gibt bei Raytrace Shadows 3 Einstellungen:

Shadow Radius (bzw. Light Radius, Light Angle )

Dieser Wert bestimmt die Härte des Schattens. Ein Radius von 0 erzeugt 
scharfe Kanten - ein Wert von 1 erzeugt weiche Kanten. 

Manche Lichter, wie Area Light, haben diese Einstellungsmöglichkeit nicht. 
Die Einstellung wird dann aus der Position und Rotation des Lichtes abge-
leitet.

Depth Map Shadows Scharfe Kante

Depth Map Shadows Weiche Kante

Raytrace Shadows

Shadow Rays  Je höher der Wert desto höher die Qualität der Schatten, (desto höher die Renderzeit)

Ray Depth Limit bestimmt, wie oft in einer rekursiven Reflektion ein Schatten sichtbar.

Mit Schatten arbeiten
Man kann Panels umstellen die Schattierung sofort berechnen, ohne dass man einen Testrender erzeugen muss. Man 
sollte immer erst die gesamte Ausleuchtung der Szene fertig haben und dann diesen Modus aktivieren. 

Hierfür aktiviert man im Panelmenü Lighting > Shadows

Dies sollte man wieder deaktivieren wenn man weiter modelliert/animiert, da ansonsten Maya sehr langsam reagiert.
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Mental Ray Lights and Shadows

Area Lights

Das Maya Standard Area Light beleuchtet Objekte unnatürlich hell. Mental Ray Area Lights werden anders berech-
net und erzeugen ein „natürlicheres“ Licht. Der Unterschied ist sehr subtil, im Beispiel nur erkennbar an der etwas 
helleren Teekanne.

Maya Area Lights werden umgewandelt zu Mental Area Lights indem man in den Einstellungen das Attribut mental 
Ray > Area Light > Use Light Shape aktiviert. Der Unterschied ist sehr subtil, das Mental Ray Licht ist etwas „realis-
tischer“ und unter Umständen einfacher zu konfigurieren, da Objekte schwächer beleuchtet werden.

Das „Type“- Attribut lässt das Arealight weitere Formen annehmen wie z.B. „Cylinder“ für Neonröhren.

Während man die Beleuchtung noch austestet sollte man einen High Samples Wert von 8 benutzen. Für den finalen 
Render sollte man einen Wert von mindestens 32 benutzen um das Rauschen in der Szene zu minimieren. High 
Sample Limit und Low Samples muss man nur konfigurieren wenn man eine Animation rendert.

Mit dem Attribut „Visible“ wird das Licht direkt in Lichtquellen sichtbar. Die Shape Intensity sollte mindestens iden-
tisch mit dem Intensity Wert sein, da die Decayrate auch auf diesen Wert angewandt wird.

Maya Default Mental Ray High Samples = 8 Mental Ray High Samples = 32

Attribute Editor Einstellungen

Arealight-Spotlight
Ein Spotlight lässt sich genau wie das 
Area Light mit den Mental Ray Ein-
stellungen erweitern.

Dieses Licht lässt sich genau wie das 
Area Light konfigurieren, jedoch hat 
man hier die Möglichkeit Attribute 
vom Spotlight wie z.B. „Cone An-
gle“, die das Licht noch weiter einzu-
schränken und kontrollieren.

Depth Map Shadows

Man erhält mit Mental Ray Depth Map Shadows sehr schnell das gewünschte Ergebnis. Um sie zu verwenden muss 
bei dem Licht unter mental ray > Shadows „Use mental ray shadow map overrides“ aktiviert werden.

 Die Resolution muss weiterhin eingestellt werden. Unabhänig von dieser wird im Softness Factor bestimmt, wie 
verwischt der Schatten werden soll. Mit der Anzahl der Samples erhöht man die Qualität der Schatten (min. Wert für 
Final Render = 32) Es lässt sich so mit einer geringen Auflösung hochqualitative Schatten erzeugen.

Maya Spotlight Mental Ray Area-Spotlight

Maya Default Mental Ray Samples = 1 Mental Ray Samples = 32

Attribute Editor Einstellungen
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Regular Shadowmap

Direct Light - No Shadow Map Camera

Raytracing

Direct Light - Shadow Map Camera

Depthmap Detail Map

Detail Shadow Map
Mit einer Detail Shadow Map lässt sich für transparente Objekte auch transparente Schatten darstellen. Es ist nicht so 
genau wie das Raytracing, jedoch spart es Rechenzeit solche Schatten zu verwenden und sehen besser aus als reguläre 
Depth Map Shadows.

In den Rendersettings unter Quality >Shadows > Shadow Maps lässt sich unter Format „Detail Shadow Maps 
auswählen“. In der jeweiligen Lichtquelle im Attribute Editor muss man dann unter mental Ray > Shadow das 
„Shadow Map Format“ auf  „Detail Shadow Map“ umstellen.

Shadow Map Cameras
Insbesondere bei „Directonal Lights“, die keine eigentliche Lichtquelle ist und nur aus paraelle Lichtstrahlen besteht, 
wird bei der Depthmap berechnung versucht immer alle Geometrie der Szene 
auf einmal zu beleuchten. Dies führt dazu das die Resolution bzw. sogar die 
max. Resolution in manchen Fällen nicht ausreicht um die gesamte Szene 
zu beleuchten (und die Renderzeit unnötig erhöht). Das gerenderte Bild hat 
meistens sehr grobe oder fehlerhafte Schatten. 

Die Fehler können bei jedem Lichttyp auftreten mit einer Shadowmap Ca-
mera lässt sich dieses Problem beheben. Es wird eine Camera benutzt um die 
Schattenregion genau zu definieren.

Hierfür wird unter mental ray > Shadows > Shadow Map Overrides  „Use 
Shadow Map Camera“ aktiviert. Mit dem Camera Aperature - Attribut und 
der Position des Light Icons (auch beim Directional Light) wird die Position 
der Camera festgelegt und dementsprechend die Schatten gerendert.

Light-Rig
Ein Light-Rig wird verwendet um verschiedene Beleuchtungsszenarien mehrfach zu verwenden. Dies erspart einem 
für jede neue Szene die gesamte Beleuchtung neu einzustellen.  Für eine Animation braucht man jedoch eine eigene 
individuelle Umgebung und Beleuchtung.

Schritt 2: Curve

Schritt 4: Fertiges Loft

Backdrop
1.	 Für diesen Schritt in die SideView wechseln. Create > CV-Curves mit 

x-gedrückt die Kurve zeichen (siehe Bild)

2.	 Duplizieren (STRG-D) und Transform (TranslateX = 12)

3.	 Surfaces > Loft

4.	 Wechsel des Maya-Modus  auf Rendering (F6 oder über das drop-
down menü) Lighting/Shading > Assign new Material> mia_
material_x

Anmerkung: Im Marking Menu des Lofts (RMB auf den Loft) gibt es auch 
den Befehl. Man kann sich so einen Wechsel zwischen Modulen sparen. 

5.	 Im Attribute Editor auf mia_material_x1 wechseln und auf back-
drop_material umbenennen.

6.	 Unter Presets das Material MatteFinish > Replace auswählen

Anmerkung: Das Preset „MatteFinish“ ist es ein diffuses nicht reflektie-
rendes Material. Das sich ideal als Studio Hintergrund eignet. 

7.	 Einen Weisston für das Attribut „Color“ einstellen (LMB auf die Farb-
fläche).

8.	 Das Loft auf eine eigene Ebene “Backdrop” setzen.
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Studio Lighting: Softbox
Eine Softbox ist ein flächiges Licht, das sanft die Umgebung beleuchtet. Es 
hat eine besonders markante rechteckige Form bei der Reflexion. 

AreaLight
Die Lichtquelle die einer Softboxbeleuchtung am nächsten kommt ist das 
Arealight.

1.	 Create > Lights > Arealight

2.	 Im Attribute Editor:

-- Farbe auf ein helles Gelb setzen (HSV - 60, 0.1,  1)

-- Intensity = 15 und DecayRate auf Linear

-- Schatten einstellen (z.B. Raytrace Shadows Shadow Rays 35)

-- Unter mental ray > Area Light > Use Light Shape aktivieren  
	 und High Samples auf 32 setzen

3.	 Das Licht mit dem Show Manipulator Tool (T) positionieren Trans-
late (10,5,10) und auf den Ursprung ausrichten

4.	 Das Licht duplizieren (STRG-D) und TranslateX -10

5.	 Die Lichter auf eine eigene Layer „Two_Softboxes_Arealights“

Schritt 5: Marking Menu on Loft Schritt 6-7: Attribute Editor vom für das Material

Beispiel einer Softbox Beleuchtung

Fertig gerenderter Bauhaus-Stuhl

Verwendung des Light-Rigs:

Beispiel: Bauhaus-Stuhl
1.	 Man öffnet das Lightrig und speichert es als neue Datei “bauhaus_

render.mb” (File > Save As)

2.	 File > Import - “bauhaus.export.ma”  (ggf. positionieren)

3.	 Dem Stuhlgerüst weist man das “mia_material_x” mit dem Preset 
„Chrome“ zu und der Sitzfläche/lehne ein weißes Phong Material.

4.	 Create > Cameras > Camera und einen Bildausschnitt wählen (Pa-
nel > Look through selected Camera, Resolution Gate)

5.	 Rendern

Martini Glas Render

Vorbemerkung
Da man jetzt nur Rendering Funktionen verwendet, kann man das Menü (F6) und Shelf auf Rendering umstellen. 
Nach jedem Schritt wo eine Kamera, Licht oder Material verändert wird sollte man einen Testrender (Siehe „Einen 
Test-Render erzeugen“ Seite 104) machen.  

Bildausschnitt wählen
1.	 Man erzeugt eine Kamera mit Create > Cameras > Camera

2.	 Im Panel Menü wählt man Panels > Look Through Selected. Man 
sieht nun durchdie Kamera. Wenn man nun mit den normalen Ka-
mera-Bewegungstools (ALT-LMB, ALT-MMB, ALT/RMB) die 
Szene verändert verändert sich die Position und Rotation der Kamera.

3.	 Man kann die  Resolution Gate  im Panel Menü View > Camera 
Settings > Resolution Gate aktivieren. Das Rechteck zeigt den ei-
gentlichen Bildausschnitt an.

4.	 Man positioniert nun die Kamera so wie man mit der Bildkompo-
sition zufrieden ist. (Diesen Schritt  muss man ggf. vor dem finalen 
Rendern nochmal anpassen)

 
3-Punkt Beleuchtung
Um die Form des Martini Glases zur Geltung zu bringen, benutzen wir 
eine 3-Punkt Beleuchtung.  Eine solche Beleuchtung besteht aus einem 
Hauptlicht(Keylight), was die hellste Lichtquelle ist, einem Fülllicht(Fill-
Light), was die Schatten aufhellt und dem Kanten Licht (Rim-Light), was 

Looking through Camera mit Resolution 
Gate

Eine erstelle Kamera in der Szene
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den Rand des Objekts auffhellt.

Die Positionen von den Lichtquellen müssen 
immer relativ zu dem Objekt und Kamera 
gesetzt werden. 
Das Key-Light sollte neben die Kamera in 
einem Winkel von 15-45° gesetzt werden. Das 
Fill-Light wird entgegengesetzt zum Key-Light 
positioniert.  Das Rim-Light wird fast ist ein 
intensives Licht was den Rand/Hintergrund 
beleuchtet

1.	 Für das Key Light Create > Lights > 
Spot Light (umbennenen auf KeyLight)

2.	 Das Key Light positionieren z.b. Trans-
lateXYZ  , RotateXYZ

3.	 Im Attribute Editor (STRG-A): 

-- Color (HSV)  180, 0.1, 1 (z.b. Cyan)

-- Intensity 20

-- Decay Rate Linear

-- Cone Angle 60

-- Penumbra Angle 20

4.	 Testrender erzeugen und ggf. die Position anpassen

5.	 Für das Fill Light Create > Lights > Point Light (umbennenen auf 
Fill Light)

6.	 Das Fill Light positionieren z.b. TranslateXYZ  , RotateXYZ

7.	 Im Attribute Editor (STRG-A): 

-- Intensity 0.7

-- Decay Rate Linear

8.	 Testrender erzeugen und ggf. die Position anpassen

9.	 Für das Rim-Light Create > Lights > Area Light

10.	 Im Attribute Editor (STRG-A): 

-- Color (HSV) 30, 0.1, 1	  (z.b. Orange),	

-- Intensity 8

11.	 Testrender erzeugen - Man sieht das die gesamte Szene vollkommen 
überbeleuchtet ist. Anstatt die Intensität mit z.B. der Decay Rate an-
zupassen lässt sich das Licht exclusiv an das Glas binden. Dazu ver-
ändert man die Light-linking Eigenschaft des Lichts unter Lighting/
Shading > Light Linking Editor > Light - Centric. 

12.	 Auf der linken Seite sieht man alle Lichter in der Szene und auf der 
rechten Seite sieht man alle Objekte der Szene. (die Lichter erscheinen 
doppelt, da man Beleuchtungsgruppen anlegen und diesen individu-
elle linking Eigenschaften geben kann)

13.	 Mit LMB klickt man auf der linken Seite Das “AreaLight1” bzw. RimLight - es werden sofort auf der rechten 
Seite alle Objekte ausgewählt.

14.	 Nun mit RMB + STRG selektiert man die Objekte aus die tatsächlich von dem Licht beleuchtet werden, also 
die Gruppe “martiniglas”.  Nichts anderes sollte selektiert sein.

15.	 Man kann nun den “Relationship-Editor” schließen. In der Vorschau wird das neue Lichtverhältnis nicht 
angezeigt, jeoch sieht man es bei einem Testrender. 

Eine Möglichkeit der Positionierung der Lichter

Key Light

Fill Light

Rim Light

Schatten
In der realen Welt versucht man viele Tricks zu verwenden um die Schatten von dem Fill-Light und Rim-Light das 
Bild nicht stört. In der 3D-Welt aktiviert man nur die Schatten die man benötigt.

1.	 Nur das Keylight erhält einen Schatten, bzw. man versucht die Fill und Rim Light so zu positionieren, dass 
kein Schatten im Bild vorkommt. Da wir im virtuellen Raum arbeiten, aktivieren wir einfach die Schatten 
nicht.

2.	 Mit dem Keylight selektiert den Unterpunkt Shadows aufmachen. Weiter unten kommt dann “Raytrace 
Shadow Attributes”

3.	 Ein Häckchen auf “Use Ray Trace Shadows” 

-- Light Radius 0.14

-- Shadow Rays 32,

-- Ray Depth Limit 1 

4.	 Speichern als (martini_glas.05.mb)

Materialien
Der Brechungsindex (Refraction) wird je nach Übergang von einem Material zu einem anderen errechnet. Bei dem 
Glas gibt es drei Übergänge. Der jeweilige Brechungsindex wird wiefolgt errechnet: Glas (1.5) / Luft (1.0) = 1.5, Was-
ser(1,33)/Glas(1,5) = 0.8, Wasser (1,33) / Luft (1,0) = 1,33.

Das Glas
1.	 Im Hypershade (Window > Rendering Editors > Hypershade)

2.	 Create > Mental Ray Materials > mia_material_x

3.	 Das Glas im Perspective selektieren und anschließend im Hypershade RMB auf das Material und im Mar-
kup-Menu “Assign Material to Selection” auswählen. 

Im Attribute Editor (STRG - A) umbenennen auf Glass		

-- Diffuse: 		 Weight  0  	 (Ein Glas hat keine diffuse Reflektion)

-- Reflection:	 Reflectivity 0.6 	 (Glas spiegelt die Umgebung)

-- Refraction:	 Index of Refraction 1.5 	 (Lichtbrechung z.B. Luft 1.0, Diamant 2.4)  
			   Transparency 1.0		  (Ein Glas ist vollständig Transparent)

-- BRDF:		  Use Fresnel Reflection  yes 	 (aktiviert physikalisch korrekte Spiegelungen) 

-- Advanced:	 Specular Balance 0 	 (deaktiviert künstliche Lichtspiegelungen)

Anmerkung: Das Glas wird unter Umständen nicht wie Glas wirken.Falls das Glas nicht Transparent aussieht beim 
ausrendern, sollte man die Qualität vom Raytracing erhöhen. (Siehe „Render Engine Einstellungen“ Seite 93)

Shadow Einstellungen
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Die Flüssigkeit
1.	 Im Hypershade (Window > Rendering Editors > Hypershade) das gerade erstelle Glass Material selektieren

2.	 Mit STRG-D (Edit > Duplicate > Duplicate without Shading Network) ein Duplikat anfertigen. 

3.	 Im Attribute Editor das  Material “glass2” Material in “water_glass” umbenennen. 

4.	 Unter Refraction RefractionIndex auf 0.8 setzen.

5.	 Unter Advanced Refraction „use Max Distance“ aktivieren, Max Distance = 2.0, „use Color at Max Distance“ 
aktivieren, Color at Max Distance auf einen blauton setzen.

6.	 Den abgetrennten Teil des Glases selektieren. RMB gedrückt halten MarkupMenu > Assign Existing Mate-
rial > water_glass

7.	 Im Hypershade das Material Duplizieren und „water“ nennen. (siehe Schritt 1-3)

8.	 Den „Index of Refraction“ auf 1.33 setzen.

9.	 Das Planar selektieren. RMB gedrückt halten MarkupMenu > Assign Existing Material > water_glass

Die Olive
1.	 RMB auf die Olive im MarkupMenu > Assign new Material

2.	 Im Menü Lambert auswählen.

3.	 Dem Lambert  (“Olive_material”)  einen Olivgrünen-Farbton (HSV 115, 0.8, 0.35) geben. 

4.	 Bei Bump Mapping auf das karierte Rechteck am Ende der Zeile klicken.

Glas Material

5.	 Im Menü Noise auswählen.

6.	 Bump Depth auf 0.1 setzen

7.	 zu “noise1” wechseln - Frequency Ratio 5, Depth Max 6

Der Zahnstocher
1.	 RMB auf den Zahnstocher im MarkupMenu > Assign new Material

2.	 Lambert wählen, es “wood” benennen.

3.	 Bei Color auf das karierte Rechteck am Ende der Zeile klicken.

4.	 Im Menü Wood auswählen.

5.	 Die Filler Color etwas aufhellen, die Layer Size auf 100 setzen (dies lässt die Jahresringe verschwinden) (mar-
tini_glas.06.mb)

Render Engine Einstellungen
1.	 Windows > Rendering Editors > Render Settings 

2.	 Unter dem Reiter Qualitiy bei Quality Presets stellt man den Modus auf „Production“.

Anmerkung: Es gibt es eine Reihe von verschiedenen voreingestellten Presets.  Im “Draft” Modus ist der Renderer 
am schnellsten jedoch hat das ausgerenderte Bild eine geringe Qualität (z.B. ist das Glas wegen fehlender Lichtbre-
chung nicht transparent). Bei dem “Production” Preset werden viele der Einstellungen wie  z.B. Anti-Aliasing und 
Raytracing richtig eingestellt. Die Qualität und Renderzeit ist wesentlich höher. Dieses Preset bietet eine gute Grund-
lage für ein final Render. 

3.	 Im Indirect Lighting Reiter unter Environment, Image Based Lighting klickt man auf Create

4.	 Es öffnet sich nun der Attribute Editor. Unter Image Based Lighting Attributes - Image Name klickt man auf 
das Verzeichnis am Ende der Zeile. 

5.	 Man wählt nun ein Bild aus  das man für die indirekte Beleuchtung verwenden möchte. (Auf der Website: 
http://www.debevec.org/Probes/ findet man Sphärenbilder im .hdr format die man gut für diesen Zweck 
verwenden kann)

Anmerkung: Die Enviroment Map wird verwendet, damit das Glas etwas zum reflektieren hat. Es wird eine Sphäre 
um die gesamte Szene gesetzt und das Bild darauf projeziert. Deswegen sind die meisten Enviromentmaps Sphären-
bilder.

6.	 Bei den RenderSettings  unter Indirect Lighting aktiviert man Final Gathering.

7.	 Nun kann man das fertige Bild ausrendern. (martini_glas.final.mb)

 http://www.debevec.org/Probes/
 http://www.debevec.org/Probes/
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Grundlagen Indirect Lighting
In der Natur trifft Licht auf eine Oberfläche und wird dann gestreut. Das Licht welches direkt auf die nächste Ober-
fläche auftrifft nennt man indirekte Beleuchtung. Der Effekt indirekter Beleuchtung ist, dass die Farbe von dem 
zuletzt aufgetroffenen Objekt in dem Schatten bzw. Untergrund zu finden ist (auch Color Bleeding genannt). 

In einer virutellen 3D-Umgebung senden Lampen reines direktes Licht aus. Um den Effekt der indirekten Beleuch-
tung zu simulieren benutzt man Global Illumination (GI) und Final Gathering (FG).

Ambient Occlusion ist der Effekt mit dem bestimmte Bereiche, wie die Ecken eines Raumes, dunkeler erscheinen, da 
weniger gestreute Photonen dorthin gelangen. Es ist somit eine Art „indirekte Schatten“.

Pointlight (direktes Licht) und AreaLight (Photonen Emitter) Direkte Beleuchtung

Direkte Beleuchtung + GI + Final GatherDirekte Beleuchtung + Global Illumination

Ambient Occlusion Pass Im Compositing zusammengesetzt zum Finalen Bild

Global Illumination

Photonen
Lichter müssen Photonen aussenden damit man Gebrauch von Global Illumination machen kann. Wie der Name 
bereits sagt, werden Photonen simuliert und von der Lichtquelle ausgestrahlt. Photonen in Mental Ray simulieren die 
in der Natur vorkommenden. Sie haben eine gewisse Energie wenn sie ausgesandt werden und verlieren einen Teil 
davon bei jeden auftreffen auf ein Material. Gleichzeitig nehmen sie die Farbe des Materials an. 

Spot, Point, Area und Directional Lights können Photonen aussenden, jedoch man sollte nicht einfach bei jeder 
Lichtquelle einfach Photonen aktivieren, dies erhöht nur unnötig die Renderzeit und ändert unter Umständen nichts 
an der Beleuchtungssituation. 

Attribute für ein Licht

Photon Color
Setzt man die Photon Color auf Weiß wird die Farbe der Photonen bestimmt durch die Oberfläche an der sie als 
letztes reflektiert wurden.

Photon Intensity
Die Photon Intensity bestimmt wie hell die Photonen sind wenn sie erzeugt werden. Je höher der Wert desto heller 
sind sie. Für stimmungsvolle Beleuchtung lässt sich die Farbe z.B. auf einen Rotton setzen für einen Sonnenunter-
gang, oder einen Blauton für Nacht usw...  

Maya Materialien reagieren schwächer auf die Photon Intensity als Mental Ray Materialien. 

Exponent
Der Exponent bestimmt die Abfallrate, also die Decay Rate der Photon Intensity. Ein Wert von 2 entspricht der Reali-
tät. Muss man nur in sehr seltenen Fällen diesen Wert verändern. Je höher der Wert, desto schneller ist die Abfallrate.

Caustics Photons/Global Illum Photons
Bestimmt die Anzahl der Photonen 
die simuliert werden Es sind zwei se-
perate Berechnungsvorgänge, daher 
kann man verschiedene Werte für 
die Photonenanzahl eingeben.

Der Wert orientiert sich immer an 
der Komplexität der Szene. Wird das 
Licht an vielen Oberflächen gestreut, 
so muss man in der Regel viele Pho-
tonen (Anzahl > 100000) ausstrah-
len. Man sollte nur soviele Photonen emittieren wie nötig, da es ein sehr rechenintensiver Vorgang ist. 

Meistens benutzt man Final Gather 
in Kombination mit Global Illumi-
nation um mit  wenigen Photonen 
ein gutes Ergebnis zu erhalten.

Mit Photonen arbeiten

10K Photonen

100K Photonen

10K Photonen + FG (16s)

100K Photonen + FG (23s)
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1.	 Zunächst muss man unter den Render Settings - Indirect Lighting, Global Illumination aktivieren. Dies 
ermöglicht das Lampen Photonen ausstrahlen können. 

2.	 Allgemein trennt man die direkte und indirekte Beleuchtung. Daher benutzt man dedizierte Photonen-
Emitter d.h. man verändert die Lampen aus der 
direkten Beleuchtung nicht, sondern fügt eine 
neue Lampe der Szene hinzu und setzt die In-
tensity auf 0.

3.	  Im Attribute Editor unter Mental Ray - Cau-
stics and Global Illumination aktiviert man 
dann „Emit Photons“

Anmerkung: Man sollte niemals mit einem Directio-
nal Light Photonen emmitieren. Da ein Directional 
Light „unendlich“ viele Lichtstrahlen über die gesamte 
Szene simuliert, müssten eine sehr hohe Anzahl von 
Photonen ausgestrahlt werden, damit überhaupt einen 
Effekt erkennen wird.  In einer Szene in dem das Di-
rectional Light durch ein Fenster in die Szene gestrahlt 
wird bietet sich z.B. eine Kombination mit einem Point 
Light, welches Photonen emmitiert an.

Globale GI Einstellungen

Accuracy
Die Accuracy Einstellung bestimmt wieviele Photonen miteinander verrechnet werden um die Helligkeit des auftref-
fenden Photons berechnen zu können. 

Niedrige Werte erzeugen ein geflecktes Resultat, hohe Werte lassen die Übergänge sanfter werden. Hohe Werte erhö-
hen allerdings die Renderzeit.

Das „gefleckte“ Resultat lässt sich auch mit Final Ga-
ther korrigieren, Daher ist es nicht immer nötig die Ac-
curacy auf hohe Werte zu setzen.

Scale
Skaliert den GI-Effekt. Man kann auf die Farb Eigen-
schaft klicken und dann im HSV-Modus unter Value 
den Wert auf bspw. 2 setzen. Dann verdoppelt sich die 
Helligkeit der auftreffenden Photonen. 0.5 halbiert die 
Helligkeit der Photonen.

Radius & Merge Distance
Bei dem Wert 0, errechnet Maya automatisch den ‚kor-
rekten‘ Radius bzw. die Merge Distance. Beide Werte 
können für die jeweilige Szene angepasst werden, um weitere Renderzeit zu sparen.

Aktivierte GI Einstellungen

Akrivierte Photonen an einem Area Light

Final Gathering
Im Gegensatz zu GI braucht Final Gathering (FG) kei-
ne Lampe die Photonen ausstrahlt. FG erzeugt eine dif-
fuse Beleuchtung der Szene.

Accuracy
Bestimmt die Anzahl von Final Gather Rays. Je höher 
der Wert desto bessere Ergebnisse. Allerdings erhöht 
sich die Rechenzeit.

Point Density
Bestimmt quasi die „Photonen Anzahl“ wie bei GI.

Point Interpolation
Bestimmt wieviele Punkte zusammengerechnet werden, um ein glatteres Ergebnis zu erhalten.

Primary Diffuse Scale
Skaliert den Effekt des ersten „Bounce“ und bestimmt damit die generelle Helligkeit.

Secundary Diffuse Scale
Skaliert den Effekt jedes weiteren „Bounce“ und bestimmt damit die Helligkeit nachdem der Strahl weitergeleitet 
wurde. Diese Eigenschaft wird nur aktiviert wenn „Secundary Diffuse Bounces“ > 0 ist.

Secundary Diffuse Bounces
Bestimmt wie oft der Strahl weitergeleitet wird.

Einstellungen für reine FG Beleuchtung
1.	 In den Render Settings geht man auf die Option „Common“ und deaktiviert Render options > „Enable 

Default Light“.

2.	 In der Szene muss man z.B. ein PolyPlane mit einem Lambert (Farbe 
Lambert, Incandecence auf weiss) erstellen. Dieses Objekt emmitiert 
kein Licht, wird jedoch bei der indirekten Beleuchtung als Leucht-
körper verwendet (wie eine Bouncecard bei der Fotographie)

3.	 In den Render Settings geht man auf die Option „Indirect Lighing“ 
und aktiviert Final Gathering > Final Gathering.

Aktiviertes Final Gathering

Default Light Deaktivieren

Bounce Card für Szene
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Incandecence für Bounce Card einstellen

Fertig gerendertes Bild

Ambient Occlusion
Ambient Occlusion (AO) ist eine sehr einfache Art und Weise Schatten in eine Szene zu bringen. Diese Schatten sind 
zwar nicht physikalisch korrekt, jedoch gut genug um einen sehr glaubhaften Effekt zu erzeugen.

AO wird üblicherweise als ein eigener Render Pass ausgerendert, da man erst in dem postproduction Schritt dem Bild 
hinzufügt.

Einstellungen für AO Pass
1.	 In den Render Settings geht man auf die Option „Passes“

2.	 Man klickt den Button „Create new render pass“ und wählt Ambient Occlusion

3.	 Mit dem AO-Pass selektiert, klickt man „Associate selected Pass with current Layer“

4.	 In der Option „Indirect Lighting“ aktiviert man Ambient Occlusion > Ambient Occlusion

Beim Rendern (Render > Batch Render)  wird nun neben dem gerenderten Bild (Beauty Pass) zusätzlich ein Ordner 
„AO“ angelegt in der die A0-Pass abgespeichert wird. 

Anmerkung: Wählt man als Dateiformat „PSD Layered“ werden alle Render Passes in eine einzelne PSD Datei  als 
Layers gespeichert.

Schrirt 2: New Render Pass erzeugen Schritt 3: AO Pass der Render Layer hinzugefügt

Schritt 4: Aktiviertes AO
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Post Production
Mit dem jeweiligen Programm (hier am Beispiel Photoshop) überblendet man den AO-Pass über die Beauty-Pass mit 
Multiply und passt die Opacity der Ebene an.

Beauty Pass ohne AO, Falsche Reihenfolge der Layer

Richtige Reihenfolge der Layer, AO auf Multiply gesetzt

Opacity der Layer angepasst, damit der Effect abgeschwächt wird
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6. Animation
In den frühen Anfängen der Animation musste jedes Bild einzeln gezeichnet werden. Ein Künstler zeichnete die 
aussagekräftigsten Bilder, die sogenannten Keyframes und viele Zeichner haben die Bilder zwischen den Keyframes 
gezeichnet. Diese Art der Animation wird Keyframe-Animation genannt. Heute werden die Inbetweens vom Com-
puter errechnet und gezeichnet.

Mit dem Computer hat man auch andere Möglichkeiten Objekte zu animieren. Man kann mathematische Formeln 
verwenden um eine Bewegung zu beschreiben oder man kann Objekten Eigenschaften zuweisen, damit sie automa-
tisch animiert werden (wie z.B. die Räder eines Autos.)
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Grundlagen

Storyboard
Man sollte am Anfang ein klares Bild von dem machen was man animieren möchte. Es ist sehr hilfreich ein Story-
board aufzumalen, egal ob man malen kann oder nicht - hauptsache man hat sich grob visualisiert was die Animation 
sein sollte.

Frames
Jedes Einzelbild einer Animation wird als Frame bezeichnet. Üblicherweise werden Animationen in Europa mit dem 
Pal-Standard 25fps(Frames per Second) abgespielt. Das bedeutet 1 Sekunde braucht 25 Frames.

Playback
Am Ende des TimeSliders hat man die Playback Controls. Klickt man Play wird die aktuelle Playback Range in einer 
Endlosschleife abgespielt.

Keyboard Shortcuts
ALT-V Playback starten/stoppen

ALT-SHIFT-V Playback auf Min Frame der Playbackrange setzen
. Zum nächsten Keyframe springen
, Zum vorhergehenden Keyframe springen

ALT-. Einen Frame vorwärts
ALT-, Einen Frame rückwärts

Keyframe Animation
Bei der Keyframe Animation werden in der Animation an bestimmten Zuständen Keyframes gesetzt und der Compu-
ter errechnet dann alle Zwischenbilder. Möchte man z.B. eine Kugel in 1 Sek von Punkt A(0,0,0) zu Punkt B(10,0,0) 
bewegen, setzt man bei Frame 1 den Ball auf Punkt A und setzt einen Keyframe, und bei Frame 25 einen Keyframe 
mit dem Ball auf Punkt B.

Es wird in Maya immer zwischen zwei gesetzten Keyframes ein „Ease in and Ease Out“ verwendet. (Siehe „Arbeiten 
mit dem Graph Editor“ Seite 105)

Keyboard Shortcuts
SHIFT-W Transform Keyframe (XYZ)
SHIFT-E Rotate Keyframe(XYZ)
SHIFT-R Scale Keyframe (XYZ)

S Key All (Keyframe für Transform, Rotate, Scale)

Motion Path Animation
Bei der Motion Path Animation, setzt man ein Objekt auf einen vordefinierten Pfad. Über eine bestimmte Zeit hin-
weg wandert das Objekt den Pfad entlang. (Die Animation beginnt am Anfang der Kurve und endet am Ende der 
Kurve).

Dies ist besonders nützlich, da man im Vorfeld die Route des Objekts visuell auslegen kann und dann einfach das 
Objekt entlang der Kurve animiert.

Reaktive Animation
Reaktive Animation benutzt man um Objekte auf eine Animation reagieren zu lassen. man bewegt z.B. ein Auto von 
A nach B, dann sollten die Räder sich dementsprechend drehen.

Workspace Einstellungen

Menü
Die Haupt Animations-Operationen für Keyframe Animation findet man im  “Animation” Menü (F2).

Shelf

Deformers

Animation

Panels

Graph-Editor
(Siehe „Arbeiten mit dem Graph Editor“ Seite 105)

Playback Speed
Spielt man eine Animation in Maya ab, so wird die Animation „so schnell wie möglich“ abgespielt d.h. die Frame 
Rate in Maya bestimmt die Abspielgeschwindigkeit. Diese hängt direkt von der Komplexität der Szene und die 
Rechenleistung des Computers ab. Sie wird bestimmt durch Anzahl der Bilder(Frames) pro Sekunde. Insbesondere 
wenn man nur eine sehr einfache Szene hat, kann es sein, dass z.B. eine Frame Rate von 120 Frames/Sekunde aus-
tritt. Ein normaler Film hat eine Frame Rate von 24 bzw. 25. Die Animation würde daher 5x schneller als Normal 
abgespielt werden.

Man kann Maya jedoch auch limitiert in „Echtzeit“, also 24 Bilder/sek, abspielen zu lassen. Mit RMB auf den Time 
Slider klicken und unter Playback Speed „Play Every Frame, Max Real-time“ aktivieren. 

Alternativ lässt sich das auch unter Window  > Setting and Preferences > Preferences TimeSlider einstellen.

Frame Rate
Standardmäßig nimmt Maya an, man entwickelt für einen Film, also eine Framerate von 24 Bilder/sek. Man sollte 
immer am Anfang seines Projekts die richtige Framerate setzen. Die Einstellungsmöglichkeit findet man unter Win-
dow > Setting and Preferences > Preferences - Settings (Working Units)
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Arbeiten mit dem Graph Editor
Der Graph Editor ermöglicht es die Keyframes graphisch zu visualisieren, sowie den Übergang von Frame zu Frame.

Den Graph Editor öffnet man mit Window > Animation Editors > Graph Editor.

Auf der rechten Seite hat man die graphische Darstellung der Animation. Selektiert man ein Objekt z.B. in der Per-
spektivischen Ansicht wird der Graphe angezeigt. Die schwarzen Punkte sind die entsprechenden Keyframes. 

Die Outliner-Liste an der linken Seite zeigt die selektierten Objekte an, sowie die Channels die bereits einen Key-
frame haben und ermöglicht schnelles selektieren von bestimmten Attributen. Man wählt sie aus der Liste auf der 
linken Seite aus (Mit SHIFT-LMB bzw. STRG-LMB macht man eine mehrfach Auswahl).

Um den Kurvenverlauf zu veränden manipuliert man entweder direkt den Keyframe oder die Kontrollpunkte der 
Keyframes. Durch Anklicken der Keyframes selektiert man diese (bzw. zieht ein Rechteck für eine mehrfach Aus-
wahl). Man kann die Punkte manipulieren, indem man zunächst mit der Taste W in das Move Tool wechselt. Mit 
MMB  lässt sich der Keyframe frei manipulieren, Mit SHIFT-MMB lässt sich der Keyframe nur horizontal oder verti-
kal verschieben (je nach dem, wie man die Maus bewegt). 

Anmerkung: Man muss immer zuerst das Move Tool selektiert haben, um den Keyframe mit MMB zu bewegen.

Keyboard Shortcuts
W, MMB Move Keyframe

W, MMB-SHIFT Horizontal bzw. vertikal Keyframe verschieben
F Focus on Keyframe (Zoomed den Graph)

ALT - MMB Move Graph
ALT-RMB Zoom Graph

Tangents 
Die Einstellung der Tangents bestimmt wie man die 
Kontrollpunkte manipulieren kann und wie der Kur-
venverlauf nach dem Keyframe interpretiert wird.

Mit dem Menü lässt sich der Typ umwandeln z.B. er-
möglicht „Spline“ gerundete Kurven, „Linear“ eckige 
und „Stepped“ springt sprunghaft zu einem anderen 
Wert.

Graph Editor mit Kontroll punkt eines Keyframes selektiert

Die jeweiligen Keyframes umgewandelt in Spline, Linear, Stepped

Expressions
Man kann eine Bewegung mit einer mathemeatischen Funktion definieren. Hierfür definiert man für jede Variable 
die man beinflussen möchte eine entsprechende Funktion.

Animation Tools

Constrains
Mit den verschiedenen Constraints lassen sich Eigenschaften von mehreren Objekten simultan und identisch modi-
fizieren.

Deformers
Deformers können zum modellieren sowie zum Animieren verwendet werden. Der Befehl „Delete History“ (ALT-D) 
löscht daher die Deformers. Möchte man die History löschen ohne die Animation durch einen Deformer zu verlieren 
wählt man Edit > Delete by Type > Non-Deformer History.

Alle Non-Linear Deformer werden zunächst einfach erstellt dann muss man die Attribute für die jeweilige Form 
konfigurieren. Anschließend kann man mit diesem Attribut deformieren.

Skeleton
Ein Animationsskelett besteht aus Joints und IK Handles. Geometrie wird als Skin an das Skelett gebunden. Beim 
Bewegen des Skeletts wird die Geometrie verformt und passt sich dem Skelett an.



106 107Keyframe Animation  ||  || Animation

Keying ausschalten, indem man auf den Schlüssel klickt.

5.	 Im Time Slider kann man nun auf Play forwards klicken und man sieht die Animation in einer Endlosschleife. 

6.	 Nun setzen wir für Frame 4  TranslateY = 8, Frame 8  TranslateY = 0, Frame 12  TranslateY = 4, Frame 16  
TranslateY = 0, Frame 20  TranslateY = 2, Frame 24  TranslateY = 0.

7.	 Mit Play sieht man, dass der Ball für die erste Sekunde hüpft, jedoch für die zweite Sekunde sich unverändert 
fortbewegt.

8.	 In diesem Beispiel wäre es besser wenn der Ball für 2 Sekunden hüpft. Dies kann man leicht verändern, indem 
man den Graph Editor verwendet Window > Animation Editors > Graph Editor. Im linken Teil sieht man die 
selektierten Objekte und die Keyframes. Im rechten Teil sieht man wie sich die Werte über die Zeit als Graph 
verändern. Die Punkte auf den Kurven sind die Keyframes.

9.	 Um sich einen besseren Überblick zu verschaffen, mit LMB auf TranslateY, um alle anderen Werte auszublen-

den (Mit LMB auf nurbsSphere1 werden wieder alle Werte angezeigt). Mit LMB eine rechteckige Selektion 
ziehen um alle Frames von TranslateY auszuwählen.

10.	 Im Graph Editor wird immer relativ zur Position des Mausklicks skaliert. Mit R (Scale Tool) und MMB auf 
den Ursprung klicken und skalieren. Wenn der letzte Frame in dem Bereich 45.5-50.4 ist, kann man aufhö-
ren.

11.	 Mit den selektierten Keyframes geht man auf Edit > Snap - so werden allen Keyframes ganze Zahlen zuge-
ordnet.

12.	 Man kann nun die Animation abspielen. Da der Ball eine konstante Geschwindigkeit hat, wirkt die Sprung-
bewegung des Balles unnatürlich. 

Graph Editor

Graph Editor nach Skalieren

Keyframe Animation 
1.	 Eine Nurbs Sphere erstellen mit Create > Nurbs Primitives > Sphere (Radius 1,  TranslateX -12)

2.	 Mit der Sphere selektiert drückt man S, oder Animate > Set Key. Dies setzt einen Keyframe für die Scale/
Rotate/Translate Eigenschaften. In der Channel Box werden alle Elemente denen je ein Key zugewiesen ist 
rosarot unterlegt. In dem Time Slider wird ein roter Strich für den Keyframe des Objektes angezeigt (man 
muss dabei das animierte Objekt selektiert haben).

3.	 In der Zeitleiste klickt man nun auf Frame 50.  Frame 50 wird aber nicht angezeigt. Im Range Slider gibt 
man deswegen für den „End-Time of Playback“ 50 ein. Automatisch wird nun für die „End time of Anima-
tion“ der Wert 50 gesetzt.

4.	 Mit Frame 50 selektiert setzt man nun die Sphere auf TranslateX = 12. Mit S erzeugt man einen weiteren 

Keyframe.

Anmerkung: Per Default ist Autokeying eingeschaltet. Hat ein Objekt bereits einen Key wird für jede Veränderung 
automatisch ein neuer Keyframe gesetzt. Man muss daher immer nur den ersten Keyframe setzen und Maya setzt alle 
weiteren Keyframes automatisch, wenn man das Objekt manipuliert. Am Ende des Range Sliders kann man Auto 

Keyframe auf Frame1 in der Timeline (roter Strich)

„End-Time of Playback“ Blau umrandet
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Motion Path Animation
1.	 Create > Nurbs Primitives > Sphere

2.	 Mit den Curve Tools kann man eine Kurve in den Raum zeichnen. Sie sollte möglichst genau der gewünsch-
ten Bewegung entsprechen.

3.	 Man selektiert das Objekt (die Sphere) und die Kurve

4.	 Animate > Motion Path > Attach to Motion Path repositioniert das Objekt auf den Anfang der Kurve. (Der 
Control Vertex Point ist identisch zu dem ersten Punkt der Kurve.) Der Range Slider definiert, wann die 
Kugel anfängt die Kurve entlang zu fahren und wie lange sie braucht um das Ende zu erreichen. (Im Graph 
Editor kann man das auch nachträglich verändern.)

5.	 Die Kurve lässt sich im Edit Modus per CVs und EPs anpassen.

Anmerkung: Weitere Keyframes, um die Geschwindigkeit anzupassen, erstellt man mit Animate > Motion Path > 
Set Motion Path Key

Anmerkung: Um effizienter mit dem Graph Editor zu arbeiten, kann man in der Toolbox das Icon persp/Graph kli-
cken.  Alternativ mit der Hotbox (Leertaste) > (North Sector)> LMB > persp/Graph. Die Animation kann nun in der 
oberen Ansicht abgespielt werden. In dem unteren Graph Editor kann man die Werte direkt verändern.

13.	 Man selektiert nun alle Keyframes mit TranslateY = 0 und macht im Graph View Menü > Tangents > Linear 

14.	 Beim abspielen sieht man nun die Kugel beschleunigen und abbremsen.

Deformers

1.	 Bei Frame 1 die Sphere selektieren und einen Nonlinear Deformer Squash erzeugen. (Create Deformers > 
Nonlinear > Squash).

2.	 Drückt man T (Show Manipulator Tool) kann man die Eigenschaften des Deformers kontrollieren. Für 
Frame 1 stellt man einen Faktor von -0.5 ein.

3.	 Wird Play gedrückt sieht man, dass der Deformer sich nicht bewegt und sich die Kugel seltsam deformiert. 

4.	 Der Deformer muss als Child Object der Kugel gesetzt werden. Dabei selektiert man zuerst den Deformer 
und dann die Kugel. Anschließend drückt man P (Edit > Parent)

5.	 Der Deformer bewegt sich nun mit, der Faktor bleibt immer gleich. Diesen kann man nun auch mit zusätz-
lichen Keyframes animieren. Um einen Keyframe für eine beliebige Eigenschaft zu setzen klickt man mit 
RMB  auf die Eigenschaft und erhält die Möglichkeit Key Selected (Channel Box) bzw. Set Key (Attribute 
Editor).

6.	 Nun setzt man, immer wenn die Kugel den Boden berührt, den Faktor auf -0.5. Für alle andere Keyframes 
hat es den Wert 0. (Mit Next Keyframe (.) und Previous Keyframe (,) lassen sich die verschiedenen Key-
frames einfacher setzen)

Graph Editor mit Linear Tangents

Squash Factor -0.5
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jedoch nur in dem Wertebereich 0-360. Wird der Wertebereich verlassen dreht sich das kleine Zahnrad nicht

10.	 Das kleine Zahnrad (pPipe2) selektieren und den Graph Editor öffnen. Man sieht, es wurden Keyframes für 
den RotateY gesetzt.

11.	 Die Keyframes selektieren und Tangents > Linear um den „Ease-In  Ease-out“ zu entfernen.

12.	 View > Infinity (aktivieren) hier wird gestrichelt angezeigt, das vor und nach den Keyframes die Werte kon-

Schritt 4: Set Driven Key Fenster

Infinity Display

Reaktive Animation
In Maya lassen sich reaktive Animationen mithilfe von „Driven Keys“ realisieren. Ein Attribut eines Driver-Objects 
beinflusst Attribute eines Driven-Objekts. 

Zahnräder
1.	 Create > Polygon Primitives > Pipe (Radius 2, Subdivision Axis 20)

2.	 Jedes zweite äußere Face selektieren und Edit Mesh > Extrude

3.	 Create > Polygon Primitves > Pipe (Radius 1, Subdivision Axis 10)

4.	 Jedes zweite äußere Face selektieren und Extude 

5.	 Das kleinere Zahnrad positionieren, sodass es mit dem größeren ver-
zahnt ist.

Driven Keys
1.	 Animate > Set Driven Key > Set...

2.	 Das große Zahnrad (pPipe1) selektieren und im „Set Driven Key“-Fenster „Load Driver“ 

3.	 Das kleine Zahnrad (pPipe2) selektieren und „Load Driven“

4.	 Die Attribute RotateY bei Driver und bei Driven selektieren (siehe Bild). 

5.	 Den Button „Key“ klicken. 

6.	 Das große Zahnrad (pPipe1) selektieren und in der Channel Box RotateY = 360

7.	 Das kleine Zahnrad (pPipe2) selektieren und in der Channel Box RotateY = -720

8.	 Den Button „Key“ im „Set Driven Key“-Fenster klicken

9.	 Rotiert man das große Zahnrad mit dem Rotate-Tool um die Y-Achse bewegt sich das kleine Zahnrad mit, 

Schritt 2: Extrude
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Expressions
In dem Beispiel soll sich eine Kugel stetig auf und ab und zur Seite bewegen. Dies wird realisiert mit der Sinus- und 
einer linearen Funktion.

1.	 Create > Nurbs Primitives > Sphere

2.	 Window > Animation Editors> Expression 
Editor

3.	 Das Attribut translateX selektieren und den 
Ausdruck „translateX = time“ eingeben

4.	 „Create“ klicken. In der ChannelBox wird das 
Attribut blau unterlegt und kann nicht mehr 
mit normalen Keyframes animiert werden

5.	 Wenn man die Animation abspielt, bewegt sich 
die Kugel auf der X-Achse

6.	 Das Attribut translateY selektieren und die 
Expression „translateY = sin(time)“ 
eingeben

7.	 „Create“

8.	 Beim Abspielen bewegt sich die Kugel auf der 
Y-Achse auf und ab und auf der X-Achse linear Expression Editor

stant bleiben.

13.	 Die Keyframes selektieren 

14.	 Curves > Post Infinity > Cycle with Offset

15.	 Curves > Pre Infinity > Cycle with Offset

16.	 Rotiert man das große Zahnrad  mit dem Rotate Tool um die Y-Achse bewegt sich das kleine Zahnrad für 

beliebige Werte von TranslateY des großen Zahnrads mit

Animation
Spielt man die Animation ab, so passiert nichts. Man muss für das Driver-Objekt (das große Zahnrad) Keyframes 
setzen. z.B. Frame 1 RotateY = 0, Frame 200 RotateY = 360

Infinity Werte angepasst, sodass die Werte sich linear erhöhen bzw. verkleinern
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Kameraführung
Grundsätzlich gelten die gleichen Regeln wie für die Einzelbildkomposition, jedoch gibt es bestimmte typische Ein-
stellungen für Filme.

Shot Typen

Umsetzung in Maya
Beim erstellen der Shots mit der Camera sollte man immer eine neue benannte Kamera z.B. „shotCam“ erstellen. 
Wenn man in die Perspektive der Kamera wechselt sollte man immer die Resolution Gate (Panelmenü > Camera 
Settings > Resolution Gate) aktiv haben. Mit der Resolution Gate sieht man genau was später gerendert wird.

Man kann ohne große Probleme einer Kamera Keyframes hinzufügen.

Simple Camera Rig
Mit einem Camera Rig, lässt sich flexibler mit einer Kamera arbeiten. Der Locator wird benutzt um die Kamera zu 
bewegen, gleichzeitig lässt sich mit dem Locator den Rotationspunkt verändern.

1.	 Eine Kamera der Szene hinzufügen (Create > Cameras > Camera). 
Die Kamera etwas auf der Y achse nach oben bewegen (TranslateY = 
5).

2.	 Einen Locator erzeugen (Create > Locator) und auf „stativ umben-
ennen.

3.	 Die Camera und dann den Locator selektieren und dann Edit > Pa-
rent (P).

4.	 Einen weiteren Locator erzeugen, auf „ziel“ umbenennen, und ihn 
vor die Kamera setzen (TranslateY = 5, TranslateZ = -5).

5.	 Erst den Locator „ziel“ und dann den Locator „stativ“ selektieren und dann Edit > Parent (P).

6.	 Den Locator und dann die Camera selektieren im Animation Menü Constrain > Aim (In den Optionen si-
cherstellen das „maintain Offset“ aktiviert ist)

Mit dem „Stativ“- Locator kann man nun die allgemeine Position der Kamera verändern und gleichzeitig hat man 
einen weiteren Rotationspunkt.

Mit dem „Ziel“-Locator lässt sich einfach die Orientierung der Kamera in allen Ansichten setzen. Ein weiterer Vorteil 
ist das man schnell ein bewegendes Objekt verfolgen kann indem man den Locator per Parent an das bewegende 
Objekt bindet.

Kamera Fahrten

Kamera Shake

Multiple Kameras

Fertiges Camera Rig

Inverse Kinematics
Mit Inverse Kinematics lassen sich komplexere Objekte einfach animieren. 
Hierfür wird ein Skelett aus Joints und IK Handles erzeugt und dann die 
Geometrie als Skin an das Skelett gebunden.

1.	 Die Datei „Animation_InverseKinematics_start.ma“ laden.

2.	 (Side View) Skeleton > Joint Tool das Basis Skelett zeichnen indem 
man sich an den Spheres orientiert.

3.	 (Top View) Mit G (bzw. Skeleton> Joint Tool) und LMB auf den 
Joint an der Handwurzel klicken, dies verbindet den neuen Joint mit 
dem bestehenden Joint. Dann einen Finger erstellen und dann noch-
mal das Joint Tool auswählen um den anderen Finger zu erstellen.

4.	 Deselektieren und auf eine freie Stelle mit RMB, Select All

5.	 Skin > Bind Skin > Rigid Bind

6.	 Mit dem Rotate Tool lässt sich nun andere Positionen vom Arm er-
stellen.

7.	 Mit dem Skeleton > IK Handle (Überprüfen das bei Current Solver: 
ikSCsolver steht) die Armwurzel mit der Handwurzel verbinden.

8.	 Man kann nun die Handwurzel Selektieren und mit dem Translate 
Tool bewegen das Ellenbogen Gelenk wird automatisch richtig aus-
gerichtet.

9.	 Mit Keyframes für das Skelett kann man nun eine Animation erstel-
len.

Anmerkung: Das ist nur eine sehr grobe Einführung in das Tool, es muss 
zusätzlich noch vieles weiteres Beachtet werden bei der Inverse Kinematic 
Animationen.

Schritt 2: Basis

Schritt 3: Fertige Finger

Schritt 7: IK Handle 
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Render Einstellungen für Animationen
Die Animation wird zunächst als Pre-Render in möglichst geringer Qualität ausgerendert. Diese erlauben einen Ein-
blick in die finale Animation und erlauben noch Feinabstimmungen an der Animation vorzunehmen. Hierfür wird 
die Maya interne Render-Engine verwendet um einen sog. Playblast zu erzeugen.

Ist man zufrieden mit der Animation kann man einen Render mit einer hoch qualitativen Render Engine machen. 
Jedoch sollte man beachten, dass die Renderzeit abhängig ist von der Komplexität die Szene (je mehr Objekte, je mehr 
Spiegelungen etc.). Daher sollte man einen Testframe von der komplexesten Stelle in der Animation rendern um ein 
Gefühl zu bekommen wie lange die Animation rechnen wird. (Anzahl der Frames * benötigte Zeit für Frame  z.b. 
5sek Animation = 125 Frames, 1 Frame braucht 5min > 125 * 5 = 625min = 10,5 Stunden). Man sollte alle anderen 
laufenden Programme schließen, damit soviel Rechenleistung wie möglich für den Renderprozess zur Verfügung 
steht.

Playblast
Ein Playblast rendert die Animation mit der Maya-Darstellungs Engine aus, d.h. so wie gerade in einer Kameraper-
spektive die Szene angezeigt wird, werden die Einzelbilder der Animation ausgerendert.

Um einen Playblast zu erzeugen RMB auf den Timeslider > Playblast.

Der Playblast wird in dem Programm „fcheck“ sofort angezeigt.

Batch Rendering
Man rendert niemals direkt eine Video-Datei. Während dem Rendervorgang kann der Computer abstürzen oder 
Fehler machen. Stattdessen rendert man eine Serie von Einzelbildern als „Batch-rendering“ Vorgang. Beim Bach 
Rendering wird eine Serie von Bildern im Hintergrund ohne graphische Ausgabe vom Bild zu bearbeitet. 

1.	 Als erstes sollte man das Image Format auf „Targa (tga)“ setzen. 

2.	 In den Render Settings unter Common : File Output wechselt man das “Frame/Animation” auf  “name.#.ext”

3.	 Sobald man eine Animation anstatt eines Frames ausgewählt hat ist “Frame Range” nicht mehr ausgegraut 
und man kann den Start und End Frame der Animation eingeben.

4.	 Man sollte umbedingt bevor man anfängt zu rendern nochmals überprüfen, das man auch die richtige Kame-
ra ausgewählt hat unter “Renderable Cameras”. 

5.	 Das Settings-Fenster kann man nun schließen und über Render > Batch Render  startet man das Rendern 
der Animation.

Dateiformate
Viele Dateiformate eignen sich nicht als Ausgabeformat. Das Jpeg-Format ist beispielsweise stark komprimiert und 
erzeugt dadurch Bildartefakte. Um das Maya iff-Format in anderen Programmen zu bearbeiten braucht man zusätz-
liche Plugins. Daher bietet es sich an in Targa, Tiff, oder OpenEXR zu rendern.

Tiff
Tagged Image File Format ist ein sehr kompliziertes Format und wird von Programm zu Programm unterschiedlich 
interpretiert. Das Tiff-Format bietet die Möglichkeit eines Alpha-Kanals und 32-Bit Unterstützung. Der Nachteil an 
diesem Format ist der hohe Speicherplatzbedarf der Einzelbilder.

Targa
Targa hat im Vergleich zu Tiff ein besseres Kompressionsverfahren und unterstützt auch einen Alpha-Kanal. Das 
Format wurde lange Zeit in der Computerspiele Industrie verwendet für bsp. Texturen etc. (Mittlerweile abgelöst 
durch das DDS-Format)

OpenEXR
Das OpenEXR-Format wurde von ILM entwickelt und unterstützt High-Dynamic-Range Farbinformationen und 
verschiedene verlustfreie und verlustbehaftete Kompressions-Algorithmen. Die Zip-Kompression liefert ein verlust-
freies Ergebnis mit einer sehr hohen Kompression.

Abschließende Bemerkungen
Kamerafahrt
In den meisten Beispielen wurden keine Kamerafahrten gemacht. Man sollte zuerst die Kamerafahrt animieren und 
dann mit der eigentlichen Animation beginnen. So spart man sich die Arbeit Objekte zu animieren die gar nicht von 
der Kamera erfasst werden.

Hirachie(Gruppen/Parenting)
Man sollte immer darauf achten mit Gruppen und einer Hirachie zu arbeiten. Es ist einfacher Teile eines Objekts zu 
animieren und dann zu einem Objekt zu gruppieren und dann, als ein zusammenhängendes Objekt, zu animieren.

Null Objekte
Man kann sich zusätzliche Objekte, wie z.B. Locator (Null Objekte) erstellen, die als Kontrollen für das eigentliche 
Objekt dienen. Man animiert dann nur den Locator und nicht das eigentliche Objekt. Möchte man dann später das 
Objekt modifizieren oder verändern ist es sehr einfach. Man muss lediglich das alte Objekt mit dem neuen austau-
schen und wieder an den Locator binden.

Datei Referenzen
Arbeitet man mit Datei Referenzen trennt man weiter Animation von Modelling. Referenzen sind dann externe 
Dateien die geladen werden um die Objekte für die Animation bereitzustellen. Mit File > Create Reference lässt sich 
so eine Referenz erstellen. Mit File > Export Selected lässt sich ein Objekt exportieren, um als gute Referenzdatei zu 
dienen.

Dupliziert man ein referenziertes Objekt so ist auch das Duplikat eine Referenz. Modifiziert man die Geometrie 
dann wird das Objekt unter Umständen nicht mehr referenziert bzw. gibt es Probleme wenn man die Originaldatei 
modifiziert.
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Fertige Batch Render Settings für eine Animation von Frame 1-10, Wichtig: nochmal runterscrollen und 
überprüfen ob die richtige Kamera ausgewählt ist.
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7. Dynamics
Bei der Dynamic Animation werden für ein Objekt physikalische Eigenschaften wie Richtung, Geschwindingkeit, 
Reibung, Masse, Masseschwerpunkt, etc. gesetzt. Dieses Verfahren ermöglicht realitätsnahe Animationen durch eine 
echte Physik-Simulation.
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Regen
1.	 Create > Polygon Primitives > Plane “rainEmitter” (TranslateY = 12, ScaleXYZ = 10)

1.	 Create > Polygon Primitives > Plane “floor” (ScaleXYZ = 100)

2.	 Mit „rainEmitter“ selektiert, Particles > Emit from Object 

3.	 Spielt man die Animation ab sieht man die Partikel sich langsam nach oben bewegen

4.	 Eins von den Partikeln selektieren und Fields > Gravity

5.	 Spielt man die Animation ab fallen alle Partikel nach unten, fallen durch den Boden und fallen weiter. 

6.	 Da die Partikel unterhalb des Bodens nicht sichtbar sind sollten sie entfernt werden um unnötige Bere-
chungen zu vermeiden. Hierfür selektiert man die Partikel und wählt im Attribute Editor den entsprechenden 
„ParticleShape“-Node aus 

7.	 Unter „Lifespan Attributes“ wählt man Lifespan Mode „Constant“ und gibt ihm einen Wert von 2. Beim wei-
teren abspielen sollten die Partikel kurz nachdem sie durch den Boden gefallen sind aufhören zu exisitieren.

8.	 Weiterhin im Attributeeditor kann man das aussehen der Partikel ändern. Unter „Render Attributes“ > „Parti-
cle Render Type“ wählt man „Streak“ aus, damit die Partikel mehr nach Regen aussehen. Anschließend klickt 
man auf Add Render Type „Current Render Type“ Es sollten nun weiter Attribute sichtbar sein, mit denen 
man das Aussehen der Partikel steuern kann.

9.	 Möchte man die Dichte des Regens verändern, so muss man in den emitter Einstellungen die Particle Rate 
verändern. (Dieser Wert kann auch animiert werden)

10.	 Alle Regentropfen fallen jetzt in der gleichen Geschwindigkeit, damit sie unterschiedlich schnell Fallen, kann 
man ein „Turbulence Field“ auf die Partikel anwenden. Hierfür die Partikel selektieren und Fields  > Turbu-
lence

11.	 In dem Attribute Editor unter „Turbulence Field Options“ > Magnitude = 2.0, Attenuation = 0.0. Spielt man 
die Animation ab hat man eine etwas natürlichere Bewegung von den Tropfen.

12.	 Möchte man den Winkel ändern wie der Regen auf die Oberfläche eintrifft, so kann man ein weiteres Field 
„Air“ anwenden. Im Attribute Editor kann man dann unter „Direction“ die Richtung bestimmen in der die 
Partikel gedrückt werden sollen z.B. (1,0,0)

Partikelsimulation

Partikel können vielseitig verwendet werden, von einfachem Regen zu Explosionen. In den meisten Fällen werden die 
Partikel von einem Ermitter erzeugt und manipuliert von Feldern.

Workspace Einstellungen
Alle Funkionen findet man im „Dynamics“ Menü (F5) nicht zu verwechseln mit dem „nDynamics“ Menü. 

Meistens dauert eine solche Simulation mehrere hundert Frames, daher sollte man die Playback range auf einen Ho-
hen Wert wie 5000 setzen.
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Grundlagen
Um mit Maya Dynamics zu arbeiten, muss man zunächst Rigid Bodies deklarieren. Alle Objekte ohne Rigid Bodies 
werden von der Dynamic Simulation nicht beachtet. „Active“ Rigid Bodies werden von  physikalischen Eigenschaften 
beeinflusst, „passive“ dienen als Collisions Objekte für die activen Rigid Bodies.

Rigid Bodies Attribute

Initial Velocity (XYZ)
Bestimmt den Bewegungsvektor am Anfang der Simulation. Aus diesem wird die Geschwindigkeit und Richtung 
des  Objekts errechnet. 

Initial Spin (XYZ)
Bestimmt am Anfang der Simulation die Geschwindigkeit und Richtung in der das Objekt um sich selbst dreht.

Center of Mass (XYZ)
Verändert man diesen Wert verschiebt man den Schwerpunkt des Objekts, was wiederum den Rotationspunkt des 
Objekts beinflusst.

Impuls (XYZ)
Während die Simulation wird durch den Impuls die Geschwindingkeit in die Richtung des Impulses konstant erhöht.

Impuls Position (XYZ)
Ähnlich wie Center of Mass beeinflusst  die Impuls Position den Ursprung des Impuls.

Spin Impuse (XYZ)
Während der Simulation wird durch den Wert die Rotation in die Richtung des Spin Impulses konstant erhöht.

Mass
Bestimmt das Gewicht und somit das Verhalten des Objekts zu anderen Objekten.

Bounciness
Bestimmt wie stark das Objekt von anderen Objekten abprallt / hüpft.

Dampening
Die Energie des Objekts wird mit diesem Faktor gedämpft der Wertebereich sollte zwischen 0 und 1 liegen.

Static Friction
Wenn das Objekt im völligen Ruhezustand ist und sich die Umgebung verändert, dann bestimmt die Static Friction 
wie hoch die Reibung des Objektes ist.

Dynamic Friction
Während sich das Objekt bewegt bestimmt die Dynamic Friction die Reibung für das Objekt.

Collision Layer
Man kann mit der Collision Layer Objektgruppen anlegen um den Simulationsaufwand zu reduzieren. Nur Objekte 
mit dem gleichen Collision Layer Wert kollidieren miteinander.

Möchte man ein Objekt haben, das mit allen Objekten interagiert, z.B. für ein Boden, setzt man den Wert auf -1.

Fields
Man kann active Rigid Bodies mit verschiedenen Fields beeinflussen wie z.B. Schwerkraft (Gravity). 

Selektiert man Geometrie Objekte und erstellt ein Field wird automatisch ein active Rigid Body für das Objekt er-
zeugt. Möchte man später noch weitere Objecte dem Field hinzufügen selektiert man das Objekt, sowie das Field und 
geht auf Fields > Affect Selected Objects. Alternativ kann man die Verbindungen mit dem  Dynamics Relationship 
Editor (Windows > Relationship Editors > Dynamic Relationship Editor) bearbeiten.

Constrains
Alle Constrains findet man im Menü Soft/Rigid Body.

Nail
Der Nail Constraint funkioniert so als ob man einen Nagel im Raum hat und das Objekt mit einem Seil daran hängt. 
Ähnlich einem Pendel.

Pin
Ein Pin verbindet zwei Objekte durch ein Seil.

Hinge
Erzeugt eine Rotationsachse, mit der ein Rigid-Body-Objekt verbunden ist. Das ist mit einer Schaukel vergleichbar, 
sie kann nur in eine Richtung schwingen.

Spring
Der Spring-Constraint ist eine Sprungfeder. Man kann mit den Attributen „Spring Stiffnes“ die Federhärte, „Spring 
Dampening“ die enstehende Reibung und mit der „Spring Rest Length“ die Länge der Feder einstellen. Ist die Spring 
Rest Length kleiner als der eigentliche Abstand zwischen dem Objekt und dem Constraint-Modifier wird das Objekt 
zu der Feder hingezogen, dementsprechend ist die Rest Length größer wird das Objekt von dem Constraint-Modifier 
weggeschossen.

Barrier
Ein Barrier erzeugt eine unsichtbare Ebene die das Objekt nicht passieren kann. Der Nachteil an dieser Ebene ist, 
dass z.B. Bounce Effecte nicht berechnet werden. Daher sollten Barriers nur im Hintergrund von einer Dynamic 
Simulation verwendet werden.
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Basic Dynamics

Ball und schiefe Ebene

1.	 Die „End-Time-of-Playback“ auf 200 setzen

2.	 Create > Nurbs Primitves > Plane (Width = 30, RotateX = 30)

3.	 Create > Nurbs Primitves > Sphere (TranslateY = 12)

4.	 Mit der Sphere selektiert Soft/Rigid Bodies > Create Active Rigid Body (Die Werte die von dem Rigid Body 
beeinflusst werden, können nun nicht mehr verändert werden und sind gelb unterlegt.)

5.	 Mit der Sphere selektiert Fields > Gravity. Dies erzeugt eine Gravitation mit Beschleunigungsfaktor 9.8

6.	 Drückt man auf Play sieht man die Kugel fallen, sie fällt jedoch einfach durch das Planar hindurch.

7.	 Mit dem Plane selektiert Soft/Rigid Bodies > Create Passive Rigid Body (Die Gravity wird die Plane nicht 
beeinflussen)

8.	 Drückt man nun auf Play kollidiert die Kugel mit der Plane und springt zur Seite. Mit den verschiedenen 
Attributen des Rigid-Body wie z.B. Bounciness, Mass, Static Friction, Dynamic Friction.

 Bake Animation
Ist man zufrieden wandelt man die Simulation in eine Keyframe Animation um. 

9.	 Edit > Keys > Bake Simulation q 

10.	 In den Optionen stellt man Channels auf „From Channel Box“, Smart Bake aktivieren, Increase Fidelity ak-
tivieren und Fidelity Key Tolerance auf 1.0 setzen.

11.	 Ohne das Fenster zu schließen selektiert man alle Objekte die man umwandeln möchte (in diesem Fall nur 
die Sphere) und selektiert die Channels für die man Keys haben möchte (siehe Bild)

12.	 Den Button „Bake“ klicken. Die Animation wird einmal abgespielt, um die Keyframes zu setzen

13.	 Damit die Sphere jetzt die Keyframes verwendet und nicht simuliert, selektiert man die Sphere und Edit > 
Delete by Type > Rigid Body

14.	 Nun kann man kleinere Anpassungen machen und die Keyframeanimation beliebig ändern.

Bake Simulation Optionen

Selektierte Channels
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Newton’s Cradle 
Ein sehr einfaches Experiment um den Energieerhaltungssatz nachzuweisen.

1.	 Die Datei „newton_cradle_start.ma“ laden. Es befindet sich nur der 
Rahmen vom Cradle in der Szene.

2.	 Create > Nurbs > Sphere (TranslateY = 2)

3.	 (Sphere selektiert) Soft/Rigid Body > Create Nail Constraint  (Trans-
lateX = 4, TranslateY = 11)

4.	 (Sphere selektiert) Soft/Rigid Body > Create Nail Constraint  (TranslateX = -4, TranslateY = 11)

5.	 (Sphere selektiert) Fields > Gravity

6.	 Man kann nun experimentieren und die Kugel an andere positionen 
setzen und die Animation abspielen (Range 1-500). Nach Dem expe-
rimentieren sollte die Kugel wieder auf Position(0,2,0) gesetzt werden.

7.	 Weitere 4 Kugeln (TranslateZ = 4;2;-2;-4) mit den entsprechenden 
Nail Constraints neben der ersten Kugel erzeugen.

8.	 Die letzte Kugel auf Position(0,2,-2) auswählen und auf die Positi-
on(0,11,-13) setzen.

9.	 Alle Kugeln und das Gravitationsfeld selektieren  Fields > Affect se-
lected Objekts

10.	 Spielt man die Animation ab so bekommt man nicht das gewünschte Ergebnis. 

11.	 Alle Kugeln selektieren und in den Rigid Body Einstellungen den Bouciness = 1 setzen.

12.	 Die Seile lassen sich mit Zylindern realisieren. Diese werden dann mit Parenting(P) an die jeweiligen Kugeln 
gesetzt und zusammen animiert.

13.	 Speichern als „newton_cradle_end.ma“

Schritt 6: Eine Fertige Kugel

Schritt 9: Kugeln und Gravitationsfeld

Einstellungen für Dynamics

Simple Collisions Objects
Um die Simulationsgeschwindigkeit zu erhöhen, sollte man möglichst einfache Objekte, also Objekte mit möglichst 
wenigen Polygonen, verwenden. Je höher die Komplexität (Anzahl der Polygonflächen) desto höher ist der Berech-
nungsaufwand der Simulation. 

Daher sollte man zusätzlich simple Objekte (Proxys) modellieren die für die Simulation verwendet werden. Dies 
könnten beispielsweise einfache Poly Cube Objekte sein. 

Das einfache active Rigid Body Objekt verbindet man mit Constrain > Parent an das komplexe Objekt. Alle Proxies 
werden auf eine eigene Displayebene hinzugefügt. Deaktiviert man die Visibility der Ebene wird die Simulation wei-
terhin ausgeführt, jedoch sieht man nur die komplexen Objekte.

Cache Simulation
Man kann um die Performance zu verbessern Teile der Simulation in einer Cache Datei abspeichern. Hierfür geht 
man in den Attribute Editor eines Rigid Body Objekts und wählt den „RigidBody Solver“ und aktiviert Rigid Sol-
ver States > „Cache Data“. Die Simulation wird jetzt nicht mehr berechnet und spielt immer gleich ab auch wenn 
man Objekte modifiziert. Erst wenn man im Solver Rigid Solver States > „Cache Data“ > Delete klickt wird die 
Simulation aktualisiert. 

Bake Animation
Die Dynamic Simulation liefert nicht jedes Mal das identische Ergebnis, es gibt meistens leichte Variationen in der 
Simulation. Um immer das gleiche Verhalten zu animieren wandelt man die Animation in Keyframes um. (In einer 
neuen Datei). Dies hat den Vorteil, das es nicht nochmal simuliert werden muss und nicht jedes mal die gleiche Ani-
mation abgespielt wird.

Mit Edit > Animation > Bake Simulation q lässt sich die Simulation in eine Keyframe-Animation umwandeln.

Rendern
Nachdem man „Bake Animation“ ausgeführt hat und fertig ist mit der gesamten Simulation geht man auf Edit > 
Delete All by Type > Rigid Bodies um sicherzustellen, dass nur die Keyframes zur Animation verwendet werden.

Danach rendert man die Animation aus. (Siehe „Render Einstellungen für Animationen“ Seite 116)
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8. Rendering
Mental Ray hat viele Eigenheiten und viele Werkzeuge um fotorealistische Effekte zu erzeugen. Hier ist eine Auswahl 
die einem beim Rendern von Bildern helfen können.

Blurring Effekte

Depth of Field
Eines der wichtigsten Mittel um dramatische Szenen zu erzeugen ist die Tiefenunschärfe (Depth of Field, DOF). Die 
Tiefenunschärfe kann bei jeder Kamera aktiviert werden. (Im Programm selbst wird ein “physical_lens_dof”-Node 
angelegt und konfiguriert)

Zunächst muss man bestimmen, auf welches Objekt die Kamera fokussieren soll. Dann ermittelt man die Distanz 
zwischen Kamera und Objekt. Die einfachste Möglichkeit dies zu bestimmen ist, (in der Camera-Ansicht) das Objekt 
zu selektieren und Display > Heads Up Display > Object Details zu aktivieren. Man kann unter „Distance-From 
Camera“ den Abstand ablesen.

physical_lens_dof
In der jeweiligen Kamera unter 
Depth of Field „Depth of Field“ ak-
tivieren. 

Die Einstellungen sind recht ein-
fach gehalten, Man kann die Focus 
Distance eingeben und den FStop 
(Blende). Kleinere Blendenzahlen 
(z.B: 5.6) erzeugen verschwom-
menere Bilder, höhere Blendenzahlen 
(z.B. 16) erzeugen klarere Bilder.

No Depth of Field

Physical, FStop 5.6

Distance 9.5 Physical, Distance 125.0

Physical, FStop 16

Heads Up Display
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mia_lens_bokeh
Der Bokeh-Lens Shader ist physikalisch korrekter als der 
normale physical_lens_dof.

Um den Shader zu verwenden, muss man in der Kamera 
unter mental Ray > Lens Shader einen neuen Node er-
zeugen (Im Create Render Node Fenster findet man den 
bokeh unter mental ray > Lenses).

Alternativ, um Multiple Lens Shader zu verwenden, unter 
mental ray > Lens Shaders > Create.

Die Hauptkontrollen vom Bokeh Shader sind:

-- Plane (Focus Distanz)

-- Radius (verwisch Faktor)

-- Samples (Qualität des verwischens)

Beide Verfahren sind sehr rechenaufwendig und somit 
zeitintensiv. In vielen Fällen ist es schneller einen ge-
fälscht Tiefenunschärfe in der Post-Production hinzuzu-
fügen.

Um Animationen zu erzeugen, in der  wo die Kamera 
konstant auf ein bewegendes Objekt fokusiert muss der 
Focus Distance Wert dementsprechend angeglichen wer-
den.

Bokeh, Radius 1.0 Bokeh, Radius 0.5

Kamera Settings

Bokeh Settings

Motion Blur
Bei animierten Objekten lässt sich eine Bewegungsunschärfe (Motion Blur) simulieren. Dieser Effekt wird nicht auf  
statische Objekte angewandt.

Motion Blur aktiviert man in den Render Settings > Quality > Motion Blur („Full“)

Motion Blur By
Bestimmt in welchen Abstand die Frames miteinander verglichen werden um den Motion Blur Effect zu errechnen. 
Z.B. rendert man Frame 1 mit Motion Blur by Wert 4, wird der 1. und 5. Frame miteinander verglichen.

Shutter Open/Close
Mit diesen Werten lässt sich genauer bestimmen wie lang der Motion Blur sein sollte.

Die weiteren Attribute muss man nur manipulieren, um den Effekt zu verfeinern.

Anmerkung: Möchte man den Effekt ausschalten für einzelne animierte Objekte. Muss man in dem Attribut Editor 
bei den Render Stats Motion Blur deativieren. 

No Motion Blur Motion Blur

Motion Blur Einstellungen
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Mental Ray: Physical Sun 
and Sky
Um eine Außenbeleuchtung zu simulieren, kann man das dafür spezialisierte 
„Physical Sun and Sky“- Shading Network verwenden. Die Besonderheit an 
diesem Shading Network ist, das man es sehr leicht verwenden kann um eine 
realistische Sonne mit einem Himmel zu erzeugen.

Um das „Physical Sun and Sky“-Network zu verwenden, geht man unter 
Render > Render Settings  unter Indirect Lighting > Enviroments > „Physical 
Sun and Sky“ und klickt auf den „Create“-Button. Final Gather wird auto-
matisch mit den Standarteinstellungen aktiviert und ein direktionales Licht 
mit dem Namen „sunShape“ in der Szene erstellt.

Das Licht „sunShape“, hat als einzige Funktion den Einfallwinkel der Sonne 
zu bestimmen. Die meisten Einstellungsmöglichkeiten bzgl, Intensity, Schat-
ten etc. werden überschrieben von dem „mia_physicalsky1“. 

Anmerkung: Neben dem mia_physical_sky wird auch für die Camera ein 
mia_exposure_simple  erstellt. (Kamera selektierien im Attribute Editor > 
mental Ray > Lens Shader). Standartmäßig ist ein Gamma von 2.2 eingestellt 
und kann ggf. das Bild unnötig auffhellen.

Wichtigsten Attribute des „mia_physical_sky“:

Multiplier
Multipliziert die Intensität des Lichts. Kann verwendet werden, um das Licht 
zu verstärken oder zu schwächen.

Haze
Mit einem Wert von z.B. 5 lässt sich der Smog einer Stadt simulieren.

Red/Blue Shift
Positive Werte z.B. 0.5 verschieben das Sonnenlicht in das rote Farbspektrum 
(z.B. in Wüsten, Mars), negative Werte z.B. -0.5 in das blaue Farbspektrum 
(z.B. auf fremden Planeten). 

Saturation
Bestimmt die Farbsättigung des Himmels. Ein Wert von 0 erzeugt einen 
grauen Himmel, Werte über 1.0 erhöhen die Farbintensität des Himmels.

Horizon Height
Mit diesem Wert kann man die Position der Horizontlinie bestimmen. In 
vielen Fällen benutzt man einen negativen Wert von z.B. -5 um die Horizont-
line verschwinden zu lassen.

Horizon Blur
Der Grad, in dem die Horizontline verschwommen wird. Ein kleiner Wert 
ist meistens ausreichend.

Ground Color
Hier lässt sich die Farbe des Bodens bzw. einer Bodentextur bestimmen.

Night Color
Zeigt das Directionale Licht „sunShape“ direkt auf die Kamera, so sieht man 
eine Sonnenscheibe.

Default Einstellungen

Flacher Winkel erzeugt Sonnenuntergang

Horizon Height angepasst

Saturation angepasst

SunDisk Scale =7, Glow Intensity = 0.5

Sun Disk Intensity
bestimmt die Leuchtkraft der Sonnenscheibe.

Sun Disk Scale
bestimmt die Größe der Sonnenscheibe.

Sun Glow Intensity
Bestimmt das Leuchten des Randes der Sonnenscheibe. Niedrige Werte erzeugen einen schärfen Rand.

Um die Schatten Qualität zu verbesseren findet man im Attribute Editor den Node „mia_physical_sun“. Das Attribut 
„Shadow Softness“ bestimmt die Härte und „Samples“ die Qualität der Schatten.

Das Shading Network wird beim Erzeugen direkt an alle perspektivischen Kameras angebunden. Erzeugt man eine 
neue Kamera und rendert das Bild aus, so wird zwar die Szene mit dem direktionalen Licht ausgeleuchtet, der Him-
mel verschwindet jedoch. Dies kann man korrigieren, indem man im Attribute Editor des „mia_physical sky“ auf den 
Button „Update Camera Connections“ klickt. 

Anmerkung: Beim Ausrendern wird der „Physical Sun and Sky“ nicht im Alpha Kanal gespeichert. Beim Öffnen 
der resultierenden Bilder in Composite oder After Effects wird daher der Himmel nicht angezeigt. Man muss den 
Alphakanal deaktivieren, um mit dem Himmel zu arbeiten.
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Mental Ray: Blackbody Simulation
Ein “Blackbody” (schwarzer Körper) ist ein idealisierter 
Körper in der Physik der jedes Licht (bzw. elektroma-
gnetische Strahlung) vollständig absorbiert. Eine wei-
tere Eigenschaft ist, dass der Körper auch Strahlung 
aussenden kann auf Grundlage der Temperatur des 
jeweilgen Spektrums. Jede reale Lichtquelle hat ihre ei-
gene Temperatur z.B. eine Glühbirne 2800K (gelblich), 
Tageslicht 5500K, bedeckter Himmel 6500K -7500K 
(bläulich) Auf dem Planckian locus lassen sich die je-
weiligen Temperaturen der Farben ablesen.

Möchte man eine bestimmte Lichtquelle simulieren, 
braucht man nur zu wissen welche Farbtemperatur die 
Lichtquelle hat und man kann sie dann in Maya mit 
dem mia_blackbody-Node (Im Bereich 0-4000K) oder 
mia_cie_d-Node (4000K-25000K) simulieren. 

Beispiel Glühbirne (2800K):
1.	 Einen Glaskörper für die Glühbrine erzeugen

2.	 Man erstellt ein AreaLight, mit dem Mental 
Ray Use Shape Attribut „Sphere“ (mit ihr lässt 
sich die Größe der Lichtkugel bestimmen)

3.	 Die Decayrate auf „Quadratic“ setzen.

4.	 Bei dem Farbattribut klickt man auf das „Create Render Node“-Icon. Unter mental Ray - Mental Ray Lights 
selektiert man „mib_blackbody

5.	 Für das „mib_blackbody“ gibt es nur die Einstellungen Temperature (z.B. 2800K Wolfram Draht Glühbirne) 
und Intensity. Grundsätzlich steuert man die Intensity des Lichtes über diesen Wert, d.h. die Lampe hat einen 
Intensity Wert von 1.0 und der Blackbody hat dann den tatsächlichen Intensity Wert. z.B. 25.

Anmerkung: Im Hypershade lässt sich der „mib_blackbody“-Node „outValue“ mit multiplen Lampen („color“) ver-
binden. So lassen sich mehrere Lampen gleichschalten.

Der Planckian Locus, mit eingezeichnerter Temperaturkurve

Von rechts nach links  2800K, 4500K, 8500K

Windows Command Line Rendering
Man kann mit der Commando Zeile rendern. Dies ist sehr vorteilhaft, da Maya hierfür nicht gestartet werden muss. 
Daher sind mehr Ressourchen zum Rendern frei d.h. es gibt einen kleinen Geschwindigkeitsbonus. 

Vorbereitungen
1.	 Unter den Systemeinstellungen unter „Erweitert“ klickt man auf Umgebungsvariablen.

2.	 Hier wählt man nun unter den System Variablen die Path Variable und klickt „Bearbeiten“.

3.	 Wichtig! Am Ende der Zeile fühgt man den Pfad zum Maya Bin Ordner hinzu.​ Der Standard Pfad ist: 
„C:\Program Files\Autodesk\maya2011\bin“ (Es sollte vor und nach dem Eintrag ein „;“ stehen)

Rendereinstellungen
Unter dem Startmenü einfach in die Suchleiste „CMD“ eingeben, um die Command Promt zu öffnen.

Man kann nun, mit der Command Line, in den Projektordner navigieren, bzw. zu der Szene die man rendern möchte.

CD C:\users\<username>\<Eigene Dateien>\maya\projects\<projektname>\scenes

Mit Render (Flags) <dateiname> lässt sich die Datei rendern. Es werden die Einstellungen aus den Render-
Settings übernommen, falls man sie nicht mit Flags überschreibt. Flags sind optionale Zusatzbefehle für die Render-
engine. Flags müssen vor dem Dateinamen eingefügt werden.

Nützliche Flags:

•	 -help (Render -help) öffnet die Hilfe (Anzeige aller Flags).

•	 -r <RenderEngine> wählt man die Renderengine (z.B. „mr“ für MentalRay).

•	 -s <Startframe> -e <Endframe> lässt eine Animation ausrendern.

•	 -cam <CameraName> wählt die Camera.

•	 -rd <Path> bestimmt man den Pfad wo man die fertige Datei rendern möchte.

Ein Beispiel befehl könnte sein:

Render -r mr -s 1 -e 125 -cam camera1 -rd C:\ani _ ball ball.mb

(In Worten: Es wird die ball.mb mit MentalRay Frame 1-125 von camera1 ausgerendert, die fertigen Dateien werden 
in den Ordner ani_ball gespeichert.)

Batch Datei
Möchte man mehrere Dateien ausrendern schreibt man mehrere Zeilen in eine Textdatei und trennt sie mit ENTER. 
Beispiel:

Render -r mr -s 1 -e 125 -cam camera1 ball.mb 
Render -r mr -s 126 -e 200 -cam camera2 ball.mb

Anschließend speichert man die Datei und ändert die Dateiendung von .txt zu .bat. Mit Doppelklick auf die .bat 
Datei wird das Skript ausgeführt.

Möchte man den Vorgang abbrechen, drückt man „STRG-C“. bzw. im Task Manager (STRG-ALT-ENTF) den 
Prozess „Render“ beenden.
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Mental Ray Satellites (Grid-Rendering)
Wenn man im Besitz von mehreren Computern ist kann man die kombinierte Rechenleistung verwenden um Bilder 
auszurendern. Dies wird mit “Mental Ray Satellites” ermöglicht. Die Computer sollten am Besten in einem Netzwerk 
mit 100MB/s verbunden sein, da am Anfang alle Texturen auf jeden einzelnen Computer übertragen werden. Unter 
gewissen Umständen ist es langsamer mit Netzwerk zu rendern als ohne Netzwerk, z.B. wenn die Szene sehr simpel 
ist und die Texturen sehr groß, sodass die Übertragung länger dauert als das Bild auszurendern.

Im Netzwerk gibt es den Master Computer, auf dem Maya installiert ist und Slaves auf denen “Mental Ray  Satellites 
installiert sind. 

Installation auf den Hosts (Slaves):
1.	 Mental ray Satellite installieren 

2.	 Schritte in der Readme.txt befolgen, um zu verifizieren, dass der Dienst gestartet ist. 

Mental Ray Satellite Downloads:

Maya 2012 Service Pack 2: http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=18428455&lin
kID=9242259

Konfiguration von Maya:
1.	 Zunächst eine Textdatei anlegen und umbenennen auf maya.rayhosts

2.	 In der Datei werden alle Netzwerkkennungen der Slaves aufgelistet die man für das Rendern benut-
zen möchte. Sie müssen im Netzwerk, in dem man sich befindet, erreichbar sein (d.h. Firewalls für 
die jeweiligen Ports deaktivieren und Maya Zugriff auf das Netzwerk gewähren etc.)  Das Format für 
die Einträge ist: “hostname:<Port number>” bspw. pc-host1 und pc-host2 mit dem Default Port 7411 
 
PC-HOST1:7411 PC-HOST2:7411

Anmerkung: Ein  # vor einer Zeile kommentiert man die Zeile aus und wird von Maya nicht beachtet

3.	 Alternativ kann man die IP-Adresse verwenden. z.B. 192.168.0.10:7411

4.	 Die Datei maya.rayhosts muss sich in “prefs” Verzeichnis befinden:

      Windows 7

         32-bit:	 \Users\<username>\Documents\maya\2012\en_US\prefs

         64-bit:	 \Users\<username>\Documents\maya\2012-x64\en_US\prefs

      Mac OS X

          /Users/<username>/Library/Preferences/Autodesk/maya/en_US/2012/prefs

      Linux (64-bit)

          ~/maya/2012-x64/prefs

Anmerkung: Als Alternative kann man die maya.rayhosts Datei in das Installationsverzeichnis verschieben. Befin-
det sich im User Verzeichnis eine weitere rayhosts Datei, so wird diese verwendet. 
	 Linux /usr/autodesk/maya2012-x64/ 
	 Windows C:\Program Files\Autodesk\maya2012\ 
	 Mac OS X /Applications/Autodesk/maya2012/

Eine Datei über das Netzwerk rendern:
Per Default ist bereits immer Lokales- und Netzwerkrendern aktiviert.

Unter Render > Render Current Frame q bzw. Render > Batch Render q unter Network kann man diese Ein-
stellung ändern.

http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=18428455&linkID=9242259
http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=18428455&linkID=9242259
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Paint Effects 
Paint Effects sind Effekte, die man direkt als Körper zeichnen kann, oder auf einem bestehenden Objekt erstellt.Man 
findet die vorgefertigten Paint Effecte unter Window > General > Visor > „Paint Effects“.

Um einen Paint Effect auf ein Objekt anzuwenden selektiert man das Objekt  und macht es „paintable“ (Paint Ef-
fects > Make Paintable). Im Visor selektiert man dann den Brush den man verwenden möchte und zeichnet dann 
auf das Objekt. Im Attribute Editor kann man dann weitere Eigenschaften anpassen.

Anmerkung: Falls der Pinsel auf der falschen Seite der Oberfläche zeichnet, so macht man den letzten Schritt rück-
gängig. Man muss die Richtung der Normalen korrigieren. Man wählt das Objekt aus und gibt für ein Nurbs Objekt 
“Edit NURBS > Reverse Surface Direction”, oder für ein Poly-Objekt “Normals > Reverse” ein. 

Mental Ray kann „Paint Effects“ nicht ausrendern. Zuerst muss man den Effekt in ein Polygonobjekt über Modify > 
Convert > Paint Effects to Polygon umwendeln. Danach muss man dem Objekt einen Shader zuweisen.

Roter Strich zeigt nach außen (die Norma-
len sind korrekt)

Mit dem „waterMesh“-SurfaceBubbles 
Brush auf dem Glas gezeichnet 

Painteffect in Polygone umgewandelt und 
mit Mental Ray ausgerendert



139﻿ || 

9. Projekte
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Architekturvisualisierung (Interior)Architekturvisualisierung (Exterior)
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Cartoon / Styleized Abstract
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10. Anhang
Anhang A beschäftigt sich mit der Postproduction in dem Programm Autodesk Composite

Anhang B Beschreibt Methoden um eine Bildersequenz in eine Video Datei umzuwandeln

Anhang C ist eine kurze Einführung und Linksammlung für MEL Skripting.

Anhang D beschreibt die Punkte Kriterien für Studenten von dem Kurs „Projektkomptenz Multimedia Maya“

Freelancer General Tipps

Matchmover?

Post-Production mit Composite
Post-Production ist eine Kunst für sich. Die wichtigste Regel bei der Post Production ist das man nur subtile Verän-
derungen macht.

3D gerenderte Bilder tendieren dazu sehr „perfekt“ zu wirken. Dies ist in der Realität jedoch selten der Fall. Bei der 
Post-Production sollte man daher immer das Bild leicht „verschlechtern“ mit z.B. Add Grain. Die Bilder werden we-
sentlich realistischer wirken.

Im Post-Production Schritt gibt es mehrere Programme die in der Industrie verwendet werden. Die Bekanntesten 
sind Adobe - Aftereffects, The Foundry - Nuke, und Autodesk Composite (Früher Toxik gennant) und etliche andere. 

Das gängiste Einsteiger Programm ist Adobe After Effects. Dieses Programm ist Ebenen basiert. Die anderen Pro-
gramme sind Node basiert (wie Nuke oder Composite). Der Vorteil solcher Programme ist, dass das Node-Netzwerk 
als Skript ausgespeichert wird und man es sehr leicht für multiple Projekte wiederverwenden kann. Ein weiterer Vor-
teil ist, das die Nodes durch ihre Input und Output Eigenschaften sofort angezeigt werden können. Daher braucht 
man keine „Pre-Comps“, wie bei auf Layern basierten Programmen.

Programm Übersicht 
Startet man das Programm ist die Oberfläche zunächst leer mit File > New erzeugt man eine neue Composition 
(.txcomposition). Es wird dann ein Output Node erzeugt. Klickt man den Output Node an kann man im unteren 
Bereich die Attribute für den Output Node verändern, z.B. das Bildformat oder die Laufzeit der Animation.

Alle weiteren Nodes die den Output beeinflussen müssen direkt oder über andere Nodes mit dem Output-Node 
verbunden sein.

Um eine Komposition zu beginnen importiert man sein Material mit File Import (Strg-I). Im Datei-Dialog erschei-
nen Bild-Sequenzen als einzelne Dateien.

Klickt man nun an der rechten Seite des Clip-Node erhält man den Output. Diesen lässt man nun mit dem Output 
Node verbinden indem man auf die linke Seite davon klickt.

In der Pick-List lässt sich bspw. ein CC Basic Node erstellen. Damit dieser einen Effekt auf den Clip hat muss der 

Input und Output nicht verbunden Input und Output verbunden

Output Einstellungen
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Clip als Input (linke Seite) verbunden sein und der Output (rechte Seite) mit dem Output-Node. Hierfür muss man 
die bestehende Verbindung zwischen Clip und Output löschen und erzeugt zwei neue Verbindungen. Eine zwischen 
Clip und CC Basic und eine zwischen CC Basic und Output-Node.

Man kann nun für CC Basic Einstellungen vornehmen und anschließend die Frames rendern (File > Render) . An-

schließend auf Start klicken.

Anmerkung: Es werden wieder Einzelbilder ausgerendert, die man dann zu einem Containerformat wie .avi, .mov 
etc. komprimiert.

Wichtige Nodes:

Blend/Comp
Um zwei Filme inenander überblenden zu lassen braucht man ein „Blend/Comp“ Node.

CC Basic
Hier lassen sich alle grundlegenden Farbkorrekturen vornehmen.

CC Histo
Man kann das Histogramm anpassen um viele verschiedene Effekte zu erzeugen. Man kann durch anpassen des 
schwarz und weiß-Punkts z.B. das Farbspektrum spreizen und so ein farbenkräftigeres Bild erzeugen. 

Add Grain
Benutzt man eine analoge Kamera oder eine digitale Fotokamera, so hat der Film bzw. Chip ein Rauschen. Mit Add 
Grain lässt sich auch einem gerenderten Bild ein Rauschen hinzufügen.

CC Color Eigenschaften

Renderfenster

Bildersequenz in eine Video Datei umwan-
deln
Alle gängigen Videobearbeitungssoftware können aus einer Serie von Einzelbildern Videosequenzen erzeugen. Man 
muss darauf achten, dass die Einzelbilder nummeriert und vollständig sind.

Photoshop
Seit der CS3 Version von Photoshop lässt sich Videomaterial bearbeiten. 

1.	 Um eine Bilderserie als Animation zu öffnen muss man über das Menü Datei > Öffnen gehen und selectiert 
die erste Datei der Sequenz aus. 

2.	  Man setzt ein Häckchen bei Image Sequence.

3.	 Als Standartwert rendert Maya die Animation mit 24 Bildern/Sekunde, dies muss man dann im Dialog-
fenster eingeben.

4.	 Man sieht nun in den Layers ein kleines zusätzliches Filmicon was andeutet das es sich um eine Animation 
handelt.

5.	 Um die Animation abzuspielen, geht man unter Window > Animati-
on. Hier erhält man ein Fenster mit weiteren Kontrollen.

6.	 Man kann nun die Animation und die Einzelbilder mit Ebenenef-
fecten wie z.B. Levels, Contrast manipulieren.

7.	 Die Animation kann man nun ausrendern unter Datei > Export > 
Render Video.    

8.	 In dem Dialogfenster bennent man die Datei und den Pfad wohin die 
Datei gespeichert werden soll.

Verändertes Layer Icon

Open Dialog

Frame Rate Dialog
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9.	 Man stellt die Rendersettings auf „Quicktime Movie“ mit dem Codec H.264 (High Quality, RGB 24bits).  
(Falls der Codec H.264 nicht eingestellt ist, klickt man auf Settings, Im „Movie Settings“-Fenster klickt man 
dann im Videobereich auf Settings und wählt dann als Compression Type „H.264“ aus dem Dropdown-
menü aus.)

Virtual Dub
Eine kostenlose Alternative ist Virtual Dub (Download unter www.virtualdub.org)

1.	 Man öffnet die Bildsequenz mit Datei > Öffnen. Hier wählt man das erste Bild der Sequenz aus.

2.	 Unter Video > Compression wählt man den Codec aus, den man verwenden möchte. (Es bietet sich hier z.B. 
der Xvid Codec an www.xvid.org)

3.	 Optional: Einsatz von Filtern mit Video > Filter

4.	 Unter Datei > Save as Avi wird die Datei als Video-datei abgespeichert.

Animation Timeline, mit unten links Kontrollen zum abspielen der Animation

MEL Skripting
Man kann alle Funktionen von Maya mithilfe von MEL-Skripten ansteuern. Auch wenn man noch keine Program-
miererfahrung hat ist es einfach Skripte zu erstellen. Man kann viele Befehle einfach im Skript Editor ablesen. Pro-
grammierer können mit Mel, Python, und C++/QT Skripte und Erweiterungen von Maya programmieren.

Skript Editor
Im oberen Teil sieht man die History der ausgeführten Maya Befehle. Um ein eigenes Skript zu erstellen könnte man  
eine Reihe von Operationen in Maya ausführen und dann einfach die Befehle aus der History kopieren. Manchmal 
werden ein Teil der Befehle nicht angezeigt. Möchte man sich wirklich alle Befehle anzeigen lassen wählt man Histo-
ry > Echo All Commands.

Im unteren Teil  lassen sich eigene Skripte erstellen. Der Editor unterstützt Syntax Highlighting. Möchte man das 
Skript ausführen, selektiert man den Code und drückt Strg-Enter. (Drückt man nur Enter wird der Skript Editor 
zurückgesetzt)

Shelf Customization
Die einfachste Variante um Skripte abzuspeichern ist den Code im Skript Editor zu selektieren und mit MMB auf die 
Shelf ziehen. Es wird ein neues Icon erstellt und durch Klicken auf die Shelf wird der Code ausgeführt.

Man kann das Icon wieder löschen, indem man es (wie jedes Shelf Objekt) mit MMB auf den Mülleimer zieht.

Mit MMB und auf den Skript Editor ziehen kann man den Code im Code Editor bearbeiten.Der bearbeitete Code 
kann nur als neues Shelf Item abspeichert werden.

Nützliche Scripts

Default Settings

Man sollte sich ein eigenes Skript schreiben, was einem die persönlichen Mayaeinstellungen automatisch aktiviert.
Hier ist ein Skript das die Einstellungen von Seite 26 übernimmt.

//deactivate View Cube

viewManip -visible off;

optionVar -iv viewCubeShowCube 0;

//gray background

displayPref -displayGradient false;

//poly center face selection

polySelectConstraint -wholeSensitive off;

//ininite undo

undoInfo -infinity on; intFieldGrp -e -enable false queueSizeIFG;

//enable autosave

optionVar -iv autoSaveEnable true;autoSave -en true;layout -e -en true Prefer
encesWindow|formLayout46|prefTitleFrame|prefTabs|frameLayout91|prefFileIOCol|f
rameLayout155|columnLayout75|autoSaveLayout1; layout -e -en true PreferencesW
indow|formLayout46|prefTitleFrame|prefTabs|frameLayout91|prefFileIOCol|frameLa
yout155|columnLayout75|autoSaveLayout2;{ int $autoSaveDestination = (̀ optionVar 
-q autoSaveDestinatioǹ  == 1); layout -e -en $autoSaveDestination Preferences

http://www.virtualdub.org/
http://www.xvid.org
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Window|formLayout46|prefTitleFrame|prefTabs|frameLayout91|prefFileIOCol|frameL
ayout155|columnLayout75|autoSaveLayout2|autoSaveBrowseLayout;};

optionVar -iv autoSaveLimitBackups true; autoSave -limitBackups true;intSliderGrp 
-e -en true autoSaveMaxBackups;

//Turn off Interactive Creation

toggleCreateNurbsPrimitiveAsTool;

toggleCreatePolyPrimitiveAsTool;

Activate Mental Ray Plugin
Häufig wird Mental Ray nicht automatisch geladen (z.B. nach einem Absturz von Maya). Das Skript lädt Mental Ray 
und setzt es als Default Renderer.

//Loads mentalRay if not yet active

if(!̀ pluginInfo -query -loaded -name „Mayatomr“̀ ) {

	 loadPlugin Mayatomr;

	 pluginInfo -edit -autoload true Mayatomr;

}

//sets Renderer to MentalRay

setAttr „defaultRenderGlobals.currentRenderer“ -type „string“ „mentalRay“;

Reset Renderview
Es kommt vor, dass die RenderView einfach grau erscheint dieses Skript erzeugt eine neue View.

$exists=0;

 for ($item in g̀etPanel -scriptType „renderWindowPanel“̀ ) {

 	 if ( $item == „renderView“ ) {

 		  print „renderView exists.\n“;

 		  $exists=1;

 	 }

 }

 if ( $exists == 0 ) {

 	 for ($item in g̀etPanel -scriptType „renderWindowPanel“̀ ) {

 		  if ( $item == „renderWindowPanel1“ ) {

 			   deleteUI renderWindowPanel1;

 			   $renderPanel = s̀criptedPanel -type „renderWindowPanel“ 
-unParent renderVieẁ ;

 			   scriptedPanel -e -label `interToUI $renderPanel` $renderPa-
nel;

			   print „renderView reset.\n“;

 		  }

 	 }

 }

Maya API Resources
Zum Abschluss eine kurze Übersicht nützlicher Links.

Notepad++
Der Editor Notepad++ unterstützt mit einem Plugin Syntax Highlighting für MEL

http://notepad-plus-plus.org/

http://www.creativecrash.com/downloads/applications/syntax-scripting/c/mel-language-definition-for-note-
pad-

Autodesk:
http://download.autodesk.com/global/docs/mayasdk2012/en_us/index.html

MEL:
http://cg.tutsplus.com/tutorials/autodesk-maya/maya-mel-procedural-modeling-for-artists-uis

http://cg.tutsplus.com/tutorials/autodesk-maya/procedural-modeling-with-mel-scripts-in-maya-day-2/

http://www.comet-cartoons.com/3ddocs/mayaAPI/

http://nccastaff.bournemouth.ac.uk/jmacey/RobTheBloke/www/

http://ewertb.soundlinker.com/maya.php
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Legacy Mental Ray Anti-Aliasing
Beim ausrendern kann es vorkommen, das die Kanten bzw. Bereiche mit einem hohen Kontrast sehr verpixelt und 
nicht glatt ausgerendert werden. Anti-Aliasing, verbessert die Kantenglättung. Unter Render Settings bei Quality > 
Anti-Aliasing Quality findet man alle Einstellungsoptionen.

Anti-Aliasing Quality

Sampling Mode
Adaptive Sampling ist die beste Einstellung, um die Rechenzeit nicht unnötig zu erhöhen. Die Minimum Sample 
Level ist um 2 niedriger als die Maximum Sample Level.

Fixed Sampling setzt die Min und Max Sample Level auf das gleiche Level. (Dies erhöht nur die Rechenzeit ohne 
einen sichtbaren Effekt auf das finale Bild)

Custom Sampling lässt beliebige Werte setzen. 

(Min/Max) Sample Level
Das Sample Level bestimmt die Anzahl der Pixel, die 
benutzt werden, um die Glättung zu errechnen. Da die 
Renderzeit für Anti-Aliasing exponentiell steigt, sollte 
man nur wenn nötig die max. Sample Level erhöhen. 

Diagnose Samples
Wenn man das Häckchen bei Diagnose Samples setzt, 
so wird das Bild ausgerendert und danach wird ein Bild 
gezeichnet, in dem die Anti-Aliasing berechnet wurde. 
Diese Darstellung hilft zu sehen, wo es Probleme beim 
Anti-Aliasing gibt.

Anti-aliasing Contrast
Der Anti-Aliasing Contrast bestimmt, welches Sampling 
Level verwendet werden soll. Je niedriger der Wert, desto 
niedriger muss der Kontrast zwischen zwei Pixeln sein 
damit das Max. Sample Level verwendet wird. Je höher 
der Wert, desto seltener wird das Max. Sample Level be-
nutzt.

Multi Pixel Filtering

Filter
Bestimmt das Weichzeichner-Verfahren. Man kann zwischen Box, Triangle, Gauss, Mitchell, Lanczos wählen. 

Filter Size
Bestimmt die Größe der FilterMatrix, d.h. wieviele umliegende Pixel in die Weichzeichen-Berechnung eines einzel-
nen Pixels einfließt.

Anti Aliasing Settings

No Anti-Aliasing Gauss, FilterSize = 3 Mitchell, FilterSize = 4

Anmerkung: Eine gute Einstellung für das Multi-Pixel Filtering ist das Gauss Verfahren mit Werten von 2.5 oder 
2.0. Zu hohe Werte können das Bild zu weich erscheinen lassen. Alternativ bekommt man gute Ergebnisse mit dem 
Mitchell-Verfahren.

Arbeiten mit Anti-Aliasing
Bei Draft-Render Qualität braucht man sich nicht um Anti-Aliasing zu kümmern. Adaptive Sampling, Min Sample 
Level 0 und Anti-aliasing Contrast 0.1 beeinflusst kaum die Renderzeit.

Bei Production-Render Qualität sollte man die Einstellungen bei Adaptive Sampling, Min Sample Level 2 und Anti-
Aliasing Contrast auf 0.1 setzen. 

Ein Wert von 2 für die Max. Sample Level ist ein guter Wert für das Verhältnis von Qualität zu Rechenzeit. Ist das 
nicht ausreichend, sollte man  in 0.1 Schritten den Anti-aliasing Contrast verringern. Bei einem Wert von unter 0.01 
sollte man die Max Sample Level erhöhen und den Anti-Aliasing Contrast wieder auf 0.1 setzen.
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