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Einleitung
Der Begriff „Maya“ kommt aus dem Sanskrit und bedeutet Illusion. Die 3D-
Modellierungssoftware Maya ist ursprünglich auf fotorealitische Animati-
onen spezialisiert gewesen. Sie wurde konstant weiterentwickelt, sodass sie 
nun für jede Art von Animation verwendet werden kann.

Dieses Skript dient dazu, die Grundlagen des 3D-Modellierens  und Ani-
mierens mit Maya zu verdeutlichen. Die erworbenen Fähigkeiten sind auf die 
meisten 3D-Programme anwendbar. 

Die einfachste Art und Weise Maya zu lernen ist mit dem Programm herum-
zuspielen und auf Entdeckungsreise zu gehen.

„Remember to play, it‘s the best way to learn“ Bert Monroy

Überblick des Skripts
Zuerst beschäftigt sich das Skript mit den Grundlagen des Maya Userinter-
faces. 

Die darauf folgenden Kapitel sind gemäß dem Arbeitsprozess aufgebaut: Mo-
dellieren, Rendern, Animieren. Da Maya ein nodebasiertes System ist, kann 
man die Arbeitsschritte aber auch nach belieben in der Reihenfolge ändern. 

Beim „Modelling“ werden die Modellier-Techniken NURBS und Polygon 
zum Erstellen von Objekten genauer betrachtet. Lichter und Schatten, sowie 
Materialeigenschaften werden beim anschließenden „Rendering“ zugewie-
sen. Hierfür wird primär die Render Engine „Mental Ray“ verwendet. Die 
Objekte können nun animiert werden. Dies geschieht entweder mithilfe von 
des Keyframe Verfahrens wo man manuell gesetzten Keyframes oder mit ei-
ner physikalischen Simulation. 

Wireframe View

Lambert Default Shading

Direct Illumination
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Herangehensweise des Skripts
Es werden zuerst die Tools für das jeweilige Kapitel vorgestellt und dann anhand eines praktischen Beispiels nochmals 
vorgestellt. Am Ende des Beispiels gibt es Übungsaufgaben um selbstständig den Umgang mit den Werkzeugen zu 
üben.

Geschichte von Maya
Maya ist durch eine Kombination der drei Softwarelinien „Wavefront - Ad-
vanced Visualizer“, „Thomson Digital Image - Explore“ und „Alias - Power 
Animator“ entstanden. Mit diesen ursprünglichen Softwarepaketen wurden 
fotorealistische Bilder erzeugt wie z.B. die Special Effects von “Terminator 
2”(James Cameron, 1991) oder “Jurassic Park” (Steven Spielberg, 1993). 

Während der Entwicklung von Maya 1.0 (1999) hat das Produktionsteam 
mit dem Animierer Chris Landreth zusammengearbeitet. Er hatte mit der 
Beta-Version den ersten Kurzfilm “Bingo” (1998) gemacht. Kurz darauf wur-
de Maya für die Animationen in “The Matrix” (Wachowski-Brothers, 1999) 
und in “The Mummy” (Stephen Sommers, 1999) verwendet. In “The Matrix” 
wurden dabei primär die “Sentinels”, Roboter mit mehreren Armen, ani-
miert, in “The Mummy” sind die tausenden von Skarabäen als Partikelsystem 
simuliert worden.

Dies führte dazu, dass “Industrial Light and Magic” (ILM) Maya als Stan-
dard für die Special Effects Industrie einführte. Derzeit hat Maya ca. 42% 
Marktanteil. An zweiter Stelle kommt 3DSMax mit 40% Marktanteil (Stand 
April 2010, 3500 Teilnehmer an der Studie). Animationshäuser bevorzugen 
Maya wegen seiner einfachen Erweiterbarkeit. Es verfügt eine Python- und 
C++ Schnittstelle und verfügt über eine eigene Skriptsprache MEL. Seit der 
2011 Version ist Maya im QT-Framework geschrieben und kann auch um 
QT-Widgets erweitert werden. 

Der heutige Anwendungsbereich von Maya ist nicht auf die Animation in 
Filmen beschränkt, sondern erstreckt sich auch über die Entwicklung von 
3D-Objekten für Computerspiele, Architekturvisualisierung und Physiksi-
mulationen.

“The Matrix” - Sentinel

“The Mummy” - Scarabs

“Terminator 2” - Morphing
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Schreibweisen in diesem Skript
Manche Schreibweisen sind durchgehend in dem Skript zu finden und werden hier erläutert.

Zwar ist Maya für eine Vielzahl von Betriebssystemen ausgelegt, jedoch sind die jeweiligen Oberflächen identisch.

Die Auswahl eines Menüpunkts wird wie folgt dargestellt:

-- Menü > Befehl (wie z.B. File > New Scene)

Wenn die spezifischen Konfigurationseinstellungen eines Menüpunkts benutzt werden sollen:

-- Menü > Befehl q  (wie z.B. Create > NURBS Primitives Cube q)

Maus- und Tastaturbefehle werden in dieser SCHRIFTART angezeigt.

-- RMB - Rechte Maus Taste (right mouse button)

-- LMB - Linke Maus Taste (left mouse button)

-- MMB - Mittlere Maus Taste (middle mouse button)

Installationshinweise
Unter Windows Vista/7 muss man die Installation als Administrator ausführen. Darüberhinaus muss die UAC (User 
Account Control) deaktiviert werden damit die Installation erfolgreich ausgeführt werden kann.

Auf Windows Systemen sollte man vor dem ersten Starten von Maya sicherstellen, dass eine aktuelle Version von 
DirectX installiert ist. Diese lässt sich auf der Microsoft DirectX Webseite herunterladen (http://www.microsoft.
com/windows/directx/).

Nützliche Tools die man optional zu Maya mit installieren kann ist die „Maya Documentation“ ein umfangreiches 
Handbuch was jede noch so kleine Funktion dokumentiert und  „Autodesk Composite“ (früher „Toxik“), ein Node-
basiertes Post-Production Compositing Tool. (Siehe „Anhang A: Post-Production mit Autodesk Composite“ Seite 129)
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Weiterführende Literatur

Getting Started Manual
Das offizielle Einsteiger-Handbuch stellt viele grundlegenden Funktionen von Maya vor.

http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=9502844&linkID=9242256

Maya Dokumentation
Bei der Installation von Maya lässt sich optional die Dokumentation mitinstallieren.Das ist sehr zu empfehlen, da sie 
gleichzeitig die Hilfe-Datei von Maya darstellt, äußerst umfangreich ist und sehr viele Probleme mit anschaulichen 
Beispielen erklärt.

Autodesk Area Community

Die Autodesk Area Community hat eine Sammlung von mehreren Tutorials und nützlichen Plugins, wie z.B. die 
Maya Bonus Tools.

http://area.autodesk.com/

Bonus Tools: http://area.autodesk.com/bonus_tools

Autodesk Students Community
Für persönliche Zwecke haben Studenten die Möglichkeit eine Studentenlizenz von Autodesk zu erhalten. 

http://students.autodesk.com/

Maya Station
Der offizielle Blog vom Maya Support Team. Insbesondere wichtig für Maya Updates und Workarounds für existie-
rende Bugs.

http://mayastation.typepad.com

CG Society - Society of Digital Artists
Eine umfangreiche Website mit Forenbereich und interessanten Informationen über die aktuellen Neuigkeiten in der 
CG-Szene. 

http://www.cgsociety.org/

Maya Tutorial Sammlung: http://forums.cgsociety.org/showthread.php?threadid=6360

Creative Crash
Eine Plattform auf der sich 3D-Artists, Modelle, Texturen etc. austauschen und Showcases von ihren Arbeiten zeigen 
können.

http://www.creativecrash.com/

Tuts+ Network
Das Tuts+ Network verfügt über eine Reihe von verschiedenen Websites die sich über viele medienrelevante Themen 
beschäftigt. Das CGTuts+ beschäftigt sich mit  Maya, 3DSMax, Blender etc. und bietet neben Tutorials auch Tex-
turen und andere Ressourcen.

http://cg.tutsplus.com/

Lynda.com
Eine Website mit kostenpflichtigen Video Tutorials für viele verschiedenene Programme. Hat eine sehr gut ausgear-
beitete einführungen in komplexen Maya Themen.

http://www.lynda.com/Maya-training-tutorials/255-0.html

Digital Tutors
Der offizielle Autodesk Partner für Video Tutorials für Maya.

http://www.digitaltutors.com/11/training.php?cid=5
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Grundlagen
„Without having a goal it is difficult to score.“ Paul Arden

Warum sind wir hier?
Die Frage ist zwar philosophisch und nicht in einigen Sätzen zu beantworten, im Rahmen von dem Skript sind wir 
hier um gute Animationen zu erstellen.

Dann stellt sich die Frage: „Was sind denn gute Animationen?“ Eine gute Animation muss emotional ansprechen. Da-
her erzählt sie meistens eine gute Geschichte, nur mit Bildern und ohne Worte. Gleichzeitig achtet man auch darauf, 
dass der technische Teil dazu harmoniert und es optisch anspricht.

Somit stellt sich die Frage: „Was ist eine gute Geschichte?“ Das ist einfach zu beantworten, denn eine gute Geschichte 
baut auf einer guten Idee auf.

Daher sollte man sich immer im Vorfeld einige Gedanken machen was man denn erzählen möchte und ob die Idee 
die man verfolgt auch tatsächlich gut ist. Sobald man eine gute Idee hat, kann man auf das Ziel hinarbeiten diese zu 
verwirklichen.

Wie bekommt man gute Ideen?
„An idea is nothing more nor less than a new combination of old elements.“ James Webb Young

James Webb Young hat 1940 das Buch „A Technique for Producing Ideas“ veröffentlicht. Im Prinzip hat er eine kurze 
Formel beschrieben wie man eine gute Idee erhalten kann.

1.	 Informationen sammeln: Bereits hier scheitern die meisten. Man braucht viele verschiedene Informationen 
über viele verschiedene Themen. Man muss einerseits viele allgemeine aber andererseits auch viele spezielle Infor-
mationen sammeln. Dieser Prozess sollte das ganze Leben lang anhalten. Je mehr Wissen man ansammelt, desto 
einfacher ist es neue Verbindungen zwischen bekannten Elementen aufzubauen.

2.	 Informationen verdauen: Hat man alle Informationen auf ihre Nützlichkeit überprüft, versucht man nun 
sie miteinander zu kombinieren. In diesem Schritt sollte man jede Teilidee die einem einfällt aufschreiben.

3.	 Abstand nehmen: Die meisten Ideen sind nicht beim Nachdenken über die Informationen gekommen, 
sondern sie kommen einfach beim Duschen, oder irgend einer anderen alltäglichen Aktivität. Sofern man genügend 
Informationen bearbeitet hat, arbeitet das Unterbewusstsein einfach weiter an der Idee. Daher kann man Abstand 
nehmen und etwas anderes machen.

4.	 Der Eureka Moment: Irgendwann taucht dann einfach eine Idee aus dem nichts auf. Wenn nicht, einfach 
weiter Ideen aufschreiben und Informationen sammeln.

5.	 Die Idee verfeinern: Eine frisch geborene Idee ist noch grob und unspezifisch, muss jetzt noch bearbeitet 
und geformt bzw. spezifiziert werden.

6.	 Die Idee mit anderen teilen: Durch Austausch mit anderen Menschen verbessert sich die Idee automatisch. 
Je mehr man von seinem Wissen und Ideen weitergibt, desto mehr kommt von der Welt zurück.

7.	 Von vorne anfangen:  Man hat bis jetzt eine hervorragende Leistung erbracht. Nun kann man mit dem 
gesammelten Wissen über die Schwierigkeiten und Hürden des Problems den Prozess von neuem beginnen. So lässt 
sich die Idee noch weiter verbessern.

Von der Idee zur Animation
1.	 	 Pre-Production: Mit Skizzen und einem Storyboard wird die Animation festgelegt. 

2.	 Modeling: Mit den Skizzen werden die einzelnen Objekte modelliert. 

3.	 Texturing: Dem Objekt (Modell) werden die Materialien und Texturen hinzugefügt.

4.	 Animation: Das Modell wird entweder durch Keyframes animiert oder durch Zuweisung  
		  physikalischer Eigenschaften. 

5.	 Lighting: Es werden Lichter und Schatten in die Szene gesetzt.
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6.	 Rendering:  Aus dem nun fertigen Modell werden die resultierenden Bilder erzeugt.

7.	 Post-Production: Die fertigen Bilder unterlaufen Farbkorekturen (Color Grading) und ggf. eine abschlie-
ßende Komposition.

Umsetzung einer Idee in Maya
Abgesehen von Pre- und Post-Production ist jeder Arbeitsschritt in Maya mithilfe von Modulen realisiert. Diese 
Modularisierung wird durch das Node-Konzept von Maya unterstützt, d.h. jedes Objekt ist ein Node und hat Ein- 
und Ausgabeverbindungen zu anderen Nodes. Daher können z.B. Modell und Materialien unabhängig voneinander 
erstellt und erst im finalen Schritt durch Verbinden der Nodes zusammengeführt werden. Dies ermöglicht flexible 
Workflows.

Pre-Production
Im Pre-Production Schritt arbeitet man mit „Storyboards“ und „Layouts“. Enthält die Animation Charaktere, fertigt 
man auch sogenannte „Model Sheets“ an. 

Storyboard
Die beste Art und Weise ein Storyboard anzufertigen, ist weiterhin mit Papier und Stift. Es eignen sich schon sehr 
grobe Konzeptzeichnungen, um den späteren Inhalt der Szenen darzustellen. Das Storyboard zieht sich dann bei der 
Umsetzung wie ein roter Faden durch alle Produktionsschritte.

Storyboards können auch in einfache Animatics (Stop-Motion Clips) umgewandelt werden um ein Gefühl zu bekom-
men ob die Szenen zeitlich zueinander passen.

Layouts
Ist das Storyboard fertig und entspricht die Umsetzungen den eigenen Vorstellungen, versucht man das Layout der 
einzelnen Umgebungen festzulegen, z.B. das Aussehen der gesamten Umgebung aber auch Details wie die Art der 
Kostüme von Charakteren.

Model Sheet
Für die Charaktere werden Model Sheets angelegt um ein klareres Bild vom Aussehen der Welt und der Charaktere 
sowie deren möglicher Bewegungen machen zu können. Dies sind wichtige Vorüberlegungen für den Aufbau und ei 
nötige Flexibilität des Charakters.

Animatic
Das Storyboard wird grob umgesetzt damit man schnell sehen kann wie die Animation wirkt. Dies ist notwendig um 
ein Gefühl zu bekommen ob die Animation funktioniert oder nicht. 

Man kann gar nicht genug betonen wie wichtig es ist einen klaren Überblick über das gesamte Projekt zu haben. 
Ein  Storyboard ist unverzichtbar, Layouts und Modelsheets erleichtern es seine Vision vorzustellen. Arbeitet man in 
einem Team zusammen hat jedes Mitglied eine eigene Vorstellung von der Animation. Diese Vorgestellten Hilfsmittel 
helfen Missverständnisse zu vermeiden.
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Die Standard Manipulatoren

Arbeiten im 3D-Raum
Die Arbeit im 3D-Raum ist vergleichbar mit dem Umgang einer Kamera in der Realität. Durch die Kamera sieht man  
nur einen  bestimmten Ausschnitt aus der Welt. Wenn man ein Objekt aus verschiedenen Blickwinkeln betrachten 
will, so muss man die Kameraposition verändern. Bedingt durch den Öffungswinkel treten Verzerrungen auf.  

Die perspektivische Kamera hat eine 35mm Öffnung was  der normalen Wahrnehmung entspricht (perspektivische 
Ansicht).

Eine alternative Darstellung im 3D-Raum ist die orthografische Ansicht - entspricht z.B. Blaupausen - wo alle Projek-
tionsstrahlen parallel zueinander sind. In Maya entspricht das der Top, Side und Front View.

Eine Besonderheit von 3D-Programmen ist, dass die Kamera nicht Objekte anzeigt die zu nah oder zu weit entfernt 
von ihr sind. Dies verhindert unnötiges Berechnen von Objekten, die kaum sichtbar sind bzw. das gesamte Bild ein-
nehmen würden. Das wird mit der “Near Clip Plane” und der “Far Clip Plane” ermöglicht. Nur Objekte innerhalb 
dieser Ebenen werden angezeigt, alle anderen werden ignoriert.

Koordinatensystem
Viele 3D-Programme benutzen ein kartesisches Koordinatensystem. Der Ursprung liegt im Punkt (0,0,0).

Die Startperspektive von Maya zeigt ein kleines Koordinatengitter (Grid) welches die XZ-Ebene repräsentiert. Die 
positiven Y-Werte sind über der XZ-Ebene.

In Maya werden die Achsen durchgehend im gleichen Farbschema dargestellt: Rot für X, Grün für Y und Blau für Z.

Oben links: „top-View“, Oben rechts: Perspective-View(„persp“) Unten links: „front-View“, 
Unten rechts: Side-View
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Maya Basic User Interface
Doe Arbeit mit Maya erfordert eine 3-Tasten Maus. Viele Funktionen des Programms können nur durch die 3. Maus-
taste benutzt werden, beispielsweise die Navigation innerhalb einer Szene.

Das Interface ist Anfangs sehr überwältigend mit vielen verschiedenen Einstellungsmöglichkeiten und versteckten 
Funktionen. Es ist nicht wichtig alle Funktionen auf einmal zu lernen. Mit der Zeit gewöhnt man sich sehr leicht an 
das Programm.

Maya Workspace
Als Standardansicht wird ein Panel mit der Kameraansicht “Perspective” (kurz persp) angezeigt.

Panels
Jedes Panel hat sein eigenes Panel Menü sowie eine Leiste mit Anzeigeoptionen. In einem Panel wird standardmäßig 
die “Camera View Type” eingeblendet, sowie ein “Axis Direction Indicator”.

Dieses Panel hat den Titel “persp”, da man auf die Szene durch die perspektivische Kamera blickt.

Der Ursprung (Origin) des Koordinatensystems in einem Grid befindet sich in dem Schnittpunkt der beiden schwar-
zen Linien. Alle Werte in Maya werden relativ zu diesem Punkt errechnet.

Menu Bar
Die Funktionen von Maya sind gegliedert in mehrere Menu Sets : Animation (F2), Polygons (F3), Surfaces (F4), 
Dynamics (F5), Rendering (F6), nDynamics (F7). 

Mit einem neuen Menu Set ändert sich auch manche Menüeinträge. Falls man einen bestimmten Menüpunkt nicht 
finden kann, sollte man überprüfen ob man sich im richtigen Menu Set befindet.

Anmerkung: Alle Menüs können als 
Tearoff Menü, also als kleines eigen-
ständiges Fenster benutzt werden. So 
bleiben sie auch bei einem Wechsel 
des Menu Sets bestehen. 
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Status Line

Die Status Line ist in mehrere Elemente aufgeteilt:

Menu Set Dropdown - zeigt das aktuelle Menu Set an und ermöglicht den Wechsel in andere Menu Sets.

File System Icons  - New Scene, Open File, Save File

Selection Set (per default ausgeblendet) - eine Kontrolle für die gerade aktive Selektionsart.

Selection Mode Icons - verändert das allgemeine Selektierverfahren.

Selection Mask Icons - lassen den ausgewählten Selektionsmodus noch genauer bestimmen.

Snapping Icons - ermöglichen, dass Objekte an Objekten/Komponenten einschnappen.

Rendering Icons - die grundlegenden Renderingtools und -einstellungen.

Select Field - ermöglicht eine genaue Transformation des gerade selektierten Objekts.

Anmerkung: Unerwünschte Teile der Status Line können durch Klicken auf die kleine Linie vor den Icons 
ausgeblendet werden.  
 
 
 
 Ausgeklappte Icons Eingeklappte Icons

Shelf
Die Shelf wird verwendet um schnell an Tools zu gelangen. Mit einem einzigen LMB Klick wird ein Befehl ausgeführt. 
Möchte man neben den Standardbuttons noch seine eigenen Menübefehle hinzufügen, so drückt man STRG+SHIFT 
und klickt mit der linken Maustaste auf den entsprechenden Menübefehl. Der Befehl wird nicht ausgeführt, aber es 
wird ein neues Icon dem gerade aktiven Shelftab hinzugefügt.

Channel Box / Layer Editor
Im Channel Box werden die typischen Eigenschaften eines selektierten Objekts aufgelistet; diese Werte werden per 
Tastatureingabe verändert. Durch selektieren mehrerer Felder gleichzeitig können diese simultan auf den gleichen 
Wert gesetzt werden. Im unteren Bereich INPUT sieht man die Konstruktions-Nodes des Objekts.

Der Layer Editor lässt Objekte verschiedenen Layern zuordnen. Es gibt drei Typen von Layern. Mit einer Display-
Layer lässt sich die Sichtbarkeit von Objekten verändern. Mit einer Render-Layer verändert man das Verhalten der 
Renderengine für die selektierten Objekte und mit Animations-Layern kann man die Animationen eines Objects 
aufteilen.

Time Slider

Der Time Slider ist eine Zeitlinie, mit der zu bestimmten Frames gesprungen werden kann (LMB auf die Leiste oder 
manuelle Eingabe im Feld neben der Leiste). Keyframes werden darauf als rote Striche angezeigt; durch Selektieren 
und Gedrückthalten von MMB lassen sich diese verschieben. Am Ende der Leiste sind die Playback Controls um die  
Frames abzuspielen.

Curves Shelf

Time Slider
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Range Slider
Mit dem Range Slider manipuliert man die Zoomstufe des Time Sliders. Mit den Zahleneingaben kann man auch 
die maximale Anzahl der Frames verändern. Der Schlüssel am Ende der Bar ist der Auto-Keyframe Toggle - wenn 
aktiviert, fügt er animierten Objekten automatisch neue Keyframes zu wenn sie in einem Frame verändert werden.

Command Line
Hier können direkt MEL oder Pythonbefehle eingeben werden. Auf der rechten Seite sieht man den Konsolen-
Output. Falls irgendeine Operation fehlgeschlagen, verfärbt sich der Konsolenuntergrund rot. 

Der Button am Ende der Zeile öffnet den Skript Editor, der alle bisher ausgeführten Befehle auflistet. Klickt man auf 
die Aufschrift MEL lässt sich Wechseln zu der Python-Eingabe.

Toolbox

Die Toolbox bietet Zugriff auf alle grundlegenden Manipulationswerkzeuge und wird wegen den zugehörigen Key-
boardshortcuts auch QWERTY-Tools genannt (siehe Bild).

Der untere Bereich Views bietet eine Auswahl verschiedener Panel-Views. Diese unterteilen den Bildschirm in meh-
rere Fenster um effizientere Workflows zu ermöglichen. Maya bietet hierzu einige vorgefertigte Views, lässt sich aber 
auch um eigene erweitern.

Help Line
Die Help Line zeigt das gerade verwendete Werkzeug sowie eine detaillierte Anleitung, wenn es sich um ein kompli-
zierteres Tool handelt.

Range Slider

Command Line

ToolBox

Help Line
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RMB auf einer NURBS Sphere und das 
dazugehöringe Marking Menu

Marking Menus
Maya bietet viele sogenannte Marking Menus. Diese lassen sich durch Ge-
drückthalten von RMB öffnen und sind im Prinzip kontextabhängige Popup-
Menüs, zeigen also je nach Kontext unterschiedliche Elemente an. Für Ob-
jekt lässt sich so beispielsweise die Darstellungsweise ändern, während sich 
auf leerem Raum ein Selektionsmenü öffnet. Zieht man die Maus in Rich-
tung eines Befehls und lässt RMB wieder los, so wird dieser ausgeführt.

Marking Menus sind kontextabhängig. RMB auf einem Objekt lässt die Dar-
stellungweise ändern, wohingegen im leeren Raum RMB ein Selections Menü 
öffnet.

Zusätzlich gibt es dann noch Tastenmodifier. Zum Beispiel lässt sich mit  
RMB + H ein Marking Menu öffnen mit dem man schnell das aktive Menu 
Set wechseln kann. 
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Keyboard Shortcuts
Um mit Maya zu arbeiten muss man Keyboard-Shortcuts beherrschen. Die am meisten benutzten Shortcuts sind ALT 
und eine Maustaste gedrückt für die Kamerasteuerung, sowie LEERTASTE kurz gedrückt um von der aktuellen 
Ansicht in die vorhergehende zu wechseln (dabei muss ein  Panel aktiv selektiert sein).

Camera Controls
Um sich im 3D-Raum zu bewegen, gibt es vier Möglichkeiten:

1.	 Tumble (Kamerarotation): ALT + LMB

2.	 Dolly (Kameraposition rein oder raus bewegen): ALT + RMB

3.	 Track (Kamera auf einer Schiene bewegen): ALT + MMB

4.	 Zoom: Mit dem Mausrad scrollen

Um zu einer bestimmten Stelle hinzuzoomen kann man auch STRG + ALT + LMB gedrückt halten und macht 
eine Selektion von oben nach unten um auf die Selektion hereinzuzoomen. Um herauszuzoomen, selektiert man von 
unten nach oben.

Anmerkung: A lässt die Kamera für einen optimalen Überblick auf die gesamte Szene zoomen. F lässt die Kamera 
auf eine Selektion fokussieren. Diese Funktionen können mit SHIFT für alle offenen Ansichten durchgeführt werden.

Hotbox
Bei länger gedrückt gehaltener  LEERTASTE erscheint die Hotbox. Diese enthält genau die gleichen Befehle wie die 
Menubar, rspart aber den langen Weg mit der Maus zum Rand des Bildschirms.

Darüberhinaus ist das Menü in Zonen eingeteilt, in denen man mit der RMB Marking Menus öffnen kann. Das nütz-
lichste Menü findet man direkt auf dem Maya Button in der Mitte der Hotbox. Mit diesem Menü kann man schnell 
vom aktiven Panel in ein Standard-Kamerapanel (persp, top, side, front) wechseln.

Anmerkung: Die Hotbox kann so konfiguriert werden, dass sie nur das Menü des aktiven Moduls anzeigt.Hierfür 
öffnet man die Hotbox (LEERTASTE) und LMB auf Hotbox Controls, wählt aus dem Menü das gerade aktive Modul 
aus und wählt den Befehl „Show only <aktives Modul>“.

Hotbox
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Displayeigenschaften des View Panels
In View Panels kann man mit 1(geringe Qualität), 2(mittlere Qualität), 3(hohe Qualität) die Displayqualität des 
selektierten NURBS-Objekts verändern - dies hat keinen Einfluss auf das spätere Rendern. Es ist nur dazu da um 
schnellere Previews zu erhalten.

Bei Polygon-Objekten wird beim Benutzen der Taste 2 (Smoothing with Polycage), oder 3 (Smooth Mesh Preview) 
ein Smoothing angewendet. Dies hat Einfluss auf das spätere Rendern. Mit 1 kann man den ursprünglichen Zustand 
wiederherstellen.

4 - der Wireframe Modus

5 - der Shader Modus 

6 - der Shader Modus mit Texturen

7 - der Shader Modus mit Texturen und Licht

Wireframe Shader Shader mit Texturen
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Die wichtigsten Shortcuts im Überblick
Die QWERTY-Tools, (Q Select Tool, W Move Tool, E Rotate Tool, R Scale Tool, T Show Manipulator, Y Last Tool 
Used) sind wohl die am häufigsten benutzten Tools in Maya. Die Tastaturkürzel sind  gleichbleibend über das ge-
samte Programm und können in vielen Interaktionsfenstern benutzt werden.

General

Q Select
W Move Tool
E Rotate Tool
R Scale Tool
T Show Manipulator Tool
Y Last Used Tool

Z Undo
SHIFT – Z Repeat

D Toggle Edit Pivot Point (nur mit Move,Rotate, Scale)
INS Edit Pivot Point

STRG-D Duplicate

STRG-SHIFT-D Duplicate Special
SHIFT-D Duplicate with previous Transform

Camera
ALT + LMB Tumble (rotieren)
ALT + RMB Dolly (Zoomen)
ALT + MMB Track 

Snapping

X Toggle Grid Snapping
C Toggle Curve Snapping
V Toggle Point Snapping

Animation

SHIFT-W Transform Keyframe
SHIFT-E Rotate Keyframe
SHIFT-R Scale Keyframe 

S Key All (Keyframe für Transform, Rotate, Scale)
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Arbeiten mit Nodes
In Maya wird jedes Element (Kurven,  Polygon-Objekte, Texturen, etc.)  intern als einzelnes Node repräsentiert oder 
als Serie von verbundenen Nodes.

Als Beispiel: Eine neu erzeugte Nurbs-Sphere hat drei Nodes:

1.	 Transform Node: Speichert alle Translationen, Rotationen und Skalierungen

2.	 Shape Node:  Verwaltet alle Eigenschafften über das Aussehen des Objekts

3.	 Input Node:  Enthält Informationen wie die Geometrie erzeugt wurde

4.	 Shading Node: Verwaltet die Material-Eigenschaften für den Render-Prozess

Anmerkung: Beim Duplizieren (STRG-D) eines Objekts werden nicht die Input Nodes dupliziert! Mit Edit > Dupli-
cate Special mit der Option „Duplicate Input Connections“ ist es möglich.

Viele Nodes werden automatisch erzeugt. Man kann sich die Nodes visualisieren lassen im Hypergraph. Shadernodes 
werden im Hypershade visualisiert. (Siehe „Arbeiten mit dem Hypershade Editor“ Seite 67) Um Werte von Nodes zu 
verändern benutzt man den Attribute Editor oder die Channel Box. 

Hypergraph
Der Hypergraph lässt sich in zwei Modi ausführen:

Hierarchy
In diesem Modus wird die Hierarchie, also alle Eltern-Kind-Beziehungen der 
Objekte einer Szene graphisch dargestellt.

Connections
Man muss zunächst ein Objekt auswählen um dann den Hypergraph Connections zu öffnen. Hier sieht man für ein 
einzelnes Objekt wie es mit anderen Nodes verknüpft ist. Man kann hier auch „hereinzoomen“ auf einzelne Objekte 
und die weiteren Connections der einzelnen Nodes sehen. 

Am Beispiel einer NURBS-Sphere werden folgende Nodes dargestellt: „makeNurbsSphere1“ (Input Node), „nurbs-
SphereShape1“ (Shape Node), „initalShadingGroup“ (Shading Node) und „nurbsSphere1“ (Transform Node)

Mit RMB auf den einzelnen Nodes lassen sich die Verbindungen zwischen verschiedenen Nodes erstellen. Mit DEL 
lassen sich Nodes löschen.

Hypergraph Hierarchy

Hypergraph Connections
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Attribute Editor
Öffnet man den Attribute Editor findet man die gleichen vier Nodes wie im Hypergraph Connections Editor. Hier 
sind alle Einstellungsmöglichkeiten für die einzelnen Nodes. Zusätzlich lassen sich hier für viele Eigenschaften Keys 
für Animationen setzen. Hier kann ein Node umbenannt oder mit einem Kommentar versehen werden.. 

Anmerkung: Es bietet sich an den Attribute Editor (STRG-A) als eigenes Fenster zu benutzen, anstatt immer den 
ChannelBox Editor auszutauschen. Unter Window>Settings and Preferences> Preferences (linkes Menü) Inter-
face muss hierfür bei „Open Attribute Editor:“ die Option „open in separate window“ ausgewählt werden.

Der Attribute Editor
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Tipps zu Einstellungen der Maya UI
Unter Window > Settings and Preferences > Preferences (im folgenden abgekürzt mit Preferences) lassen sich die 

meisten Einstellungen vornehmen.

Infinite Undo/Redo aktivieren
Undo (Z) und Redo (SHIFT-Z) sind standartmäßig auf 50 Undo-Schritte limitiert. 

Dies lässt sich ändern unter Preferences - (Settings) - Undo. Dort setzt man die Queue auf Infinite oder einen belie-
bigen  anderen Wert.

Autosave aktivieren
Autosave wurde mit Maya 2011 neu eingeführt. Da Maya oftmals bei komplexen Berechnungen abstürzt, ist es sehr 
sinnvoll das Autosave feature zu aktivieren:  Unter Preferences - (Settings) - Files/Projects bei dem unter dem Punkt 
Autosave bei Enable ein Häckchen setzen.

ViewCube deaktivieren
Der ViewCube verleitet dazu, nur mit der Maus und nur innerhalb eines Panels zu arbeiten, anstatt sich mit Tasta-
turkürzeln auseinanderzusetzen. 

Daher sollte man den Viewcube deaktivieren indem man unter Preferences - (Interface) - ViewCube das Häckchen 
bei „Show ViewCube“ entfernt.

Interactive Creation deaktivieren
Interactive Creation erlaubt es interaktiv eine Geometrie in ein Viewport zu erzeugen. Jedoch weichen dabei unter 
Umständen die Eigenschaften von einer direkt erzeugten Geometrie ab. Außerdem ist es in den meisten Fällen ein-
facher eine Geometrie direkt zu erzeugen um sie dann mit den QWERTY-Tools anzupassen.

Alle Beispiele im Skript verwenden keine Interactive Creation. Man deaktiviert Interactive Creation indem man das 
Häcken unter Create > NURBS Primitives > Interactive Creation, sowie bei Create > Polygon Primitives > Inter-
active Creation entfernt.

Hintergrund Gradient deaktivieren
Man kann den Hintergrund Gradient von Panels deaktivieren indem man unter Preferences - (Display) - bei „Back-
ground gradient“ auf „Off“ umschaltet.
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Modelling
In Maya gibt es drei Typen von Geometrie: NURBS, Polygon und Sub-Division Surfaces. Jeder dieser Typen hat seine 
eigenen Vor- und Nachteile. Diese verschiedenen Geometrietypen können innerhalb einer Szene gemischt verwendet 
werden.

Beim Modellieren können verschiedene grundsätzliche Vorgehensweisen verwendet werden. Für welchen man sich 
entscheidet, hängt dabei von persönlichen Präferenzen ab.

Spline/Curve-Modelling
Beim Spline-Modelling  zeichnet man die äußeren Kanten eines Objekt (ähnlich einer Blaupause) und lässt Maya die 
Geometrie aus den Kurven erstellen. 

Box-Modelling
Man manipuliert Primitive solange, bis sie die gewünschte Form haben. Der Vorteil dieser Variante ist, dass man von 
einem groben Modell ausgehen kann, das dann Schritt für Schritt verfeinert wird.

Sculpting
Beim Sculpting erzeugt man eine Rohmasse, die man d durch Abtragen, Hinzufügen oder Verformen zu dem ge-
wünschten Ergebnis hin bearbeitet. Man muss sich das vorstellen wie mit Ton oder Marmor zu arbeiten. Maya ist 
nicht auf Sculpting spezialisiert, es bietet nur einfache Werkzeuge dafür. Pixologic ZBrush oder Autodesk Mudbox 
ist spezialisiert auf Sculpting und kann Maya Geometrien importieren und bietet deswegen hierfür nur einfache 
Werkzeuge.
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Workspace Einstellungen

Menü
Um mit Nurbs zu arbeiten braucht man das Menü „Surfaces“ (F4). Um mit Polygonen zu arbeiten braucht man das 
Menü „Polygons“ (F3).

Panels
Grundsätzlich benutzt man beim Modelling zwei Perspektiven, die Single View Perspective und die Four View Per-
spective. Zwischen ihnen kann durch kurzes drücken von LEERTASTE gewechselt werden.

Single View Perspektive
Die Single-View Ansicht bietet mit einer perspektivischen Kamera einen Überblick über die Szene. Sie ist die Stan-
dardansicht in Maya (im Menü: Window >  Saved Layout >  Single Perspective View). 

Anmerkung: Mit STRG-LEERTASTE lassen sich alle UI-Elemente (wie die Toolbox, Timeline etc.) ausblenden. 
Drückt man ein weiteres mal STRG-LEERTASTE so lassen sich die ausgeblendeten Elemente wieder einblenden.

Four View Perspective 
Diese Perspektive erlaubt einen schnellen Wechsel zur orthographischen Ansicht der Szene. Einzelne Fenster der 
Perspektive lassen sich über den ganzen Bildschirm ausweiten, indem der Mouse-Cursor über das gewünschte Fenster 
bewegt und LEERTASTE gedrückt wird.

Shelf
Maya bietet für jeden Modellier-Typ eine eigene Shelf an: „Curves“ und „Surfaces“ für das NURBS Modelling, „Po-
lygon“ für das Polygon- und „SubDiv“ für das SubDivision Modelling. Darüber hinaus  kann die „Deformers“ Shelf 
für einfachen Zugriff auf Deformations-Werkzeuge verwendet werden.

Curves Shelf

Surfaces Shelf
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CV-Curve Tool der Curves-Shelf hinzufügen
Das CV-Curve Tool wird sehr häufig verwendet und sollte der Curves-Shelf hinzugefügt werden.

1.	 Shelf auf Curves setzen.

2.	 Mit STRG+SHIFT den Menüpunkt Create > CV-Curve auswählen. Am Ende der Shelf sollte ein neues Icon 
erscheinen.

3.	 Das neue Icon mit MMB neben das EP-Curve Tool ziehen.

Polygon Shelf
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NURBS - Grundlagen
Definition
Non-Uniform Rational B-Spline (kurz: NURBS) sind eine Weiterentwicklung von Bézier-Kurven. Im 3D-Raum 
kann man mehrere solche Kurven verwenden um eine Oberfläche (Surface) aufzuspannen.

Es gibt zwei verschiedene Arten um eine NURBS Geometrie zu erzeugen:

•	 Man zeichnet Kurven in den Raum und lässt eine Fläche anhand der Kurven erzeugen. 

•	 Manipulieren eines Primitivs (Sphere, Cylinder, Cone, etc. mit Ausnahme des Box Primitivs) hin zu der ge-
wünschten Form. 

In den meisten Fällen wird ersteres (sogenanntes Curve-Modelling) mit NURBS betrieben.

Curves
Eine einfache Kurve besteht aus einem Span, einer Linie zwischen zwei Edit Points (EP). Die Anzahl der Control 
Vertex Points (CV) richtet sich nach dem Grad der Kurve + 1. So hat eine Linear Curve (Grad 1) 2 CV Points, eine  
Cubic-Curve (Grad  3) entsprechend 4 CV Points.

Eine komplexe Kurve besteht aus multiplen Spans. Die Kurve verläuft durch die Edit Points und werden durch die 
CV-Points „angezogen“.

NURBS Curves können auf zwei unterschiedliche Arten erstellt werden:

•	 EP-Curves: Beim Erstellen der Curve werden die Edit Points gesetzt

•	 CV-Curves: Beim Erstellen der Curve werden die Control Vertex Curves gesetzt

Man zeichnet die Kurven indem man die Punkte mit LMB auf die top, side oder front view setzt. Man zeichnet kaum 
in der perspektivischen Ansicht Kurven. Alle Punkte werden auf der XZ-Ebene gezeichnet es passiert leicht, dass die 
Linie perspektivisch verzerrt wird. Zum Abschluss bestätigt man mit ENTER.

NURBS Curve Components
Neben dem Objekt-Modus lassen sich auch Komponenten eines Objektes selektieren und modifizieren. Hierfür RMB 
auf das Objekt klicken und wählt den entsprechenden Darstellungsmodus aus dem Selektions-Menü aus.

Edit Point
Mit Edit Points kann man leicht erkennen aus wievielen Spans eine Kurve besteht. Ihre Position kann zwar verändert 
werden, dies passiert jedoch nur sehr selten bzw. nur für sehr geringfügige Anpassungen. CVs eignen sich viel besser 
um Curven zu modifizieren.

Control Vertex
CV-Points beinflussen indirekt die Form der Kurve. Die ersten beiden Control Vertex (CV) Punkte einer Kurve 
werden als zwei hohle Quadrate angezeigt, , um die Richtung der Kurve zu verdeutlichen. Die restlichen CVs sind 
dann ausgefüllte Quadrate. 

Da CVs nur Punkte im Raum sind, kann nur ihre Position im Raum verändert werden. Selektiert man mehrere CVs 
so kann man in Relation zu dem Pivot Point skalieren und rotieren. Beim Skalieren werden die Punkte eigentlich 

Oben Edit Points, Unten CV-Points Eine CV-Point erstellte Curve Eine EP-Point erstellte Curve
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nicht skaliert, sondern nur im Raum bewegt.

Curve Point
Ein Curve Point ist ein selektierter Punkt auf der Kurve, der nicht verändert werden kann. Man kann mit (Edit Cur-
ves > Insert Knot) diesen Punkt als Edit Point der Kurve hinzufügen. So erhält man einen neuen Edit Point und die 
entsprechende Anzahl von CVs.

Curve Tools
Hier wird nur eine Auswahl an häufig benutzten Curve Tools vorgestellt.

Anmerkung: Viele der Curve Tools haben bei der Eigenschaft „Keep Originals“ ein Häckchen gesetzt. Mit dieser 
Option bleiben die ursprünglichen Kurven erhalten, wenn das Tool verwendet wird. Da sie meistens jedoch nicht 
mehr benötigt werden, kann das Häckchen entfernt werden.

Attach Curves
„Attach Curves“ verbindet mehrere Kurven. Die Reihenfolge in der die Kur-
ven selektiert werden spielt eine Rolle. Es wird immer das Ende der ersten 
Kurve mit der nächsten Kurve verbunden.

Im Modus „Blend“ werden beide Kurven ineinander übergeblendet.  Der 
„Blend Bias“-Faktor stellt eine Gewichtung dar, welche der beiden ausgewähl-
ten Kurven von den Veränderungen weniger beeinflusst wird. Ein Wert von 
0.5 lässt beide Kurven gleichviel manipuliert werden. Bei einem Faktor von 
1.0 wird die erste Kurve gering beinflusst, bei 0.0 entsprechend die zweite. 

Anmerkung: Um den gewünschten Effekt zu erzielen, können auch höhere 
Werte als 1.0 bzw. niedrigere Werte als 0.0 eingegeben werden. 

Im Modus „Connect“ wird die erste Kurve vollkommen unberührt gelassen 
und die zweite Kurve wird verformt um eine direkte Verbindung zum End-
punkt der ersten Kurve herzustellen. Dies kann zu sehr spitz verlaufenden Er-
gebnissen führen. Dies kann durch Setzen des Häckchens bei „Keep Multiple 
Knots“ vermieden werden.

Detach Curves
Es muss ein Punkt, wie z.B. ein „Curve Point“ oder „Edit Point“ auf ihr selek-
tiert werden. „Detach Curves“ trennt die Kurve  an dieser Stelle.

Open/Close Curves
Mit Open/Close Curves schließt bzw. öffnet einen Kreis an der Seam Stelle (Der Beginn/Ende eines Kreises).

Cut Curves
Zwei Kurven können mittels „Cut Curves“ an ihrem Schnittpunkt getrennt werden. Es entstehen vier Kurven.

Duplicate Surface Curves
Selektiert man ein Isoparm auf einem Nurbsobjekt, so lässt sich dieses Isoparm extrahieren als eigene Kurve mit dem 
„Duplicate Surface Curves“. (Siehe „Isoparm“ Seite 27)

Bézier Curves
Man kann auch Bezier Curves ähnlich wie z.B. das Pen Tool in Adobe Illustrator. Eine detaillierte Anleitung zum 
Tool findet sich in den Tool Settings (Window > Setting and Preferences > Tool Settings).

Die Kurven wurden mit Maya 2011 eingeführt. Sie können in den meisten Fällen genauso verwendet werden wie 
normale Curve-Objekte. Wenn Fehler auftreten kann man mit Edit > Convert > Bezier to Nurbs die Kurve zu einer 
Nurbs-Curve umwandeln und gegebenenfalls manuell anpassen.

Attach Curves mit Blend

Attach Curves mit Connect
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Nurbs Primitive erzeugen
Man erzeugt Nurbs Primitive mit Create > Nurbs Primitives. Da Nurbsobjekte keine exakten 90° Winkel erzeugen 
können, besteht ein Würfel eigentlich aus sechs unabhänigen gruppierten Ebenen. Das gleiche gilt auch für einen 
Zylinder oder Kegel mit Deckel deswegen wird gleich eine Gruppe für die Geometrie mit erzeugt.

Surface Components

Isoparm
Isoparametric curves (auch Isoparm genannt) sind Linien die entlang der Oberfläche laufen und die Geometrie defi-
nieren. Sie haben ein eigenes Koordinaten System mit den Achsen UV. 

Isoparms können nicht direkt manipuliert werden. Hat mein ein Isoparm selektiert fügt man es der Geometrie hinzu 
mittels Edit Nurbs > Insert Isoparm.  So werden der Geometrie mehrere CV-Points hinzufügt die man manipulieren 
kann um die Geometrie genauer zu definieren.

Control Vertex
Ein Control Vertex (CV) kontrolliert alle darunterliegenden Isoparms. Da CVs nur Punkte im Raum sind, kann nur 
ihre Position im Raum verändert werden. Selektiert man mehrere CVs so wird in Relation zu dem Pivot Point skaliert 
und rotiert. 

Hull
Die Hull Ansicht verbindet alle CVs eines Isoparms und lässt so das darunterliegende Isoparm manipulieren. Man 
kann sie skalieren, rotieren und bewegen.

Surface Tools
All diese Tools findet man im Modul „Surfaces“ unter Surfaces. Für eine bessere Übersicht in den Beispielbildern 
wurden die Objekte verschoben, um die Ursprungskurven sichtbar zu machen.

Revolve Tool

Ein selektiertes Isoparm (gelb) Ein selektierter CV (gelb) - der Einfluss des 
Cvs auf das Objekt ist weiß dargestellt

Eine selektierte Hull dessen CVs sind gelb  
dargestellt

Ein Revolve Objekt.
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Das Revolve Tool rotiert eine Kurve um eine Achse um einen Schwingkörper zu erzeugen.

Um das Revolve Tool zu verwenden muss man eine Kurve ausgewählt haben. Die Kurve wird dann um eine Achse 
(Default y-Achse des Pivot Points) geschwungen. An den Editpoints der Kurve werden Isoparms erzeugt. Durch die 
Anzahl der „Sections“ wird die Zahl der Isoparms in U-Richtung festgelegt.

Standartmäßig wird ein Schwingkörper um die gesamte Achse also von 0°-360° erzeugt.  Das lässt sich durch Ändern 
der Werte in  „Start Sweep“ (Startwinkel) und „End Sweep“ (Endwinkel).

Loft

Ein Loft erzeugt eine Fläche zwischen mindestens zwei Kurven. Sollen mehrere Kurven verwendet werden, ist die 
Reihenfolge in der sie selektiert werden von Bedeutung.

Man sollte darauf achten, dass die verwendeten Kurven über die gleiche Anzahl von Edit Points verfügen. Beim er-
stellen der Geometrie wird jeder Edit Point verbunden mit dem Edit Point der anderen Kurve. 

Ansonsten erhält man eine seltsame Verteilung von Isoparms auf dem neuen Objekt. Um die Anzahl der Edit Points 
anzugleichen, ist  Edit Curves > Insert Knot sehr hilfreich. (Siehe „Curve Point“ Seite 26)

Planar

Ein Planar ist eine Fläche, die definiert wird durch in einer Ebene liegenden geschlossene Kurve (z.B. Kreise, Recht-
ecke). Es ist auch möglich mehrere Kurven zu verwenden. Liegt eine Kurve innerhalb einer anderen Kurve, so wird 
der innere Kreis ausgeschnitten.   

Ein Planar ist immer ein rechteckiges Nurbs Planar. Wenn man z.B. ein kreisförmiges Planar erzeugt, so ist das nur 
optisch ein Kreis. Man hat keine CV-Points um den Rand zu manipulieren. Der Kreis wurde auf die Fläche projeziert 

Loft mit zwei Kurven

Planar: Es wird aus den 3 Kurven ein einziges Planar Objekt erzeugt
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und dann mit dem Trim-Tool ausgeschnitten. Daher ist der Rand eines Planars kein Isoparm sondern eine Trim Edge.

Man sollte es vermeiden Planar Objekte zu verwenden. In manchen Situationen bieten sie aber eine schnellere und 
einfachere Lösung. Alternativ können unter Umständen Boundaries verwendet werden.

Extrude 
Ein NURBS Extrude hat drei Modi:

-- Tube: Erzeugt eine Fläche indem es eine Profil-Kurve entlang einer Pfad-Kurve gezogen wird. Die Reihen-
folge wie man die Curves selektiert definiert dessen Aufgabe. 

-- Flat: Erzeugt eine Fläche wie im Tube Modus jedoch nur in einer Ebene 

-- Distance: Erzeugt eine Fläche mit nur einer Profil-Kurve und einer gegebenen Distanz

Birail

Das Birail 1 Tool, Birail 2 Tool und Birail 3+ Tool erzeugen Flächen indem mindestens eine Profil-Kurve entlang zwei 
Schienen entlanggezogen werden. Der Abstand zwischen den Schienen definiert wie die jeweilige Kurve an diesem 
Punkt skaliert wird.

Benutzt man mehrere Profilkurven wird die Profilkurve zusätzlich gemorphed von Profilkurve zu Profilkurve. Man 
sollte daher darauf achten das alle Profil kurven die gleiche Anzahl von EP-Points haben.

Wichtig: Die Endpunkte der Profilkurven müssen auf den Schienen liegen. Dies stellt man sicher indem man Die 
Anfangs und End-EP-Points per Curve-Snapping an den Schienen festmacht.

Tube Flat Distance

Birail 1 Object
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Boundary

Ein Boundary besteht aus 3 oder 4 Kurven und interpretiert eine Fläche zwischen diesen Kurven. Um das beste Er-
gebnis zu bekommen sollte man die Endpunkte der Kurven miteinander verbinden und sie sollten die gleiche Anzahl 
von EP-Points haben.

Bevel/Bevel Plus

Erzeugt eine abgeschrägte Fläche auf Basis der Kurve. 

Insbesondere Text lässt sich so einfach in eine Fläche umwandeln. In neueren Versionen von Maya ist das Bevel Plus 
tool integriert in dem Text Tool.

Boundary

Bevel Object
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Martini Glas
Betrachtet man einen Martini, so besteht er aus einem Glas, einer Flüssigkeit, einem Stäbchen und einer Olive. Das 
Glas ist ein Schwingkörper,   es muss also zunächst eine Kurve erstellt und um die y-Achse rotiert werden.Als Flüssig-
keit wird vorerst ein kegelförmiges Objekt verwendet, das genau das Innere des Glases ausfüllt.Das Stäbchen ist ein 
einfacher Zylinder und die Olive ist eine zu einem Oval deformierte Kugel 

Das Glas
1.	 Kurz die LEERTASTE drücken um aus der Single 

View in die Four View wechseln. 

2.	 Die Side View anklicken und kurz die LEERTA-
STE drücken um die Side View als Single View zu 
erhalten.

3.	 Das CV-Curve Tool selektieren und die Taste X 
(Grid-Snapping)  gedrückt haltend auf den Ur-
sprung klicken. Dies ist notwendig damit im spä-
teren Schwingkörper kein Loch entsteht. Danach 
kann man die Taste loslassen und die restlichen 
Punkte setzen um eine Querschnittslinie eines hal-
ben Martiniglases zu zeichnen (siehe Bild). Den 
letzten Punkt setzt man wieder mit gedrückt gehal-
tenem X auf die Y-Achse und drückt ENTER um 
die Kurve fertig zu stellen.

Anmerkung:  Die Tastaturkürzel - X (Grid), C (Curve), V (Point) wählen das Snapping nicht permanent aus. Wenn 
man das Snapping mit der Tastatur benutzen möchte, so muss man die Taste gedrückt halten. Alternativ kann man 
Snapping  dauerhaft auswählen indem man es im Menü mit der Maus anklickt.

4.	 Die Kurve im Object Mode (RMB auf das Objekt > Object Mode) selektierten und Surfaces > Revolve

Die CV-Punkte des halben Martiniglas-Querschnittes
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5.	 Man kann nun mit der Leertaste zurück in die Four View.

6.	 Das Glas kann man mit dem Move Tool auf der Z-Achse bewegen, 
damit die Kurve sichtbar wird.

7.	 Drückt man die Taste 5 so erscheint das Glas im Shaded modus. Mit 
der Taste 4 kommt man wieder in den Wireframe Modus.

8.	 Man kann nun die Kurve auswählen und im Control Vertex Mode 
(RMB auf das Objekt > Control Vertex) mit dem Move Tool (W) 
die Punkte verändern; das Glas verändert sich simultan mit, da es die 
Input-Curve ist.

Anmerkung: Wenn man die Kurve auswählt, so erscheint das Glas lila. Da-
mit wird angezeigt, dass die Kurve ein Konstruktions-Input für den Revolve-
Körper ist. Verändert man die Kurve, so wird das Objekt simultan mitver-
ändert.

9.	 Die Curve ist nun überflüssig. Man selektiert sie im Object Mode 
und mit ENTF löscht man sie.

10.	 Das Glas selektiert man und im Channel Box macht man einen Dop-
pelklick auf „revolvedSurface1“ und benennt es “MartiniGlas”

11.	 Im ChannelBox setzt man TranslateZ auf 0

12.	 Speichern unter martini_glas.01.ma (Maya ASCII)

Flüssigkeit im Glas
1.	 Im Isoparm Modus (RMB auf das Objekt > Isoparms) selektiert man 

mit dem Selection Tool (Q) ein Isoparm aus welches den halben 
Querschnitt des Glases darstellt. (Es sollte eine gelbe Linie, oder gelb 
gestrichelte Linie erscheinen)

2.	 Mit Edit Curves > Duplicate Surface Curves erzeugt man eine Kur-
ve aus dem Isoparm.

3.	 Man dupliziert ein weiteres Isoparm vom „MartiniGlas“ welches die 
Höhe der Flüssigkeit im Glas definiert. Man muss darauf achten, dass 
man ein Isoparm auf dem inneren Rand des Glases auswählt. 

4.	 Mit dem Selection Tool (Q) zieht man mit LMB ein Rechteck um 
“MartiniGlas” und beide Kurven. Die Kurven und das “MartiniGlas” 
sind ausgewählt.

5.	 Mit SHIFT gedrückt haltend klickt man auf das “MartiniGlas” um 
es zu deselektieren. Man hat nun beide Kurven ausgewählt.

6.	 Edit Curves > Cut Curves q - Hier entfernt man das Häkchen bei 
„Keep Originals“ und klickt anschließend Apply. Als Resultat hat 
man drei Kurven. 

7.	 Man selektiert die Profilkurve auf der innenseite des Glases und 
macht ein Surfaces > Revolve (siehe Bild)

8.	 Man selektiert die obere kreisförmige Linie und macht ein Surfaces 
> Planar

9.	 Man verändert die Selection Mask indem man „Surfaces“ deselektiert 
(siehe Bild). Mit dem Selection Tool kann man ein Rechteck um das 
Martini Glas ziehen. (Nur Kurven sind selektiert.) 

Grid-Snapping aktiviert

Schritt 4: Die Kurve selektiert mit der er-
zeugten Revolve-Surface

Schritt 2:Äußeres Isoparm selektiert

Schritt 3: Inneres Isoparm selektiert

Schritt 7: RevolveSchritt 9: Selection Mask
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10.	 Man kann nun alle Kurven löschen (ENTF).

11.	 Die Selection Mask wieder zurücksetzen (Surfaces aktivieren).

12.	 Ähnlich wie Schritt 5 selektiert man das Planar und das Revolve Ob-
jekt. Mit STRG-G gruppiert man sie und nennt sie “Liquid”.

13.	 Im Layer Editor (unter dem ChannelBox) klickt man auf das Icon 
„New Layer with selected Objects“.

14.	 Mit Doppelklick auf der neuen Ebene kann man sie auf „Glas“ um-
benennen.

15.	 Man selektiert das „MartiniGlas“ und mit RMB auf der Ebene wählt 
man „Add Selected Objects“

16.	 Den “Display type” der Ebene ändert man auf “template” , durch 
klicken auf das mittlere Rechteck neben dem Ebenennamen. 

17.	 Speichern martini_glas.02.ma

Anmerkung:  Wenn sich Objekte auf einer Layer mit einem Displaytype 
„Template“ oder „Reference“ befinden, so sieht man die Objekte, kann sie 
jedoch nicht manipulieren. Man muss erst den Displaytype wieder auf Nor-
mal (leeres mittleres Rechteck) setzen um die Objekte wieder verändern zu 
können.

Die Olive
1.	 Create > Nurbs Primitives > Create Nurbs Sphere

2.	 Mit RMB auf dem Objekt wechselt man in den ControlVertex Modus 
bzw. Hull Modus.

3.	 Mit dem Move (W) und Scale Tool (R) manipuliert man solange die 
Controlvertex Punkte bis sie einer Olive ähnelt.

4.	 Das Objekt “Olive” nennen.

Der Zahnstocher
1.	 Create > Nurbs Primitives > Cylinder

2.	 Mit dem Scale-Tool (R) den Zylinder so manipulieren, dass er die 
Olive aufsticht.

3.	 Den Zylinder auf “Zahnstocher” umbenennen.

4.	 Die “Olive” und “Zahnstocher” gruppieren und im Martiniglas posi-
tionieren. (martini_glas.03.mb)

Rendervorbereitungen
1.	 Man ändert den Displaytype der Ebene “Glas” auf Normal

2.	 Selektiert alle Objekte und gruppiert sie (STRG-G) und benennt die 
Gruppe „MartiniGlas“.

3.	 Nun skaliert man die Gruppe, sodass sie eine Höhe von 3 hat.  
(martini_glas.04.mb)

(Fortsetzung “Mental Ray: Martini Glas” Seite 79)

Schritt 8 - Planar

Layers Controls - mit RMB auf den Ebe-
nennamen öffnet alle Layer- Funktionen

Olive mit Zahnstocher
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Übungsaufgaben
1.	 Eine Flasche Wein mit Weinglas modellieren.

2.	 Einen Chemie Baukasten, Reagenzgläser, Messbecher, Mörser mit Schale modellieren.

Anmerkung: Mit dem Edit Curves > Offset Curves lässt sich die Kurve relativ zur Original Kurve  duplizieren und 
skalieren. So muss man nur die Äußere Kurve zeichnen und kann die Innere davon ableiten. (Und mit einer dritten 
Kurve und Attach Curves verbinden.)
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Spielwürfel
Ein Würfel hat stark abgerundete Ecken und somit einen Kreis als Grund-
form jeder Seite. Die Punkte sind meistens in die Flächen gestanzt. Betrachtet 
man den Würfel genauer erkennt man die Distribution der Punkte, addiert 
man die Punkte der zugewandten Seite mit der abgewandten Seite ergibt sich 
immer 7.

Grundform
1.	 Create>Nurbs Primitves> Circle (Radius 3)

2.	 STRG-D um den Kreis zu duplizieren.

3.	 Das Duplikat TranslateY = 6

4.	 Beide Kreise auswählen und gruppieren (STRG-G)

5.	 Modify> Center Pivot

6.	 Die Gruppe duplizieren und RotateX = 90

7.	 Die Gruppe nochmals duplizieren und RotateY = 90

8.	 Alle Curves auswählen und Edit Curves > Cut-Curve (ggf. den 
Schritt wiederholen, jeder Kreis sollte geviertelt sein)

9.	 Für jede Seite des Würfels selektiert man alle 4 Kreissegmente und 
macht Surfaces> Boundary (6xWiederholen)

Anmerkung:  Um das letzte Tool nochmal zu verwenden drückt man G 
(Repeat last tool)

10.	 Für jede Ecke wählt man die drei anliegenden Curves aus und wählt 
Surfaces > Birail 1 Tool (8xWiederholen)

Schritt 7: Dupilizerte Gruppen

Schritt 8: 2x Cut Curves 

Schritt 3: Duplizierte Circles
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11.	 Alles auswählen und  die History löschen ALT-SHIFT-D (Edit > 
Delete by Type > History)

Punkte
1.	 Eine Nurbs Sphere erstellen mit Radius 0.5, Translate(X,Y,Z) (0,6,1).

2.	 Die Sphere 5x duplizieren und ensprechend dem Bild anordnen.

3.	 Die 6 Spheres gruppieren (STRG-G).

4.	 Den Pivot Point um TranslateY=3 setzen. Hierfür wählt man das 
Translate Tool (W) und hält dann D(Show Pivot Point Manipulator) 
und X (Grid Snapping) gedrückt und manipuliert den Pivot Point in 
der Side View.

5.	 Die Gruppe 5x Duplizieren und auf die entsprechende Seiten rotie-
ren.

6.	 Die unnötigen Spheres löschen. Bei einem Würfel ist das Ergebnis der 
gegenüberliegenden Seiten immer 7.

7.	 Die Spheres mit dem Translate Tool (W) positionieren.

8.	 Alle Spheres einer Seite und die dazugehörige Boundary selektieren. 
Dann Edit Nurbs > Intersect Surfaces.

9.	 Mit dem Trim Tool klickt man auf die Bondary. Die Boundary wird 
nun gestrichelt weiß angezeigt, man klickt nochmal auf die Teile die 
man behalten will (diese werden dann mit durchgezogenen weißen 
Linien angezeigt) und drückt anschließend ENTER.

10.	 Man trimmt jetzt auch alle Spheres, sodass nur noch die Hälfte der 
Kugeln im Würfel zu sehen ist. (Das Panel Auf Wireframe setzen mit 
4 um einfacher die Halbkugel zu selektieren)

11.	 Den Trim Vorgang wiederholt man für jede Seite. Anschließend alles 
auswählen und Delete History ALT-SHIFT-D.

Schritt 9: Boundary auf den Seiten Schritt 10: Birails für die Ecken

Schritt 2: Anordnung der Spheres

Schritt 6: Angeordnete Spheres

Schritt 10: Birails für die Ecken

Schritt 10: Birails für die Ecken
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Bauhaus Stuhl
Bauhaus ist eine Kunstschule die insbesondere im Design und Architektur 
markante Designs entwickelt hat. Dieser Stuhl ist angelehnt an einen solchen 
Design Stuhl. Er besteht aus einem einzigen Chrom Rohr, einem Sitz und 
einer Lehne.

Das Stuhlgerüst
1.	 Zu der Perspektive „Side“ wechseln (LEERTASTE kurz drücken, 

Side Perspektive anklicken, LEERTASTE kurz drücken)

2.	 Einen Kreis (Erstes Icon auf der Curves-Shelf anklicken oder Cre-
ate> Nurbs Primitives > NURBS Circle) erstellen. Diese Werte Ma-
nuell im Channel Box eingeben: Translate x=0, y = 5, z = -10, Ro-
tateY= -90, RotateZ = 90 

3.	 Mit dem Kreis noch ausgewählt im Channel Box das Input -Menü 
aufklappen und bei makeNurbCircle den Radius auf 5 und den 
Sweep auf 180 setzen.

4.	 Man möchte jetzt für den Untergrund des Stuhls eine Linie vom Ur-
sprung des Koordinatensystems zum unteren Ende der Kurve zeich-
nen. Hierfür wählt man das EP-Curve Tool aus und mit X-TASTE 
(Grid Snapping) gedrückt auf den Ursprung des Koordinaten-
systems den ersten Punkt klicken. Danach mit nur der C-TASTE 
(Curve Snapping) gedrückt den zweiten Punkt an einer beliebigen 
Stelle auf den Kreis mit der linken Maustaste gedrückt haltend setzen 
(Click-Drag). Die Maus bewegen, sodass der Punkt an das untere 
Ende des Halbkreises gelangt (Die Maus richtung Ursprung bewe-
gen). Danach wird die Maustaste losgelassen. Mit ENTER beendet 
man das EP-Curve Tool.

5.	 Für die Lehne: Eine weitere EP-Curve anlegen mit dem ersten Punkt 

Schritt 3: Ein seitlicher Halbkreis

Schritt 5: Die vollständige Kurve
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am oberen Ende des Halbkreises den ersten Punkt mit Hilfe des Curve Snappings (Taste C-gedrückt halten 
mit Click-Drag) setzen. Den weiteren Punkte wie im Bild setzen.

6.	 Die Untergrund-Curve auswählen und mit dem Halbkreis auswählen. (SHIFT gedrückt halten um mehrere 
Objekte auszuwählen.

7.	 Edit Curves > Attach Curves q Die Einstellungen auf Connect setzen und das Häckchen bei Keep Origi-
nals entfernen und anschließend auf „Attach“ klicken. Die beiden Kurven sind nun miteinaner verbunden. 
Man muss immer mindestens zwei Kurven ausgewählt haben um das Attach Curves Tool zu verwenden.

Anmerkung: Ändert man die erweiterten Einstellungen bei einem Tool, so bleiben diese Einstellungen als Standar-
teinstellungen erhalten. Man kann jederzeit die Originaleinstellungen wiederherstellen, wenn man in dem jeweiligen 
Dialog Edit > Reset Tool auswählt.

Schritt 10: Die Zwei Kurven 

Schritt 12: Die Zwei Ansichten in der man Abwechselnd arbeitet

8.	 Die resultierende Kurve mit der Lehne auch mit Edit Curves > At-
tach Curves verbinden. Nun hat man eine einzelne durchgehende 
Kurve.

9.	 In die „persp“- Ansicht wechseln. 

10.	 Die Kurve nun mit STRG-D (Edit > Duplicate) duplizieren und an-
schließend auf der x-Achse verschieben (TranslateX = 12) 

Anmerkung: Wenn man ein Objekt dupliziert liegt das Duplikat genau über 
dem Original.  Man muss es erst verschieben um zwei Objekte zu sehen.

11.	 Zu der Ansicht Four View wechseln.

12.	 Mit dem Create > CV-Curve Tool in der Perspektive „persp“ und 
„Curve Snapping“ den ersten Punkt an das untere Ende der ersten 
Kurve setzen. Danach in der Perspektive „top“, die restlichen Kur-
venpunkte setzen. Den letzten Punkt in der Perspektive „persp“mit 
Curve Snapping an die zweite Curve setzen (wie im Bild). Mit Enter 
die Kurve-Tool beenden.

13.	 Den vorhergehenden Schritt wiederholen für das obere Ende der 
Kurven.

14.	 Alle Kurven mit Attach Curves verbinden (Stuhlkurve) 
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Anmerkung: Immer zwei Kurven auf einmal miteinander verbinden. Falls bei dem Verbinden der letzten Kurve ein 

Fehler auftritt, so muss man die Richtung einer Kurve umkehren mit Edit Curves -> Reverse Direction. 

15.	 In der Perspektive „persp“ einen weiteren Kreis (NURBS Circle) erstellen, RotationX = 90, Radius 0.5)

16.	 Den Kreis und die Stuhlkurve auswählen

17.	 Surfaces > Extrude q

18.	 Alle Elemente sollte man auf eine eigene Ebene setzen und anschließend die Ebene auf Template setzen.

19.	 Speichern als bauhaus_stuhl.01.mb

Der Sitz & Lehne
1.	 Einen weiteren NURBS Circle im Ursprung erstellen in der Perspektive persp, (RotationX = 90, Radius 0.8)

2.	 Die mittleren beiden EditPoints auswählen Edit Curves > Detach Curves.

3.	 Wechsel zu der Front View die rechte Hälfte des Kreises verschiebt man auf der x-Achse TranslateX = 12 

4.	 Mit dem Create > EP- Curve Tool  verbindet man die beiden Kreise und anschließend wieder mit dem Attach 
Curves zusammensetzen.

5.	 Mit der Kurve ausgewählt Edit > Delete by Type > Delete History 
(ALT-SHIFT-D)

6.	 Die Ebene mit dem Stuhlgestell wieder sichtbar machen und die Kur-
ve auf Höhe der Sitzfläche verschieben wie im Bild (am einfachsten ist 
dies mögich in der side view)

7.	 Die Kurve Duplizieren (wie im Bild) und mit beiden Kurven ausge-
wählt ein Loft (Surfaces-> Loft) erstellen.

8.	 Die Sitzfläche nun duplizieren, verschieben, rotieren, skalieren, so-
dass sie zu der Lehne passt. 

Anmerkung: Der Pivot Point wird bei einem Loft immer auf den Ursprung gesetzt, um einfacher zu skalieren etc. 
kann man den Pivot Point auch wieder in das Zentrum der Fläche setzen mit Modify > Center Pivot Point.

9.	 Alle Elemente auswählen und STRG-G (Edit > Group) und die Gruppe umbennen auf “Chair”.

10.	 Man kann nun alle Kurven löschen, 

11.	 Speichern als bauhaus_stuhl.02.ma

Schritt 4: Die resultierende Kurve
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Vorbereiten auf das Rendern
Da wir den Stuhl nicht in dieser Szene Datei ausrendern werden exportieren wir die Stuhl-Geometrie.

1.	 Die Gruppe „Chair“ auswählen (Eine Fläche anklicken und die Pfeiltaste nach oben drücken, oder im Out-
liner) 

2.	 Die History löschen (ALT-SHIFT-D)

3.	 Modfiy > Center Pivot

4.	 Die Gruppe zunächst mit Grid Snapping an den Ursprung setzen.

5.	 In der Side View den Stuhl auf der Y-Achse bewegen damit der Stuhl auf der XZ-Ebene steht.

6.	 Überprüfen das die Vorderseite des Stuhls in Z-Richtung zeigt

7.	 Modify> Freeze Transformations

8.	 Immer noch mit dem Stuhl ausgewählt File > Export Selection bauhaus_stuhl.export.ma
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Anmerkungen zu NURBS

Tesselation
Für den Rendervorgang wird das NURBS Objekt in ein Polygon Objekt 
umgewandelt. Diesen Prozess nennt man Tesselation. In den meisten Fällen 
muss man sich keine Gedanken darüber machen. In seltenen Ausnahmen 
kann es passieren, dass ein Objekt sehr „eckig“ statt rund gerendert wird, 
dann muss man die Tesselation Attribute anpassen. (Diese Findet man im 
Shape Node des Objekts)

Man kann die Tesselation Attribute Automatisch anpassen lassen. Hierzu 
selektiert man das Objekt und im Modul „Rendering“ > Render> Set Nurbs 
Tesselation

Man kann auch Manuell im Attribute Editor im Shape Node unter Tessel-
ation einstellen. Hierzu wählt man „Display Render Tesselation“ und dann 
manipuliert man die Werte der Tesselation. Je nach dem ob man „Enable 
Advanced Tesselation“ aktiviert hat muss man die Simple Tesselation oder die 
Advanced Tesselation anpassen. Durch manipulieren der Regler sieht man 
sofort was die Regler machen und ob das Resultat besser oder schlechter wird. 
Am Ende sollte man wieder „Display render Tesselation“ ausschalten.

Anmerkung: Man sollte die Regler nicht unnötig hoch setzen d.h. man sollte 
versuchen mit möglichst kleinen Werten das Problem beheben. Ansonsten 
hat man beim Rendern eine sehr ineffiziente Szene.

Vorher: Eckige Kante

Vorher: Simple Tesselation

Nacher: Advanced Tesselation

Nacher: Runde Kante

Tessalation Attribute
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Polygon - Grundlagen
Definition
Ein Polygon ist eine Figur in einer Ebene aufgebaut durch eine endliche Anzahl von geraden Linien Man braucht ein 
minimum 3 Linien bzw. 3 Punkte um eine Ebene aufzuspannen bzw. um ein Polygon Objekt zu erzeugen.

Es gibt drei verschiedene Arten um eine Polygon Geometrie zu erzeugen:

•	 Man setzt Vertexpunkte in den Raum, die ein Polygon ergeben. 

•	 Man manipuliert ein Primitiv (Sphere, Cube, Cylinder, Cone, etc.) solange bis es die gewünschte Form hat. 

•	 Man zeichnet Kurven in den Raum und lässt eine Fläche anhand der Kurven erzeugen. 

Üblicherweise fängt man mit einem Poly-Cube Primitiv an und manipuliert ihn, daher der Begriff „Box-Modelling“.

Components

Vertex 
Ein Vertex ist ein Punkt im Raum. Man kann nur eine Translation auf sie anwenden. Ein Vertex sollte nur in Ver-
bindung mit einer Edge exisiteren.

Edge
Eine Edge ist durch zwei Vertex Punkte definiert. Eine einzelne Edge ist eine fehlerhafte Geometrie und sollte nur in 
Verbindung mit einem Face existieren.

Face
Eine Face ist definiert durch umliegende Edges. Für eine optimale Geometrie sollten alle Faces eines Objekts entwe-
der Triangles (3 Edges) oder Quads (4 Edges) haben.

Multi
Ermöglicht das gleichzeitige selektieren von Vertex, Edge und Face-Componenten.

Anmerkung: Mit display Face Centers wird ein Punkt in der Mitte von Faces angezeigt. Dies erleichtert Faces zu 
selektieren. Unter Window > Setting & Preferences > Preferences geht man in der linken Leiste auf Selection und 
wählt dann unter Polygon Selection - Select Faces with Center 

Polygon Tools

Extrude

Split Polygon Tool /Interactive Split Tool

Edge Loop Tool

obere vier Vertex Punkte selektiert obere vier Edges selektiert obere Face selektiert
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Boolean Operations
Unter Mesh > Booleans findet man die drei Typen von Boolschen Operationen die man auf 3D Objekte anwenden 
kann.

Union verschmelzt zwei Objekte. Difference entfernt das zweite Objekt aus dem ersten Objekt. Intersection erzeugt 
eine Schnittmenge von beiden Objekten.

In manchen Fällen kann die Boolesche Operation fehlschlagen. In den meisten Fällen liegt es daran das die Norma-
len der Faces in verschiedene Richtungen zeigen. Mit Normals > Conform lässt sich das Problem in vielen Fällen 
beheben.

Eine andere Variante das Problem ist, die betreffenden Faces von den Objekten mit Extract als eigene Objekte zu 
erstellen und dann die Boolesche Operation auszuführen. Anschließend fügt man die Extrudierten Faces mit Mesh 
> Combine, Edit Mesh> Merge bzw. Mesh > Cleanup wieder zusammen. 

Anmerkung: Boolesche Operatoren erzeugen schnell neue interessante Formen, aber die resultierende Geometrie  
besteht meistens nicht mehr nur aus Quads/Triangles und muss unter Umständen nachträglich korrigiert werden.

Tool Settings 
Man kann für die Move, Rotate und Scale Tools noch weitere Einstellungen vornehmen. Hierfür muss man die „Tool 
Settings“ (Window > Settings and Preferences > Tool Settings) öffnen. 

Reflection
Ermöglicht symmetrisches arbeiten mit symmetrischen Objekten. Aktiviert man Reflection so sollte man auch die 
„Reflection Axis“ bestimmen. 

Wurde das Objekt nur auf einer Seite verändert kann es passieren, dass nicht die richtigen Polygone auf der gegen-
überliegenden Seite ausgewählt werden. Es hilft wenn man in den Tool Settings „Reflection Space“ auf World setzt.

Wenn man ein symmetrisches Objekt erstellen möchte sollte man die Hälfte des Objekts löschen (ggf. mit Edge 
Loops oder dem Split-Polygon Tool die Hälfte genau definieren). Im Objekt-Modus Mesh > Mirror Geometryq  
und die entsprechende Achse auswählen.

Soft Selection
Der „Soft Selection“-Modus ermöglicht umliegende Objekte/Componenten 
zu selektieren. Mit dem Keyboard Shortcut (B) aktiviert und deaktiviert man 
die Soft Selection.

-- Falloff Mode: bestimmt welche Objekte betroffen sind: Die Modi 
Volume und Surface sind beschränkt auf das selektierte Objekts. Die 
Modi Global und Object beeinflussen multiple Objekte.  

-- Falloff-Radius: definiert die selektierten Objekte durch die Selekti-
on und dem maximalen Abstand definiert durch den „Falloff-Radius“. 

-- Falloff Curve: bestimmt wie stark die Objekte beeinflusst werden von der Selektion. Ändert man die Form 
der Kurve kann die Selektion angepasst werden.

-- Falloff Color: beinflusst nur die Darstellung im Viewport

IntersectionDifferenceUnion

Soft Selection
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Weitere Eigenschaften von Polygon Objekten

Unnatürlich scharfe Kanten

Cube ohne Bevel Cube mit Bevel (Offset= 0.01) Cube mit Bevel (Offset = 0.2, Segments=5)

Rendert man Polygone aus haben sie meist sehr scharfe Kanten z.B. die eines Würfels. Solche extrem kantigen Ob-
jekte exisitieren in der Natur nicht. Kanten in der Natur sind leicht abgerundet, z.B. durch Abnutzung. Um diesen 
typischen 3D-Look zu vermeiden, muss man an Kanten einen Bevel anwenden. Hierfür wählt man die Edges aus die 
man abstumpfen möchte und geht auf Edit Mesh > Bevel. Bereits ein Offset-Wert von 0.01 ist ausreichend um den 
typischen 3D-Look zu vermeiden. Optional lassen sich die Kanten abrunden indem man die Anzahl der Segments 
erhöht.

Normalen
Normalen bestimmen welche Seite außen und welche Seite innen sich befindet. Bei einer korrekten Objekt Zeigen 
alle Normalen Konform in die gleiche Richtung. Um die Normalen anzuzeigen geht man auf Display > Polygons > 
Face Normals. Es werden mit grünen Strichen die Richtung der Oberfläche angezeigt.  Eine Alternative Möglichkeit 
ist im Panel-Menü unter Lighting > Two Sided Shading zu deaktiveren. Drückt man 5, wird nun die Innenseite Eines 
Objektes schwarz (unbeleuchtet) dargestellt. 

Es passiert leicht durch z.B. skalieren, dass die Normalen nicht mehr richtig sind. Mit Normals > Conform werden 
die Faces korrigiert. Die Mehrheit der Faces bestimmt die Richtung des Objekts. Unter Umständen muss man per 
Hand die Normalen richtig setzen. Mit Normals > Reverse lassen sich einzelne Faces korrigieren oder auch das 
gesamte Objekt. 

Im Beispiel ist der obere Teil des linken Diamanten fehlerhaft, dies erkennt man in der Normals Anzeige, da die 
grünen Striche nicht nach außen gehen. Einfacher erkennt man die Fehler wenn Two Sided Shading deaktiviert ist, 
da sieht man sofort der obere Teil ist einfach schwarz.

Mit Normals > Conform, lässt sich das Problem lösen, jedoch sind die Seiten vertauscht. Also selektiert man das 
Objekt und macht ein Normals > Reverse. Dann ist das Objekt vollständig korrigiert.

Normals anzeige Two Sided Shading Deaktviert Normals Conform

Anmerkung: Bei NURBS tritt manchmal das gleiche Problem auf. Man kann dies korrigieren mit Edit Nurbs > 
Reverse Surface Direction.

Surface Tools
Alle Nurbs Tools im Menüpunkt „Surfaces“ (Siehe „Surface Tools“ Seite 27) um aus Kurven eine Fläche zu erzeugen 
kann man verwenden um Polygon Objekte zu erzeugen. Hierfür muss man nur in dem jeweiligen Tool in den Eigen-
schaften unter „Output Geometry:“  Polygon setzen. Das Dialogfenster erweitert sich und man kann die Tesselation 
Eigenschaften bestimmen. Man erzielt gute Ergebnisse wenn man Tesselation method auf „Control Points“ setzt. 
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Die resultierende Geometrie wird im Vergleich zu einer Nurbs Geometrie sehr eckig wirken. Mit der Smooth Mesh 
Preview oder einem Mesh > Smooth.
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Kleines Flugzeug
1.	 Zu der Perspektive Four View wechseln

2.	 Im Side View Panel das als Backdrop das Bild polyAirplane als Hin-
tergrund setzen (Häckchen bei view in all planes ausschalten)

3.	 Einen Poly-Cube (Create > Poly Primitives > Poly Cube im Ursprung 
erstellen mit der Eigenschaft (Input Menu) Width 6, Height 6, Depht 
12

4.	 Mit RMB den SelektionsModus auf Faces setzen.

5.	 In der Perspektive presp das hintere Ende des Cubes auswählen.

6.	 Mit dem Extrude Face tool zieht man nun die Face

Anmerkung: Das Extrude Tool macht ein neues Face und verbindet sie mit 
den ursprünglichen Polygonen. Der Manipulator vom Extrude Face kombi-
niert das Transform, Skalier und Rotationstool - um zwischen den Modi zu 
wechseln klickt man einmal auf das jeweilige Tool und die jeweiligen Achsen 
werden dann deutlich(Pfeile für Move, Cubes für Skalieren, Kreis für Rotate)  
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Diamond Ring

Der Diamant
1.	 Create > Polygon Primitves > Cylinder (Radius 1)

2.	 In der Channelbox ändert man in den Inputs (“polyCylinder1”) die 
Subdivision Axis zu 8.

3.	 Man wechselt in den Faces Modus (RMB auf den Zylinder > Faces) 
und löscht alle Faces unterhalb der achteckigen Fläche.

4.	 Nun wechselt man in den Edges Modus (RMB auf den Zylinder > 
Edges) und löscht alle Edges innerhalb der Fläche, sodass man ein 
Oktagon erhält.

5.	 Unter Edit Mesh > Keep Polygons together entfernt man das Häck-
chen.

6.	 Weiterhin im Edges Modus selektiert man alle acht Edges indem 
man auf die einzelnen Edges klickt und dabei SHIFT gedrückt hält.

7.	 Edit Mesh > Extrude - Mit dem grünen Pfeil(z-Achse) des Extrude 
Manipulators zieht man eine neue Fläche aus dem Oktagon und be-
wegt sie anschließend mit dem blauen Pfeil ein wenig nach unten. 
(LocalTranslateZ -0.35, LocalTranslateY -0.5) 

8.	 In der ChannelBox im Input “polyExtrudeEdge” die Eigenschaft Lo-
calScaleX auf 0 setzen - Dies lässt die Fläche spitz zulaufen. Jedoch 
befinden sich jetzt 2 Polygone an der gleichen Position, das ist also 
eine fehlerhafe Geometrie.

9.	 Um den Fehler in der Geometrie zu beheben selektiert man das ge-
samte Objekt und benutzt Edit Mesh > Merge.

Schritt 2: Zylinder mit 8 Seiten

Schritt 7: Extrude

Schritt 4: Ein Oktagon
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Anmerkung: Wenn man das Extrude Tool verwendet, kann man die Para-
meter in der Channelbox/Attribute Editor manuell setzen. So kann man die 
Parameter z.B. exakt auf 0 setzen.

10.	 Nun benutzt man das Edit Mesh > Append Tool um Flächen zwi-
schen den Spitzen hinzuzufügen. Dies macht man indem man das 
Tool auswählt und jeweils zwei aneinanderliegende Edges selektiert. 
(siehe Bild) Anschließend drückt man ENTER. Man muss diesen Vor-
gang für jede Spitze wiederholen.

Anmerkung: Mit dem Tastaturkürzel G kann man immer das zuletzt ver-
wendete Tool wieder aufrufen. Das ist sehr nützlich wenn man wiederho-
lende Aufgaben erledigen muss.

11.	 Man selektiert alle acht Edges am unteren Rand indem man auf die 
einzelnen Edges klickt. Nun wieder ein Edit Mesh > Extrude. (Local-
TranslateY  -0.5, LocalScaleX 0)

12.	 Edit Mesh > Merge um die Geometrie zu korrigieren

13.	 Mit Edit Mesh > Append Tool für jede Spitze.

14.	 Mit Edit Mesh > Split Polygon Tool (Maya 2012: Interactive Split 
Polygon Tool) Splittet man die durch das Append Tool gemachten 
Faces in zwei gleiche Dreiecke. (Siehe Bild). Man LMB klickt einmal 
auf die Spitze des Dreiecks und einmal auf die Mitte der unteren 
Edge. Anschließend drückt man ENTER. Man muss diesen Vorgang 
für jede Face wiederholen.

15.	 Im Vertex Modus selektiert man jeden zweiten Vertex am unteren 
Rand des Objekts. In der topView und dem Scale Tool skaliert man 
die Punkte nach außen, sodass die Grundform kreis förmig wird. 
(siehe Bild)

16.	 Man selektiert den unteren Rand Im Edges Modus und aktiviert Edit 
Mesh > Keep Faces Together

17.	 Mit  Edit Mesh > Extude klickt man einmal auf den  kleinen hell-
blauen Kreis (dies verändert den Pivot Point von local zu global) 
Danach zieht man den grünen Pfeil ein kurzes Stück nach unten. 
(TranslateY -0.2)

18.	 Ein weiteres Edit Mesh > Extrude (TranslateY -2)

19.	 Mit den Edges noch selektiert Edit Mesh > Merge to Center

20.	 Im Objekt Modus die History Löschen (SHIFT-ALT-D)

21.	 Speichern als diamondRing.01.ma

Schritt 10: Das Append Tool angewandt 
(bevor Enter Gedrückt wurde)

Schritt 11: Extrude

Schritt 17: Extrude

Schritt 14: Split Polygon

Schritt 15: Kreisförmige Anordnung der 
Vertex Punkte

Schritt 19: Merge to Center



49Diamond Ring || 

Der Ring
1.	 Create > Polygon Primitives > Pipe (TranslateY -7, RotateX 90, Ra-

dius 5, Height 3)

2.	 Create > Polygon Primitives > Cylinder (TranslateY -2, RotateY 30, 
Radius 0.7, Height 0.3, Subdivision Axis 6)

3.	 In der „sideView“ zeichnet man eine CV-Kurve für die Halterung des 
Diamanten. Den Anfangspunkt setzt man kurz vor den Cylinder.

4.	 Man selektiert eine Curve und das am naheliegenste Face des Zylin-
ders.

5.	 Mit Edit Mesh > Extrude (Divisions 10-30 je nach Kurve, Taper 0.1) 
kann man entlang der Kurve extrudieren.

Schritt 2: Angeordnete Primitive

<Beschreibung>
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DNA-Helix
Um eine simple DNA-Helix zu modellieren müssen wir nur wissen, dass die 
Ebenen in einem 36° Winkel zueinander stehen. rechtsdrehend 10 Basen-
paare für eine Windung.

Basenpaar
1.	 Create > Nurbs Sphere (TranslateX = 5) 

2.	 Create > Polygon Cube (TranslateX = 2, Width = 4.5, Height = 0,2 
Subdivisions Depth =2 )

3.	 Beides selektieren, gruppieren STRG-G

4.	 Duplizieren STRG-D, skalieren (ScaleX = -1)

5.	 In der „topView“ beide Cubes im Vertex Modus auswählen entwe-
der per Selektionsmaske, oder RMB auf den ersten Cube > Vertex, 
SHIFT+LMB auf zweiten Cube, RMB auf den zweiten Cube > Vertex

6.	 Die mittleren Vertex Punkte zur Seite verschieben. (Siehe Bild) Hier-
für muss man in den Tool Settings die Move Axis auf „World“ setzen.

7.	 In der „persp“-Ansicht im Objektmodus die beiden Cubes selektieren 
und rotieren (RotateX = 30)

8.	 Alle Objekte zusammen gruppieren

Helix
1.	 Edit > Duplicate Special q (Siehe Bild)

2.	 Im Hirarchie Selektions-Modus alle Objekte auswählen und gruppie-
ren bzw. im Outliner alle Gruppen Selektieren und zu einer Gruppe 
(mit Namen „DNA“) vereinigen.

Schritt 4

Schritt 6

Move Tool Axis auf World umgestellt
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3.	 Delete History, Freeze Transformations

4.	 Speichern unter dna.01.ma

Duplicate Special Einstellungen
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Mirror geometry
Reflection
Blueprints
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Eigene Modelle modellieren
Wenn man anfängt eigene Modelle zu erstellen, sollte man zuerst eine klare Vorstellung haben von dem Objekt was 
man gerne Modellieren möchte. Hierfür erstellt man eine Referenz in Form eines Fotos oder Zeichnung. 

Man kann sich diese Referenz als Hintergrund in die ViewPanels laden. Hierfür geht man auf das PanelMenü View 
> Image Plane > Import Image. Man sollte die Referenzbilder nur in der Top, Side und Front view Camera laden, 
da diese statisch sind und die Position sich nicht verändert.

Es gibt die Möglichkeit das Bild nur dann anzuzeigen wenn man durch die Kamera blickt. In den Attributen für die 
ImagePlane > Image Plane Attributs > Display looking through camera. 

Anmerkung: Image Planes von orthographischen Kameras (Top, Side, Front) werden nicht ausgerendert. Jedoch bei 
perspektivischen Kameras wird es ausgerendert.

Man sollte nun das Objekt näher analysieren. 

Aus welchen Primitiven bestehen die einzelnen Teile des Objekts? Wenn man das Hauptobjekt in kleinere Teile bricht 
so stellt man fest das viele Objekte einfach nur aus Kugeln, Halbkugeln, Zylindern und Würfeln bestehen.

Bei diesem Schritt stellt man auch fest, das ein Objekt sich an manchen Stellen wiederholt oder Symmetrisch ist. Bei 
Wiederholungen muss man die Stelle nur einmal modellieren und benutzt dann Duplicate bzw. Duplicate Special. 
Bei Symmetrischen Objekten, kann man direkt die Geometrie auf die andere Seite Projezieren, so muss man nur die 
Hälfte des Objekts modelleiren. 

Danach überlegt man sich wie man am besten die Details ausarbeitet, in machen Fällen ist ein Polygon objekt gün-
stiger in manchen Fällen ist ein Nurbs Objekt besser. es hängt davon ab mit welchen Werkzeugen man die Details 
später ausarbeiten möchte.

Jetzendlich wie man modelliert hängt davon ab welche Technik man persönlich bevorzugt. Man muss das model-
lieren üben und verschiedene Ansätze ausprobieren. Man spart sich viel arbeiten wenn man nicht das Gesamtobjekt 
ansieht sondern es in kleine Teile aufteilt und diese nach und nach abarbeitet. 

Abschließende Schritte
Nachdem man mit dem Modellieren fertig ist, sollte man die Szene und Objekte optimieren. 

Man kann nun Hilfsobjekte löschen, wie Curves.

Mit einem Objekt selektiert Modify > Freeze Transformations. Dies setzt die aktuelle Transformationswerte als die 
Standartwerte also TranslateXYZ (0,0,0), ScaleXYZ (1,1,1) und RotationXYZ (0,0,0).

Anschließend kann man die Gesamte Konstruktions History löschen. Edit > Delete by Type > History (SHIFT-
ALT-D). Dies löscht alle Input-Nodes. Braucht man noch Input-Nodes wie Deformatoren (z.B. Lattice, Squash, etc.) 
wählt man Edit > Delete by Type > Non-Deformer History.

Man sollte auch allen Objekten einen Namen geben. Insbesondere Szenen wo man mit mehreren Objekten arbeiten 
kann es extrem unübersichtlich werden innerhalb kürzester Zeit.
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Rendering
“There’s nothing quite like turning a grey-shaded model into something that looks real - or that could be real.” Lee Lainier

Rendering ist der Vorgang indem aus der modellierten Szene ein Bild errechnet wird. Zunächst muss man eine 
Render Engine auswählen danach muss man der Szene und den Objekten mehrere Eigenschaften zuweisen:

Materialien
Dem Modell werden Shader zugewiesen. Je nach Typ von Shader können eine Vielzahl von echten sowie unechten 
Materialien simuliert werden. 

Lichter und Schatten
Um die Szene zu Beleuchten setzt man virtuelle Lampen in den Raum. Diese sind nach realen Lampen von Filmsets 
nachgeahmt. Diese Lampen geben ein direktes Licht ab, jedoch werfen diese Lichter keine Schatten. Schatten muss 
man für jedes Licht einzeln aktivieren. 

Darüber hinaus kann man noch eine „indirekte“ Beleuchtung aktivieren. Dies simuliert die Eigenschaft von Pho-
tonen, das sie die Farbe annehmen von der Fläche an der sie zuletzt reflektiert wurden.

Kamera
Man benutzt beim Rendern immer eine Kamera. Die Kamera funktioniert ähnlich wie eine echte Foto/Film-Kamera 
und definiert den Bildausschnit wie das Bild gerendert wird.



55Workspace Einstellungen || 

Workspace Einstellungen

Menü
Um zu rendern braucht man das Menü „Rendering“ (F6). 

Panels

Beim vorbereiten für das Rendern benutzt man den „Hypershade Editor“, die „Render View“ und eine Kamera-
Ansicht.

Shelf
Die “Rendering”-Shelf ist eingeteilt in Lichter, Camera,  Basis Shader und Render Einstellungen

Mental Ray Plugin aktivieren
Manche Funktionalitäten von Maya liegen als Plugin vor. Um Plugins in Maya zu laden muss man Window > Set-
tings and Preferences > Plugin Manager und dort für das Plugin ein Häckchen bei load setzen. (bzw. Auto load 
damit es automatisch mit Maya geladen wird). 

Plugin-Manager mit aktiviertem Mental Ray Plugin
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Viele Beispiele im Skript verwenden das Mental Ray Plugin (Siehe „Mental Ray“ Seite 57). Man sollte sicherstellen 
das Mayatomr.dll aktiviert ist.

Unter Umständen kann das Plugin Deaktiviert werden, wenn Maya z.B. abstürzt dann muss man  das Plugin noch-
mals aktivieren. Ein einfaches MEL-Skript dafür findet man im Anhang. (Siehe „Activate Mental Ray Plugin“ Seite 
132)

Mental Ray als Standart Renderer einstellen
Damit Mental Ray immer als Standard Renderer zur Verfügung steht kann man unter Window > Settings and 
Preferences > Preferences unter Settings - Rendering bei „Preferred renderer:“ im Dropdown Menü mental ray 
auswählen.

Falls Maya abstürzen sollte und das Plugin nicht geladen wird, wird der Maya Software renderer verwendet.
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Grundlagen Rendering

Arbeitsschritte
-- Render Engine auswählen

-- Shader den Materialien hinzufügen, ggf. Texturieren

-- Eine Kamera der Szene hinzufügen

-- Beleuchtung: direkte Beleuchtung der Szene mit Lichtern und Schatten definieren und indirekte Beleuch-
tung mit Global Illumination und Final Gather

-- Final Render

Render Engines
Die erste Frage die sich beim Rendern stellt ist „Welche RenderEngine soll man verwenden?“. Die jeweiligen Rende-
rengines haben ihre Vor- und Nachteile und werden für verschiedene Zwecke eingesetzt und bestimmen daher das 
weitere Vorgehen. Hier werden die verschiedenen RenderEngines vorgestellt.  In allen Beispielen wird Mental Ray 
verwendet.

Maya Software

Ein Allzweckrenderer der direkt in Maya eingebaut ist - Es ist ein Hybrid Renderer der die Geschwindigkeitsvorteile 
eines Scanrenderers mit echtem Raytracing verbindet. Generell hat die Qualität des Bildes höhere Priorität als die 
Geschwindigkeit des Ausrenderns.

Der SoftwareRenderer hat den Vorteil, dass man das IPR (Interactive Photo Realistic rendering) Tool verwenden 
kann um das fertig gerenderte Bild interaktiv verändern zu können. Sowie durch seine direkte Integration, dass man 
einfach komplexe Shadingeigenschaften erstellen kann.

Maya Hardware
Im Grunde ist es ein hardwarebeschleunigter Allzweckrenderer. Im Allgemeinen ist der Hardwarerenderer schneller 
als der Softwarerenderer, ein weiterer Vorteil des Hardwarerenderers ist das Ausrendern von Hardware Partikeln. 
Jedoch kann der Hardwarerenderer keine Sub-D Objekte rendern und hat darüber hinaus noch weitere Limitationen. 

Meistens rendert man alle Objekte mit einem Softwarerenderer aus und lässt die Partikel Effekte mit Maya Hardware 
ausrendern.

Mental Ray
Ist ein photorealistischer Raytrace Renderer. Dieser Renderer kann alle Materialien des Maya Software Renderers ver-
wenden und zusätzlich noch spezielle Mental Ray Materialien. Mental Ray kann auch den IPR-Renderer benutzen.

Mental Ray ist nicht direkt in Maya eingebaut sondern ist ein Plugin (Mayatomr.mll) 

Maya Vector 
Wie der Name bereits sagt ist Maya Vector ein Vektor Renderer. Dies ist besonders nützlich um Blaupausen des  
Modells zu erstellen. Die unterstützten Formate sind: Scalable Vector Graphics (SVG), Adobe Flash (SWF), Adobe 
Illustrator (AI) oder Postscript (EPS) 

Maya Vector wird selten verwendet und ist daher ein Plugin (VectorRenderer.mll)

Weitere Render Engines
Es gibt auch weitere Renderengines für Maya wie z.B. Visual Dynamics - V-Ray (http://www.vray.com/vray_for_
maya/) oder Pixar - Renderman (https://renderman.pixar.com/products/tools/rfm.html)

Wir werden uns hauptsächlich mit dem Mental Ray Renderer beschäftigen, da dieser Renderer in vielen gängigen 
3D-Modellierprogrammen, wie 3dsMax zur Verfügung steht.

Eine Render Engine auswählen
Unter den Render Settings direkt unter der Menüzeile ist „Render Using“ ein Dropdown Menü was anzeigt welcher 
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Renderer gerade verwendet wird.

Render-Vorbereitungen
Das Rendern braucht sehr viel Rechenleistung und deswegen werden hierfür sog. RenderFarms verwendet. Pixar 
braucht durchschnittlich 7 Stunden um ein einziges Bild für ihre Animationsfilme zu erzeugen, sogar mit ihrer Ren-
derFarm. (Wired Magazine 6/2010) . Daher sollte man viele Testrenderings von einzelnen Teilen machen, bevor man 
einen finalen Render macht. 

Vor jedem Render sollte man unbedingt Abspeichern und alle unnötigen Programme schließen. Der Computer wird 
während dem Rendern üblicherweise kaum bzw. gar nicht reagieren. 

Um den RenderVorgang eines Einzelbildes abzubrechen muss man ESC drücken. Es dauert 1-10sek bis der Computer 
darauf reagiert.

Einen Test-Render erzeugen
In der Regel erstellt man mehrere Test-Render bevor man die Szene ausrendert. Diese Render haben eine sehr geringe 

Qualität und dienen nur um zu sehen ob einzelne Materialien, oder die Beleuchtung korrekt eingestellt ist. 

Anmerkung: Um im Output Fenster den Fortschritt des Renderns angezeigt zu bekommen (nur bei mental Ray) 
muss man unter Render > Render Current Frame q  gehen und unter Messages: Verbosity Level auf  “Progress 
Messages” setzen. 



59Arbeiten mit der Render View || 

Arbeiten mit der Render View
Die Render View selbst hat eine Reihe von Funktionen die einem das Arbeiten und das Ausrendern sehr erleichtern.

Repeat Last Render

Dieser Button wiederholt einfach, den gleichen Render von der gleichen Kamera mit der man als letztes gerendert 
hat. Ungleich zu dem Button „Render Current Frame“ auf der Status Line, muss daher nicht vorher bestimmt wer-
den. D.h. man kann weiter in Maya arbeiten und immer wenn man zurückkommt zur RenderView wird die gleiche 
Kamera ausgerendert.

Render Region/Snapshot

Mit LMB kann man eine rechteckige Auswahl  auf dem Image Display Bereich selektieren. Drückt man den Button 
wird nur diese Region gerendert. Um die Auswahl wieder aufzuheben muss man einmal kurz LMB klicken.

Dies benutzt man wenn man Details korrigieren möchte ohne viel Zeit zu 
verschwenden  das ganze Bild auszurendern.

Wenn man noch keinen Render von der aktiven Perspektive gemacht hat, 
so kann man auf Snapshot klicken und man bekommt einen render von der 
Szene im Wireframe-Modus. Man kann nun ohne raten eine genaue Region 

auswählen die man ausgerendert haben möchte. 

Interactive Photorealistc Render (IPR)
Man benutzt das IPR ist das man schnell einen Überblick bekommen kann 
wie Lichter und Farben wirken. Mit dem IPR kann man eine Render Region 
auswählen. Der Unterschied zwischen Render Region und IPR, ist das man 
nun Materialeigenschaften verändern kann und die Veränderungen werden 
in Echtzeit in der Render View übernommen. 

Wenn man das IPR verwendet, sollte man die Qualität der Rendering Engine auf sehr niedrig stellen dies Erlaubt 
dem IPR sehr schnell die Veränderungen zu übernehmen. Man kann für das IPR-Rendering nur MayaSoftware und 
Mental Ray verwenden.

Um einen IPR-Render zu erzeugen klickt man auf Repeat last IPR Render und selektiert die Region mit der man 
arbeiten möchte.

Render Settings
Öffnet die Render Settings.

Display RGB/Alpha/Real Size
„Display RGB“ zeigt das gerenderte Bild in Farben an, „Display Alpha“ zeigt den Alpha Kanal an.

Man kann auf dem Bild mit den normalen Camera Kontrollen Zoomen und bewegen. Möchte man ein unskaliertes 
Bild haben, klickt man einfach „Display Real Size“.

Keep Image /Remove Image
Wenn man verschiedene Werte verändert, möchte man machmal einen Vergleich zwischen vorher und nacher ma-
chen.

Die RenderView Icons

Beispiel von einem Snapshot und anschlie-
ßender Render Region



60 || Rendering

Klickt man auf „Keep Image“, so wird das Bild temporär abgespeichert d.h. schließt man Maya so werden alle geren-
derten Bilder wieder entfernt. Nachdem man ein Bild temporär gespeichert hat, kann man nun etwas in der Szene 
verändern und nochmal rendern. Mit dem Scrollbalken am unteren Rand vom Fenster kann man von Bild zu Bild 
springen.

Möchte man ein Bild nicht mehr sehen so klickt man Remove Image und das aktuelle Bild wird entfernt.

Wenn man sich notieren möchte was man eigentlich verändert hat zwischen den Bildern, so kann man mit RMB auf 
die Icons Klicken und „Keep Image with Comment“ auswählen. Der Kommentar wird dann unten bei den Render-
informationen angezeigt.

Render Diagnostics
Die Render Diagnostics öffnet das Output Fenster und zeigt die letzten Meldungen der Render Engine an. Dies 
braucht man wenn z.B. Fehler beim ausrendern auftreten.                                                                

Render Engine
Das Dropdown Menü lässt einen die Render Engine auswählen ohne die Render Settings dafür zu öffnen. (Insbeson-
dere ist dies nützlich, wenn Objekte nicht angezeigt werden beim ausrendern. Benutzt man z.B. ein mia_material_x 
so kann Maya Software die Geometrie nicht rendern dann kann man hier überprüfen ob man auch mit Mental Ray 
rendert.)

IPR Controls
Die IPR Controls sind nur dann aktiv wenn man einen IPR Render macht. Der Pause Button pausiert den IPR 
Render, d.h. man kann veränderungen machen ohne das der render sofort neu ausgerechnet wird. Daneben ist eine 
anzeige wieviel zwischenspeicher für den IPR render benötigt wird. Und der Rote Knopf beendet das IPR-rendering.
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Kameras
In Maya hat man die Wahl ob man nur ein Einzelbild rendert oder eine Ani-
mation. Es wird immer eine virtuelle Kamera benutzt um das Bild auzuren-
dern. Es stehen einem immer die 3 Ortographischen Kameras „top“, „front“, 
„side“ und die perspektivische Kamera „persp“ zur Verfügung. 

In der Praxis verwendet man die „persp“ Kamera für das Modellieren und 
modifiziert sie oft wenn man sich in der Szene orientiert. Deswegen setzt 
man immer in die Szene eine neue Kamera die nur für das Rendern der Szene 
verwendet wird.

In Maya gibt es zwei Typen von Kameras. Die Standard Kamera simuliert 
eine Film Kamera und schießt ein einziges Bild. Die Stereo-Kamera besteht 
aus mehreren Standardkameras. Mit dieser Kamera können 3D-Bilder er-
zeugt werden (z.B. für 3D-Kinofilme wie Avatar). Man braucht dann spezi-
elle Displays bzw. Brillen um das Bild zu betrachten. Daher werden wir uns 
nur mit normalen Kameras beschäftigen

Eine Kamera erzeugen
Mit Create > Cameras > Camera erzeugt man eine Standart Kamera. 

Man findet auch „Camera and Aim“ und „Camera and Aim and Up“. Alle 
drei sind die gleiche Kamera, nur mit verschiedenen Kontrollattributen akti-
viert. Es reicht wenn man eine „Camera“ erzeugt. Braucht man später weitere Kontrollen kann man sie im Attribute 
Editor unter „Camera Attributes“- Controls hinzufügen. 

Allgemeine Attribute

Angle of View / Focal Length / Camera Scale
Mit dieser Einstellung lässt sich die perspektivische Verzerrung bestimmen die bei dem verwenden von Kameraob-
jektiven entstehen. Die Wertebereiche für die Focal Length ist für Weitwinkel Objektive 3-15, für normal Objektive 
35-55 und für Telezoom Objektive 100-550. 

Der Öffnungswinkel (Angle of View) und Brennweite (Focal Length) sind direkt voneinander Abhängig (d.h. setzt 
man den einen Wert wird automatisch der andere gesetzt). Das Camera Scale Attribut wirkt als Multiplikator für die 
Angle of View bzw. Focal Length

Near Clip Plane / Far Clip Plane:
Virtuelle Kameras müssen aus praktischen Grüunden  Objekte die zu nah bzw. zu weit von der Kamera entfernt sind 

abschneiden. 

Meistens tritt dieser Effekt auf wenn die Far Clip Plane zu niedrig gesetzt wurde. Man mulitipliziert den Wert schritt-
weise mit 10 um einen geeigenten Wert zu bestimmen. Die Near Clip Plane bestimmt wie nah Objekte sein können 
ohne abgeschnitten zu werden. Falls Fehler auftreten dividiert man den Wert schrittweise um 10.

Anmerkung: Mit der Standard Kamera hat man keine Tiefenunschärfe. Man muss der Kamera zusätzlich einen 
Lens-Shader zuweisen (Siehe „Depth of Field“ Seite 120)

Teleobjektiv (120mm)Normal (35mm)Weitwinkel (10mm)

perspektivische Kamera

orthographische Kamera
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Mit Cameras arbeiten
Wenn man durch ein Panel auf die Szene sieht versucht Maya soviel wie mög-
lich anzuzeigen. Beispielsweise ist die default Renderauflösung 640x480 also 
4:3, benutzt man einen 16:9 Monitor wird mehr angezeigt als was später 
gerendert wird. 

Um den Bereich angezeigt zu bekommen der ausgerendert wird, muss man 
für das Panel das Resolution Gate aktivieren im PanelMenu (View > Came-
ra Settings > Resolution Gate)

Das Resolution Gate wird bestimmt über die Render Settings unter Com-
mon > Image Size.

Resolution Einstellungen
Je nach Ausgabe Medium muss man die „Dots per inch“ (dpi) anpassen. z.B. 72dpi sind ausreichend für Fernseher/
Monitore, 150-300dpi je nach Drucker.

Typische Video Auflösungen:

320x240px (QVGA) bzw 640x480px (VGA): auch “Desktop”-Auflösung genannt. Diese ist sehr klein und eignet 
sich gut um Testrender zu erzeugen. Seitenverhältnis 4:3

720x480 (DVD): Die Dvd Auflösung Seitenverhältnis 4:3

1280x720 (HD720) bzw. 1920x1080 (HD1080): Der Standard für HD Fernseher sowie BlueRay mit Seitenver-
hältnis 16:9

2K, 3k, 4k: Cinema Standardauflösungen die Breite ist z.B. für 2K 2x 1024px die Höhe ergibt sich aus dem verwen-
deten Seitenverhältnis.

In den „Image Size“-Presets findet man weitere Formate

Far Clipping Plane Error

Resolution Einstellungen
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Gesetz der Drittel

Leitlinien

Symmetrie

Einzelbildkomposition
In der Bildgestaltung wird die Anordung der Gestaltungselemente Komposition genannt. Für die Fotografie/Malerei 
sowie Filmtechnik haben sich einige Grundlagen etabliert. Diese Grundlagen kann man ebenso auf Maya Kameras 
anwenden.

Gesetz der Drittel
Meistens wenn man einen Fotografen frägt was man für eine Bild komposition verwenden soll, dann antwortet er: 
Das Prinzip der Drittel. Es ist eine gängige Art und Weise immer im Drittel eines Bildes das interessanteste Objekt zu 
platzieren. Das liegt vor allen Dingen daran, das die Drittelschnittpunkte fast 
auf dem Goldenen Schnitt liegen und somit ein harmonisches Bild liefern.

Anmerkung: Der Goldener Schnitt (Goldenes Verhältnis, Göttlicher Schnitt) 
ist in der Natur und in der Kunst immer wiederkehrendes Verhältnis mit dem 
Wert ~1,619. Beispiel: Das Breitbild Format 16:9 hat ein Verhältnis von ~1,77

Leitlinien
Einfache Strukturen und „Linien“ im Bild verdeutlichen Tiefe und Räum-
lichkeit, es ist für den Betrachter angenehmer und gewohnter wenn Leitlinien 
im Bild vorhanden sind, so findet sich der Betrachter geführt von dem Bild. 
Der Betrachter empfindet das Bild harmonischer und im Einklang

Symmetrie
Ein andererer Ansatz gegensätzlich der ersten Regel, ist die vollkommene 
Symmetrie. Dieser Kompostitionstyp, setzt das Objekt in die genaue Mitte 
des Bildes. Die Wirkung entfaltet sich erst wenn ein Symmetrisches Objekt, 
wie ein Gebäude oder eine Blume oder eine interessante symmetrische Form 
abbildet. 

Ist das Objekt nicht genau in der Mitte verfehlt der Effekt, da das Gehirn 
diese Abweichung als störend empfindet. Meistens wirkt jedoch diese Kom-
postion als langweilig und unnatürlich, da Symmetrie langweilig ist und un-
natürlich erscheint.

Gerader Horizont
Eigentlich nicht erwähenswert, doch oft vergessen. Oftmals bildet man ein-
fach eine Landschaft ab, und der Horizont ist irgendwie schräg im Bild. Dies 
lenkt sehr von der eigentlich schönen Landschaft ab.  Auch hier muss das Ge-
hirn den Fehler korrigieren und somit arbeiten muss obwohl es nicht arbeiten sollte und nur das Bild genießen sollte. 

Perspektiven Wechsel
Eines der Dinge die beim positionieren der Kamera immer ans Tageslicht kommt ist seine eigenene  Perspektive wie 
man Dinge betrachtet. Um schönere Bilder von manchen Motiven zu bekommen lohnt es sich mal seine Perspektive 
zu ändern. z.B. Bei Gebäuden lässt sich durch ein Perspektivenwechsel aus einem langweiligem Geböude ein interes-
santes Gebäude machen.

Man hat folgende Möglichkeiten seinen Blickwinkel zu ändern:

Man verändert die Position und den Winkel von der Camera zu dem Objekt.

Einfach mal mit den Kameraeinstellungen der Kamera experimentieren. z.B: die Brennweite der Kamera verändern, 
oder die Depth of Field verändern.
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Bruch eines Musters
Wenn ein Homogenes Muster sich im Hintergrund befindet so lässt sich ein Objekt davorstellen und das Gehirn wird 
seinen vollen Fokus auf dieses richten, da es das Muster bricht.

Bruch der Regeln
Irgendwann wird es auch reizvoll einfach die etablierten Regeln zu missachten und was vollkommen anderes machen. 
Sofern man sich bewusst ist wie und warum man die Regel gerade bricht. Doch man kann nur dann Regeln brechen 

wenn man sie auch kennt... Also sollte man sich zunächst die etablierten Regeln lernen.
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Grundlagen Shading
Für die Renderengine ist ein 3D-Modell nur ein Gittermodell. Diesem Modell wird eine Materialeigenschaft (Ein 
Shader bzw. Shadingnetwork) zugewiesen. Jedes Objekt muss einen Shader haben, deswegen wird Standardmäßig 
ein graues Lambert Material (lambert1) zugewiesen. Materialien in der Realität werden bestimmt durch viele Eigen-
schaften wie z B. Diffuse Reflection, 

Anmerkung: Jede Geometrie sollte ein bestimmtes Material haben, beim rendern sollte kein Material den Default 
Shader zugewiesen haben. Gleichzeitig sollte man das lambert1 nicht löschen und man sollte es nicht modifizieren. 

Diffuse Reflection
Jedes Material, was nicht transparent ist, hat eine dif-
fuse Reflektion. Im Prinzip ist das die Grundlage dafür 
wie das Licht gestreut wird. Ein geringer wert für ein 
diffuses Material würde direkt Reflektieren wie z.B. ein 
Spiegel, Chrome. Solche Materialien haben eine glatte 
Oberfläche. Ein sehr diffuses Material wäre hingegen 
z.B. Beton oder Papier diese haben sehr rauhe Oberflä-
chen und streuen das Licht in alle Richtungen. 

Glossy/Blurred Reflection
Eine Glossy Reflection simuliert die Eigenschaft wenn 
ein Material quasi spiegelhaft die Umgebung spiegelt. 
Wie z.B. Porzellan oder Chrome. Hier ist zu beachten, 
dass die wenigsten Materialien perfekt die Umgebung 
spiegeln z.B. Silber oder Gold. zwarreflektieren  diese 
Materialien, jedoch ist es eine verschwommene Reflek-
tion. Dies wird mit der Blurred Reflection Eigenschaft 
kontrolliert.

Fresnel Reflection
Der Fresnel Effect ist ein physikalischer Effect der die 
Reflektion je nach Einfallwinkel des Lichts errechnet. 
Das bedeutet, das Teile des Objekts was zu der Kamera 
hin zeigen weniger Reflektieren als die Teile des Ob-
jekts die einen Winkel zu der Kamera einnehmen.

Specular Highlights
Maya unterscheidet zwischen der Umgebung die re-
flektiert wird und die Lichtquellen die in dem Material 
gespiegelt werden. Diese Trennung kommt nicht in der 
Natur vor. Man benutzt diese Trennung in 3D-Pro-
grammen, weil virtuelle Lichtstrahlen von einem un-
endlich kleinen Punkt ausgesendet werden und so nicht 
direkt im Material gespiegelt werden können. 

Refraction
Wenn ein Objekt transparent ist, so wird das Licht 
gebrochen, diesen Effect nennt man Refraction.  Der 
Factor der Lichtbrechung (Index of Refraction IOR) 

<Beschreibung>

<Beschreibung>

<Beschreibung>



66 || Rendering

richtet sich nach den physikalischen Eigenschaften von Materialien. So hat Glas beispielsweise einen Brechungsfak-
tor von 1.4. 

Benötigt man ein Material mit einer rauhen Oberflächenstruktur, so muss man blur Refraction benutzen.

Shader Typen

Maya Basis Shader

Lambert

Blinn

Ramp Shader

Phong / Phong E

Ramp Shader

Anisitropic Shader
Um Microstrukturen in der Oberfläche zu simulieren verwendet man ein Anisitropic Material. Solche Strukturen 
findet man z.B. auf der Unterseite einer DVD oder bei Seide.

Mental Ray Shader
Mental Ray kann die Maya Shader rendern, jedoch gibt es auch eigene Mental Ray Shader. Diese Shader können nur 
von Mental Ray benutzt werden. Rendert man versehentlich das Bild mit z.B. Maya Software, so werden die Objekte 
komplett transparent.

Legacy Shader (dilectric  material, dgs_material, mib_)
Die drei Shader, dilectric, dgs und mib sind sehr komplexe Shader. Um mit diesen Shadern zu arbeiten braucht man 
viele Kenntnisse über verschiedene Shaderstrukturen um das gewünschte Ergebnis zu erhalten. Beispielsweise mit 
dem dilectric_material lässt sich schnell ein Glasmaterial mit einer Refraction erstellen. Jedoch der wesentliche Nach-
teil von diesem Material ist, das die Schatten die das Material wirft keine Transparenzen aufweist. Dadurch müsste 
man komplizierte Tricks verwenden um doch einen halbtransparenten Schatten zu erhalten.

Diese Shader sind übriggeblieben aus früheren Versionen von Mental Ray. Das neuerere mia_material ist einfach 
zu bedienen und kann alle drei vorrangegangenen Typen ersetzen. Desweiteren werden einige Schwächen behoben. 

Architectual Material (mia_material)

Shader einem Objekt hinzufügen

Hypershade Editor:
RMB-Objekt

Shelf
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Arbeiten mit dem Hypershade Editor
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Teapot Shading
„If you can shade a Teapot - you can shade anything“ In den Anfängen der Computergrafik hat man eine Teekanne 
verwendet um Shader auszutesten. Der Vorteil einer Teekanne ist, ist das sie harte Kanten sowie weiche Kanten hat. 
Wenn es auf der Teekanne gut aussieht, sieht es wahrscheinlich auch auf dem eigentlichen Objekt gut aus. 

Heute ist so ein Testrender mit Teekanne unnötig, da man den Shader meistens direkt auf das Objekt anwenden kann 
und es ausrendern kann.  Jedoch kann man viel lernen wenn man Shader an Teekannen austestet.

Teekanne Modellieren
1.	 Eine CV-Curve für den Hauptkörper erstellen

2.	 Unter Surfaces > Revolve q setzt man Sections: 32, Output Geometry: Polygons und Tesselation Method: 
Control Points

3.	 Mit dem Revolve Objekt selektiert Taste 3 drücken

4.	 Eine weitere Curve für den Griff, und eine weitere für den Trichter(??) anlegen

<Beschreibung>
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Grundlagen Direct Lighting
Im Grunde ist Direct Lighting, jede Lichtquelle die einen Schatten wirft. Alle Lampen in Maya sind nachgebildet von 
den gleichen Licht Typen und Beleuchtungs mittel die verwendet werden können für eine Filmproduktion. 

Default Light
In 3D-Umgebungen gibt es eigentlich kein Licht solange man kein Licht der Szene hinzugefügt hat. Daher hat Maya 
ein eingebautes „Default Light“ dies wird verwendet damit man ohne zusätzliche Lichter die Szene ausrendern kann. 
Insbesondere auch damit man überhaupt während dem modellieren irgendwas sehen kann.

Sobald man ein Licht der Szene hinzufügt wird dieses Licht automatisch ausgeschaltet. In manchen Fällen gibt es 
jedoch Konflikte,  daher kann man das Default Light in den Render Settings manuell ausschalten. 

Lichter in Maya erzeugen
Man kann entweder über Create > Lights oder über die Shelf Rendering Lichter in Maya erzeugen.

Die Shelf Icons:Ambient Light, Directional Light, Point Light, Spot Light, Area Light, Volume Light

Jedes Licht hat sein eigenes Light-Icon, in den meisten Fällen kommt das Licht von diesem Punkt. Das Light-Icon 
bzw. die Lichtquelle selbst wird beim ausrendern nicht ausgerendert.

Licht Typen

Ambient Light
Dieses Licht gibt ein weiches Licht in jede Richtung. Es erzeugt daher ein sehr diffuses Licht. Die  Intensität hat daher 
kaum Varianz. Es versucht eine indirekte Beleuchtung zu simulieren.

Das „Ambient Shade“-Attribut bestimmt das Verhältnis zwischen omidirec-
tionalen und direkten Strahlen. Ein Wert von 1 entspricht das alle Licht-
strahlen von dem Light-Icon in der Szene stammen, damit ist es identisch zu 
einem Point Light. Ein Wert von 0 lässt das Licht von der Lampe an jeder 
Position im Bild identisch stark erscheinen (Dadurch gibt es keine Schatten 
mehr und alles sind nur noch Farbflächen). Per Default ist der Wert auf 0.45 
gesetzt. Die Positionierung des Lichts hat kaum Einfluss auf das Licht. 

Ambient Lights werden eigentlich nicht verwendet, da es einen sehr flachen 
Eindruck im Bild erzeugt bzw. mit anderen Lichtquellen hat man mehr 
Kontrolle über das Licht. Das Licht wurde nur der Vollständigkeitshalber 
erwähnt.

Directional Light
Dieser Licht Typ ermöglicht die Simulation von unendlich vielen parallelen Lichtstrahlen von einer unbestimmten 
Lichtquelle. Daher bietet es sich an Directonal Light zu verwenden für Son-
nenlicht.

Dadurch das die Strahlen parallel von einer unbestimmten Quelle kommen, 
spielt die  Positionierung  des Light Icons keine Rolle.  Nur die Rotation des 
Light-Icons hat einen Einfluss auf das Licht.

Möchte man z.B.. Sonnenlicht durch ein Fenster strahlen lassen, so muss 
man die Schatten von der Lichtquelle aktivieren ansonsten wird der gesamte 
Raum mit Licht erfüllt. 

Point Light
Die Lichtquelle vom Pointlight ist ein einzelner Punkt und Licht strahlt von dem Punkt in alle Richtungen. Daher 

Ambient Light

Directional Light
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ist es ein gutes Licht um Glühbirnen, Kerzen, LEDs oder ähnliches zu simu-
lieren.

Da alles Licht von einem fixen Punkt ausgeht hat nur die Positionierung 
einen Einfluss aufs Licht.

Spot Light
Sind Lichter die reale Spotbeleuchtungen aus dem Theater/Film simulieren. 
Ähnlich wie das Point Light entstammt das Licht von einem bestimmten 
Punkt, wird jedoch dann durch einen Kegel in die Szene projiziert. Die gän-
gigsten Anwendung für diesen Licht Typ sind, Taschenlampen, Scheinwerfer 
und Spotbeleuchtungen darzustellen.

Positionierung und Rotation haben einen Einfluss auf das Licht. Darüber 
hinaus kann man den Öffnungswinkel über das Cone Angle Attribut verän-
dern um einen größeren/kleineren Bereich zu beleuchten.

Area Light
Dieses Licht simuliert eine Fläche aus Lichtern die in eine Richtung strahlt. 
Das Licht selbst wird von einer Reihe von Sampling-Punkten aus dem Light-
Icon in die Szene in alle Richtungen ausgestrahlt. Dies ist ein sehr diffuses 
Licht wie aus einer Softbox. Der Verwendungszweck ist  z.B. Licht aus einem 
Fernseher, Leuchtstoffröhren etc.

Positionierung, Rotation, Skalierung haben einen Einfluss aufs Licht. Skalie-
rung verändert gleichzeitig auch die Intensität des Lichtes, da die Sampling-
Points Anzahl immer gleich bleibt.

Volume Light
Das Volume Light ist ein künstlicher Licht Typ. Mit einem Volume Light, 
funktioniert es wie ein Point Light, nur das Licht existiert nur innerhalb der 
Begrenzung des Light-Icons. Das Licht entspricht keiner natürlichen Licht-
quelle und wird daher nur für bestimmte Special-Effects verwendet.

Position, Skalierung haben einen Effekt auf das Licht. Per default wird ein 
Sphärisches Licht verwendet, jedoch wenn man die Einstellungen verändert 
wie z.B.. die Begrenzung von Sphere zu Box ändert dann hat auch die Rota-
tion einen Einfluss auf das Licht.

Allgemeine Attribute

Color
Alle Lichter haben als Standardwert weiß als Farbe. Jedoch kommt in der 
Natur eigentlich kein Licht reines weiß. Sogar das Sonnenlicht ist je nach 
Tageszeit, rötlich oder bläulich. Florescent blau, Glühbirnen haben einen 
gelblichen Stich.

Intensity
Dies bestimmt die Lichtstärke wenn sie auf eine Oberfläche auftrifft.

Decay Rate
Die Decay Rate definiert den Abfall der Licht-Intensität von Lampen. Be-
nutzt man keine Decay Rate, so ist die Licht-Intensität gleich stark egal wo 
das Licht auftrifft. Daher ist es ein sehr unnatürlicher Effect wenn man Lich-
ter ohne Decay Rate verwendet. Mit einer Linearen Decay Rate berechnet 
sich die Intensität an jedem Punkt mit Intensity = 1/Distanz (̂Faktor). 
Die Quadratic als Faktor 2 entspricht das reale Verhalten von Licht. Cubic ist 
mit einem Faktor von 3 lässt die Licht Intensität schneller abfallen als in der 
Realität und wird nur in seltenen Fällen verwendet.

In den meisten Fällen reicht es jedoch eine Linear Decay Rate zu verwenden, 

Spot Light

Point Light

Area Light

Volume Light
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das verbraucht später beim ausrendern weniger Ressourcen und ist eine gute Annäherung an natürliche Lichter. 

Im Allgemeinen benutzt man nicht die Formel um zu errechnen wie das Licht eingesetzt werden sollte. Man passt die 
Intensity und Decay Rate ein paar Mal an und nimmt dann ansprechendste Variante. (In vielen Fällen muss man die 
Intensity drastisch erhöhen, damit man das Licht überhaupt noch sehen kann).

Im Beispiel ist es das gleiche leicht gelbe Point Light, mit verschiedenen Decay Rate/Intensity Einstellungen.

Mit Lichtern arbeiten
Man kann die Lampen in der Szene simulieren wenn man 7 drückt. Alter-
nativ kann man im Panelmenü auf Lighting > Use All Lights. Wenn man in 
diesen Modus wechselt und keine Lampen in der Szene vorhanden sind, dann 
werden alle Objekte schwarz dargestellt.

Mit dem „Show Manipulator Tool“ (T), bekommt man zwei Move Handles 
für das Licht, einen um die Position des Lichts zu bestimmen und einen um 
die Ausrichtung zu bestimmen. Man kann zusätzlich  z.B. beim Spotlight 
durch verschiedene Einstellungsmöglichkeiten wechseln indem man auf den 
kleinen Kreis unter dem Pivot klickt.

Anmerkung: Das Spot Light positioniert man am einfachsten indem man das Licht selektiert und dann im Panel 
Menü auf Panels > Look through selected Camera. Das Panel verändert seine Ansicht sodass man durch das Licht 
schaut.

No Decay, Intensity 1 Linear Decay, Intensity 5 Quadratic Decay, Intensity 25

Spot Light mit Show Manipulator Tool

Panel aus Perspektive des Spotlights
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Schatten
Für jede Lampe muss man bestimmen ob sie Schatten wirft. Standard mäßig wirft eine Lampe keinen Schatten, man 
muss ihn immer erst manuell aktivieren. Dies ermöglicht einfacher z.B. eine  drei-Punkt Beleuchtung, wo nur das 
Haupt-Licht einen Schatten werfen soll und die anderen Lampen möglichst keinen Schatten werfen.

Es gibt zwei Typen von Schattenberechnung, DepthMap Shadows und Raytrace Shadows. DepthMap Shadows sind 
grundsätzlich schneller auszurendern als Raytrace Shadows. Letztere orientieren sich mehr an physikalisch realis-
tischen Gegebenheiten. Man kann für jede Lampe entweder Depth Map Shadows oder Raytrace Shadows benutzen. 

Depth Map Shadows
Bei DepthMap Shadows wird eine DepthMap erzeugt und dann mit einem Filter verwischt. Die DepthMap ist im 
Grunde ein Bild aus der Perspektive des Lichtes. In diesem Bild ist die Information gespeichert von der Distanz von 
Objekten gegenüber dem Licht. Beim ausrendern wird dann geprüft ob der Punkt eine höhere Distanz zum Licht hat 
als in der DepthMap, ist das der Fall, dann wird er dunkel gemacht. Da dies für jeden Punkt wiederholt wird entsteht 
dann ein Schatten.

Im Grunde gibt es für DepthMap Shadows zwei Variablen - Die “Resolution” der DepthMap und die “Filter Size”. 
Der Filter bestimmt den Grad des verwischens. 

•	 Um scharfe Kanten bei den Schatten zu erhalten, erhöht man die Auflö-
sung und benutzt einen geringen Filter. (Ein Wert von 0 für Filter Size 
entfernt das Verwischen komplett)

•	 Um weiche Kanten zu erhalten benutzt man eine geringe Auflösung und 
einen großen Filter. (Dadurch das man einen unscharfen Schatten er-
zeugen möchte ist eine hohe Auflösung unnötig. So verkürzt man auch 
die Rechenzeit für das rendern. Falls das zu viele Artefakte erzeugt, muss 
man die Resolution und Filtersize erhöhen).

Das Bias Attribut, kann man in den meisten Fällen auf dem Wert 0.001 las-
sen, falls Artefakte im Schatten beim rendern auftreten sollen kann man den 
Wert in 0.001 Schritten erhöhen.

Der größte Vorteil von DepthMap Shadows ist, das man die DepthMaps 
nur einmal erstellen muss und man dann die DepthMaps wieder verwenden 
kann. 

Der Nachteil an dem Verfahren ist jedoch das man keine korrekten Schatten 
von Transparenten Objekten erzeugen kann. 

Generell ist die Verwendung von DepthMap Shadows eher trickreich. Neben 
diesen Standart Einstellungen gibt es noch viel Erweiterte Einstellungen um 
z.B. Schattenartefakte zu vermeiden. Es gibt darüberhinaus für Mental Ray 
eigene Einstellungsmöglichkeiten die etwas simpler sind. (Fortsetzung „Men-
tal Ray Shadows“ Seite 74)

Raytrace Shadows
Bei Raytrace Shadows werden Shadowrays von der Lampe verschickt und 
dann dementsprechend eingefärbt. Daher können Transparenzen korrekt 
dargestellt werden.

Es gibt bei Raytrace Shadows 3 Einstellungen:

Shadow Radius/Light Radius/Light Angle 

Bestimmt die Härte des Schattens. 0 erzeugt scharfe Kanten - 1 erzeugt wei-
che Kanten. 

Manche Lichter, wie Area Light, haben diese Einstellungsmöglichkeit nicht. 
Die Einstellung wird dann aus der Position und Rotation des Lichtes abge-
leitet.

Depth Map Shadows Scharfe Kante

Depth Map Shadows Weiche Kante

Raytrace Shadows
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Shadow Rays  Je höher der Wert desto höher die Qualität der Schatten, (desto Höher die Renderzeit)

Ray Depth Limit bestimmt wie oft in einer rekursiven Reflektion ein Schatten sichtbar sind.

Mit Schatten arbeiten
Man kann Panels umstellen, das sie die Schattierung sofort berechnen - ohne das man einen Testrender erzeugen 
muss. Man sollte immer erst die gesamte Ausleuchtung der Szene fertig haben und dann diesen Modus aktivieren. 

Hierfür aktiviert man im Panelmenü Lighting > Shadows

Dies sollte man wieder deaktivieren wenn man modelliert/animiert, da ansonsten Maya sehr langsam reagiert beim 
manipulieren von Objekten.
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Mental Ray Lights
Einstellungsänderung

Mental Ray Shadows

Depth Map Shadows

Directional Light
Da eigentlich ein „Directonal Light“ eigentlich nur Paraelle Lichtstrahlen hat, daher auch keine eigentliche Licht-
quelle, wird versucht immer alle Geometrie der Szene auf einmal zu beleuchten. Dies führt dazu das die Resolution 
in manchen Fällen nicht ausreicht um die gesamte Szene zu beleuchten.

Man kann mit Mental Ray noch zusätzlich die Shadow Map Camera 
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Light-Rig
Ein Light-Rig wird verwendet um verschiedene Beleuchtungsszenarien mehrfach zu verwenden. Dies erspart einem 
für jede neue Szene die Gesamte Beleuchtung neu einzustellen.  Ein weiterer Vorteil ist das man mehrere verschiedene 
Modelle hinweg das gleiche Erscheinungsbild wahrt.

Die Limitation von diesem Verfahren ist das es nur dazu dient einzelne Modelle auszuleuchten. Für eine Animation 
braucht man seine eigene individuelle Umgebung und Beleuchtung.

Backdrop
1.	 Zu der SideView wechseln

2.	 Create > CV-Curves mit x-gedrückt die Kurve zeichen (siehe Bild)

3.	 Duplizieren (STRG-D) und Transform (TranslateX = 12)

4.	 Surfaces > Loft

5.	 Wechsel des Maya-Modus  auf Rendering (F6 oder über das drop-
down menü) Lighting/Shading > Assign new Material> mia_
material_x

Anmerkung: Im Marking Menu des Lofts (RMB auf den Loft) gibt es auch 
den Befehl. Man kann sich so einen Wechsel zwischen Modulen sparen. 

6.	 Im Attribute Editor auf mia_material_x1 wechseln - hier sollte man 
das Material umbenennen auf backdrop_material.

7.	 Unter Presets das Material MatteFinish > Replace auswählen

Anmerkung: Das Material mia_material_x is generell ein metallisches Ma-
terial. In diesem Fall mit dem Preset MatteFinish, ist es ein Diffuses nicht 

Schritt 2: Curve

Schritt 4: Fertiges Loft
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reflektierendes Material - Ideal herzunehmen als Studio Hintergrund. 

8.	 Man kann nun über die diffuse Einstellungen die Farbe verändern über die Color Eigenschaft z.B. in Weiss.

9.	 Das Loft auf seine Eigene Ebene “Backdrop” setzen.

Studio Lighting: Softbox
Eine Softbox ist ein flächiges Licht was sanft die Umgebung beleuchtet. Eine Softbox hat eine besonders Markante 
Rechteckige Form in der Reflexion. 

AreaLight
Die Lichtquelle die am nächsten einer Softboxbeleuchtung kommt ist das 
Arealight.

1.	 Create > Lights > Arealight

2.	 Im Attribute Editor:

-- Farbe zu einem hellen Gelb (HSV - 60, 0.1,  1)

-- Intensity = 15 und DecayRate auf Linear

-- Schatten einstellen (z.B. Raytrace Shadows Shadow Rays 35)

-- Unter Mental Ray - Area Light - Use Light Shape aktivieren  
	 und High Samples auf 32 setzen

3.	 Das Licht mit dem Show Manipulator Tool (T) positionieren auf  Translate (10,5,10) und auf den Ursprung 
ausrichten

4.	 Das Licht duplizieren (STRG-D) und TranslateX -10

5.	 Die Lichter auf eine eigene Layer „Two_Softboxes_Arealights“

Verwendung des Light-Rigs:

Beispiel: Bauhaus-Stuhl
1.	 Man öffnet das Lightrig und speichert es als neue Datei “bauhaus_

render.mb” (File > Save As)

2.	 File > Import - “bauhaus.export.ma”  (ggf. positionieren)

3.	 Dem Stuhlgerüst weist man ein “mia_material_x” mit dem Preset 
Chrome zu und der Sitzfläche/lehne ein weißes Phong Material.

4.	 Create > Cameras > Camera und wählt einen Bildausschnitt (Pa-
nel > Look through selected Camera, Resolution Gate)

5.	 Rendern

Schritt 5: Marking Menu on Loft Schritt 6-7: Attribute Editor vom für das Material

Beispiel einer Softbox Beleuchtung

Fertig gerenderter Bauhaus-Stuhl
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Grundlagen Indirect Lighting
In der Natur trifft Licht auf eine Oberfläche und wird dann gestreut, dieses Licht was dann auf die nächste Oberflä-
che auftrifft nennt man indirekte Beleuchtung. Der Effekt von indirekter Beleuchtung ist, dass die Farbe von dem 
zuletzt aufgetroffenen Objekt in dem Schatten bzw. Untergrund zu finden ist (auch Color Bleeding genannt). 

In einer virutellen 3D-Umgebung senden Lampen reines direktes Licht aus. Um den Effekt der indirekten Beleuch-
tung zu simulieren benutzt man Global Illumination (GI) und Final Gathering (FG).

Eine weitere Eigenschaft von natürlichem Licht ist das es von transparenten Objekten gebrochen und fokussiert wird 
wie z.B. der Brennpunkt einer Lupe, oder die Reflexion von Wasser auf der Wand von einem Schwimmbad. Dies wird 
mit Caustics simuliert.

Ambient Occlusion ist der Effect, das manche Bereiche, wie die Ecken eines Raumes, dunkeler sind weil nicht viele 
gestreute Photonen dorthin gelangen.

Global Illumination

Photonen
Lichter müssen Photonen aussenden damit man Gebrauch machen kann von Global Illuminations oder Caustics. 
Wie der Name bereits sagt werden Photonen simuliert und von der Lichtquelle ausgestrahlt. Photonen in Mental Ray, 
simulieren wie in der Natur vorkommende Photonen. Sie haben eine gewisse Energie wenn sie ausgesandt werden 
und verlieren Energie bei jedem auftreffen auf ein Material, gleichzeitig nehmen sie die Farbe an von dem Material. 

Spot, Point, Area und Directional Lights können Photonen aussenden. Jedoch sollte man nicht einfach bei jeder 
Lichtquelle einfach Photonen aktivieren, dies erhöht nur unnötig die Renderzeit und ändert unter Umständen nichts 
an der Beleuchtungssituation. 

Attribute für ein Licht

Photon Color
Setzt man die Photon Color auf Weiß wird die Farbe der Photonen rein bestimmt durch die Oberfläche an der sie als 
letztes Reflektiert wurde.

Photon Intensity
Die Photon Intensity bestimmt wie Hell die Photonen sind wenn sie gerade erzeugt werden. Je höher der Wert desto 
heller sind die Photonen. Für Stimmungsvolle Beleuchtung lässt sich auch die Farbe auf ein Rot-Ton setzen für einen 
Sonnenuntergang, oder einen blauton für Nacht etc.

Maya Materialien reagieren schwächer auf die Photon Intensity als Mental Ray Materialien. 

Exponent
Der Exponent bestimmt die Abfallrate, also die Decay Rate von der Photon Intensity. Ein Wert von 2 entspricht 
der Realität. Man muss nur in sehr seltenen Fällen diesen Wert verändern. Je Höher der Wert desto schneller ist die 
Abfallrate.

Caustics Photons/Global Illum Photons
Bestimmt die Anzahl der Photonen die simuliert werden für den Caustics Effect bzw. Global Illuminations. Caustics 
und Global Illumination sind zwei seperate Berechnungsvorgänge, daher kann man verschiedene Werte für die Pho-
tonenanzahl eingeben.

Der Wert jedoch orientiert sich immeran der Komplexität der Szene. Wird das Licht an vielen Oberflächen gestreut 
werden, so muss man in der Regel viele Photonen (Anzahl > 100000) ausstrahlen, jedoch sollte man nur soviele Pho-
tonen emittieren wie nötig. Niedrige Werte sind besser für die Renderzeit, hohe Werte hingegen erhöhen die Qualität 
und somit Renderzeit. Meistens benutzt man daher Final Gather in Kombination mit Global Illumination. Man 
kann eine wenige Photonen aussenden und das Ergebnis mit FG verbesseren.
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Mit Photonen arbeiten
1.	 Zunächst muss man unter den Render Settings - Indirect Lighting, Global Illumination aktivieren. Dies 

ermöglicht es das Lampen Photonen ausstrahlen können. 

2.	 Allgemein trennt man die direkte und indirekte Beleuchtung. Daher benutzt man dedizierte Photonen Emit-
ter. d.h. man verändert die Lampen aus der direkten Beleuchtung nicht, sondern fügt eine neue Lampe der 
Szene hinzu und setzt die Intensity auf 0.

3.	  Im Attribute Editor unter Mental Ray - Caustics and Global Illumination aktiviert man dann „Emit Pho-
tons“

Anmerkung: Man sollte niemals mit einem Directional Light Photonen emmitieren. Dadurch das ein Directional 
Light „unendlich“ viele Lichtstrahlen über die gesamte Szene simuliert, müsste man eine sehr hohe Anzahl von Pho-
tonen ausstrahlen, damit man überhaupt einen Effekt sehen kann.  In einer Szene wo das Directional Light durch ein 
Fenster in die Szene gestrahlt wird z.b. Bietet sich eine Kombination mit einem Point Light was Photonen emmitiert 
innerhalb des Zimmers 

Globale GI Einstellungen

Accuracy
Die Accuracy Einstellung bestimmt wieviele Photonen miteinander verrechnet werden um die Helligkeit des auftref-
fenden Photons zu berechnen. 

Niedrige Werte machen ein sehr geflecktes Resultat, hohe Werte lassen die Übergänge sehr sanft werden. Hohe Werte 
erhöhen die Renderzeit.

Das geflekte Resultat lässt sich auch mit Final Gather korrigieren, daher ist es nicht immer nötig die Accuracy auf 
Hohe Werte zu setzen.

Scale
Skaliert den GI-Effekt. Man kann auf die Farb Eigenschaft klicken und dann im HSV modus unter Value den Wert 
auf z.B. 2 setzen verdoppelt sich die Helligkeit der auftreffenden Photonen. 0.5 halbiert die Helligkeit der Photonen.

Radius

Material Eigenschaften

Final Gather

Caustics
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Mental Ray: Martini Glas 

Vorbemerkung
Da man jetzt nur Rendering Funktionen verwendet, kann man das Menü (F6) und Shelf auf Rendering umstellen. 
Nach jedem Schritt wo eine Kamera, Licht oder Material verändert wird sollte man einen Testrender (Siehe „Einen 
Test-Render erzeugen“ Seite 58) machen.  

Bildausschnitt wählen
1.	 Man erzeugt eine Kamera mit Create > Cameras > Camera

2.	 Im Panel Menü wählt man Panels > Look Through Selected. Man 
sieht nun durchdie Kamera. Wenn man nun mit den normalen Ka-
mera-Bewegungstools (ALT-LMB, ALT-MMB, ALT/RMB) die 
Szene verändert verändert sich die Position und Rotation der Kamera.

3.	 Man kann die  Resolution Gate  im Panel Menü View > Camera 
Settings > Resolution Gate aktivieren. Das Rechteck zeigt den ei-
gentlichen Bildausschnitt an.

4.	 Man positioniert nun die Kamera so wie man mit der Bildkompo-
sition zufrieden ist. (Diesen Schritt  muss man ggf. vor dem finalen 
Rendern nochmal anpassen)

 
3-Punkt Beleuchtung
Um die Form des Martini Glases zur Geltung zu bringen, benutzen wir 
eine 3-Punkt Beleuchtung.  Eine solche Beleuchtung besteht aus einem 
Hauptlicht(Keylight), was die hellste Lichtquelle ist, einem Fülllicht(Fill-
Light), was die Schatten aufhellt und dem Kanten Licht (Rim-Light), was 

Looking through Camera mit Resolution 
Gate

Eine erstelle Kamera in der Szene
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den Rand des Objekts auffhellt.

Die Positionen von den Lichtquellen müssen 
immer relativ zu dem Objekt und Kamera 
gesetzt werden. 
Das Key-Light sollte neben die Kamera in 
einem Winkel von 15-45° gesetzt werden. Das 
Fill-Light wird entgegengesetzt zum Key-Light 
positioniert.  Das Rim-Light wird fast ist ein 
intensives Licht was den Rand/Hintergrund 
beleuchtet

1.	 Für das Key Light Create > Lights > 
Spot Light (umbennenen auf KeyLight)

2.	 Das Key Light positionieren z.b. Trans-
lateXYZ  , RotateXYZ

3.	 Im Attribute Editor (STRG-A): 

-- Color (HSV)  180, 0.1, 1 (z.b. Cyan)

-- Intensity 20

-- Decay Rate Linear

-- Cone Angle 60

-- Penumbra Angle 20

4.	 Testrender erzeugen und ggf. die Position anpassen

5.	 Für das Fill Light Create > Lights > Point Light (umbennenen auf Fill 
Light)

6.	 Das Fill Light positionieren z.b. TranslateXYZ  , RotateXYZ

7.	 Im Attribute Editor (STRG-A): 

-- Intensity 0.7

-- Decay Rate Linear

8.	 Testrender erzeugen und ggf. die Position anpassen

9.	 Für das Rim-Light Create > Lights > Area Light

10.	 Im Attribute Editor (STRG-A): 

-- Color (HSV) 30, 0.1, 1	  (z.b. Orange),	

-- Intensity 8

11.	 Testrender erzeugen - Man sieht das die gesamte Szene vollkommen 
überbeleuchtet ist. Anstatt die Intensität mit z.B. der Decay Rate an-
zupassen lässt sich das Licht exclusiv an das Glas binden. Dazu ver-
ändert man die Light-linking Eigenschaft des Lichts unter Lighting/
Shading > Light Linking Editor > Light - Centric. 

12.	 Auf der linken Seite sieht man alle Lichter in der Szene und auf der 
rechten Seite sieht man alle Objekte der Szene. (die Lichter erscheinen 
doppelt, da man Beleuchtungsgruppen anlegen und diesen individu-
elle linking Eigenschaften geben kann)

13.	 Mit LMB klickt man auf der linken Seite Das “AreaLight1” bzw. RimLight - es werden sofort auf der rechten 
Seite alle Objekte ausgewählt.

14.	 Nun mit RMB + STRG selektiert man die Objekte aus die tatsächlich von dem Licht beleuchtet werden, also 
die Gruppe “martiniglas”.  Nichts anderes sollte selektiert sein.

15.	 Man kann nun den “Relationship-Editor” schließen. In der Vorschau wird das neue Lichtverhältnis nicht 
angezeigt, jeoch sieht man es bei einem Testrender. 

Eine Möglichkeit der Positionierung der Lichter

<Beschreibung>

<Beschreibung>

<Beschreibung>
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Schatten
In der realen Welt versucht man viele Tricks zu verwenden um die Schatten von dem Fill-Light und Rim-Light das 
Bild nicht stört. In der 3D-Welt aktiviert man nur die Schatten die man benötigt.

1.	 Nur das Keylight erhält einen Schatten, bzw. man versucht die Fill und Rim Light so zu positionieren, dass 
kein Schatten im Bild vorkommt. Da wir im virtuellen Raum arbeiten, aktivieren wir einfach die Schatten 
nicht.

2.	 In der Lampe den Unterpunkt Shadows aufmachen. Weiter unten kommt dann “Raytrace Shadow Attributes”

3.	 Ein Häckchen auf “Use Ray Trace Shadows” 

-- Light Radius 0.14

-- Shadow Rays 34,

-- Ray Depth Limit 1 

4.	 Speichern als (martini_glas.05.mb)

Materialien

Das Glas
1.	 Im Hypershade (Window > Rendering Editors > Hypershade)

2.	 Create > Mental Ray Materials > mia_material_x

3.	 Das Glas im Perspective selektieren und anschließend im Hypershade RMB auf das Material und im Mar-
kup-Menu “Assign Material to Selection” auswählen. 

Im Attribute Editor (STRG - A) umbenennen auf Glass		

-- Diffuse: 		 Color (HSV) 0, 0, 0.2 	 (z.B. Dunkelgrau) 
			   Weight  0.7  (Bestimmt die diffuse Reflektion)

-- Reflection:	 Reflectivity 0.25 (Wie stark die Spiegelung der die Umgebung im Material) 
	 		  Glossiness  0.9	 (Unschärfe der Reflektionen im Material)

-- Refraction:	 Index of Refraction 1.4 	 (Lichtbrechung z.B. Luft 1.0, Diamant 2.4)  
			   Transparency 1.0	 (Transparenz des Materials) 
			   Glossiness  0.9		  (Unschärfe der Reflektionen im Material) 
			   Glossy Samples 8	 (Qualität der Unschärfe der Reflektionen)

Anmerkung: Das Glas wird unter Umständen nicht wie Glas wirken.Falls das Glas nicht Transparent aussieht beim 
ausrendern, sollte man die Qualität vom Raytracing erhöhen. (Siehe „Render Engine Einstellungen“ Seite 82)

Die Flüssigkeit
1.	 Im Hypershade (Window > Rendering Editors > Hypershade) das gerade erstelle Glass Material selektieren

2.	 Mit STRG-D (Edit > Duplicate > Duplicate without Shading Network) ein Duplikat anfertigen. 

3.	 Im Attribute Editor das  Material “glass2” Material in “water” umbenennen. Unter Refraction die Farbe auf 
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einen Blauton setzen, und RefractionIndex auf 1.3 oder 1.2 setzen.

4.	 Die Gruppe “Liquid “auswählen.

5.	 Mit RMB auf die selectierte Gruppe klicken im MarkupMenu > Assign Existing Material > water.

Die Olive
1.	 RMB auf die Olive im MarkupMenu > Assign new Material

2.	 Im Menü Lambert auswählen.

3.	 Dem Lambert  (“Olive_material”)  einen Olivgrünen-Farbton (HSV 115, 0.8, 0.35) geben. 

4.	 Bei Bump Mapping auf das karierte Rechteck am Ende der Zeile klicken.

5.	 Im Menü Noise auswählen.

6.	 Bump Depth auf 0.1 setzen

7.	 zu “noise1” wechseln - Frequency Ratio 5, Depth Max 6

Der Zahnstocher
1.	 RMB auf den Zahnstocher im MarkupMenu > Assign new Material

2.	 Lambert wählen, es “wood” benennen.

3.	 Bei Color auf das karierte Rechteck am Ende der Zeile klicken.

4.	 Im Menü Wood auswählen.

5.	 Die Filler Color etwas aufhellen, die Layer Size auf 100 setzen (dies lässt die Jahresringe verschwinden) (mar-
tini_glas.06.mb)

Render Engine Einstellungen
1.	 Windows > Rendering Editors > Render Settings 
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2.	 Unter dem Reiter Qualitiy bei Quality Presets stellt man den Modus auf „Production“.

Anmerkung: Es gibt es eine Reihe von verschiedenen voreingestellten Presets.  Im “Draft” Modus ist der Renderer 
am schnellsten jedoch hat das ausgerenderte Bild eine geringe Qualität (z.B. ist das Glas wegen fehlender Lichtbre-
chung nicht transparent). Bei dem “Production” Preset werden viele der Einstellungen wie  z.B. Anti-Aliasing und 
Raytracing richtig eingestellt. Die Qualität und Renderzeit ist wesentlich höher. Dieses Preset bietet eine gute Grund-
lage für ein final Render. 

3.	 Im Indirect Lighting Reiter unter Environment, Image Based Lighting klickt man auf Create

4.	 Es öffnet sich nun der Attribute Editor. Unter Image Based Lighting Attributes - Image Name klickt man auf 
das Verzeichnis am Ende der Zeile. 

5.	 Man wählt nun ein Bild aus  das man für die indirekte Beleuchtung verwenden möchte. (Auf der Website: 
http://www.debevec.org/Probes/ findet man Sphärenbilder im .hdr format die man gut für diesen Zweck 
verwenden kann)

Anmerkung: Die Enviroment Map wird verwendet, damit das Glas etwas zum reflektieren hat. Es wird eine Sphäre 
um die gesamte Szene gesetzt und das Bild darauf projeziert. Deswegen sind die meisten Enviromentmaps Sphären-
bilder.

6.	 Bei den RenderSettings  unter Indirect Lighting aktiviert man Final Gathering.

7.	 Nun kann man das fertige Bild ausrendern. (martini_glas.final.mb)
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Animation
In den frühen Anfängen der Animation musste jeder Frame einzeln gezeichnet werden. DIn-betweens werden vom 
Computer errechnet.
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Workspace Einstellungen

Menü
Die Haupt Animations-Operationen für Keyframe Animation findet man im  “Animation” Menü (F2).

Shelf

Deformers

Animation

Panels

Graph-Editor

Playback Speed
Spielt man eine Animation in Maya ab, so wird die Animation „so schnell wie möglich“ abgespielt d.h. die Frame 
Rate in Maya bestimmt die Abspielgeschwindigkeit. Die Frame Rate ist direkt abhängig von der Komplexität der 
Szene und die Rechenleistung des Computers. Sie wird bestimmt durch Anzahl der Bilder(Frames) pro Sekunde. 
Insbesondere wenn man nur eine sehr einfache Szene hat kann es sein das z.B. man eine FrameRate von 120 Frames/
Sekunde hat. Ein normaler Film hat eine FrameRate von 24 bzw. 25. Die Animation würde daher 5x schneller als 
Normal abgespielt werden.

Man kann Maya jedoch auch limitieren in „Echtzeit“ also 24 Bilder/sek abspielen zu lassen. Mit RMB auf den Time 
Slider klicken und unter Playback Speed „Play Every Frame, Max Real-time“ aktivieren. 

Alternativ lässt sich das auch unter „Window  > Setting and Preferences > Preferences“ - TimeSlider Einstellen.

Frame Rate
Standartmäßig nimmt Maya an man entwickelt für Film also eine Framerate von 24 Bilder/sek. Man sollte immer 
am Anfang seines Projekts die richtige Framerate setzen. Die Einstellungsmöglichkeit findet man unter Window > 
Setting and Preferences > Preferences - Settings (Working Units)
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Grundlagen

Storyboard
Man sollte am Anfang bevor man sich an den Computer setzt ein klares Bild machen was man animieren möchte. 
Es ist sehr hilfreich ein Storyboard aufzumalen - es ist egal ob man malen kann oder nicht, Hauptsache man hat sich 
grob visualisiert was die Animation sein sollte.

Frames
Jedes Einzelbild einer Animation wird als Frame bezeichnet. Üblicherweise werden Animationen in Europa mit dem 
Pal-Standard 25fps(Frames per Second) abgespielt. Das bedeutet 1 Sekunde braucht 25 Frames.

Playback
Am Ende des TimeSliders hat man die Playback Controls. Klickt man Play wird die aktuelle Playback Range in einer 
Endlosschleife abgespielt.

Keyboard Shortcuts
ALT-V Playback starten/stoppen

ALT-SHIFT-V Playback auf Min Frame der Playbackrange setzen
. Zum nächsten Keyframe springen
, Zum vorhergehenden Keyframe springen

ALT-. Einen Frame vorwärts
ALT-, Einen Frame rückwärts

Keyframe Animation
Bei der Keyframe Animation werden in der Animation an bestimmten Zuständen Keyframes gesetzt und der Com-
puter errechnet sich dann alle Zwischenbilder. Möchte man z.B. eine Kugel in 1 Sek von Punkt A(0,0,0) zu Punkt 
B(10,0,0) bewegen, setzt man bei Frame 1 den Ball auf Punkt A und setzt einen Keyframe, und bei Frame 25 einen 
Keyframe mit dem Ball auf Punkt B.

Es wird in Maya immer zwischen zwei gesetzten Keyframes ein „Ease in and Ease Out“ verwendet. (Siehe „Arbeiten 
mit dem Graph Editor“ Seite 88)

Keyboard Shortcuts
SHIFT-W Transform Keyframe (XYZ)
SHIFT-E Rotate Keyframe(XYZ)
SHIFT-R Scale Keyframe (XYZ)

S Key All (Keyframe für Transform, Rotate, Scale)

Motion Path Animation
Bei der Motion Path Animation, setzt man ein Objekt auf einen vordefinierten Pfad über eine bestimmte Zeit hinweg 
wandert das Objekt den Pfad entlang. (Die Animation beginnt am Anfang der Kurve und endet am Ende der Kurve.)

Reaktive Animation (?)
Reaktive Animation benutzt man um Objekte reagieren zu lassen auf eine Animation. z.B. man bewegt ein Auto von 
A nach B, dann sollten die Räder sich dementsprechend drehen, dies wird mit Reaktive Animation gelöst.

Expressions
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Man kann eine Bewegung mit einer mathemeatischen Funktion definieren. Hierfür definiert man für jede Variable 
die man beinflussen möchte eine entsprechende Funktion.

Inverse Kinematics (?)
- Pose to Pose?

Animation Tools

Constrains

Deformers

Skeleton



88 || Animation

Arbeiten mit dem Graph Editor
Der Graph Editor ermöglicht einen die Keyframes Graphisch zu visualisieren sowie die Eigenschaften kontrollieren 
wie die Frames dazwischen interpretiert werden.

Linear

Beschleunigen

Abbremsen

Ease-In Ease-Out

Switch
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Keyframe Animation 
1.	 Eine Nurbs Sphere erstellen Create > Nurbs Primitives > Sphere (Radius 1,  TranslateX -12)

2.	 Mit der Sphere selektiert drückt man S, oder Animate > Set Key. Dies setzt einen Keyframe für die Scale/
Rotate/Translate Eigenschaften. In der Channel Box werden alle Elemente denen je ein Key zugewiesen ist 
rosarot unterlegt. In dem Time Slider wird ein roter Strich für den Keyframe des Objektes angezeigt (man 
muss dabei das animierte Objekt selektiert haben).

3.	 In der Zeitleiste klickt man nun auf Frame 50.  Frame 50 wird aber nicht angezeigt. Im Range Slider gibt 
man deswegen für den „End-Time of Playback“ 50 ein. Automatisch wird nun für die „End time of Anima-
tion“ der Wert 50 gesetzt.

4.	 Mit Frame 50 selektiert setzt man nun die Sphere auf TranslateX = 12. Mit S erzeugt man einen weiteren 
Keyframe.

Anmerkung: Per Default ist Autokeying eingeschaltet. Hat ein Objekt bereits einen Key wird für jede Veränderung 

Keyframe auf Frame1 in der Timeline (roter Strich)

„End-Time of Playback“ Blau umrandet
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automatisch ein neuer Keyframe gesetzt. Man muss daher immer nur den ersten Keyframe setzen und Maya setzt 
alle weiteren Keyframes automatisch wenn man das Objekt manipuliert. Am Ende des Range Sliders kann man Auto 
Keying ausschalten, indem man auf den Schlüssel klickt.

5.	 Im Time Slider kann man nun auf Play forwards klicken und man sieht die Animation in einer Endlosschleife. 

6.	 Nun setzen wir für Frame 4  TranslateY = 8, Frame 8  TranslateY = 0, Frame 12  TranslateY = 4, Frame 16  
TranslateY = 0, Frame 20  TranslateY = 2, Frame 24  TranslateY = 0.

7.	 Mit Play sieht man, dass der Ball für die erste Sekunde hüpft, jedoch für die zweite Sekunde sich unverändert 
fortbewegt.

8.	 In diesem Beispiel wäre es besser wenn der Ball für 2 Sekunden hüpft. Dies kann man leicht verändern, in-
dem man den Graph Editor verwendet Window > Animation Editors > Graph Editor. Im linken Teil sieht 
man die selektierten Objekte und die Keyframes. Im rechten Teil sieht man wie sich die Werte über die Zeit 
verändern als Graph. Die Punkte auf den Kurven sind die Keyframes.

9.	 Um sich einen besseren Überblick zu verschaffen, mit LMB auf TranslateY um alle anderen Werte auszublen-
den. (Mit LMB auf nurbsSphere1 werden wieder alle Werte angezeigt.)

10.	 Mit LMB eine rechteckige Selektion ziehen um alle Frames von TranslateY auszuwählen.

11.	 Im Graph Editor wird immer relativ zur Position des Mausklicks skaliert. Mit R (Scale Tool) mit MMB auf 
den Ursprung klicken und skalieren. Wenn der letzte Frame in dem Bereich 45.5-50.4 ist kann man aufhören 
zu skalieren.

12.	 Mit allen Keyframes selektiert geht man auf Edit > Snap - so werden allen Keyframes wieder ganze Zahlen 
zugeordnet.

Graph Editor

Graph Editor nach Skalieren
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13.	 Man kann den Graph Editor nun schließen und die Animation abspielen. Da der Ball eine konstante Ge-
schwindigkeit hat, wirkt die Sprungbewegung des Balles unnatürlich. 

14.	 Um nun effizienter mit dem Graph Editor zu arbeiten, kann man in der Toolbox das Icon persp/Graph kli-
cken.  Alternativ mit der Hotbox (Leertaste) > (North Sector)> LMB > persp/Graph. Die Animation kann 
nun abgespielt werden in der oberen Ansicht. In dem unteren Graph Editor kann man die Werte direkt 
verändern.

15.	 Man selektiert nun alle Keyframes mit TranslateY = 0 und macht im Graph View Menü > Tangents > Linear 

16.	 Beim abspielen sieht man nun die Kugel beschleunigen und abbremsen.

Deformers
1.	 Bei Frame 1 die Sphere selektieren und einen Nonlinear Deformer Squash erzeugen. (Create Deformers > 

Nonlinear > Squash).

2.	 Drückt man T (Show Manipulator Tool) kann man die Eigenschaften des Deformers kontrollieren. Für 
Frame 1 stellt man einen Faktor von -0.5 ein.

3.	 Drückt man Play, so sieht man, dass der Deformer sich nicht bewegt und sich die Kugel seltsam deformiert. 

4.	 Man muss den Deformer als Child Object von der Kugel setzen, indem man zuerst den Deformer selektiert, 
und dann die Kugel und anschließend P (Edit > Parent)

5.	 Nun bewegt sich der Deformer mit, jedoch bleibt der Faktor immer gleich. Diesen kann man nun auch mit 
Keyframes animieren. Um einen Keyframe für eine beliebige Eigenschaft zu setzen klickt man mit RMB  auf 
die Eigenschaft und erhält die Möglichkeit Key Selected (Channel Box) bzw. Set Key (Attribute Editor).

6.	 Man setzt nun immer wenn die Kugel den Boden berührt den Faktor auf -0.5 und für alle andere Keyframes 
hat es den Wert 0. (Mit Next Keyframe (.) und Previous Keyframe (,) lässt sich einfacher die verschiedenen 
Keyframes setzen)

Graph Editor mit Linear Tangents

Squash Factor -0.5
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Motion Path Animation
1.	 Create > Nurbs Primitives > Sphere

2.	 Mit den Curve Tools kann man eine Kurve in den Raum zeichnen. Sie sollte möglichst genau der gewünsch-
ten Bewegung entsprechen.

3.	 Man selektiert das Objekt (die Sphere) und die Kurve

4.	 Animate > Motion Path > Attach to Motion Path repositioniert das Objekt auf den Anfang der Kurve. (Der 
Control Vertex Point ist identisch zu dem ersten Punkt der Kurve.) Der Range Slider definiert, wann die 
Kugel anfängt die Kurve entlang zu fahren und wie lange sie braucht um das Ende zu erreichen. (Im Graph 
Editor kann man das auch nachträglich verändern.)

5.	 Die Kurve lässt sich im Edit Modus per CVs und EPs anpassen und die Kugel wird weiterhin entlang der 
Kurve bewegt.

Anmerkung: Weitere Keyframes um die Geschwindigkeit anzupassen erstellt man mit Animate > Motion Path > 
Set Motion Path Key
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Reaktive Animation
In Maya lassen sich reaktive Animationen mithilfe von „Driven Keys“ realisieren. Ein Attribut eines Driver-Objects 
beinflusst Attribute eines Driven-Objekts. 

Zahnräder
1.	 Create > Polygon Primitives > Pipe (Radius 2, Subdivision Axis 20)

2.	 Jedes zweite äußere Face selektieren und Edit Mesh > Extrude

3.	 Create > Polygon Primitves > Pipe (Radius 1, Subdivision Axis 10)

4.	 Jedes zweite äußere Face selektieren und Extude 

5.	 Das kleinere Zahnrad positionieren, sodass es mit dem größeren ver-
zahnt ist.

Driven Keys
1.	 Animate > Set Driven Key > Set...

2.	 Das große Zahnrad (pPipe1) selektieren und im „Set Driven Key“-Fenster „Load Driver“ 

3.	 Das kleine Zahnrad (pPipe2) selektieren und „Load Driven“

4.	 Die Attribute RotateY bei Driver und bei Driven selektieren (siehe Bild). 

5.	 Den Button „Key“ klicken. 

6.	 Das große Zahnrad (pPipe1) selektieren und im Channel Box RotateY = 360

7.	 Das kleine Zahnrad (pPipe2) selektieren und im Channel Box RotateY = -720

8.	 Den Button „Key“ klicken im „Set Driven Key“-Fenster

9.	 Rotiert man das große Zahnrad mit dem Rotate-Tool um die Y-Achse bewegt sich das kleine Zahnrad mit, 
jedoch nur in dem Wertebereich 0-360. Wird der Wertebereich verlassen dreht sich das kleine Zahnrad nicht

Schritt 2: Extrude
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10.	 Das kleine Zahnrad (pPipe2) selektieren und den Graph Editor öffnen. Man sieht es wurden Keyframes für 
den RotateY gesetzt.

11.	 Die Keyframes selektieren und Tangents > Linear um den „Ease-In  Ease-out“ zu entfernen.

12.	 View > Infinity (aktivieren) hier wird gestrichelt angezeigt, das vor und nach den Keyframes die Werte kon-
stant bleiben.

Schritt 4: Set Driven Key Fenster

Infinity Display
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13.	 Die Keyframes selektieren 

14.	 Curves > Post Infinity > Cycle with Offset

15.	 Curves > Pre Infinity > Cycle with Offset

16.	 Rotiert man das große Zahnrad  mit dem Rotate Tool um die Y-Achse bewegt sich das kleine Zahnrad mit 
für beliebige Werte von TranslateY des großen Zahnrads

Animation
Spielt man die Animation ab, so passiert nichts. Man muss für das Driver-Objekt (das große Zahnrad) Keyframes 
setzen. z.B. Frame 1 RotateY = 0, Frame 200 RotateY = 360

Infinity Werte angepasst, sodass die Werte sich linear erhöhen bzw. verkleinern
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Expressions
In dem Beispiel soll sich eine Kugel stetig auf und ab und sich zur Seite bewegen. Dies wird realisiert mit der Sinus-
funktion und einer linearen Funktion.

1.	 Create > Nurbs Primitives > Sphere

2.	 Window > Animation Editors> Expression 
Editor

3.	 Das Attribut translateX selektieren und den 
Ausdruck „translateX = time“ eingeben

4.	 „Create“ klicken. Im ChannelBox wird das At-
tribut blau unterlegt und kann nicht mehr mit 
normalen Keyframes animiert werden

5.	 Wenn man die Animation abspielt, bewegt sich 
die Kugel auf der X-Achse

6.	 Das Attribut translateY selektieren und die 
Expression „translateY = sin(time)“ 
eingeben

7.	 „Create“

8.	 Beim Abspielen bewegt sich die Kugel auf der 
Y-Achse auf und ab und auf der X-Achse linear Expression Editor
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Inverse Kinematics
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Camera Animation

Camera Rig
Mit einem Camera Rig, lässt sich flexibler mit einer Camera arbeiten. Der Locator wird benutzt um die Camera zu 
bewegen, gleichzeitig lässt sich mit dem Locator den Rotationspunkt verändern.

1.	 Create Locator

2.	 Create Camera

3.	 Parent Camera to Locator

4.	 Offset Camera on Y-Axis

Kamera Fahrten

Kamera Shake

Vertigo Effect
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Abschließende Bemerkungen

Kamerafahrt
In den meisten Beispielen wurde keine Kamerafahrt gemacht. Man sollte meistens zuerst die Kamerafahrt animieren 
und dann mit der eigentlichen Animation beginnen. So spart man sich die arbeit Objekte zu animieren die gar nicht 
von der Kamera erfasst werden.

Gruppen

Es lässt sich auch für jede 

Datei Referenzen und Null Objekte



100 || Animation

Render Einstellungen für Animationen
Wenn man eine Animation ausrendert macht man die ersten Render in möglichst geringer Qualität. Diese Pre-
Render dienen dafür um Feinabstimmung an der Animation vorzunehmen. Hierfür wird die Maya interne Render-
Engine verwendet um einen sog. Playblast zu erzeugen.

Ist man zufrieden mit der Animation kann man einen Render mit einer hoch qualitativen Render Engine zu machen. 
Jedoch sollte man beachten das die Renderzeit abhängig ist von wie komplex die Szene ist (je mehr Objekte, je mehr 
Spiegelungen etc.) Daher sollte man einen Testframe von der komplexesten Stelle in der Animation rendern um ein 
Gefühl zu bekommen wie lange die Animation rechnen wird. (Anzahl der Frames * Zeit benötigt für Frame  z.b. 5sek 
Animation = 125 Frames, 1 Frame braucht 5min > 125 * 5 = 625min = 10,5 Stunden). Man sollte alle anderen lau-
fenden Programme schließen damit soviel Rechenleistung wie möglich für den Renderprozess zur Verfügung steht.

Playblast
Ein Playblast rendert die Animation mit der Maya-Darstellungs engine aus - d.h. so wie gerade in einer Kameraper-
spektive die Szene angezeigt wird werden die Animation Einzelbilder ausgerendert.

Um einen Playblast zu erzeugen RMB auf den Timeslider > Playblast.

Der Playblast wird in dem Programm fcheck sofort angezeigt.

Batch Rendering
Man rendert niemals als eine einzelne Video-Datei. Während dem Rendervorgang kann der Computer abstürzen 
oder Fehler machen. Man rendert stattdessen eine Serie von Einzelbildern als „Batch-rendering“ Vorgang. Beim Bach 
Rendering wird eine Serie von Bildern im Hintergrund ohne graphische Ausgabe vom Bild zu bearbeitet. 

1.	 Als erstes sollte man das Image Format auf „Targa (tga)“ setzen. 

2.	 In den Render Settings unter Common : File Output wechselt man das “Frame/Animation” auf  “name.#.ext”

3.	 Sobald man eine Animation anstatt eines Frames ausgewählt hat ist “Frame Range” nicht mehr ausgegraut 
und man kann den Start und End Frame der Animation eingeben.

4.	 Man sollte umbedingt bevor man anfängt zu rendern nochmals überprüfen, das man auch die Richtige Ka-
mera ausgewählt hat bei “Renderable Cameras”. 

5.	 Das Render Settings Fenster kann man nun schließen und über Render > Batch Render  startet man das 
Rendern der Animation.

Dateiformate
Viele Dateiformate eignen sich nicht als Ausgaabeformat. Das Jpeg-Format ist beispielsweise stark komprimiert und 
erzeugt bei der Kompression Bildartefakte. Um das Maya iff-Format in anderen Programmen zu bearbeiten braucht 
man zusätzliche Plugins.2

Targa

Tiff

OpenEXR
Entwickelt von ILM 

Indirekte Beleuchtung
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Fertige Batch Render Settings für eine Animation von Frame 1-10, Wichtig: nochmal runterscrollen und 
überprüfen ob die richtige Kamera ausgewählt ist.
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Dynamics
Bei der Dynamic Animation werden für ein Objekt physikalische Eigenschaften wie Richtung, Geschwindingkeit, 
Reibung, Masse, Masseschwerpunkt, etc. gesetzt. Dieses Verfahren ermöglicht realitätsnahe Animationen durch eine 
echte Physik-Simulation.
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Workspace Einstellungen

Menü
Einfache Physik Simulationen findet man im „Dynamics“ Menü (F5). Erweitererte Physik Simulationen findet man 
im „nDynamics“ Menü (Kein Shortcut).

Shelf

Dynamics

Panels

Playback Speed
(Siehe „Playback Speed“ Seite 85)

Frame Rate
(Siehe „Frame Rate“ Seite 85)
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Grundlagen
Um mit Maya Dynamics zu arbeiten muss man zunächst Rigid Bodies deklarieren. Alle Objekte ohne Rigid Bodies 
werden von der Dynamic Simulation nicht beachtet. Active Rigid Bodies werden von  physikalischen Eigenschaften 
beeinflusst. Passive Rigid Bodies dienen als Collisions Objekte für die active Rigid Bodies.

Rigid Bodies Attribute

Initial Velocity (XYZ)
Bestimmt den Bewegungsvektor am Anfang der Simulation. Aus diesem wird die Geschwindigkeit und Richtung 
des  Objekts bestimmt. 

Initial Spin (XYZ)
Bestimmt die Geschwindigkeit und Richtung in der das Objekt um sich selbst dreht am Anfang der Simulation.

Center of Mass (XYZ)
Verändert man diesen Wert verschiebt man den Schwerpunkt des Objekts, was wiederum den Rotationspunkt des 
Objekts beinflusst.

Impuls (XYZ)
Während die Simulation wird durch den Impuls die Geschwindingkeit in die Richtung des Impulses konstant erhöht.

Impuls Position (XYZ)

Spin Impuse (XYZ)
Während die Simulation wird durch den Spin Impuls die Rotation in die Richtung des Spin Impulses konstant er-
höht.

Mass
Bestimmt das Gewicht und somit das Verhalten des Objekts mit anderen Objekten.

Bounciness
Bestimmt wie stark das Objekt von anderen Objekten abprallt / hüpft.

Dampening
Die Energie des Objekts wird mit diesem Faktor gedämpft der Wertebereich sollte zwischen 0 und 1 liegen.

Static Friction
Wenn das Objekt im völligen Ruhezustand ist und sich die Umgebung verändert, dann bestimmt die Static Friction 
wie hoch die Reibung ist von dem Objekt.

Dynamic Friction
Während sich das Objekt bewegt bestimmt die Dynamic Friction die Reibung für das Objekt.

Collision Layer
Man kann mit der Collision Layer Objekte die miteinander agieren gruppieren um den Simulationsaufwand zu redu-
zieren. Nur Objekte mit dem gleichen Collision Layer Wert kollidieren miteinander.

Möchte man ein Objekt haben was mit allen Objekten interagiert, z.B. für ein Boden, setzt man den Wert auf -1.

Fields
Man kann active Rigid Bodies mit verschiedenen Fields beeinflussen wie z.B. Schwerkraft (Gravity). 

Selektiert man Geometrie Objekte und erstellt ein Field wird automatisch ein active Rigid Body für das Objekt er-
zeugt. Möchte man später noch weitere Objecte dem Field hinzufügen selectiert man das Objekt und das Field und 
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geht auf Fields > Affect Selected Objects. Alternativ kann man die Verbindungen mit dem  Dynamics Relationship 
Editor (Windows > Relationship Editors > Dynamic Relationship Editor) bearbeiten.

Constrains
Alle Constrains findet man im Menü Soft/Rigid Body.

Nail

Pin

Hinge
Erzeugt eine RotationsAchse an der ein Rigid

Spring

Barrier
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Basic Dynamics

Ball und schiefe Ebene

1.	 Die „End-Time-of-Playback“ auf 200 setzen

2.	 Create > Nurbs Primitves > Plane (Width = 30, RotateX = 30)

3.	 Create > Nurbs Primitves > Sphere (TranslateY = 12)

4.	 Mit der Sphere selektiert Soft/Rigid Bodies > Create Active Rigid Body (Die Werte die von dem Rigid Body 
beeinflusst werden, können nun nicht mehr verändert werden und sind gelb unterlegt.)

5.	 Mit der Sphere selektiert Fields > Gravity. Dies erzeugt eine Gravitation mit Beschleunigungsfaktor 9.8

6.	 Drückt man auf Play sieht man die Kugel fallen, jedoch fällt sie einfach durch das Planar hindurch.

7.	 Mit dem Plane selektiert Soft/Rigid Bodies > Create Passive Rigid Body (Die Gravity wird die Plane nicht 
beeinflussen)

8.	 Drückt man nun auf Play kollidiert die Kugel mit der Plane und springt zur Seite. Mit den verschiedenen 
Attributen des Rigid-Body wie z.B. Bounciness, Mass, Static Friction, Dynamic Friction.

 Bake Animation
Ist man zufrieden wie der Ball fällt wandelt man die Simulation in eine Keyframe Animation um. 

9.	 Edit > Keys > Bake Simulation q 

10.	 In den Optionen stellt man Channels auf „From Channel Box“, Smart Bake aktivieren, Increase Fidelity ak-
tivieren und Fidelity Key Tolerance auf 1.0 setzen.

11.	 Ohne das Fenster zu schließen selektiert man die alle Objekte die man umwandeln möchte (in diesem fall nur 
die Sphere) und selektiert die Channels für die man Keys haben möchte (siehe Bild)

12.	 Den Button „Bake“ klicken. Die Animation wird einmal abgespielt um die Keyframes zu setzen
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13.	 Damit die Sphere jetzt die Keyframes verwendet und nicht simuliert wird selektiert man die Sphere und Edit 
> Delete by Type > Rigid Body

14.	 Nun kann man kleinere Anpassungen machen und die Keyframeanimation beliebig ändern.

Bake Simulation Optionen

Selektierte Channels
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Newton’s Cradle 
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Rope Tutorial
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Shattering Effects
Mit Maya Dynamics lässt sich 

DMM Cinematic Effects
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Particle Effects
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Dynamics Performance verbessern

Simple Collisions Objects
Um die Simulationsgeschwindigkeit zu erhöhen sollte man möglichst einfache Objekte, also Objekte mit möglichst 
wenigen Polygonen, verwenden. Je höher die Komplexität (Anzahl der Polygonflächen) desto höher ist der Berech-
nungsaufwand von der Simulation. 

Man sollte zusätzlich simple Objekte (Proxys) modellieren die für die Simulation verwendet werden. Dies können 
beispielsweise einfache Poly Cube Objekte sein. Für active Rigid Bodys verbindet man das komplexe Objekt mit 
Constrain > Parent an den Proxy-Körper. Alle Proxies werden auf eine eigene Displayebene hinzugefügt. Deaktiviert 
man die Visibility der Ebene wird die Simulation weiterhin ausgeführt, jedoch sieht man nur die komplexen Objekte.

Solver Einstellungen

Solver Genauigkeit

Multiple Solver

Cache Simulation
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Render Einstellungen für Dynamics

Bake Animation
Eine Dynamic Animation lässt sich in Keyframes umwandeln. Dies hat den Vorteil, das es nicht nochmal simuliert 
werden muss sowie jedes mal die gleiche Animation abgespielt wird.

Graph Editor simplify Keys

Rendern
Nachdem man „Bake Animation“ ausgeführt hat und man fertig ist mit der Gesamten Simulation geht  man auf Edit 
> Delete All by Type > Rigid Bodies um sicherzustellen, das nur die Keyframes zur Animation verwendet werden.

Danach Rendert man die Animation aus. (Siehe „Render Einstellungen für Animationen“ Seite 100)
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Martini Glas nDynamic Fluid
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nCloth



Advanced Modeling



Allgemeine Tools

Duplicate Special

Align Tool

Circle in poly

Character Modelling

Building Modelling / Room Modelling
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Advanced Rendering
Techniken um die Renderzeiten zu verkürzen, sowie spezielle Rendereffecte erzeugen.
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Mental Ray: Anti-Aliasing
Beim ausrendern kann es vorkommen, das die Kanten bzw. Bereiche mit einem hohen Kontrast von Objekten sehr 
verpixelt und nicht glatt ausgerendert werden. Anti-Aliasing, verbesstert die Kantenglättung. Unter Render Settings 
bei Quality, Anti-Aliasing Quality findet man alle Einstellungsoptionen.

Anti-Aliasing Quality

Sampling Mode
Adaptive Sampling ist die Beste Einstellung um nicht 
die Rechenzeit unnötig zu erhöhen. Die Minimum 
Sample Level ist um 2 niedriger als die Maximum Sam-
ple Level.

Fixed Sampling setzt die Min und Max Sample Level 
auf das gleiche Level. (Dies erhöht nur die Rechenzeit 
ohne einen sichtbaren Effekt auf das finale Bild)

Custom Sampling lässt beliebige Werte setzen für das 
Min und Max Sample Level. 

(Min/Max) Sample Level
Das Sample Level bestimmt die Anzahl der Pixel die 
benutzt werden um die Glättung zu errechnen. Da die 
Renderzeit für Anti-Aliasing exponentiell steigt, sollte 
man nur wenn es nötig ist die Max. Sample Level er-
höhen. 

Diagnose Samples
Wenn man das Häckchen bei Diagnose Samples setzt, 
so wird das Bild ausgerendert und danach wird ein Bild 
gezeichnet wo Anti-Aliasing berechnet wurde. Diese 
Darstellung hilft zu sehen wo es Probleme beim Anti-
Aliasing gibt.

Anti-aliasing Contrast
Der Anti-aliasing Contrast, bestimmt welches Sampling Level verwendet werden soll. Je niedriger der Wert, desto 
niedriger muss der Kontrast sein zwischen zwei Pixeln damit das Max. Sample Level verwendet wird. je höher der 
Wert desto seltener wird das Max. Sample Level benutzt.

Multi Pixel Filtering

Filter
Bestimmt das Weichzeichner-Verfahren. Man kann zwischen Box, Triangle, Gauss, Mitchell, Lanczos wählen. 

Filter Size
Bestimmt die größe der FilterMatrix, d.h. wieviele umliegende Pixel in die Weichzeichen Berechnung eines einzelnen 
Pixels einfließt.

Anmerkung: Eine gute Einstellung für das Multi-Pixel Filtering ist der Gauss Verfahren mit Werten von 2.5 oder 
2.0, zu hohe Werte können das Bild zu weich erscheinen lassen.

Arbeiten mit Anti-Aliasing
Bei Draft-Render Qualität braucht man sich nicht um Anti-Aliasing kümmern. Adaptive Sampling, Min Sample 
Level 0 und Anti-aliasing Contrast 0.1 beeinflusst kaum die Renderzeit.

Anti Aliasing Settings
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Motion Blur

Render Diagnostics

wiederverwendung von final gather
wiederverwendung von depthmap etc.

Bei Production-Render Qualität sollte man die Einstellungen auf Adaptive Sampling, Min Sample Level 2 und Anti-
Aliasing Contrast 0.1 setzen. 

Ein Wert von 2 für die Max. Sample Level ist ein guter Wert für das Verhältnis Qualität zu Rechenzeit. Ist das nicht 
ausreichend, sollte man  in 0.1 Schritten den Anti-aliasing Contrast verringern. Bei einem Wert von unter 0.01 sollte 
man die Max Sample Level erhöhen und den Anti-Aliasing Contrast wieder auf 0.1 setzen.

Mental Ray: 32-Bit Workflow
Mit den Standard Einstellungen werden die Bilder mit einer 8-Bit Farbtiefe ausgerendert. Jedoch lassen sich die Bilder 
auch in einer 16-Bit bzw. 32-Bit Farbtiefe ausrendern. 

werden Bilder ausgerendert statt einer 8-bit Farbtiefe sondern mit einer 32-bit Farbtiefe. Dies ermöglicht es einem in 
der späteren Post-Production auf mehr Farbdaten zuzugreifen und somit einfacher auf die Beleuchtungssituation im 
Bild zu verändern.

Depth of Field

Photoshop

Depth of Field

mia_lens_bokeh
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Paint Effects 
Paint Effects sind Effekte die man direkt als Körper zeichnen kann, oder auf einem bestehenden Objekt erstellt.Man 
findet die vorgefertigten Paint Effecte unter Window > General > Visor hier dann den Reiter „Paint Effects“.

Um einen Paint Effect auf ein Objekt anzuwenden selektiert man das Objekt  und macht es „paintable“ (Paint Effects 
> Make Paintable). Im Visor selektiert man dann einen Brush den man verwenden möchte und zeichnet dann auf 
das Objekt. Im Attribute Editor kann man dann weitere Eigenschaften anpassen.

Anmerkung: Falls der Pinsel auf der falschen Seite der Oberfläche zeichnet, so macht man den letzten Schritt rück-
gängig. Man muss die Richtung der Normalen korrigieren. Man wählt das Objekt aus und sagt für ein Nurbs Objekt 
“Edit NURBS > Reverse Surface Direction”, oder für ein Poly-Objekt “Normals > Reverse”. 

Mental Ray kann „Paint Effects“ nicht ausrendern. Man muss daher zuerst den Effect in ein Polygonobjekt umwen-
deln über Modify > Convert > Paint Effects to Polygon. Danach muss man dem Objekt einen Shader zuweisen.

Roter Strich zeigt nach außen (die Norma-
len sind korrekt)

Mit dem „waterMesh“-SurfaceBubbles 
Brush auf dem Glas gezeichnet 

Painteffect in Polygone umgewandelt und 
mit Mental Ray ausgerendert
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Mental Ray: Physical Sun and Sky
Um eine Außenbeleuchtung zu simulieren, kann man das dafür spezialisierte „Physical Sun and Sky“- Shading Net-
work verwenden. Die Besonderheit an diesem Shading Network ist, das man es sehr leicht verwenden kann um eine 
realistische Sonne mit einem Himmel zu erzeugen.

Um das „Physical Sun and Sky“-Network zu verwenden geht man unter Render > Render Settings  unter Indirect 
Lighting unter Enviroments findet man „Physical Sun and Sky“ und klickt auf den „Create“-Button. Final Gather 
wird automatisch mit den Standarteinstellungen aktiviert sowie ein Direktionales Licht in der Szene erstellt mit dem 
Namen „sunShape“.

Das Licht „sunShape“, hat als einzige Funktion den Einfallwinkel der Sonne zu bestimmen. Die meisten Einstel-
lungsmöglichkeiten bzgl, Intensity, Schatten etc. werden überschrieben von dem „mia_physicalsky1“. 

Wichtigsten Attribute des „mia_physical_sky“:

Multiplier
Multipliziert die Intensität des Lichts, kann verwendet werden um das Licht zu verstärken oder zu schwächen.

Haze
Mit einem Wert von z.B. 5 lässt sich der Smog einer Stadt simulieren.

Red/Blue Shift
Positive Werte z.B. 0.5 verschieben das Sonnenlicht in das rote Farb Spek-
trum (z.B. in Wüsten, Mars), negative Werte z.B. -0.5 in das blaue Farb Spek-
trum (z.B. auf fremden Planeten). 

Saturation
Bestimmt die Farbsättigung des Himmels. Ein Wert von 0 erzeugt einen 
grauen Himmel, Werte über 1.0 erhöhen die Farbintensität des Himmels.

Horizon Height
Mit diesem Wert kann man die position der Horizontlinie bestimmen. In 
vielen Fällen benutzt man einen Negativen Wert von z.B. -5 um die Hori-
zontline verschwinden zu lassen.

Horizon Blur
Der Grad indem die Horizontline verschwommen wird. Ein kleiner Wert ist 
meistens ausreichend.

Ground Color
Hier lässt sich die Farbe des Bodens bzw. eine Bodentextur bestimmen.

Night Color
Zeigt das Directionale Licht „sunShape“ direkt auf die Kamera so sieht man 
eine Sonnenscheibe.

Sun Disk Intensity
Bestimmt die Leuchtkraft der Sonnenscheibe

Sun Disk Scale
Bestimmt die Größe der Sonnenscheibe

Sun Glow Intensity
Bestimmt das Leuchten des Randes der Sonnenscheibe. Niedrige Werte er-
zeugen einen schärfen Rand.

Um die Schatten Qualität zu verbesseren findet man im Attribute Editor den Node „mia_physical_sun“. Das Attribut 
„Shadow Softness“ bestimmt die Härte der Schatten und „Samples“ bestimmt die Qualität der Schatten.

Das Shading Network wird beim erzeugen direkt an alle perspektivischen Kameras angebunden. Erzeugt man eine 

<Beschreibung>

<Beschreibung>

<Beschreibung>
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neue Kamera und Rendert das Bild aus, so wird zwar die Szene mit dem direktionalen Licht ausgeleuchtet, jedoch 
verschwindet der Himmel. Dies kann man korrigieren, indem man im Attribute Editor des „mia_physical sky“ auf 
den Button „Update Camera Connections“ klickt. 

Anmerkung: Beim ausrendern wird der „Physical Sun and Sky“ nicht in den Alpha Kanal gespeichert. Beim öffnen 
der resultierenden Bilder in Composite oder After Effects wird daher Der Himmel nicht angezeigt. Man muss jedig-
lich den Alphakanal deaktivieren um mit dem Himmel zu arbeiten.
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Mental Ray: mib_blackbody
Ein “Blackbody” (schwarzer Körper) ist ein idealisierter 
Körper in der Physik der jedes Licht (bzw. elektroma-
gnetische Strahlung) vollständig absorbiert. Eine wei-
tere Eigenschaft ist, dass der Körper auch Strahlung 
aussenden kann aufgrund der Temperatur des jeweil-
gen Spektrums. Jede reale Lichtquelle hat ihre eigene 
Temperatur z.B. eine Glühbirne 2800K (gelblich), Ta-
geslicht (5500K), bedeckter Himmel 6500K -7500K 
(bläulich) Auf dem Planckian locus lassen sich die je-
weiligen Temperaturen zu Farben ablesen.

Möchte man eine bestimmte Lichtquelle simulieren, 
braucht man nur zu wissen welche Farbtemperatur die 
Lichtquelle hat und man kann sie dann in Maya mit 
dem mia_blackbody-Node simulieren. 

Beispiel Glühbirne:
1.	 Einen Glaskörper für die Glühbrine erzeugen

2.	 Man erstellt ein AreaLight, mit dem Mental 
Ray Use Shape Attribut „Sphere“ (So lässt sich 
die Größe der Lichtkugel bestimmen)

3.	 Die Decayrate auf „Quadratic“ setzen.

4.	 Bei dem Farbattribut klickt man auf das „Create Render Node“-Icon. Unter mental Ray - Mental Ray Lights 
selektiert man „mib_blackbody

5.	 Für das „mib_blackbody“ gibt es nur die Einstellungen Temperature (z.B. 2800K Wolfram Draht Glühbirne) 
und Intensity. Grundsätzlich steuert man die Intensity des Lichtes über diesen Wert d.h. die Lampe hat einen 
Intensity Wert von 1.0 und der Blackbody hat dann den tatsächlichen Intensity Wert. z.B. 25.

Anmerkung: Im Hypershade lässt sich der „mib_blackbody“-Node „outValue“ mit multiplen Lampen („color“) ver-
binden. So lassen sich mehrere Lampen gleichschalten.

Der Planckian Locus, mit eingezeichnerter Temperaturkurve
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Windows Command Line Rendering
Man kann mit der Commando Zeile rendern. Dies ist sehr vorteilhaft, da Maya hierfür nicht gestartet werden muss. 
Daher sind mehr Ressourchen frei um zu Rendern. Das gibt das einen kleinen Geschwindigkeits Bonus. 

Vorbereitungen
1.	 Unter den Systemeinstellungen unter Erweitert klickt man auf Umgebungs Variablen.

2.	 Hier wählt man nun unter den System Variablen die Path Variable und klickt Bearbeiten.

3.	 Wichtig! Am Ende der Zeile fühgt man den Pfad zum Maya Bin Ordner hinzu.​ Der Standard Pfad ist: 
„C:\Program Files\Autodesk\maya2011\bin“ (Es sollte vor und nach dem Eintrag ein „;“ stehen)

Rendereinstellungen
Unter dem Startmenü einfach in die Suchleiste „CMD“ eingeben um die Command Promt zu öffnen.

Man kann nun mit der Command Line in den Projektordner navigieren bzw. zu der Szene die man rendern möchte.

CD C:\users\<username>\<Eigene Dateien>\maya\projects\<projektname>\scenes

Mit Render (Flags) <dateiname> lässt sich die Datei Rendern. Es werden die Einstellungen aus den Ren-
derSettings übernommen (falls man sie nicht mit Flags überschreibt). Flags sind optionale Zusatzbefehle für den 
Renderer. Flags müssen vor dem Dateinamen eingefügt werden.

Nützliche Flags:

•	 -help (Render -help) öffnet die Hilfe (Anzeige von allen Flags).

•	 -r <RenderEngine> wählt man die Renderengine (mr für MentalRay).

•	 -s <Startframe> -e <Endframe> lässt sich eine Animation ausrendern.

•	 -cam <CameraName> wählt man die Camera.

•	 -rd <Path> bestimmt man den Pfad wo man die fertige Datei rendern möchte.

Ein Beispiel Befehl könnte sein:

Render -r mr -s 1 -e 125 -cam camera1 -rd C:\ani _ ball ball.mb

(In Worten: Es wird die ball.mb mit MentalRay Frame 1-125 von camera1 ausgerendert die fertigen Dateien werden 
in den Ordner ani_ball gespeichert.)

Batch Datei
Möchte man mehrere Dateien ausrendern schreibt man mehrere Zeilen in eine Text datei und trennt sie mit ENTER. 
Beispiel:

Render -r mr -s 1 -e 125 -cam camera1 ball.mb 
Render -r mr -s 126 -e 200 -cam camera2 ball.mb

Anschließend speichert man die Datei und ändert die Dateiendung von .txt zu .bat. Mit Doppelklick auf die .bat 
Datei wird das Skript ausgeführt.

Möchte man den Vorgang abbrechen drückt man „STRG-C“. bzw. im Task Manager (STRG-ALT-ENTF) den Pro-
zess „Render“ abrrechen.
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Mental Ray Satellites (Grid-Rendering)
Wenn man im Besitz von mehreren Computern ist kann man die kombinierte Rechenleistung verwenden um Bilder 
auszurendern. Dies wird mit “Mental Ray Satellites” ermöglicht. Die Computer sollten am Besten in einem Netzwerk 
mit 100MB/s verbunden sein, da am Anfang alle Texturen auf jeden einzelnen Computer übertragen werden. Unter 
gewissen Umständen ist es langsamer mit Netzwerk zu rendern als ohne Netzwerk wenn die Szene sehr simpel ist und 
die Texturen sehr groß sodass die Übertragung länger dauert als das Bild auszurendern.

In dem Netzwerk gibt es den Master Computer, auf dem Maya installiert ist und Slaves auf denen “Mental Ray  Sa-
tellites installiert sind. 

Installation auf den Hosts (Slaves):
1.	 Mental ray Satellite installieren 

2.	 Schritte in der Readme.txt befolgen um zu verifizieren das der Dienst gestartet ist. 

Mental Ray Satellite Downloads:

Maya 2011 Service Pack 1: http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=15770983&lin
kID=9242259

Maya 2012 Hotfix 2: http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=17137651&link
ID=9242259

Konfiguration von Maya:
1.	 Zunächst eine Textdatei anlegen und umbenennen auf maya.rayhosts

2.	 In der Datei werden alle Netzwerkkennungen der Slaves aufgelistet die man für das rendern benut-
zen möchte. Sie müssen im Netzwerk in dem man sich befindet erreichbar sein (d.h. Firewalls für die je-
weiligen Ports deaktivieren und Maya zugriff auf das Netzwerk gewähren etc.)  Das Format für die Ein-
träge ist:  “hostname:<Port number>” als Beispiel pc-host1 und pc-host2 mit dem Default Port 7411 
 
PC-HOST1:7411 PC-HOST2:7411

Anmerkung: Mit  # vor einer Zeile kommentiert man die Zeile aus und wird von Maya nicht beachtet

3.	 Alternativ kann man die IP-Adresse verwenden. z.B. 192.168.0.10:7411

4.	 Die Datei maya.rayhosts muss sich in “prefs” Verzeichnis befinden:

      Windows 7

         32-bit:	 \Users\<username>\Documents\maya\2011\en_US\prefs

         64-bit:	 \Users\<username>\Documents\maya\2011-x64\en_US\prefs

      Mac OS X

          /Users/<username>/Library/Preferences/Autodesk/maya/en_US/2011/prefs

      Linux (64-bit)

          ~/maya/2011-x64/prefs

Anmerkung: Als Alternative kann man die maya.rayhosts Datei in das Installationsverzeichnis verschieben. Befin-
det sich im User Verzeichnis eine weitere rayhosts Datei, so wird diese verwendet. 
	 Linux /usr/autodesk/maya2011-x64/ 
	 Windows C:\Program Files\Autodesk\maya2011\ 
	 Mac OS X /Applications/Autodesk/maya2011/
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Eine Datei über das Netzwerk rendern:
Per Default ist bereits immer Lokales und Netzwerkrendern aktiviert.

Unter Render > Render Current Frame q bzw. Render > Batch Render q unter Network kann man diese Ein-
stellung ändern.
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Anhang
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Anhang A: Post-Production mit Autodesk Composi-
te
Im Post-Production Schritt gibt es mehrere Programme die in der Industrie verwendet werden. Die Bekanntesten sind 
Adobe - Aftereffects, The Foundry - Nuke, und Autodesk Composite und etliche andere Programme. 

Das gängiste Einsteiger Programm ist Adobe After Effects. Dieses Programm ist Ebenen basiert und somit sehr intu-
itiv. Man kann sich leicht vorstellen wie eine Ebenen übereinander liegen.

Die meisten industriell verwendeten Programme sind Node basiert (wie Nuke oder Composite). Der Vorteil von 
solchen Programmen ist, dass das Node-Netzwerk als Skript ausgespeichert wird und man es sehr leicht wiederver-
wenden kann für multiple Projekte. Ein weiterer Vorteil ist, das die Nodes sofort angezeigt werden können durch 
ihre Input und Output Eigenschaften daher braucht man keine „Pre-Comps“ wie bei Layer basierten Programmen.

Übersicht der Wichtigsten Nodes:

Blend/Comp

Um zwei Filme inenander überblenden zu lassen braucht man ein „Blend/Comp“ Node.

CC Color

Curves

CC Hist

Add Grain

Post-Production ist eine Kunst für sich. Die wichtigste Regel bei der Post Production ist das man nur subtile Verän-
derungen macht.

3D gerenderte Bilder tendieren dazu sehr „perfekt“ zu wirken. Die Realität ist jedoch ist nicht perfekt. Bei der Post-
Production sollte man daher immer das Bild leicht „verschlechtern“ mit z.B. Add Grain. Die Bilder werden wesentlich 
realistischer wirken.
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Anhang B: Bildersequenz in eine Video Datei um-
wandeln
Alle gängigen Videobearbeitungssoftware können aus einer Serie von Einzelbildern Videosequenzen erzeugen. Man 
muss darauf achten, dass die Einzelbilder nummeriert und vollständig sind.

Photoshop
Seit der CS3 Version von Photoshop lässt sich Video direkt in Photoshop editieren. Photoshop ist limitiert nur das 
Bildmaterial von Videos zu editieren.

1.	 Um eine Bilderserie als Animation zu öffnen muss man über das Menü Datei > Öffnen gehen und selectiert 
die erste Datei der Sequenz aus. 

2.	  Man setzt ein Häckchen bei Image Sequence.

3.	 Als Standartwert rendert Maya die Animation mit 24 Bildern/Sekunde, dies muss man dann im Dialog-
fenster eingeben.

4.	 Man sieht nun in den Layers ein kleines zusätzliches Filmicon was andeutet das es sich um eine Animation 
handelt.

5.	 Um die Animation abzuspielen, geht man unter Window > Animati-
on. Hier erhält man ein Fenster mit weiteren Kontrollen.

6.	 Man kann nun die Animation und die Einzelbilder mit Ebenenef-
fecten wie z.B. Levels, Contrast manipulieren.

7.	 Die Animation kann man nun ausrendern unter Datei > Export > 
Render Video.    

8.	 In dem Dialogfenster bennent man die Datei und den Pfad wohin die 
Datei gespeichert werden soll. Verändertes Layer Icon

Open Dialog

Frame Rate Dialog
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9.	 Man stellt die Rendersettings, auf Quicktime Movie mit dem Codec H.264 (High Quality, RGB 24bits) 
eingestellt sind.  (Falls der Codec H.264 nicht eingestellt ist, klickt man auf Settings, Im Movie Settings 
Fenster klickt man dann im Videobereich auf Settings und wählt dann als Compression Type H.264 aus 

dem Dropdownmenü aus.)

Virtual Dub
Eine kostenlose Alternative ist Virtual Dub (Download unter www.virtualdub.org)

1.	 Man öffnet die Bildsequenz mit Datei > Öffnen. Hier wählt man das erste Bild der Sequenz aus.

2.	 Unter Video > Compression wählt man den Codec aus den man verwenden möchte. (Es bietet sich hier z.B. 
der Xvid Codec an www.xvid.org)

3.	 Optional: Einsatz von Filtern mit Video > Filter

4.	 Unter Datei > Save as Avi wird die Datei als Video-datei abgespeichert.

Animation Timeline, mit unten links Kontrollen zum abspielen der Animation
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Anhang C: MEL Skripting
Man kann alle Funktionen von Maya mithilfe von MEL-Skripten ansteuern.

Shelf Customization

Scripts

Activate Mental Ray Plugin

//Loads mentalRay if not yet active

if(!̀ pluginInfo -query -loaded -name „Mayatomr“̀ ) {

	 loadPlugin Mayatomr;

	 pluginInfo -edit -autoload true Mayatomr;

}

//sets Renderer to MentalRay

setAttr „defaultRenderGlobals.currentRenderer“ -type „string“ „mentalRay“;
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Punkte / Schein Kriterium
Jeder Teilnehmer des Kurses muss eine 5-10-Sekunden Animation abgeben Das Thema ist frei wählbar.

Abgabe Termin: 30.9.11

Um zu bestehen müssen folgende Kriterien erfüllt sein:

1.	 Eigene modellierte Modelle (Hauptobjekt, Umgebung)

2.	 Materialien für die Modelle

3.	 Direktes Licht und Schatten für die Szene (wo passend)

4.	 Indirektes Licht (Global Illumination, Final Gather)

5.	 Eine Animation des Hauptobjekts (Keyframe Animation oder Dynamics)

6.	 natürliche Kameraführung 

7.	 Ein nicht triviales Objekt (frei wählbar aus Modelling, Lighting&Materialien oder Dynamics&Animation)

8.	 Kommentare, Anmerkungen und Verbesserungsvorschläge zu der „finalen Abgabe“ müssen umgesetzt werden

Auf freiwilliger Basis kann man auch vor der finalen Abgabe ein Storyboard, ein Pre-Render (Einzelbild ausgeren-
dert). und ein Playblast abgegeben werden die kommentiert werden.

Abgabe:
Eine Email an: borgfriend@gmx.net

Betreff: PKMM SS11 Finale Abgabe

Inhalt: 

-- Vorname, Nachname, Matrikelnummer, (Bachelor/Diplom)

-- Projektdatei (*.ma) und zugehörige Dateien (Texturen etc.) (ohne Einzelbilder)

-- VideoDatei mit der ausgerenderten Animation. (Kompression H264, AAC) 

Anhang als zip-Datei “vorname_nachname.zip” (max. 10MB Dateigröße) (Alternativ Download Link)

Anmerkungen:
Die Kritierien sollen nur die Animation unterstützen. Der Arbeitsaufwand für das Projekt sollte um die ca. 50-60+ 
Stunden sein.

Die Animation kann ein beliebiges Seitenverhältnis haben. 4:3, 16:9 oder andere Kino-Formate sind zulässig. (Breite 
min. 640px)

Die Animation wird später auf der Medieninformatik Website veröffentlicht. Wenn dies nicht erwünscht ist, bitte in 
der Abgabe anmerken.

Objekte/Materialien die von Websiten verwendet werden müssen in einer seperaten Text-Datei deklariert werden und 
möglichst in der Szene im Objektnamen vermerken.

Fragen, per Email und möglichst mit angehängter Szene-Datei (.ma)


