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Rendering
“There’s nothing quite like turning a grey-shaded model into something that looks real - or that could be real.” Lee Lainier

Rendering ist der Vorgang indem aus der modellierten Szene ein Bitmap-Bild errechnet wird. Hierfür muss man dem Modell 
mehrere Eigenschaften zuweisen, wie z.B. Lichter, Schatten, Materialien etc.

Render-Vorbereitungen
Das Rendern braucht sehr viel Rechenleistung und deswegen werden hierfür sog. RenderFarms verwendet. Pixar braucht 
durchschnittlich 7 Stunden um ein einziges Bild für ihre Animationsfilme zu erzeugen, sogar mit ihrer RenderFarm. (Wired 
Magazine 6/2010) . Daher sollte man viele Testrenderings von einzelnen Teilen machen, bevor man einen finalen Render 
macht. 

Vor jedem Render sollte man unbedingt Abspeichern und alle unnötigen Programme schließen. Der Computer wird während 
dem Rendern üblicherweise kaum bzw. gar nicht reagieren. 

Render Engines
Maya Software

Ein Allzweckrenderer der direkt in Maya eingebaut ist - Es ist ein Hybrid Renderer der die Geschwindigkeitsvorteile eines 
Scanrenderers mit echtem Raytracing verbindet. Generell hat die Qualität des Bildes höhere Priorität als die Geschwindigkeit 
des Ausrenderns.

Der SoftwareRenderer hat den Vorteil, dass man das IPR (Interactive Photo Realistic rendering) Tool verwenden kann um 
das fertig gerenderte Bild interaktiv verändern zu können. Sowie durch seine direkte Integration, dass man einfach komplexe 
Shadingeigenschaften erstellen kann.

Maya Hardware
Im Grunde ist es ein hardwarebeschleunigter Allzweckrenderer. Im Allgemeinen ist der Hardwarerenderer schneller als der 
Softwarerenderer, ein weiterer Vorteil des Hardwarerenderers ist das Ausrendern von Hardware Partikeln. Jedoch kann der 
Hardwarerenderer keine Sub-D Objekte rendern und hat darüber hinaus noch weitere Limitationen. 

Mental Ray

Ist ein photorealistischer Raytrace Renderer. Dieser Renderer kann alle Materialien des Maya Software Renderers verwenden 
und zusätzlich noch spezielle Mental Ray Materialien.

Mental Ray ist nicht direkt in Maya eingebaut sondern ist ein Plugin (Mayatomr.mll) 

Maya Vector 
Wie der Name bereits sagt ist Maya Vector ein Vektor Renderer. Dies ist besonders nützlich um Blaupausen des  Modells zu 
erstellen. Die unterstützten Formate sind: Scalable Vector Graphics (SVG), Adobe Flash (SWF), Adobe Illustrator (AI) oder 
Postscript (EPS)

Maya Vector wird selten verwendet und ist daher ein Plugin (VectorRenderer.mll)

Weitere Render Engines
Es gibt auch weitere Renderengines für Maya wie z.B. Visual Dynamics - V-Ray (http://www.vray.com/vray_for_maya/) oder 
Pixar - Renderman (https://renderman.pixar.com/products/tools/rfm.html)

Anmerkung: Um Plugins in Maya zu laden muss man Window > Settings and Preferences > Plugin Manager und dort 
dann für das Plugin ein Häckchen bei load setzen. (bzw. Auto load damit es automatisch mit Maya geladen wird)

Grund Surface Shader

Lambert

Blinn
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Phong

Bump Mapping vs. Surface Mapping

Cameras

Lampen

Schatten
Für jede Lampe muss man bestimmen ob sie Schatten wirft. DepthMap Shadows sind grundsätzlich schneller auszurendern 
als Raytrace Shadows. Letztere orientieren sich mehr an physikalisch realistischen Gegebenheiten.

Depth Map Shadows

Bei DepthMap Shadows wird eine DepthMap erzeugt und dann mit einem Filter verwischt.

Im Grunde gibt es für Depthmap Shadows zwei Variablen - Die “Resolution” der Depthmap und die “Filter Size”., die den Grad 
des Verwischens bestimmt. 

•	 Um scharfe Kanten bei den Schatten zu erhalten, erhöht man die Auflösung und benutzt einen geringen Filter.

•	 Um weiche Kanten zu erhalten benutzt man eine geringe Auflösung und einen großen Filter.

Raytrace Shadows
Bei Raytrace Shadows werden Shadowrays von der Lampe verschickt und dann dementsprechend eingefärbt. Daher können 
Transparenzen korrekt dargestellt werden.

Es gibt bei Raytrace Shadows 3 Einstellungen:

Shadow Radius/Light Radius/Light Angle (je nach Licht typ - Area Light hat keine Einstellungen werden durch die Position 
und Rotation bestimmt) - 0 erzeugt sharfe Kanten - 1 erzeugt weiche Kanten.

Shadow Rays  Je höher der Wert desto höher die Qualität der Shatten, (desto Höher die Renderzeit)

Ray Depth Limit bestimmt wie oft in einer rekursiven Reflection ein Schatten sichtbar sind.

Hypershade Editor

Render Settings
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Mental Ray: Martini Glas 
Vorbemerkung
Da man jetzt nur Rendering Operationen verwendet, sollte man das Menü (F6) und Shelf auf Rendering umstellen. 

Nach jedem Schritt wo eine Kamera, Licht oder Material verändert wird sollte man einen Testrender machen. 

Zunächst muss man die Renderengine auf mental Ray setzen mit Render > Render using > mental ray. 

Nun kann man Testrender machen mit Render > Render Current Frame 

Anmerkung: Um im Output Fenster den Fortschritt des Renderns angezeigt zu bekommen (nur bei mental Ray) muss man 
auf Render > Render Current Frame q  gehen und unter Messages : Verbosity Level auf  “Progress Messages” setzen

Bildausschnitt wählen
1.	 Man erzeugt eine Kamera mit Create > Cameras > Camera. Es wird eine perspektivische Kamera mit 35mm Öff-
nungswinkel erzeugt. Den Öffnungswinkel kann man mit Focal Length verändern, aber wir belassen ihn zunächst bei 35mm

2.	 Im Panel Menü wählt man Panels > Look Through Selected Object/Camera. Wenn man nun mit den normalen 
Kamera-Bewegungstools (ALT-LMB, ALT-MMB, ALT/RMB) die Szene verändert so verändert sich die Position und 
Rotation des selektierten Objekts.

3.	 Im Panel Menü View > Camera Settings > Resolution Gate aktiviert man ein Rechteck um zu sehen welcher Aus-
chnitt tatsächlich später gerendert wird.

4.	 Man positioniert nun die Kamera so wie man mit der Bildkomposition zufrieden ist.

Anmerkung: Es gibt die Möglichkeit in der Kamera selbst den Öffnungswinkel und die Art der Kamera zu verändern. Als De-
fault wird eine perspektivische Kamera mit einer 35mm Öffnung erzeugt.  Man kann auch die Tiefenschärfe verändern indem 
man Depth of Field einsetzt.

3-Punkt Beleuchtung
Um das Martini Glas richtig zur Geltung zu bringen, benutzt man eine sog. 3-Punkt Beleuchtung - so entsteht ein Kernschat-
ten der die Rundung des Glases besser zur Geltung kommen lässt. Das Key-Light sollte neben die Kamera in einem Winkel 
von  15-45°  gesetzt werden. Das Fill-Light sollte weniger als die Hälfte der intensität des Key-Lights haben und entgegeng-
esetzt zum Keylight positioniert werden. Das Rim-Light ist ein intensives Licht was den Rand/Hintergrund beleuchtet

1.	 Für das Key Light Create > Lights > Spot Light

2.	 Im Attribute Editor (Strg-A) 
			   Color  1, 1, 0		  (Farbe des Lichts, z.b. Cyan) 
			   Intensity 2.0,	 	 (Die Leuchtstärke) 
			   Decay Rate Linear, 	 (Die Eigenschaft wie das Licht an Intensität verliert) 
			   Cone Angle  60		  (Wie weit der Öffnungswinkel des Lichts ist) 
			   Penumbra Angle 20	 (Wie sehr die Intensität am Rand des beleuchteten Bereichs abfällt)

3.	 Für das Fill Light Create > Lights > Ambient Light

4.	 Im Attribute Editor (Strg-A)  
			   Intensity 0.7		  (Die Leuchtstärke)

5.	 Für das Rim-Light Create > Lights > Area Light

6.	 Im Attribute Editor (Strg-A) 
			   Color 1, 0.46, 0 
			   Intensity 8		  (Die Leuchtstärke)
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7.	 Damit nun durch das Rim Light nicht die Gesamte Szene massiv aufhellt, verändert man die Light linking Eigen-
schaft des Lichts unter Lighting/Shading > Light Linking Editor > Light - Centric.

8.	 Auf der linken Seite sieht man alle Lichter in der Szene und auf der Rechten Seite sieht man alle Objekte der Szene. 
(die Lichter erscheinen Doppelt, da man Beleuchtungsgruppen anlegen kann und diese individuelle linking Eigenschaften 
geben kann)

9.	 Mit LMB klickt man auf der linken seite Das “AreaLight1” bzw. Rim;Light - es wird sofort auf der Rechten Seite alle 
Objekte ausgewählt.

10.	 Nun mit RMB + STRG selectiert man die Objekte aus die tatsächlich von dem Licht beleuchtet werden - die Gruppe 
“martiniglas”.  Nichts anderes sollte selektiert sein.

11.	 Man kann nun den “Relationship-Editor” schließen. In der Vorschau 

Schatten
1.	 Nur das Keylight erhält einen Shatten, bzw. man versucht die Fill und Rim Light so zu positionieren das kein Schatten 
im Bild vorkommt - da wir im virtuellen Raum arbeiten - aktivieren wir einfach die Schatten nicht.

2.	 In der Lampe den unterpunkt Shadows aufmachen.  weiter unten kommt dann “Raytrace Shadow Attributes”

3.	 Ein Häckchen auf “Use Ray Trace Shadows” 

4.	 Light Radius 0.14, Shadow Rays 10, Ray Depth Limit 1

Materialien

Das Glas
1.	 Im Hypershade (Window > Rendering Editors > Hypershade)

2.	 Create > Mental Ray Materials > mia_material_x

3.	 Das Glas im Perspective selektieren und anschließend im Hypershade RMB auf das Material und im MarkupMenu 
“Assign Material to Selection” auswählen. 

4.	 Im Attribute Editor (Strg - A) umbenennen auf Glass 
		  Diffuse: 
			   Color 0.2, 0.2, 0.2 		 (Die Grundfarbe des Materials z.B. Dunkelgrau) 
			   Weight  0.7		  (Bestimmt mit Transparency und Reflectivity die diffuse Reflektion) 
		  Reflection: 
			   Reflectivity 0.25		  (Wie stark sich die Umgebung im Material spiegelt) 
			   Glossiness  0.9		  (Unschärfe der Reflektionen im Material) 
		  Refraction: 
			   Index of Refraction 1.4 	 (Wert der die LichtBrechung im Material z.B. Luft 1.0, Wasser 1.33, Diamant 2.4)  
			   Transparency 1.0		 (Transparenz des Materials) 
			   Glossiness  0.9	 	 (Unschärfe der Reflektionen im Material) 
			   Glossy Samples 8		 (Qualität der Unschärfe der Reflektionen)

Die Flüssigkeit
1.	 Im Hypershade das Glass Material selektieren

2.	 Mit Strg-D (Edit > Duplicate > Duplicate without Shading Network) ein Duplikat anfertigen. 

3.	 Im Attribute Editor das  Material “glass2” Material in “water” umbenennen. Unter Refraction die Farbe auf einen Bl-
auton setzen, und RefractionIndex auf 1.3 oder 1.2 setzen.

4.	 Die Gruppe “Liquid “auswählen.

5.	 Mit RMB auf die selectierte Gruppe klicken im MarkupMenu > Assign Existing Material > water.
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Die Olive
1.	 RMB auf die Olive im MarkupMenu > Assign new Material

2.	 Im Menü Lambert auswählen.

3.	 Dem Lambert  (“Olive_material”)  einen Olivgrünen-Farbton geben. 

4.	 Bei Bump Mapping auf das karierte Rechteck am Ende der Zeile klicken.

5.	 Im Menü Noise auswählen.

6.	 Bump Depth auf 0.1 setzen

7.	 zu “noise1” wechseln - Frequency Ration 5, Depth Max 6

Der Zahnstocher
1.	 RMB auf den Zahnstocher im MarkupMenu > Assign new Material

2.	 Lambert wählen, es “wood” benennen.

3.	 Bei Color auf das karierte Rechteck am Ende der Zeile klicken.

4.	 Im Menü Wood auswählen.

5.	 Die Filler Color etwas aufhellen, die Layer Size auf 100 setzen (dies lässt die Jahresringe verschwinden)

Render Engine Einstellungen
1.	 Window > Rendering Editors > Render Settings 

2.	 Unter dem Reiter Qualitiy - Quality Presets gibt es eine Reihe von verschiedenen Voreigestellten Presets.  Im “Draft” 
Modus ist der Renderer am schnellsten jedoch auch mit der geringsten Qualiät. Man stellt den Renderer auf “Production” 
um. Viele der Einstellungen wurden nun umgestellt. Macht man nun ein Testrender ist die Renderzeit wesentlich länger. - 
Daher sollte man alle Einstellungen vornehmen und dann ein Testbild rendern.

3.	 Im Indirect Lighting Reiter unter Enviroment - Image Based Lighting klickt man auf Create

4.	 Es öffnet sich nun der Attribute Editor unter Image Based Lighting Attributes - Image Name klickt man auf das Ver-
zeichnis am Ende der Zeile. 

5.	 Man wählt nun ein Bild aus was man zu der Indirekten Beleuchtung verwenden möchte. (Auf der Website: http://
www.debevec.org/Probes/ findet man Sphären bilder im .hdr format die man gut für diesen Zweck verwenden kann)

6.	 Nun wieder weiter im  Render Settings Fentster noch Final Gathering aktivieren indem amn unter Final Gathering das 
Häckchen setzt bei Final Gathering und eine Accurracy von 512 setzt.

7.	 Nun kann man das Fertige Bild ausrendern.

Anmerkung: Die Enviromant Map wird verwendet, damit das Glas etwas zum reflektieren hat. Es wird um die gesamte Szene 
eine Sphäre gesetzt und das Bild darauf projeziert, deswegen sind die meisten Enviromentmaps Sphärenbilder. Final Gathering 
ist die Eigenschaft das sich der Schatten eines Objektes leicht verfärbt je nach Farbe des Objektes.


